Neu JTL Hosting - Verbindungsprobleme

dizan

Aktives Mitglied
23. Juli 2014
8
0
Hallo,

während ich die aktuelle Version der WAWI auf meinen Rechnern problemlos ans Laufen bekomme und auch die Verbindung zur bei JTL gehosteten Datenbank snn.jtl-software.de anstandslos funktioniert, klappt das bei einem meiner Kunden überhaupt nicht und zwar auf mehreren verschiedenen Rechnern.

Die Datenbank kann noch über die JTL-Datenbankverwaltung eingerichtet und bearbeitet werden, das mit Passwort versehene Standardprofil kann mit den Userdaten sogar die angelegten Mandanten sehen und darin sogar Operationen wie Datenbankbereinigung etc. durchführen! Sobald ich aber versuche mich mit meinem Admin-User über den Wawi-Client auf der Datenbank anzumelden, kommt eine Fehlermeldung:

"Fehler bei der Verbindung:
SQLState: '01000'
SQL Server-Fehler: 53
[Microsoft][OBDC SQL Server Driver][DBNELIB]ConnectionOpen
(Connect()).
Fehler bei der Verbindung:
SQLState: '08001'
SQL Server-Fehler: 17
[Microsoft][OBDC SQL Server Driver][DBNETLIB]SQL Server existiert
nicht oder Zugriff verweigert

Ich habe schon die Firewall deaktiviert, JTL Wawi in die Ausnahmeliste der Firewall aufgenommen aber auch mit deaktivierter Firewall kein Durchkommen. Der ODBC-Treiber ist nicht (mehr) eingerichtet, nachdem er neuerdings nicht mehr benötigt wird.

Wer kann hier helfen?

viele Grüße
DiZan
 

_simone_

Sehr aktives Mitglied
17. Februar 2013
3.245
463
Emsland
Firma
Notun Delend
Das Problem hatten wir auch bei der 1.2.x.x.
Geholfen hat die Identifizierung des SQL-Ports und eine Mandantenerstellung nach folgender Syntax:
[Servername],[Portnummer]\[Instanz]
bsp:
MEINSERVER,49357\JTLWAWI
 

ag-websolutions.de

Sehr aktives Mitglied
29. Dezember 2009
14.548
233
Bei dieser -durchaus sinnvollen- Konfiguration aber darauf achten, dass die Porteinstellung des SQL-Servers auf "statisch" eingestellt wird und nicht auf "dynamisch" bleibt.

Ansonsten kann es nach einenm restart des DB-Servers dazu kommen, dass dieser sich einen anderen Port reserviert und dadurch die Verbindung nicht mehr klappt.
 
  • Gefällt mir
Reaktionen: HMS_IT

Alex_M

Aktives Mitglied
27. Oktober 2015
16
2
Moin,

bitte darauf achten die richtige Wawi-Version einzusetzen. Das Problem kann auch entstehen, wenn man versucht einen Wawi-Client Version 1.x mit einer DB-Version 0.9x zu verbinden.

Gruß
Alex
 

dizan

Aktives Mitglied
23. Juli 2014
8
0
Bei dieser -durchaus sinnvollen- Konfiguration aber darauf achten, dass die Porteinstellung des SQL-Servers auf "statisch" eingestellt wird und nicht auf "dynamisch" bleibt.

Ansonsten kann es nach einenm restart des DB-Servers dazu kommen, dass dieser sich einen anderen Port reserviert und dadurch die Verbindung nicht mehr klappt.

Da es sich um einen Server handelt, der von der Firma JTL gehostet wird, gehe ich davon aus, dass diese Voraussetzungen erfüllt sind.

Viele Grüße
Dirk
 

dizan

Aktives Mitglied
23. Juli 2014
8
0
Moin,

bitte darauf achten die richtige Wawi-Version einzusetzen. Das Problem kann auch entstehen, wenn man versucht einen Wawi-Client Version 1.x mit einer DB-Version 0.9x zu verbinden.

Gruß
Alex
Wie bereits oben deutlich beschrieben gibt es einen Haufen Computer die mit dieser Datenbank einwandfrei arbeiten bzw. kommunizieren können.
So wie ich das kenne, erzwingt die Wawi ein Datenbankupdate, wenn Programmversion und Datenbankversion nicht zueinander passen. Insofern kann ich mir nicht vorstellen, dass so etwas passieren kann.
Abgesehen davon ist die Datenbank auf einem aktuellen Stand.

viele Grüße
Dirk
 

Ähnliche Themen