Gelöst JTL connector funktioniert mit xtc modfied 2.0.4.0 nicht

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

wr-exclusive

Neues Mitglied
19. Februar 2018
6
0
#1
Beim Aufruf des http://meinshop.de/jtlconnector erhalte ich folgende Fehlermeldung

Hat wohlmlmöglich was mit dem xtc modified update auf 2.0.4.0 zu tun.

Connector 2.0 ist ja nur für folgende Versionen zugelassen 2.0.2.0-2.0.3.0

Ich bitte hiermit um ein Update des Connectors, danke!

{"result":null,"error":{"code":-32600,"message":"Invalid Request","data":"Exception 'jtl\\Connector\\Core\\Exception\\RpcException' (Code: -32600) with message 'Invalid Request' in phar:\/\/\/hp\/cm\/ab\/vh\/www\/shop\/jtlconnector\/index.php\/vendor\/jtl\/connector\/src\/jtl\/Connector\/Core\/Rpc\/RequestPacket.php:173"},"jtlrpc":"2.0","id":"unknown"}
 

daniel.jtl

Moderator
Mitarbeiter
12. März 2014
1.277
25
#2
Bitte auch die Anleitung durchlesen. Die Meldung ist beim Aufruf im Browser völlig beabsichtigt und normal, das ist kein Fehler.
 

wr-exclusive

Neues Mitglied
19. Februar 2018
6
0
#3
Trotzdem kann das JTL WAWI keine Verbindung mit dem Connector aufnehmen. Connector Einstellungen sind korrekt, vor dem Update auf xtc modified 2.0.4.0 ging der Sync einwandfrei.

Fehler beim Verbindungsaufbau: Exception bei core.connector.auth: syntax error, unexpected ':', expecting ';' or '{'

syntax error, unexpected ':', expecting ';' or '{'

Response: {"result":null,"error":{"code":4,"message":"syntax error, unexpected ':', expecting ';' or '{'","data":"Shutdown! File: phar:\/\/\/hp\/cm\/ab\/vh\/www\/shop\/jtlconnector\/index.php\/vendor\/doctrine\/instantiator\/src\/Doctrine\/Instantiator\/Instantiator.php - Line: 95"},"jtlrpc":"2.0","id":"unknown"}
Fehlermeldung WAWI 1.3.17.1 siehe Anhang
 

Anhänge

Zuletzt bearbeitet:

wr-exclusive

Neues Mitglied
19. Februar 2018
6
0
#4
Diese Fehlermeldung erscheint beim Verbindungstest aus dem WAWI herraus.

Hier der letzte Eintrag aus dem Errorlog vom jtlconnector

[2018-06-22 13:05:26] global.ERROR: Shutdown! File: phar:///hp/cm/ab/vh/www/shop/jtlconnector/index.php/vendor/doctrine/instantiator/src/Doctrine/Instantiator/Instantiator.php - Line: 95 - Type: 4 - Message: syntax error, unexpected ':', expecting ';' or '{' [] []
 

Anhänge

wr-exclusive

Neues Mitglied
19. Februar 2018
6
0
#6
Hallo, der Connector hat ja jetzt 3 Jahre lang funktioniert, erst seit dem Update letzte Woche von xtc modified 2.0.3.0 auf 2.0.4.0 geht der Connector nicht mehr.

Euer Connector unterstützt auch nur bis 2.0.3.0 laut Kundenmenü.
 

wr-exclusive

Neues Mitglied
19. Februar 2018
6
0
#7
Also selbst nach der neuinstallation des connectors unter modified 2.0.4.0 geht der sync immernoch nicht.

Es liegt also an der Shopsoftware 2.0.4.0

Das JTL- WAWI gibt beim Verbindungstest folgende Meldung aus, siehe Screenshot.
 

Anhänge

daniel.jtl

Moderator
Mitarbeiter
12. März 2014
1.277
25
#8
Hallo, der Connector hat ja jetzt 3 Jahre lang funktioniert
Naja, das ist nun ehrlich gesagt kein Argument. 3 Jahre sind viel Zeit, und es gibt auf allen Seiten ständig Änderungen und Anpassungen die nachgezogen werden müssen.

Nun gut, das hat ja einen Grund weswegen wir offiziell auch nur bis 2.0.3 unterstützen. 2.0.4 wurde dann eben noch nicht getestet und freigegeben.
Bei der abgebildeten Fehlermeldung liegt es aber mit großer Wahrscheinlichkeit eher an nicht erfüllten Server-Voraussetzungen (zb altes PHP) und nicht am Shop.
 

wr-exclusive

Neues Mitglied
19. Februar 2018
6
0
#9
Naja, das ist nun ehrlich gesagt kein Argument. 3 Jahre sind viel Zeit, und es gibt auf allen Seiten ständig Änderungen und Anpassungen die nachgezogen werden müssen.


Nun gut, das hat ja einen Grund weswegen wir offiziell auch nur bis 2.0.3 unterstützen. 2.0.4 wurde dann eben noch nicht getestet und freigegeben.
Bei der abgebildeten Fehlermeldung liegt es aber mit großer Wahrscheinlichkeit eher an nicht erfüllten Server-Voraussetzungen (zb altes PHP) und nicht am Shop.
Ich glaube nicht das es an den nicht erfüllten, siehe Screenshot aus dem Installer. Das Update auf 2.0.4.0 wurde jedoch benötigt um den Shop DSGVO konform zu machen. Ich hoffe das der Connector nochmal ein Update bekommt, damit dieser mit der aktuellen Version von XT Modified läuft.
 

Anhänge

knoopdog

Gut bekanntes Mitglied
4. November 2009
140
0
#10
Hallo,
wir haben aktuell das selbe Problem mit der Connector-Verbindung. Wir haben folgende Versionen installiert:

- modified eCommerce Shopssoftware v2.0.4.2 rev 11374 dated: 2018-07-23
- Connector > modified eCommerce 2 (2.0.1) für 2.0.2 bis 2.0.4
- JTL Wawi Version > 1.3.19.3

Der "integrity-check" ist positiv. http://unitybmx.inetpros.de/integrity-check/

Hat bereits einer den Connector mit den oben angegebenen Versionen erfolgreich verbunden?

Anbei die Log-Datei von dem Connector.
 

Anhänge

Nobby

Gut bekanntes Mitglied
23. April 2009
222
6
#11
Gibt es dazu schon eine passende Lösung oder Workaround?
Check zeigt alles okay an, beim Aufruf des Connectorinstallers zeigt sich aber lediglich das Hintergundbild des Installers.

Installiert ist folgendes (exakt wie bei knoopdog):
- modified eCommerce Shopssoftware v2.0.4.2 rev 11374 dated: 2018-07-23
- Connector > modified eCommerce 2 (2.0.1) für 2.0.2 bis 2.0.4
- JTL Wawi Version > 1.3.19.3
 

knoopdog

Gut bekanntes Mitglied
4. November 2009
140
0
#13
Hallo,
bei uns war das Problem, dass wir den Upload mit dem Mac und der App "Transmit" gemacht haben. Obwohl dort der binäre Modus eingestellt war hatte es nicht funktioniert. Wir haben es dann mit der App "Filezilla" gemacht und damit hatten wir dann keine Probleme mehr gehabt.