Neu Fehlermeldung im Header bei Umstellung auf php 7.1, 7.2 oder 7.3 - Updaten?

  • Offizielle Event-Absagen wegen Covid-19
    Alle Infos dazu findet ihr hier: Offizielles Statement

  • "Hermes B2C" wird zum 29.02.2020 abgeschaltet und durch das neue "Hermes-Shipping-Interface" (HSI) ersetzt.
    Wer noch "Hermes B2C" nutzt sollte rechtzeitig umsteigen
    Weiterführende Infos gibt es hier: Infos zur Schnittstelle

DiplomWurst

Aktives Mitglied
3. Juli 2016
46
3
Wir haben noch eine alte Shop Version

4.05 (Build: 5)

Wenn wir die php version ändern kommt:

Deprecated: define(): Declaration of case-insensitive constants is deprecated in x/x/x/includes/config.JTL-Shop.ini.php on line 3

line 3 sind die Shop urls.

Admin Login funktioniert dann auch nicht:

Meldung : Cross site request forgery!

Des weiteren fehlen Umlaute und Bestseller Artikel werden nicht angezeigt.
Einzige größere Plugin ist Dropper.

Sollen wir den Shop mal updaten oder ist der Fehler wo anders? Wir laufen jetzt wieder auf 7.0 und die Fehlermeldung wird nur im Admin Menü angezeigt.

Vielen Dank, falls jemand uns hilft.
 

DiplomWurst

Aktives Mitglied
3. Juli 2016
46
3
Haben gerade auf 4.06 16 upgedatet und wenn wir die php version ändern auf 7.1 / 7.2 oder 7.3 dann tritt immer noch der Fehler auf.
Ich werde mal die neue .htacces nehmen und diese anpassen. Vielleicht liegt es daran.
Sonst irgendeine Idee was das Problem ist?
 

DiplomWurst

Aktives Mitglied
3. Juli 2016
46
3
Immer noch der gleiche Fehler, haben jetzt die neue -htaccess genutzt und diese abgeändert, keine Änderung. Zeile 3 der Shop Config sind nur die beiden Urls, einmal mit www. und einmal ohne. Seltsam.

Wir haben noch drei Wochen, dann werden die Php Versionen bis 7.2 eingestellt. Wir machen das also nicht zu Spaß.
 

DiplomWurst

Aktives Mitglied
3. Juli 2016
46
3
Vielen Dank! Das hat geholfen.

Seltsam dass dies bis PHP 7.0 fehlerfrei lief.

Wir werden jetzt erstmal alle anderen Shops updaten.
 

Rainer S

Moderator
Mitarbeiter
8. August 2018
306
43
Ja wie die Meldung eigentlich ja klar aussagt, es ist deprecated , das hat ja nichts mit dem Shop zu tun sondern ist eine PHP eigene Funktion die zukünftig einfach nicht mehr existent ist, das sagt die Meldung aus.