Neu Fehlermeldung beim Abgleich

Lilo

Aktives Mitglied
13. Oktober 2019
2
1
Hallo zusammen,

ich hoffe Ihr könnt mir helfen.
Beim Abgleich unseres JTL-Wawis mit dem Shopware6 bekomme ich immer folgende Fehlermeldung ausgespuckt:

Fehler:

Exception: Controller = Product | Action = push |....... The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Return value of Shopware\Core\Framework\DataAbstractionLayer\FieldSerializer\JsonFieldSerializer::encodeJson() must be of the type string, bool returned

Ich habe dooferweise die Artikel aus den Fehlermeldungen deaktiviert und bekomme sie jetzt nicht wieder hochgeladen.

Viele Grüße,

Jana
 
  • Gefällt mir
Reaktionen: mxmax

Lilo

Aktives Mitglied
13. Oktober 2019
2
1
Hallo Tim,
danke für die schnelle Rückmeldung. Die beiden Log-Dateien hänge ich an.

Danke und viele Grüße,

Jana
 

Anhänge

  • Connector-Abgleich-Debug 20221006 15-30-17.txt
    456,1 KB · Aufrufe: 7
  • prod-2022-10-07-txt.txt
    330,9 KB · Aufrufe: 4

mxmax

Mitglied
9. September 2021
35
5
ggf. direkt ein Ticket aufmachen über dein JTL Kundencenter, sofern du Support-Berechtigt bist.
Hallo, ich hatte dazu ein Ticket geschrieben. Das wurde aber vorab geschlossen..ohne dass der Fehler gelößt wurde.
In den Shopwarelogs sei der Fehler nicht zu finden laut dem JTL Helpdesk. Ich bin gerade etwas ratlos... Über den Connector lassen sich nur noch Kunden und Bestellungen abrufen.. bei Abgleich von Artikeln kommt jedes Mal der Fehler wie bei Lilo
 

mxmax

Mitglied
9. September 2021
35
5
Ich bin immernoch ratlos, was das Problem beim Abgleich erzeugt. Hat hier niemand ähnliche Erfahrungen gemacht?

Wir benutzen in Shopware 6 keine Erweiterung die sich in Entitäten einklinken würde... Der Fehler entsteht einfach beim Onlineshopabgleich von JTL zu Shopware.
 

eCommercify

Mitglied
14. Februar 2022
22
13
Ich bin immernoch ratlos, was das Problem beim Abgleich erzeugt. Hat hier niemand ähnliche Erfahrungen gemacht?

Wir benutzen in Shopware 6 keine Erweiterung die sich in Entitäten einklinken würde... Der Fehler entsteht einfach beim Onlineshopabgleich von JTL zu Shopware.
Vielleicht ein Attribut in der Wawi, das leer ist und in Shopware als "NOT NULL" deklariert ist, also nicht leer bleiben darf?
 

lohkaes

Gut bekanntes Mitglied
27. April 2007
199
6
Hallo Zusammen,

folgende Fehlermeldung hatte ich heute beim Abgleich:

ERROR​

Message:
HTTP error: 301
Time:
2022-11-20T08:29:38.485705+0100
Channel:
core
Context:
{
"context": "remote_content"
}
request:
{
"uri": "/jtlconnector/?jtlauth=xxxxxxxx",
"method": "POST",
"query": {
"jtlauth": "xxxxxxxxxxx",
"module": "frontend",
"controller": "jtlconnector",
"action": "index"
},
"post": {
"jtlrpc": "{\r\n \"method\": \"delivery_note.push\",\r\n \"params\": [\r\n {\r\n \"items\": [\r\n {\r\n \"info\": [],\r\n \"productId\": [\r\n \"\",\r\n 7023\r\n ],\r\n \"id\": [\r\n \"\",\r\n 4350\r\n ],\r\n \"deliveryNoteId\": [\r\n \"\",\r\n 3723\r\n ],\r\n \"customerOrderItemId\": [\r\n \"\",\r\n 6730\r\n ],\r\n \"quantity\": 5.0\r\n }\r\n ],\r\n \"trackingLists\": [\r\n {\r\n \"name\": \"DPD-Versand nach DE\",\r\n \"codes\": [\r\n \"\"\r\n ]\r\n }\r\n ],\r\n \"entityType\": \"DeliveryNote\",\r\n \"id\": [\r\n \"\",\r\n 3723\r\n ],\r\n \"customerOrderId\": [\r\n \"\",\r\n 4855\r\n ],\r\n \"note\": \"\",\r\n \"creationDate\": \"2022-11-17T08:23:36Z\",\r\n \"isFulfillment\": false\r\n }\r\n ],\r\n \"jtlrpc\": \"2.0\",\r\n \"id\": \"xxxxxxxxxxxxxxxx\"\r\n}"
}
}
session:
No session data available
shopId:
1

Installiert ist die aktuellste Konektorversion, die aktuelleste 5er Shopversion und die Wawi-Version 1.6.44.0
Bug oder ein anderes Problem?
 

eCommercify

Mitglied
14. Februar 2022
22
13
Hallo Zusammen,

folgende Fehlermeldung hatte ich heute beim Abgleich:

ERROR​

Message:
HTTP error: 301
Time:
2022-11-20T08:29:38.485705+0100
Channel:
core
Context:
{
"context": "remote_content"
}
request:
{
"uri": "/jtlconnector/?jtlauth=xxxxxxxx",
"method": "POST",
"query": {
"jtlauth": "xxxxxxxxxxx",
"module": "frontend",
"controller": "jtlconnector",
"action": "index"
},
"post": {
"jtlrpc": "{\r\n \"method\": \"delivery_note.push\",\r\n \"params\": [\r\n {\r\n \"items\": [\r\n {\r\n \"info\": [],\r\n \"productId\": [\r\n \"\",\r\n 7023\r\n ],\r\n \"id\": [\r\n \"\",\r\n 4350\r\n ],\r\n \"deliveryNoteId\": [\r\n \"\",\r\n 3723\r\n ],\r\n \"customerOrderItemId\": [\r\n \"\",\r\n 6730\r\n ],\r\n \"quantity\": 5.0\r\n }\r\n ],\r\n \"trackingLists\": [\r\n {\r\n \"name\": \"DPD-Versand nach DE\",\r\n \"codes\": [\r\n \"\"\r\n ]\r\n }\r\n ],\r\n \"entityType\": \"DeliveryNote\",\r\n \"id\": [\r\n \"\",\r\n 3723\r\n ],\r\n \"customerOrderId\": [\r\n \"\",\r\n 4855\r\n ],\r\n \"note\": \"\",\r\n \"creationDate\": \"2022-11-17T08:23:36Z\",\r\n \"isFulfillment\": false\r\n }\r\n ],\r\n \"jtlrpc\": \"2.0\",\r\n \"id\": \"xxxxxxxxxxxxxxxx\"\r\n}"
}
}
session:
No session data available
shopId:
1

Installiert ist die aktuellste Konektorversion, die aktuelleste 5er Shopversion und die Wawi-Version 1.6.44.0
Bug oder ein anderes Problem?
Keine Session-Daten. Das bedeutet, dass entweder in PHP SQLite nicht aktiv ist oder das db-Verzeichnis bzw. die DB-Datei nicht beschrieben werden kann. Kontrolliere einmal in der phpinfo(), ob SQLite verfügbar ist, danach die Verzeichnisrechte des db-Verzeichnisses.
 
  • Gefällt mir
Reaktionen: lohkaes

eCommercify

Mitglied
14. Februar 2022
22
13
Bei mir ist die Fehlermeldung verschwunden, nachdem ich Shopware 6 auf die neuste Version geupdated hatte
Offenbar hatten Nutzer mit Shopware 5 und mit Shopware 6 da Probleme. Beim 6er Connector hat der Benutzer keinerlei Einfluss auf die Konfigurationsparameter des Connectors auf dem SaaS-Server. Natürlich können auch verschieden Einstellungen im Shop oder auf dem Shopserver manches Problem verursachen.
 

lohkaes

Gut bekanntes Mitglied
27. April 2007
199
6
Keine Session-Daten. Das bedeutet, dass entweder in PHP SQLite nicht aktiv ist oder das db-Verzeichnis bzw. die DB-Datei nicht beschrieben werden kann. Kontrolliere einmal in der phpinfo(), ob SQLite verfügbar ist, danach die Verzeichnisrechte des db-Verzeichnisses.
Hallo, also das Problem besteht erst seit dem Update auf die Connectorversion 2.17. Es scheint aber so, als ob alles Daten vom bzw. zum Shop übertragen werden. Hat das Problem sonst noch wer? Danke.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehlermeldung beim Abgleich mit Shop WooCommerce-Connector 3
Neu Fehlermeldung beim Abgleich mit Shop5 JTL-Wawi - Fehler und Bugs 0
Neu Fehlermeldung beim Wareneingang in WMS "Artikel wurde nicht gefunden" obwohl der Artikel anscheinend korrekt angelegt wurde. JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Nach Update Fehlermeldung beim einstellen von Kinderartikeln. kaufland.de - Anbindung (SCX) 1
Neu Fehlermeldung Umlagerung - FBA User helfen Usern - Fragen zu JTL-Wawi 3
Neu Fehlermeldung mit JTL Voucher "JTL-Vouchers Exception: File RequestException.php at line 113...." Plugins für JTL-Shop 0
Neu JTL2Lexoffice - Fehlermeldung bei Rechnungsimport Debitorennummer nachträglich ändern Schnittstellen Import / Export 2
Neu Fehlermeldung bei Zahlungsabgleich JTL-Wawi 1.6 0
Neu Fehlermeldung bei Anlage von Weiterleitungen JTL-Shop - Fehler und Bugs 0
Neu Fehlermeldung von JTL-Vouchers Plugins für JTL-Shop 0
Neu im Kunden menu "nachricht senden" vorgefertigte vorlagen fehlermeldung kein email empfänger JTL-Wawi - Ideen, Lob und Kritik 0
JTL Wawi keine Anmeldung mehr möglich. Nach dem LogIn kommt folgende Fehlermeldung JTL-Wawi 1.6 7
Beantwortet Fehlermeldung nach Shop-Update Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Theme Editor Fehlermeldung Änderung wird nicht übernommen Templates für JTL-Shop 4
Neu Fehlermeldung bei Umlagerung: EXTERNAL_ID_MAPS_MULTIPLE_IAIDS Amazon-Anbindung - Fehler und Bugs 0
Neu Wawi 1.6.43 / Shopabgleich 5.15 Fehlermeldung Datei Pfad zu lang User helfen Usern - Fragen zu JTL-Wawi 0
Neu Eigene Felder - Fehlermeldung "Name nicht eindeutig!" JTL-Wawi - Fehler und Bugs 5
Neu Fehlermeldung Label werden nicht erstellt - Amazon Prime durch Verkäufer DHL Amazon-Anbindung - Fehler und Bugs 0
Fehlermeldung SLR401 - fehlerhaftes Bild kaufland.de - Anbindung (SCX) 9
Neu Onlineshop-Abgleich in Wawi erzeugt direkt eine Fehlermeldung Onlineshop-Anbindung 6
Neu Fehlermeldung neue Varianten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Ticket erstellen - der Wert NULL kann in die dErstellDatum-Spalte nicht eingefügt werden. Servicedesk (Beta) 1
Neu Beim Angebotsimport wird der falsche Lagerbestand importiert (Anzahl bereits verkaufter Artikel als Bestand) eBay-Anbindung - Fehler und Bugs 0
Neu JTL-POS stürzt beim Verbinden des internen Druckers von sunmi T2s ab JTL-POS - Fehler und Bugs 4
Issue angelegt flexible Druckerauswahl beim Druck aus WMS 1.6.44 nicht mehr möglich [WAWI-65863] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Webinar: Euer Checkout beim Check-up: Die Checkout Clinic zu Gast bei JTL Messen, Stammtische und interessante Events 2
Neu Fehler beim Update eines Mandanten Installation von JTL-Wawi 1
Neu Probleme beim Import von Aufträgen JTL-Ameise - Fehler und Bugs 1
Neu Fehler beim Shopabgleich JTL-Wawi - Fehler und Bugs 1
Fehler beim 1. Shop-Update Einrichtung JTL-Shop5 1
Fehler beim Öffnen von Kunden JTL-Wawi 1.7 3
Neu Option zum Ausblenden beim Ticket anlegen Servicedesk (Beta) 2
Neu Digitale Unterschrift beim Auftrag anhängen? Arbeitsabläufe in JTL-Wawi 1
Neu PayPal und Klarna Bestellungen werden beim Shopabgleich als Bezahlt gesetzt. Gambio-Connector 0
Neu Export Rechnungen (Filter beim Export und doppelte Einträge wenn via JTL-POS bezahlt) JTL-Ameise - Ideen, Lob und Kritik 0
Neu Wawi Anmeldung nicht möglich Fehler 26 ( Fehler beim bestimmen des angegebenen Servers / der angegeben Instanz JTL-Wawi - Fehler und Bugs 5
Fehler beim Abgleich von Wawi 1.6.43.0 mit Shop 5.1.5, Verletzung der PRIMARY KEY-Einschränkung JTL-Wawi 1.6 12
Neu Artikel mit Stückliste gibt beim Packtisch+ selsame Mengen aus JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Einspielen der Datenbank Sicherung Installation von JTL-Wawi 1
Neu Fehler beim Import von abweichenden Lieferadressen JTL-Wawi - Fehler und Bugs 0
Neu auto Belegdruck beim Rechnungserstellen abstellen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Dropshipping-Artikel verfügbar obwohl kein Bestand beim Lieferanten Allgemeine Fragen zu JTL-Shop 4
Neu Ebenfalls Fehler beim erstmaligen Komplettabgleich - benötige zeitnahe Hilfe Shopify-Connector 0
Neu Probleme bei der Preisanzeige eines Artikels beim JTL Shop 5 mit Nova Template Technische Fragen zu Plugins und Templates 12
Neu Falsche Shop-Rabatte werden beim Artikel angezeigt Fehler und Bugs in JTL-Wawi 0
Neu Fehler beim Vererben JTL-Wawi - Fehler und Bugs 2
Neu Fehlermeldungen beim Prime Label Kauf Amazon-Anbindung - Fehler und Bugs 7
Neu Amazon Anbindung Abgleich Lagerbestand wird nicht aktualisiert Amazon-Anbindung - Fehler und Bugs 1
Neu SW6 Connector Artikel Abgleich bricht ab - Allowed memory Size Shopware-Connector 8
Neu Worker gleicht Daten nicht mit ebay und Amazon ab - Shop Abgleich funktioniert Einrichtung und Installation von JTL-eazyAuction 1

Ähnliche Themen