Neu Fehlermeldung beim Abgleich

Lilo

Aktives Mitglied
13. Oktober 2019
2
1
Hallo zusammen,

ich hoffe Ihr könnt mir helfen.
Beim Abgleich unseres JTL-Wawis mit dem Shopware6 bekomme ich immer folgende Fehlermeldung ausgespuckt:

Fehler:

Exception: Controller = Product | Action = push |....... The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Return value of Shopware\Core\Framework\DataAbstractionLayer\FieldSerializer\JsonFieldSerializer::encodeJson() must be of the type string, bool returned

Ich habe dooferweise die Artikel aus den Fehlermeldungen deaktiviert und bekomme sie jetzt nicht wieder hochgeladen.

Viele Grüße,

Jana
 
  • Gefällt mir
Reaktionen: mxmax

Lilo

Aktives Mitglied
13. Oktober 2019
2
1
Hallo Tim,
danke für die schnelle Rückmeldung. Die beiden Log-Dateien hänge ich an.

Danke und viele Grüße,

Jana
 

Anhänge

  • Connector-Abgleich-Debug 20221006 15-30-17.txt
    456,1 KB · Aufrufe: 15
  • prod-2022-10-07-txt.txt
    330,9 KB · Aufrufe: 7

mxmax

Aktives Mitglied
9. September 2021
45
6
ggf. direkt ein Ticket aufmachen über dein JTL Kundencenter, sofern du Support-Berechtigt bist.
Hallo, ich hatte dazu ein Ticket geschrieben. Das wurde aber vorab geschlossen..ohne dass der Fehler gelößt wurde.
In den Shopwarelogs sei der Fehler nicht zu finden laut dem JTL Helpdesk. Ich bin gerade etwas ratlos... Über den Connector lassen sich nur noch Kunden und Bestellungen abrufen.. bei Abgleich von Artikeln kommt jedes Mal der Fehler wie bei Lilo
 

mxmax

Aktives Mitglied
9. September 2021
45
6
Ich bin immernoch ratlos, was das Problem beim Abgleich erzeugt. Hat hier niemand ähnliche Erfahrungen gemacht?

Wir benutzen in Shopware 6 keine Erweiterung die sich in Entitäten einklinken würde... Der Fehler entsteht einfach beim Onlineshopabgleich von JTL zu Shopware.
 

Nockherberg

Mitglied
14. Februar 2022
28
15
Ich bin immernoch ratlos, was das Problem beim Abgleich erzeugt. Hat hier niemand ähnliche Erfahrungen gemacht?

Wir benutzen in Shopware 6 keine Erweiterung die sich in Entitäten einklinken würde... Der Fehler entsteht einfach beim Onlineshopabgleich von JTL zu Shopware.
Vielleicht ein Attribut in der Wawi, das leer ist und in Shopware als "NOT NULL" deklariert ist, also nicht leer bleiben darf?
 

lohkaes

Gut bekanntes Mitglied
27. April 2007
217
11
Hallo Zusammen,

folgende Fehlermeldung hatte ich heute beim Abgleich:

ERROR​

Message:
HTTP error: 301
Time:
2022-11-20T08:29:38.485705+0100
Channel:
core
Context:
{
"context": "remote_content"
}
request:
{
"uri": "/jtlconnector/?jtlauth=xxxxxxxx",
"method": "POST",
"query": {
"jtlauth": "xxxxxxxxxxx",
"module": "frontend",
"controller": "jtlconnector",
"action": "index"
},
"post": {
"jtlrpc": "{\r\n \"method\": \"delivery_note.push\",\r\n \"params\": [\r\n {\r\n \"items\": [\r\n {\r\n \"info\": [],\r\n \"productId\": [\r\n \"\",\r\n 7023\r\n ],\r\n \"id\": [\r\n \"\",\r\n 4350\r\n ],\r\n \"deliveryNoteId\": [\r\n \"\",\r\n 3723\r\n ],\r\n \"customerOrderItemId\": [\r\n \"\",\r\n 6730\r\n ],\r\n \"quantity\": 5.0\r\n }\r\n ],\r\n \"trackingLists\": [\r\n {\r\n \"name\": \"DPD-Versand nach DE\",\r\n \"codes\": [\r\n \"\"\r\n ]\r\n }\r\n ],\r\n \"entityType\": \"DeliveryNote\",\r\n \"id\": [\r\n \"\",\r\n 3723\r\n ],\r\n \"customerOrderId\": [\r\n \"\",\r\n 4855\r\n ],\r\n \"note\": \"\",\r\n \"creationDate\": \"2022-11-17T08:23:36Z\",\r\n \"isFulfillment\": false\r\n }\r\n ],\r\n \"jtlrpc\": \"2.0\",\r\n \"id\": \"xxxxxxxxxxxxxxxx\"\r\n}"
}
}
session:
No session data available
shopId:
1

Installiert ist die aktuellste Konektorversion, die aktuelleste 5er Shopversion und die Wawi-Version 1.6.44.0
Bug oder ein anderes Problem?
 

Nockherberg

Mitglied
14. Februar 2022
28
15
Hallo Zusammen,

folgende Fehlermeldung hatte ich heute beim Abgleich:

ERROR​

Message:
HTTP error: 301
Time:
2022-11-20T08:29:38.485705+0100
Channel:
core
Context:
{
"context": "remote_content"
}
request:
{
"uri": "/jtlconnector/?jtlauth=xxxxxxxx",
"method": "POST",
"query": {
"jtlauth": "xxxxxxxxxxx",
"module": "frontend",
"controller": "jtlconnector",
"action": "index"
},
"post": {
"jtlrpc": "{\r\n \"method\": \"delivery_note.push\",\r\n \"params\": [\r\n {\r\n \"items\": [\r\n {\r\n \"info\": [],\r\n \"productId\": [\r\n \"\",\r\n 7023\r\n ],\r\n \"id\": [\r\n \"\",\r\n 4350\r\n ],\r\n \"deliveryNoteId\": [\r\n \"\",\r\n 3723\r\n ],\r\n \"customerOrderItemId\": [\r\n \"\",\r\n 6730\r\n ],\r\n \"quantity\": 5.0\r\n }\r\n ],\r\n \"trackingLists\": [\r\n {\r\n \"name\": \"DPD-Versand nach DE\",\r\n \"codes\": [\r\n \"\"\r\n ]\r\n }\r\n ],\r\n \"entityType\": \"DeliveryNote\",\r\n \"id\": [\r\n \"\",\r\n 3723\r\n ],\r\n \"customerOrderId\": [\r\n \"\",\r\n 4855\r\n ],\r\n \"note\": \"\",\r\n \"creationDate\": \"2022-11-17T08:23:36Z\",\r\n \"isFulfillment\": false\r\n }\r\n ],\r\n \"jtlrpc\": \"2.0\",\r\n \"id\": \"xxxxxxxxxxxxxxxx\"\r\n}"
}
}
session:
No session data available
shopId:
1

Installiert ist die aktuellste Konektorversion, die aktuelleste 5er Shopversion und die Wawi-Version 1.6.44.0
Bug oder ein anderes Problem?
Keine Session-Daten. Das bedeutet, dass entweder in PHP SQLite nicht aktiv ist oder das db-Verzeichnis bzw. die DB-Datei nicht beschrieben werden kann. Kontrolliere einmal in der phpinfo(), ob SQLite verfügbar ist, danach die Verzeichnisrechte des db-Verzeichnisses.
 
  • Gefällt mir
Reaktionen: lohkaes

mxmax

Aktives Mitglied
9. September 2021
45
6
Bei mir ist die Fehlermeldung verschwunden, nachdem ich Shopware 6 auf die neuste Version geupdated hatte
 

Nockherberg

Mitglied
14. Februar 2022
28
15
Bei mir ist die Fehlermeldung verschwunden, nachdem ich Shopware 6 auf die neuste Version geupdated hatte
Offenbar hatten Nutzer mit Shopware 5 und mit Shopware 6 da Probleme. Beim 6er Connector hat der Benutzer keinerlei Einfluss auf die Konfigurationsparameter des Connectors auf dem SaaS-Server. Natürlich können auch verschieden Einstellungen im Shop oder auf dem Shopserver manches Problem verursachen.
 

lohkaes

Gut bekanntes Mitglied
27. April 2007
217
11
Keine Session-Daten. Das bedeutet, dass entweder in PHP SQLite nicht aktiv ist oder das db-Verzeichnis bzw. die DB-Datei nicht beschrieben werden kann. Kontrolliere einmal in der phpinfo(), ob SQLite verfügbar ist, danach die Verzeichnisrechte des db-Verzeichnisses.
Hallo, also das Problem besteht erst seit dem Update auf die Connectorversion 2.17. Es scheint aber so, als ob alles Daten vom bzw. zum Shop übertragen werden. Hat das Problem sonst noch wer? Danke.
 

lohkaes

Gut bekanntes Mitglied
27. April 2007
217
11
Hallo Zusammen,

leider besteht der Fehler beim Abgleich immer noch. Das Problem besteht seit dem Update auf die ConnectorVersion 2.17. Hab nun mal ein Logfile erstellen lassen:

Unbehandelte Ausnahme #959190594F6282F vom Typ System.Exception in
System.Exception: Fehler beim Verbindungsaufbau: Exception bei global_data.pull:

DeserializeObject-Error: Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Path '', line 0, position 0.
bei Newtonsoft.Json.JsonTextReader.ParseValue()
bei Newtonsoft.Json.JsonTextReader.Read()
bei Newtonsoft.Json.JsonReader.ReadForType(JsonContract contract, Boolean hasConverter)
bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
bei Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
bei Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
bei Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings)
bei jtlCore.ControllerClasses. Connector.Core.Json.DeserializeObject[T](String json)
.
.
.

2023-01-02T06:34:20 DEBUG - [OnDataComplete] (dlvPositionen..ShopBestellungen) - SessionId match: 2055866199
2023-01-02T06:34:20 DEBUG - [OnDataFetching] (dataListViewBestellungen..AmazonBestellungsListeControl) - Setup new SessionId 1526548054 => 0
2023-01-02T06:34:20 DEBUG - BEGIN TRANSACTION;
SET TRANSACTION ISOLATION LEVEL READ UNCOMMITTED;
SELECT COUNT(*) FROM [DbeS].[lvInetBestellungPositionen] AS lvInetBestellungPositionen
WHERE (lvInetBestellungPositionen.kInetBestellung = @BestellungId);
COMMIT TRANSACTION;

@bestellungId = 0
2023-01-02T06:34:20 DEBUG - Dauer: 6ms, Result: 0
2023-01-02T06:34:20 DEBUG - [OnDataComplete] (dataListViewBestellungen..AmazonBestellungsListeControl) - SessionId match: 1526548054
2023-01-02T06:34:20 DEBUG - [GetDataSource] (dataListViewAbrechnungsdatenPos..AmazonAbrechnungsdatenControl) - Enter
2023-01-02T06:34:20 DEBUG - [GetDataSource] (dataListViewAbrechnungsdatenPos..AmazonAbrechnungsdatenControl) - Exit
2023-01-02T06:34:20 DEBUG - [OnDataFetching] (dataListViewAbrechnungsdatenPos..AmazonAbrechnungsdatenControl) - Setup new SessionId 908289489 => 685833300
2023-01-02T06:34:20 DEBUG - [OnDataComplete] (dataListViewAbrechnungsdatenPos..AmazonAbrechnungsdatenControl) - SessionId match: 908289489
2023-01-02T06:34:22 DEBUG - SELECT cWert FROM [tUserSetting] WHERE kBenutzer=@kBenutzer AND cName = @cName
@kBenutzer = 1
@cName = 'PlattformAbgleich'
2023-01-02T06:34:22 DEBUG - Dauer: 3ms, Result: {"SchließenNachAbgleich":"false"}
2023-01-02T06:34:22 DEBUG - SELECT cWert FROM [tUserLayout] WHERE kBenutzer=@kBenutzer AND cName = @cName
@kBenutzer = 1
@cName = 'jtlCore.ControllerClasses.AbgleichPlattformAbgleichForm'
2023-01-02T06:34:22 DEBUG - Dauer: 3ms, Result: {}
2023-01-02T06:34:23 DEBUG - SELECT * FROM [tShop]
2023-01-02T06:34:23 DEBUG - Dauer: 1ms, (bis zum Reader)
2023-01-02T06:34:23 DEBUG - Dauer: 2ms, 1 Zeilen
2023-01-02T06:34:23 DEBUG - SELECT COUNT(*)
FROM dbo.tArtikel
2023-01-02T06:34:23 DEBUG - Dauer: 21ms, Result: 14059
2023-01-02T06:34:24 DEBUG - Fehler bei Verbindung/Session-Call
2023-01-02T06:34:36 DEBUG - SELECT * FROM [tShop]
2023-01-02T06:34:36 DEBUG - Dauer: 1ms, (bis zum Reader)
2023-01-02T06:34:36 DEBUG - Dauer: 1ms, 1 Zeilen
2023-01-02T06:34:36 DEBUG - SELECT COUNT(*)
FROM dbo.tArtikel
2023-01-02T06:34:36 DEBUG - Dauer: 3ms, Result: 14059
2023-01-02T06:34:37 DEBUG - Fehler bei Verbindung/Session-Call
Zeitstempel: 2023-01-02T06:35:34
Locale: German (Germany)
Locale: German (Germany)
Version: 1.6.45.1
Plattform: Wawi
WawiSeed: 0.8.09356.64101
Prozessname: JTL-Wawi
Physikalischer Speicher: 461557760 / Peak: 584265728
Basispriorität: 8
Prioritätsklasse: Normal
CPU-Zeit (User): 0:02:30,9375
CPU-Zeit (System): 0:01:09,921875
Page-Size (Sytem): 2778216 / Peak: 677371904
Page-Size: 677371904 / Peak: 677371904
Offene Handles: 2385
Database:
Build: 2212081450 bcb852541c844bf290dd408884fd2e4a20dc27dc


Hat den sonst noch wer dieses Problem? Eventuell jemand eine Idee wo ich mal ansetzen könnte? Danke.
 

markito

Aktives Mitglied
11. Mai 2008
20
0
Schweiz
Hallo zusammen, Hallo lohkaes

Konntest du das Problem lösen?

Ich erhalte seit dem Update exakt dieselbe Fehlermeldung.

Und zwar wird die Fehlermeldung generiert, nach dem die Bestellung in der WAWI ausgeliefert wurde und der Lieferschein an Shopware gesendet wird.

Message: HTTP error: 301.

"jtlrpc": "{\r\n \"method\": \"delivery_note.push\"........

session: No session data available

Wawi 1.5.55.6
Connector 2.18.0
Shopware 5.7.16

Es scheint ebenfalls so, als ob alles zum Shop übertragen wird.

Sonnige Grüsse
Marco
 

lohkaes

Gut bekanntes Mitglied
27. April 2007
217
11
Hallo zusammen, Hallo lohkaes

Konntest du das Problem lösen?

Ich erhalte seit dem Update exakt dieselbe Fehlermeldung.

Und zwar wird die Fehlermeldung generiert, nach dem die Bestellung in der WAWI ausgeliefert wurde und der Lieferschein an Shopware gesendet wird.



Wawi 1.5.55.6
Connector 2.18.0
Shopware 5.7.16

Es scheint ebenfalls so, als ob alles zum Shop übertragen wird.

Sonnige Grüsse
Marco
Hallo Marco,

nein, leider immer noch nicht.
Fehlerverhalten ist bei mir 100% identisch. Fehler ist seit einem Connector-Update vorhanden und das bei zwei unterschiedlichen Installationen.
Wawi hab ich die 1.6.47.2 & Shopware ebenfalls die aktuellste Version im Einsatz. Connector ist die Version 2.17.1

Das einzige was ich mir noch vorstellen könnte, das das Problem irgendwie mit PHP zusammenhängt?

Gruß
 

markito

Aktives Mitglied
11. Mai 2008
20
0
Schweiz
Hallo Zusammen

Dann poste ich mal meine PHP Einstellungen.

Vielleicht sieht jemand den Haken?

Sonnige Grüsse
Marco
 

Anhänge

  • php.jpg
    php.jpg
    112,6 KB · Aufrufe: 17

MP1

Aktives Mitglied
1. März 2017
49
15
Bei uns leider genau das gleiche Problem, wahrscheinlich seit dem Update auf Shopware 5.7.16 oder Update des Connectors auf 2.18.0. Genau können wir das derzeit nicht sagen, an welcher Umstellung das Problem zuerst auftrat. Es scheint auch bei uns alles (anscheindend) fehlerfrei übertagen zu werden. Fehler tritt ebenfalls nur bei Übermittlung der Sendungsnummer und/oder dem Versandstatus auf.

Shopware 5.7.16
Connector: 2.18.0
Wawi: 1.5.55.6
 

MP1

Aktives Mitglied
1. März 2017
49
15
Ob es nun wirklich daran lag, können wir nicht zu 100% bestätigen, aber wir haben im Plugin in der Datei config/config.json die Erstellung des Lieferscheins deaktiviert mit:

"delivery_note": {
"push": {
"create_document": false
}
}

Seitdem tauchen keine Fehlermeldungen mehr auf. Eventuell einfach mal ausprobieren, dann könnte man den Fehler auf jeden Fall schon mal lokalisieren.
 
Ähnliche Themen
Titel Forum Antworten Datum
Beim Datei hinzufügen kommt eine Fehlermeldung JTL-Wawi 1.8 3
Neu JTL Connector Plugin Aktivierunf [Fehlermeldung] WooCommerce-Connector 0
Neu Fehlermeldung bei Installation (Warning: Cannot declare class Event, because the name is already in use ) Installation / Updates von JTL-Shop 0
Fehlermeldung in der Suche Einrichtung JTL-Shop5 0
Neu Fehlermeldung Allgemeine Fragen zu JTL-Shop 0
Neu ECO DMS - Fehlermeldung im Outlook (Versionsfehler) User helfen Usern 1
Neu Variationswerte lassen sich nicht Löschen. Fehlermeldung: Der Artikel kann sich ggf. in einem inkonsistentem Zustand befinden JTL-Wawi - Fehler und Bugs 0
Neu Fehlermeldung bei der Aktivierung der Bestandsführung Arbeitsabläufe in JTL-Wawi 4
Neu Nach Wawi Update Fehlermeldung "Connector-Anbindung 'Name' konnte nicht aktiviert werden" PrestaShop-Connector 2
Neu Mögliche steuerrechtliche Verstöße beim Nutzen der JTL Druckvorlagen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 4
Neu Zebra T21 Scanner mit Installierten JTL POS 1.0.9.3 beim Bon versuche Ich einfach zu Scannen er sucht aber kein Artikel JTL-POS - Fehler und Bugs 1
Lieferanten EK wird nicht auf Artikelebene kopiert? EK ist überall 0 beim Artikel. JTL-Wawi 1.8 8
GLN-Nummer beim Kunden hinterlegen JTL-Wawi 1.8 3
Neu Wawi Artikelattribut = externer Link wie am besten darstellen beim Artikel? Allgemeine Fragen zu JTL-Shop 0
Neu Beim duplizieren von Aufträgen werden alte Daten übernommen Arbeitsabläufe in JTL-Wawi 10
Neu Dotliqid Artikelnummer beim letzten Bindestrich aufsplitten User helfen Usern - Fragen zu JTL-Wawi 0
Beschreibung wird beim Import fehlerhaft übernommen JTL-Wawi 1.8 0
Neu Menü, Logo und Suche beim Scrollen anzeigen / Mobilansicht Templates für JTL-Shop 0
Gelöst GLS Probleme beim Erstellen von Versandetiketten Gelöste Themen in diesem Bereich 1
Neu Mehrsprachiges Menü - Beim ersten Seitenaufruf falsche Sprache Gelöste Themen in diesem Bereich 11
Neu Webp Bild aufruf Fehler beim ersten mal laden JTL-Shop - Fehler und Bugs 2
RLIMIT_NPROC is exceeded & fehler 503 beim Abgleich und beim Bestellabschluss Einrichtung JTL-Shop5 0
Neu ebay- Angebote-laufende Angebote: Fehler beim Laden der Daten, der mehrteilige Bezeichner "Custom-fWawiArtikelpreisBrutto" konnte nicht gebunden werde JTL-Wawi - Fehler und Bugs 2
Neu Bitte um Hilfe beim Export/Import von Attributen JTL Ameise - Eigene Exporte 0
Neu Problem beim Update von 5.0.0 auf 5.2.4 (Integrity constraint violation: 1062 Duplicate entry 'COUNTRY_VIEW' for key 'PRIMARY'") Installation / Updates von JTL-Shop 3
Neu Zahlungsart beim Import ändern User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Update von Exportformat Google Shopping JTL-Shop - Fehler und Bugs 1
Issue angelegt [WAWI-57041] Identifikation von Amazon-Retouren beim FFN-Partner User helfen Usern - Fragen zu JTL-Wawi 1
Absturz beim Umlagern von Bestellvorschlägen auf die Einkaufsliste JTL-Wawi 1.7 0
In Diskussion Kassenschublade öffnet nicht beim ersten Vorgang des Tages. JTL-POS - Fehler und Bugs 6
Fehler beim Artikelupload nach Ebay 21917328, 21916619, 21916970, 21919420 JTL WAWI 1.7.12.1 JTL-Wawi 1.7 0
Worker in der 1.7.15.3 hängt ständig beim Shopabgleich JTL-Wawi 1.7 12
Neu Auswahl der Charge beim Verpacken Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Neu Vorgabeplätze beim Nachschub anzeigen Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Neu Probleme beim Abgleich | unterschiedliche Shops Gelöste Themen in diesem Bereich 18
Neu Packtisch "Fehler beim verpacken" von Artikel mit Seriennr. JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu Fehler beim Bilderabgleich WooCommerce-Connector 6
Neu Fehler beim Zahlungsabgleich Wawi 1.7.15.4 JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Update von JTL-WAWI 1.8.8.2 auf 1.8.9.1 JTL-Wawi - Fehler und Bugs 6
Neu Probleme mit Ameise beim Artikelimport / Artikelaktualisierung und Lieferantenartikeln VPE JTL-Ameise - Ideen, Lob und Kritik 3
Neu Mahnlauf vorbereiten und durchführen - JTL-Wawi 1.8.8.0 - Fehler beim Abrufen. JTL-Wawi - Fehler und Bugs 0
Popup beim Packtisch+ verpacken!? WIE? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu Wawi 1.8x schmiert beim Ausdruck eines Auftrags fast immer ab und muß neu gestartet werden - nur Windows 11 JTL-Wawi - Fehler und Bugs 5
Neu Kann ich bestimmte Artikel beim Wareneingang direkt auf einen Klärplatz buchen? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu Bilder werden beim Abgleich im Shop nicht gelöscht WooCommerce-Connector 2
Neu BUG? Mobile Ansicht ungewollter Zoom beim Tippen in ein Input Feld. JTL-Shop - Fehler und Bugs 0
Kein Abgleich zum Shop, ich komme nicht in Plattformen/Verkaufskanäle rein JTL-Wawi 1.8 3
Problem ebay Abgleich JTL-Wawi 1.8 4
In Diskussion Abgleich Wawi->Pos Allgemeine Fragen zu JTL-POS 7
Bug? Worker 2.0 - Shop Abgleich "Quicksync" ist kein Quicksync mehr - Paketgröße wird ignoriert JTL-Wawi 1.8 1

Ähnliche Themen