Gelöst Fehler beim Shopabgleich GX3

PeterBik

Aktives Mitglied
10. Februar 2018
5
0
Hallo,

wollte aus einem bestehende Gambio Shop GX3, Version 3.8.0.0. alle Artikel in die WAWI ziehen. Bekomme diesen Fehler angezeigt. Habe es mit den Connectoren 2.7 und 2.8 versucht. Die WAWI hat nur einen Testartikel. Im Shop sind aber über 4000.

Abgleich-Protokoll:
Onlineshop-Abgleich beendet für 'Gambio Shop'.

Fehler:
Exception: DeserializeObject-Error: Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Path '', line 0, position 0.
bei Newtonsoft.Json.JsonTextReader.ParseValue()
bei Newtonsoft.Json.JsonTextReader.ReadInternal()
bei Newtonsoft.Json.JsonTextReader.Read()
bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.ReadForType(JsonReader reader, JsonContract contract, Boolean hasConverter)
bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
bei Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
bei Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
bei Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings)
bei jtlCore.ControllerClasses.Connector.Core.Json.DeserializeObject[T](String json)

Json:<br />
<b>Fatal error</b>: Allowed memory size of 268435456 bytes exhausted (tried to allocate 28672 bytes) in <b>phar:///var/www/web27xxxxxx/html/jtlconnector/index.php/vendor/jtl/connector/src/jtl/Connector/Core/Database/Mysql.php</b> on line <b>292</b><br />
<br />
<b>Fatal error</b>: Allowed memory size of 268435456 bytes exhausted (tried to allocate 32768 bytes) in <b>phar:///var/www/web273xxxxxx/html/jtlconnector/index.php/vendor/composer/ClassLoader.php</b> on line <b>444</b><br />
Exception bei CustomerOrder.statistic:

DeserializeObject-Error: Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Path '', line 0, position 0.
bei Newtonsoft.Json.JsonTextReader.ParseValue()
bei Newtonsoft.Json.JsonTextReader.ReadInternal()
bei Newtonsoft.Json.JsonTextReader.Read()
bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.ReadForType(JsonReader reader, JsonContract contract, Boolean hasConverter)
bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
bei Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
bei Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
bei Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings)
bei jtlCore.ControllerClasses.Connector.Core.Json.DeserializeObject[T](String json)

Json:<br />
<b>Fatal error</b>: Allowed memory size of 268435456 bytes exhausted (tried to allocate 28672 bytes) in <b>phar:///var/www/web27xxxxxx/html/jtlconnector/index.php/vendor/jtl/connector/src/jtl/Connector/Core/Database/Mysql.php</b> on line <b>292</b><br />
<br />
<b>Fatal error</b>: Allowed memory size of 268435456 bytes exhausted (tried to allocate 32768 bytes) in <b>phar:///var/www/web273xxxxxx/html/jtlconnector/index.php/vendor/composer/ClassLoader.php</b> on line <b>444</b><br />

Response: <br />
<b>Fatal error</b>: Allowed memory size of 268435456 bytes exhausted (tried to allocate 28672 bytes) in <b>phar:///var/www/web27xxxxxxxx/html/jtlconnector/index.php/vendor/jtl/connector/src/jtl/Connector/Core/Database/Mysql.php</b> on line <b>292</b><br />
<br />
<b>Fatal error</b>: Allowed memory size of 268435456 bytes exhausted (tried to allocate 32768 bytes) in <b>phar:///var/www/web27xxxxxxx/html/jtlconnector/index.php/vendor/composer/ClassLoader.php</b> on line <b>444</b><br />

Könnte mir jemand weiter helfen?

Mit freundlichen Grüßen

Peter Bikkert
 

easyelektro

Aktives Mitglied
26. Oktober 2012
1
0
hallo
wie habt ihr dieses problem geloest,habe das gleiche problem
mfg
klaus hoffmann
 

PeterBik

Aktives Mitglied
10. Februar 2018
5
0
Hallo,

haben einen stärkeren Tarif beim Hoster gebucht. Wenn auch der integrity-check anzeigte, ob genug speicher da ist, müssten wir den Tarif 2 Mal hochstufen, bis genug Speicher für den Connector zu Verfügung stand.

MfG

Peter Bikkert
 

daniel.jtl

Moderator
12. März 2014
1.277
28
Allowed memory size of 268435456 bytes exhausted
256 MB ist für ein Shop-Hosting aber auch ein Witz... 😉
Abgesehen davon ist die beste und effizienteste Lösung natürlich (sofern möglich) das ausmisten der Datenbank. Zum Beispiel inaktive Kunden löschen die seit Jahren nicht mehr bestellt haben, oder aber Bestellungen wegsichern die schon längst abgeschlossen sind.
 

Ähnliche Themen