Neu Fehler beim Gambio Connector Fehlermeldung Payment

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Hober

Aktives Mitglied
4. September 2009
5
0
Hallo,
wir bekommen die nachfolgende Fehlermeldung. Connector Check zeigt alles grün.

WAWI Version: 1.5.36.3
Gambio Shop Version v4.2.1.0
Gambio Connector Version v2.13.1

Abgleich-Protokoll:
Onlineshop-Abgleich beendet für 'Tour Made'.


Fehler:
Exception: Argument 1 passed to jtl\Connector\Gambio\Mapper\Payment::mapPaymentType() must be of the type string, null given, called in phar:///var/www/vhosts/**/html/shop/jtlconnector/connector.phar/src/Mapper/Payment.php on line 140
Argument 1 passed to jtl\Connector\Gambio\Mapper\Payment::mapPaymentType() must be of the type string, null given, called in phar:///var/www/vhosts/**/html/shop/jtlconnector/connector.phar/src/Mapper/Payment.php on line 140
Exception bei Payment.statistic: Argument 1 passed to jtl\Connector\Gambio\Mapper\Payment::mapPaymentType() must be of the type string, null given, called in phar:///var/www/vhosts/**/html/shop/jtlconnector/connector.phar/src/Mapper/Payment.php on line 140

Argument 1 passed to jtl\Connector\Gambio\Mapper\Payment::mapPaymentType() must be of the type string, null given, called in phar:///var/www/vhosts/**/html/shop/jtlconnector/connector.phar/src/Mapper/Payment.php on line 140

Response: {"result":null,"error":{"code":0,"message":"Argument 1 passed to jtl\\Connector\\Gambio\\Mapper\\Payment::mapPaymentType() must be of the type string, null given, called in phar:\/\/\/var\/www\/vhosts\/**\/html\/shop\/jtlconnector\/connector.phar\/src\/Mapper\/Payment.php on line 140","data":"Exception 'TypeError' (Code: 0) with message 'Argument 1 passed to jtl\\Connector\\Gambio\\Mapper\\Payment::mapPaymentType() must be of the type string, null given, called in phar:\/\/\/var\/www\/vhosts\/**\/html\/shop\/jtlconnector\/connector.phar\/src\/Mapper\/Payment.php on line 140' in phar:\/\/\/var\/www\/vhosts\/**\/html\/shop\/jtlconnector\/connector.phar\/src\/Mapper\/Payment.php:181"},"jtlrpc":"2.0","id":"unknown"}
 
Zuletzt bearbeitet:

bork

Gut bekanntes Mitglied
26. Januar 2007
619
21
Das Mapping für deine Zahlungsweisen hat offenbar einen Hau. Vielleicht in JTL nicht eindeutig, da mehrfach gleichnamig vorhanden? Das Mapping findet soweit ich weiß anhand des Gambio Modulnamens statt, wenn es von JTL keine direkte Unterstützung gibt: Wenn es eine gleichnamige Zahlungsweise in JTL gibt, wird es darüber gemappt. Wenn nicht, wird eine Zahlungsweisen in JTL angelegt. Um welche Zahlungsweisen geht es denn?


Ansonsten musst du JTL mal ein vollständiges Error Log schicken.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Hober

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.106
234
Hallo,

das Problem ist letztens schonmal bei einem Kunden aufgetreten. Wir haben diesbezüglich einen Hotfix erstellt, der aber noch nicht veröffentlicht ist. Der Hotfix muss noch auf einem System getestet werden, auf dem das Problem auftritt. @Hober wenn du den Hotfix testen möchtest, dann schreib mir bitte eine PM.
 
  • Gefällt mir
Reaktionen: Tho82 und TIPADA

TIPADA

Neues Mitglied
25. Januar 2021
2
0
Soltau
Hallo Zusammen,
wir wollen auch demnächst zu JTL umsteigen, leider habe ich bei dem ersten init. Datenabgleich von meinem Gambioshop zu JTL diesen Fehler.
Hat jemand eine Lösung für dieses Problem? Zahlungsweisen setzen wir ein, Klarna, Paypal, Vorkasse (mit GiroConnect).

Gambio Version: v4.3.1.0
JTL-Version: 1.5.37.0
Connector: 2.13.1

Vielen Dank! Herzliche Grüße Mario
______________________


Abgleich-Protokoll:
Onlineshop-Abgleich beendet für 'TIPADA- Shop.de'.

Fehler:
Exception: Argument 1 passed to jtl\Connector\Gambio\Mapper\Payment::mapPaymentType() must be of the type string, null given, called in phar:///homepages/18/d263504813/htdocs/tipada-shop/jtlconnector/connector.phar/src/Mapper/Payment.php on line 140
Argument 1 passed to jtl\Connector\Gambio\Mapper\Payment::mapPaymentType() must be of the type string, null given, called in phar:///homepages/18/d263504813/htdocs/tipada-shop/jtlconnector/connector.phar/src/Mapper/Payment.php on line 140
Exception bei Payment.statistic: Argument 1 passed to jtl\Connector\Gambio\Mapper\Payment::mapPaymentType() must be of the type string, null given, called in phar:///homepages/18/d263504813/htdocs/tipada-shop/jtlconnector/connector.phar/src/Mapper/Payment.php on line 140

Argument 1 passed to jtl\Connector\Gambio\Mapper\Payment::mapPaymentType() must be of the type string, null given, called in phar:///homepages/18/d263504813/htdocs/tipada-shop/jtlconnector/connector.phar/src/Mapper/Payment.php on line 140

Response: {"result":null,"error":{"code":0,"message":"Argument 1 passed to jtl\\Connector\\Gambio\\Mapper\\Payment::mapPaymentType() must be of the type string, null given, called in phar:\/\/\/homepages\/18\/d263504813\/htdocs\/tipada-shop\/jtlconnector\/connector.phar\/src\/Mapper\/Payment.php on line 140","data":"Exception 'TypeError' (Code: 0) with message 'Argument 1 passed to jtl\\Connector\\Gambio\\Mapper\\Payment::mapPaymentType() must be of the type string, null given, called in phar:\/\/\/homepages\/18\/d263504813\/htdocs\/tipada-shop\/jtlconnector\/connector.phar\/src\/Mapper\/Payment.php on line 140' in phar:\/\/\/homepages\/18\/d263504813\/htdocs\/tipada-shop\/jtlconnector\/connector.phar\/src\/Mapper\/Payment.php:181"},"jtlrpc":"2.0","id":"unknown"}
 
Zuletzt bearbeitet:

TIPADA

Neues Mitglied
25. Januar 2021
2
0
Soltau
Ein Update zur genannten Fehlermeldung:
Die Anbindung hat letztendlich mit dem Connector Hotfix 2.13.1b von Immanuel funktioniert.
Meine Spakulation, es gab eine Zahlmethode ohne Werte?!

Nun funktionierte jedenfalls der Abgleich, nach beheben einiger fehlerhafter Datum Einträge (Werte: 1000/00/00 00:00) bei zwei Kategorieren und in der Specials Tabelle der Gambio Datenbank lief der Abgleich ohne Fehler durch.

Super jetzt können wir mit JTL durchstarten!
Danke für Eure Unterstützung!
 

bork

Gut bekanntes Mitglied
26. Januar 2007
619
21
Hi,

ich hab das Problem seit dem letzten JTL Wawi Update nun auch. Gibts den Hotfix schon irgendwo?

VG
 

Tho82

Neues Mitglied
21. Januar 2021
6
1
Hallo,

das Problem tritt bei mir ebenfalls auf! Woher bekomme ich den Hotfix?

Vielen Dank und viele Grüße,

Tho
 

T. Endreß

Neues Mitglied
16. Februar 2021
1
0
Hallo,

auch bei mir tritt dieser Fehler auf! Wurde das Hotfix schon veröffentlicht und falls ja wo kann ich es finden?

Vielen Dank und herzliche Grüße Tobias
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.106
234
Hallo Tho,

die Connector Version steht in der Datei "version" im Connector Verzeichnis. Alternativ kann die Connector Version dem Onlineshop-Abgleich Log entnommen werden (Endpoint version: x.y.z).
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Gambio Abgleich Fehler beim Produktabgleich/Bilder Gambio-Connector 9
Neu [Fehler] Gambio Abgleich Fehler beim Produktabgleich Gambio-Connector 1
Neu Fehler auf Übertragungsebene beim Empfang von Ergebnissen vom Server. (provider: Session Provider, error: 18 - Verbindung von Peer geschlossen) eBay-Anbindung - Fehler und Bugs 0
Neu Fehler beim versenden von Rechnungen per mail User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Seit gestrigem Win10 Update Fehler beim DHL Label Druck JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 3
Neu Fehler beim Ausliefern von Aufträgen - Ein ungültiger Längenparameter wurde an die LEFT- oder SUBSTRING-Funktion.... V1.5.38.1 JTL-Wawi - Fehler und Bugs 9
Neu Fehler in der Version 1.3.0.0 beim Befehl: JTL-Wawi - Fehler und Bugs 4
Neu Fehler 504 und Abbruch beim OnlineAbgleich JTL-Shop - Fehler und Bugs 1
Neu Fehler beim Erstellen des Fensterhandles. JTL-Wawi - Fehler und Bugs 0
Neu Probleme seit Update auf 1.5.38.1 : keine Amazon FBA Bestellungen mehr und Fehler beim Zugriff auf Wawi Logbuch Amazon-Anbindung - Fehler und Bugs 1
Neu Fehler beim Übertragen von Artikeln (Produktbeschreibung) WooCommerce-Connector 0
Neu Version 1.5.38.0 Fehler beim Neuanlegen von Artikeln nach Amazon JTL-Wawi - Fehler und Bugs 1
Neu Problem beim buchen der Inventurbestände (DB Fehler) JTL-Wawi - Fehler und Bugs 0
In Diskussion 16.01.2021 16:54:27Originalmeldung Meldung: Fehler beim Erstellen der HTTP-Anforderung für https://api.jtl-shipping.de/dhl/JtlWebApi.svc. JTL-ShippingLabels - Fehler und Bugs 2
Verwiesen an Support Fehlermeldung beim Labelerstellen: Fehler (Fehler bei Entschlüsselungsvorgang, siehe interne Ausnahme.) beim Übertragen von Daten über den HTTP-Kanal. JTL-ShippingLabels - Fehler und Bugs 1
Neu Fehler beim Export von Datev Rechnungs Daten Schnittstellen Import / Export 1
Neu Fehler beim Ausführen des Testskript für Shop 5 Installation / Updates von JTL-Shop 10
Neu Fehler und Abbruch beim Shopabgleich zu Shopware User helfen Usern - Fragen zu JTL-Wawi 3
Neu Fehler beim Speichern und Drucken einer Lagerbewertung JTL-Wawi - Fehler und Bugs 5
Neu Fehler beim Ausliefern Auftrag wird nicht ausgeliefert: Keine Teillieferung erlaubt JTL-Wawi - Fehler und Bugs 4
Neu Fehler beim aktivieren des Consent Managers in Shop 5.0 Installation / Updates von JTL-Shop 4
Neu Fehler beim importieren vom Template Themeart User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Onlineshop-Abgleich > prices[0].vat ist NULL Shopware-Connector 4
Neu JTL-Shop 5 - Fehler beim Scrollen zum Seitenende (Smartphone) JTL-Shop - Fehler und Bugs 2
Gelöst Fehler beim Einstellen von Artikle Ebay eBay-Anbindung - Fehler und Bugs 4
Neu Update 1.5.34 auf 1.5.36 -> Fehler beim DB bereinigen JTL-Wawi - Fehler und Bugs 0
Neu Fehler 32600 Fehler beim OnlineShop-Abgleich zw. JTL WAWI und Shopify Shopify-Connector 0
Neu Fehler 404 beim Shopabgleich JTL-Wawi - Fehler und Bugs 2
Gelöst Warenpost International - Fehler beim versenden Gelöste Themen in diesem Bereich 3
Neu Fehler beim Rechnungsdruck JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Update der WAWI auf eine Version ab 29.0 - Lösung bei mir... Installation von JTL-Wawi 0
Neu CSV Ein Fehler in der Kopfzeile JTL-POS - Fehler und Bugs 0
Neu Erster Lieferscheindruck nach Start der JTL-Wawi: Fehler JTL-Wawi - Fehler und Bugs 0
In Bearbeitung TSE-Fehler Swissbit Fehler 8 JTL-POS - Fehler und Bugs 3
Neu Fehler Retoure Stücklistenartikel bei teilweiser Rücksendung Arbeitsabläufe in JTL-Wawi 0
Neu Domainumzug zu Strato --> Plesk 500 Fehler, Admin-Backend erreichbar Allgemeine Fragen zu JTL-Shop 4
Neu Artikelexport aus JTL Shop 5 exportieren fehler JTL-Shop - Fehler und Bugs 1
Neu Fehler bei Umstellung auf Hermes HSI JTL-ShippingLabels - Fehler und Bugs 4
Neu Rechnungsdatenservice 2.0 Fehler - keine Objektinstanz Schnittstellen Import / Export 1
Neu Nova Child Source-Map-Fehler 404 JTL-Shop - Fehler und Bugs 1
Neu VCS Lite, Fehler/BUG bei A-Z Garantieanträgen Amazon-Anbindung - Fehler und Bugs 1
Neu eBay Abgleich Fehler - [Error][Code:21916984] eBay-Anbindung - Fehler und Bugs 7
Neu Kein Onlineshop-Abgleich möglich - Kategorie-Senden Fehler Shopware-Connector 1
In Bearbeitung ich habe TSE AUSFALL Fehler 2 bekommen. JTL-POS - Fehler und Bugs 2
Neu Update 4.06 -> 5.0.1: Fehler 500 bei Admin-Anmeldung vor System-Update Installation / Updates von JTL-Shop 3
Gelöst POS-1180 - POS Fehler 1.0.3.5 (3405) JTL-POS - Fehler und Bugs 3
Neu Fehler ebay Massenupdate - Artikel kann nicht zurückgegeben werden eBay-Anbindung - Fehler und Bugs 0
PHP Fehler nach Update - Sitemapexport Upgrade JTL-Shop4 auf JTL-Shop5 2
Gelöst Migration auf InnoDB/UTF-8 vornehmen - Fehler Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Fehler nach Onlineshopabgleich Gambio-Connector 6
Ähnliche Themen