Neu Fehler beim Einspielen des Backups auf neuem Rechner

Loads

Gut bekanntes Mitglied
26. Februar 2013
462
7
Ich will einen neuen Rechner mit dem Wawi-Server zum Laufen bringen.
Leider klappt das nicht.
Ich habe ein Backup von der Datenbank am alten Rechner gemacht.
Wenn ich dies nun bei der Datensicherungsimportierung im neuen Rechner einspielen will kommt die fehlermeldung wie im Anhang zu sehen.
Unbenannt.JPG
Was kann ich machen damit ich die Sicherung am neuen Rechner zum Laufen bekommen?
 

MichaelH

Sehr aktives Mitglied
17. November 2008
12.211
920
SQL-Meldungen sind oftmals wenig hilfreich ....

Der einfachste und sicherste Weg ist:
Alter Server:
Backup über die WAWI - .bak Datei

Neuer Sever:
SQL-Server installieren,
WAWI installieren (oder auch den SQL-Server über die WAWI installieren wenn du Express verwendest),
leere DB erstellen und
dann dort den Import der .bak Datei machen

Die .bak Datei jeweils im SQL-Verzeichnis "Backup" speichern bzw. kopieren, damit das mit den Rechten auch klappt.
 

Shopworker.de

Offizieller Servicepartner
SPBanner
4. Januar 2011
3.674
422
Arnsberg, Sauerland
Hallo loads,

du schriebst:

Was ist denn die Datensicherungsimportierung?

Es gibt 3 Möglichkeiten die Datenbank auf einem neuen Rechner zu integrieren:
- Backup über die JTL-Wawi einspielen (wie Michael beschrieben hat)
- Backup über das Managementstudio einspielen (wenn dein Screenshot von der ersten Möglichkeit stammt, dann diese Möglichkeit probieren).
- Datenbankdateien in die Instanz einfügen (würde ich nur im äußersten Notfall machen, wenn die anderen beiden Möglichkeiten nicht funktioniert haben).

Edith: Du versuchst in einen 2014er MSSQL-Server zu importieren; wenn ich das jetzt neu aufsetzen würde würde ich sofort den MSSQL-Server 2019 nehmen; der ist aktueller, schneller, kann mehr Daten im Speicher halten um nur einige der Vorteile zu nennen ...
 

Loads

Gut bekanntes Mitglied
26. Februar 2013
462
7
Ich hatte versucht das Backup über die JTL Wawi einzuspielen.
Leider weiß ich nicht wie man das Backup auch über das Managementstudio einspielen kann.
Ich habe jetzt nochmal die komplette Installation auf dem neuen Rechner gelöscht und versuche es nochmal.
 

Loads

Gut bekanntes Mitglied
26. Februar 2013
462
7
Kann es sein, dass er irgendwelche Ordner braucht die auf dem alten Rechner waren, jetzt aber auf dem Neuen nicht mehr?
Z.B. Dieser ganze Pfad ab MSSQL12.JTLWAWI existiert ja nicht auf dem neuen Rechner.
Da war aber ja beim alten Rechner die Datenbank drin.
 

Loads

Gut bekanntes Mitglied
26. Februar 2013
462
7
Edith: Du versuchst in einen 2014er MSSQL-Server zu importieren; wenn ich das jetzt neu aufsetzen würde würde ich sofort den MSSQL-Server 2019 nehmen; der ist aktueller, schneller, kann mehr Daten im Speicher halten um nur einige der Vorteile zu nennen ...

Ne, ist schon auf 2017 upgedatet.
Das hatte ich direkt vorher noch auf dem alten Rechner gemacht, weil ja bei der aktuellen Wawi auch der 2017 Server mitinstalliert wird.
Hatte auch erst überlegt 2019 einzusetzen, aber dafür genügen meine Kenntnisse nicht.
Dachte mit dem 2017 von JTL würde das einfach wieder laufen - was es aber jetzt nicht tut. :(
 

Loads

Gut bekanntes Mitglied
26. Februar 2013
462
7
Habe jetzt noch ein bisschen rumprobiert.
Jetzt kommt die Fehlermeldung 5591, Klasse 16 (Die FILESTREAM-Funktion ist deaktiviert).
Habe das auch schon überprüft und im alten System ausgeschaltet und ein neues Backup gemacht. Fehler kommt dann aber trotzdem noch wenn ich das einspielen will.
Auch das Aktivieren der Funktion über das Management tool hat nichts gebracht.
 

Loads

Gut bekanntes Mitglied
26. Februar 2013
462
7
So, habe es jetzt Dank dieses Videos doch noch geschafft die neue Installation zum Laufen zu bringen!
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehler beim Druck der Pickliste Arbeitsabläufe in JTL-Wawi 2
Neu Fehler beim Upload von Bildern mit OPC JTL-Shop - Fehler und Bugs 1
In Bearbeitung Was macht man, wenn beim Kassiervorgang ein Fehler passiert? Allgemeine Fragen zu JTL-POS 4
Neu Fehler beim Abgleich WooCommerce-Connector 0
Neu Fehler beim Abgleich des Shops Shopware-Connector 0
Neu Fehler beim Onlineshop-Abgleich PrestaShop-Connector 0
Neu Deserialize-Object Fehler beim Abgleich Technische Fragen zu den JTL-Connectoren 8
Neu Error 500 Fehler direkt beim Wawi / Shopabgleich Betrieb / Pflege von JTL-Shop 0
Neu ecodms - Fehler beim Backup User helfen Usern 0
Neu Fehler "Bearbeitungszeit" beim Import in eBay-Vorlagen JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Erstellen eines Zertifikats für POS-Schnittstelle JTL-Wawi - Fehler und Bugs 1
Neu Barcodeschema-Fehler JTL-POS - Fehler und Bugs 2
Neu Amazon Variation Fehler Amazon-Anbindung - Ideen, Lob und Kritik 0
Neu JTL-Wawi startet nicht mehr. Es ist ein Fehler aufgetreten. Der Wert darf nicht NULL sein. JTL-Wawi - Fehler und Bugs 8
Neu nach Anmeldung kommt Fehler: Der Wert darf nicht NULL sein. Parametername: key JTL-Wawi - Fehler und Bugs 2
Neu Warenkorb - Variations -if-Abfrage - wo habe ich den Fehler gemacht?????????? User helfen Usern 1
Neu JTL-Wawi Fehler bei der Anmeldung JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Fehler bei mehreren gleichen Produkten Allgemeine Fragen zu JTL-POS 3
Neu Fehler bei Übertragung (413) Request Entity Too Large + The EntityManger is closed Shopware-Connector 7
Neu Woo Connector connector.identify "Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig. WooCommerce-Connector 1
Neu Fehler im Update 1.5.46.1 auf 1.5.46.4 Installation von JTL-Wawi 11
In Bearbeitung Swissbit TSE , Fehler seit Update JTL-POS - Fehler und Bugs 23
Neu Shopabgleich Fehler "uncaught error call to a member function" Jtl Shop JTL-Wawi - Fehler und Bugs 1
JTL Shop 5: Warenkorb - Fehler bei Steuer B2B-Kunden? Ausblenden der Versandkosten, wenn 0,00 € möglich? Einrichtung JTL-Shop5 1
Neu Anbindung Script Fehler Amazon-Anbindung - Fehler und Bugs 0
Neu Update von 4.05 auf 4.06.17 Fehler - weiße Seite nach Bestellabschluss JTL-Shop - Fehler und Bugs 1
Neu Fehler nach Update auf Shop 5.0.3 Installation / Updates von JTL-Shop 1
Bilder in News und Header löschen - Fehler noch existent Einrichtung JTL-Shop5 3
Neu Fehler bei Wareneingang JTL-Wawi - Fehler und Bugs 1
Neu Emailbestätigung Shop - LocalizedEinzelpreis - Bedingung - Wo liegt der Fehler? Betrieb / Pflege von JTL-Shop 2
In Bearbeitung Es ist ein Fehler aufgetreten JTL-POS - Fehler und Bugs 2
Neu Fehler OPC Produktstream Kategorien JTL-Shop - Fehler und Bugs 1
Neu Fehler bei der Suche in der Version 4.05 geht nicht JTL-Shop - Fehler und Bugs 2
Gelöst Wawi 1.5.45 - Formulare - Rechnung - Email - Variantenwert ausgeben - wo liegt mein Fehler? O_O Gelöste Themen in diesem Bereich 1
Neu Leider gibt es nach wie vor Fehler bei der Ausgabe von Adressetiketten JTL-Wawi - Fehler und Bugs 0
Neu Fehler bei Installation der Community Free Version Einrichtung JTL-Shop5 2
Neu Google Search Console Fehler auf Kategorieseiten Allgemeine Fragen zu JTL-Shop 6
Neu FTP / Media Fehler JTL-Shop - Fehler und Bugs 2
Neu Fehler aus der Amazon Schnittstelle Amazon-Anbindung - Fehler und Bugs 1
Neu Zahlungsmodul Fehler nach Update 1.5.34.0 auf 1.5.45.1 - Keine Liste erlaubter TAN-Verfahren erhalten JTL-Wawi - Fehler und Bugs 0
Neu Fehler nach dem Template-Cache leeren JTL-Shop - Fehler und Bugs 2
Neu Fehler bei starten von JTL Client JTL-Wawi - Fehler und Bugs 5
Neu Fehler im Header auf meiner Seite Allgemeine Fragen zu JTL-Shop 2
Neu Google Core Web Vitals - CLS Fehler JTL-Shop - Ideen, Lob und Kritik 3
Neu Connector Fehler "getTaxClassId()" Shopify-Connector 2
Neu Fehler 403 und keine Bildübertragung WooCommerce-Connector 0
Gelöst Warenpost - Fehler: Hard validation error occured. JTL-ShippingLabels - Fehler und Bugs 2
Neu Rechnungen (Neu) - Export wirft Steuerfonfigurations-Fehler und exportiert Datensatz nicht JTL-Ameise - Fehler und Bugs 2
Shop Upgrade 4.06 auf 5.0.1 - Diverse Fehler ... Upgrade JTL-Shop4 auf JTL-Shop5 6
Neu Wie kann ich Fehler in der Suche umgehen/lösen? JTL-Shop - Fehler und Bugs 1

Ähnliche Themen