Neu Fehler beim Ausführen des Testskript für Shop 5

Mecklenburger

Aktives Mitglied
26. November 2017
20
1
Hallo,

beim Aufrufen des Testskripts bekomme ich folgende Fehlermeldung:

Schwerwiegender Fehler : require_once (): Fehler beim Öffnen erforderlich '.../shop5-systemcheck/vendor/composer/autoload_static.php' (include_path = '.: / Usr / lib / php7.4 ') in .../shop5-systemcheck/vendor/composer/autoload_real.php in Zeile 31

Im Verzeichnis shop5-systemcheck/vendor/composer/ befindet sich nach dem Entpacken des Testscriptdownloads auch keine Datei autoload_static.php

Wo liegt der Fehler?

Danke und Gruß
Mecklenburger
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.881
529
Halle
Hallo, es kann sein dass im Guide kurzzeitig die Version aus dem Gitlab verlinkt war, die nicht alle Abhängigkeiten enthält. Das ist aber korrigiert! Lade das Test-Script bitte erneut über die von @FMoche gen. URL herunter, entpacke es und kopiere den kompletten Inhalt auf deinen Webspace.
 

Mecklenburger

Aktives Mitglied
26. November 2017
20
1
Hallo FMoche,

das Testscript auf der von Dir verlinkten Seite führt wiederum zur folgenden Fehlermeldung:

Schwerwiegender Fehler : Nicht gefangener Fehler: Klasse 'Smarty' nicht in .../shop5-systemcheck/index.php:19 gefunden. Stapelverfolgung: # 0 {main} in ... / shop5-systemcheck / index.php in Zeile 19
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.881
529
Halle
Sicher das du alle Dateien kopiert hast!? Das Verzeichnis .../shop5-systemcheck/templates muss zudem für den Webserver beschreibbar sein.
 

Mecklenburger

Aktives Mitglied
26. November 2017
20
1
Hallo FPrüfer,

ich habe es noch mal geprüft. Alle Dateien/Verzeichnisse aus dem ZiP liegen auf dem Server und für .../shop5-systemcheck/templates bestehen Schreibrechte. Die Fehlermeldung bleibt die gleiche.
 

Mecklenburger

Aktives Mitglied
26. November 2017
20
1
Danke, Problem gelöst!
Woran lag es?
Keine Ahnung: ich habe das Paket erneut herunter geladen, entpackt auf den Server hochgeladen, die Schreibrechte auf das template-Verzeichnis gesetzt und dann lief es ohne Fehlermeldung durch.
 

DITH-Shop

Sehr aktives Mitglied
8. Juli 2013
2.902
219
Danke, Problem gelöst!
Woran lag es?
Keine Ahnung: ich habe das Paket erneut herunter geladen, entpackt auf den Server hochgeladen, die Schreibrechte auf das template-Verzeichnis gesetzt und dann lief es ohne Fehlermeldung durch.
Sagst Du mir mal bitte welche Rechte und für welchen User du die gesetzt hast?
Ich habe meines Erachtens nach nun alle Kombinationen von chmod und chown versucht - bekomme immer den Fehler "unable to write file"
 

Ähnliche Themen