Neu Fehler beim Abgleich: Exception: Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded

CafeKitsch

Neues Mitglied
9. April 2021
6
0
Hallo zusammen,

ganz neu dabei mit WaWi 1.5.42.0 und dem WooCommerce Connector 1.21.1 auf Wordpress 5.7. WooCommerce läuft unter der Version 5.1.0.

Soweit ich mitbekommen habe, sollte der Fehler aus dem Betreff eigentlich mit 1.5.41.3 behoben sein, aber das scheint den Fehler nicht zu interessieren. Möglicherweise ein Einzelschicksal?

Hier der Log:

Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Café Kitsch'.
Onlineshop-Abgleich beendet für 'Café Kitsch'.


Fehler:
Exception: Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded
Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded
Artikel-Empfangen-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.pull: Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded

Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded

Response: {"result":null,"error":{"code":10,"message":"Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded","data":null},"jtlrpc":"2.0","id":"61f48396608b4fc480ef929ac3b05490"}
Exception bei product.pull: Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded

Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded

Response: {"result":null,"error":{"code":10,"message":"Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded","data":null},"jtlrpc":"2.0","id":"7e7dc4189bd0435f92ece05d89046368"}
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.JjBcpY291ir(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.c4WcpsWvf6k(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.JjBcpY291ir(String , Object , Boolean , NetworkCredential )



Warnungen:
Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.


Es sollte der initiale Abgleich sein, es gab noch keinen einzigen erfolgreichen Abgleich. Kategorien und Merkmale konnten beim ersten Versuch gelesen werden, bei den Artikeln kommt reproduzierbar immer die genannte Fehlermeldung.

Es laufen einige Plugins wie Storefront Powerpack, WooCommerce Blöcke.

Gibt es Erfahrungen, woran es hier liegen könnte?

Viele Grüße
Zsolt Majsai für Café Kitsch in Linz
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.352
282
Hallo und herzlich willkommen im Forum @CafeKitsch!

Dem Fehler nach würde ich eher von einem falschen Zeichensatz in der Shop Datenbank ausgehen. Prüfe daher mal das Encoding der Shop Tabellen. Aktiviere im Connector bitte zusätzlich das Developer Logging und schicke mir nach einem fehlgeschlagenen Abgleich die Connector Logs per PM zu. Vielleicht kann ich darin etwas erkennen.
 

CafeKitsch

Neues Mitglied
9. April 2021
6
0
Hallo,

müsste der Connector dann nicht sofort auf einen Fehler laufen? Er lädt Kategorien und Co., erst beim product.pull läuft er auf einen Fehler. Im Übrigens hat die Datenbank UTF 8. Ist im Prinzip Standard Wordpress mit Standard WooCommerce und ein paar notwendigen Plugins.

Ich schicke die Logs.

Zsolt
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.352
282
Puh, schwer hier etwas zu "raten". Wurden denn schon Artikel übertragen oder hat er direkt beim ersten Artikel abgebrochen? Stell bitte mal in den Connector Einstellungen in JTL-Wawi die Paketgröße für den Import auf 1, starte den Abgleich und sende mir dann erneut die Logs per PM zu. Gerne auch zusätzlich den Onlineshop-Abgleich Log aus JTL-Wawi mitschicken.
 

CafeKitsch

Neues Mitglied
9. April 2021
6
0
Er bricht reproduzierbar und ausnahmslos ab, bevor er auch nur einen einzigen Artikel importieren könnte. Kategorien und Merkmale importiert er aber ohne Probleme.

Vielleicht ist auch in einem Artikel ein falsches Zeichen, aber wo und in welchem??

Ich mach mal den neuen Versuch und schicke dann die Logs.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehler beim Abgleich WooCommerce-Connector 0
Neu Fehler beim Abgleich des Shops Shopware-Connector 0
Neu Fehler beim Onlineshop-Abgleich PrestaShop-Connector 0
Neu Deserialize-Object Fehler beim Abgleich Technische Fragen zu den JTL-Connectoren 8
Neu Fehler beim Druck der Pickliste Arbeitsabläufe in JTL-Wawi 2
Neu Fehler beim Upload von Bildern mit OPC JTL-Shop - Fehler und Bugs 1
In Bearbeitung Was macht man, wenn beim Kassiervorgang ein Fehler passiert? Allgemeine Fragen zu JTL-POS 4
Neu Error 500 Fehler direkt beim Wawi / Shopabgleich Betrieb / Pflege von JTL-Shop 0
Neu ecodms - Fehler beim Backup User helfen Usern 0
Neu Fehler "Bearbeitungszeit" beim Import in eBay-Vorlagen JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Erstellen eines Zertifikats für POS-Schnittstelle JTL-Wawi - Fehler und Bugs 1
Neu Barcodeschema-Fehler JTL-POS - Fehler und Bugs 2
Neu Amazon Variation Fehler Amazon-Anbindung - Ideen, Lob und Kritik 0
Neu JTL-Wawi startet nicht mehr. Es ist ein Fehler aufgetreten. Der Wert darf nicht NULL sein. JTL-Wawi - Fehler und Bugs 8
Neu nach Anmeldung kommt Fehler: Der Wert darf nicht NULL sein. Parametername: key JTL-Wawi - Fehler und Bugs 2
Neu Warenkorb - Variations -if-Abfrage - wo habe ich den Fehler gemacht?????????? User helfen Usern 1
Neu JTL-Wawi Fehler bei der Anmeldung JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Fehler bei mehreren gleichen Produkten Allgemeine Fragen zu JTL-POS 3
Neu Fehler bei Übertragung (413) Request Entity Too Large + The EntityManger is closed Shopware-Connector 7
Neu Woo Connector connector.identify "Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig. WooCommerce-Connector 1
Neu Fehler im Update 1.5.46.1 auf 1.5.46.4 Installation von JTL-Wawi 11
In Bearbeitung Swissbit TSE , Fehler seit Update JTL-POS - Fehler und Bugs 23
Neu Shopabgleich Fehler "uncaught error call to a member function" Jtl Shop JTL-Wawi - Fehler und Bugs 1
JTL Shop 5: Warenkorb - Fehler bei Steuer B2B-Kunden? Ausblenden der Versandkosten, wenn 0,00 € möglich? Einrichtung JTL-Shop5 1
Neu Anbindung Script Fehler Amazon-Anbindung - Fehler und Bugs 0
Neu Update von 4.05 auf 4.06.17 Fehler - weiße Seite nach Bestellabschluss JTL-Shop - Fehler und Bugs 1
Neu Fehler nach Update auf Shop 5.0.3 Installation / Updates von JTL-Shop 1
Bilder in News und Header löschen - Fehler noch existent Einrichtung JTL-Shop5 3
Neu Fehler bei Wareneingang JTL-Wawi - Fehler und Bugs 1
Neu Emailbestätigung Shop - LocalizedEinzelpreis - Bedingung - Wo liegt der Fehler? Betrieb / Pflege von JTL-Shop 2
In Bearbeitung Es ist ein Fehler aufgetreten JTL-POS - Fehler und Bugs 2
Neu Fehler OPC Produktstream Kategorien JTL-Shop - Fehler und Bugs 1
Neu Fehler bei der Suche in der Version 4.05 geht nicht JTL-Shop - Fehler und Bugs 2
Gelöst Wawi 1.5.45 - Formulare - Rechnung - Email - Variantenwert ausgeben - wo liegt mein Fehler? O_O Gelöste Themen in diesem Bereich 1
Neu Leider gibt es nach wie vor Fehler bei der Ausgabe von Adressetiketten JTL-Wawi - Fehler und Bugs 0
Neu Fehler bei Installation der Community Free Version Einrichtung JTL-Shop5 2
Neu Google Search Console Fehler auf Kategorieseiten Allgemeine Fragen zu JTL-Shop 6
Neu FTP / Media Fehler JTL-Shop - Fehler und Bugs 2
Neu Fehler aus der Amazon Schnittstelle Amazon-Anbindung - Fehler und Bugs 1
Neu Zahlungsmodul Fehler nach Update 1.5.34.0 auf 1.5.45.1 - Keine Liste erlaubter TAN-Verfahren erhalten JTL-Wawi - Fehler und Bugs 0
Neu Fehler nach dem Template-Cache leeren JTL-Shop - Fehler und Bugs 2
Neu Fehler bei starten von JTL Client JTL-Wawi - Fehler und Bugs 5
Neu Fehler im Header auf meiner Seite Allgemeine Fragen zu JTL-Shop 2
Neu Google Core Web Vitals - CLS Fehler JTL-Shop - Ideen, Lob und Kritik 3
Neu Connector Fehler "getTaxClassId()" Shopify-Connector 2
Neu Fehler 403 und keine Bildübertragung WooCommerce-Connector 0
Gelöst Warenpost - Fehler: Hard validation error occured. JTL-ShippingLabels - Fehler und Bugs 2
Neu Rechnungen (Neu) - Export wirft Steuerfonfigurations-Fehler und exportiert Datensatz nicht JTL-Ameise - Fehler und Bugs 2
Shop Upgrade 4.06 auf 5.0.1 - Diverse Fehler ... Upgrade JTL-Shop4 auf JTL-Shop5 6
Neu Wie kann ich Fehler in der Suche umgehen/lösen? JTL-Shop - Fehler und Bugs 1

Ähnliche Themen