Gelöst Bilder werden nach Neuinstallation nicht angezeigt

dr.mabuse71

Mitglied
26. Januar 2019
8
1
Sehr geehrte JTL-Gemeinde,

ich habe meine Neuinstallation des JTL Shops hinter mir und - es läuft !! :)
Es gibt nur einen kleinen Fehler: anstatt der Bilder werden nur Platzhalter
angezeigt. Zum Scenario:

Hoster ist Strato
ImgaeMagick ist nicht eingebunden - ist wohl auch nicht zwingend nötig zum Betreiben des Shops,
Wawi zeigt an: Bilder erfolgreich übertragen
Habe schon versucht, im Backend den Cache zu leeren und die Bilder neu zu generieren - erfolglos.

Vielleicht kann mir jemand sagen, in welchem Ordner die Bilder im Shop liegen, welche Berechtigung der Ordner braucht.
Und: wo kann ich die Bilder in meiner DB finden, kann ich dann auch mal nachschauen, ob die richtig eingeordnet sind.

Oder andere bekannte Probleme, die bei Neuinstallation bezüglich Bildern auftreten können.

Vielen Dank für die Hilfe,
liebe Grüße
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.245
370
Hallo @dr.mabuse71

wichtig ist zum einen, dass die .htaccess ( shop-root) aktuell ist.
Zum anderen relevant sind die Ordner unter "media" (außer du benutzt noch eine 0.xxxxx JTL-Wawi). Alle Ordner unter /media/ müssen für den Webserver beschreibbar sein. Wenn die Bilder von JTL-Wawi aus erfolgreich zum Shop übersendet wurden, müssten die Bilder in /media/image/storage zu finden sein. Wenn sie dann erfolgreich (auch automatisch bei Aufruf) generiert werden, müssten die letzendlich angezeigten Bilder unter /media/image/product zu finden sein (aber dann sollten sie auch angezeigt werden).
 

dr.mabuse71

Mitglied
26. Januar 2019
8
1
Hi Julian,
vielen Dank für die Antwort. .htacess im root-dir ist NICHT aktuell, d.h. ist vom 26.01.2019 - Was meinst du denn mit aktuell ?
Sollte sich die Datei mit jedem WaWi abgleich aktualisieren ?
Wawi ist Version 1.3.21.0, Kurios: Kategoriebilder werden angezeigt, Artikelbilder nur als Platzhalter.
/media/ und Unterordner samt Dateien sind beschreibbar. Der Ordner /media/image/storage existiert nicht,
/media/image/product existiert, ist aber leer. Ich bin ratlos. Hat es was mit Imagemagick zu tun ? Sollte doch auch ohne laufen...

Liebe Grüße, Michael

p.s. die Artikelbilder sind klein, max 30k - sind die vielleicht ZU klein ?
 

Mirko.Schmidt User deaktiviert

Guest
Hallo,
am besten einmal den Ordner "storage" unter ../media/image/ anlegen. Dies ist der Ablageort der Artikelbilder. Nach ../media/image/product werden die Artikelbilder generiert.
JulianG meinte mit aktuell, dass eine .htaccess der aktuellsten Shop Version genutzt wird und keine Shop 3 oder 4.00 .htaccess.
 

Mirko.Schmidt User deaktiviert

Guest
Gerne, freut mich wenn es nun wieder funktioniert. :)
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Produktgalerie Hover Bilder werden untereinander dargestellt Templates für JTL-Shop 0
Neu Alternativtexte für Bilder werden nicht angezeigt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Galerie mit Composer erstellen - Bilder werden nicht angezeigt Betrieb / Pflege von JTL-Shop 7
Neu Grid Layout Bilder mit gleicher Größe werden unterschiedlich dargestellt User helfen Usern 0
Bilder von neuen Artikeln werden im Shop nicht angezeigt JTL-Wawi 1.6 1
Neu Connector dreht Bilder Allgemeines zu den JTL-Connectoren 0
Neu [ Kritik ] Bilder konvertieren und skalieren JTL-Wawi - Ideen, Lob und Kritik 13
Neu Bilder automatisch konvertieren per Workflow User helfen Usern - Fragen zu JTL-Wawi 0
Neu Bilder bei Amazon für Artikel und Farben ändern Amazon-Lister - Ideen, Lob und Kritik 0
bilder komprimieren JTL-Wawi 1.6 9
Neu Zwei getrennte eBay Accounts, ein Artikel, verschiedene Bilder User helfen Usern - Fragen zu JTL-Wawi 4
Bilder in Packtisch+ über Ameise möglich? JTL-Wawi 1.6 0
Neu Auswahl Konfigurationsgruppen - Die Artikel anhand Bilder auswählen Allgemeine Fragen zu JTL-Shop 0
Neu Doppelte Bilder bei Artikel-Upload Shopify-Connector 0
Neu Anzahl Bilder beim Produkt - nur 4 Stück? Allgemeine Fragen zu JTL-Shop 4
Neu Bilder im HTML Editor einfügen JTL-Wawi 1.6 0
Neu Wie füge ich Alternativtext (alt-Text) für Bilder hinzu? User helfen Usern - Fragen zu JTL-Wawi 4
Neu Bildgröße Bilder Merkmalwert im Artikelfilter ändern/vergrößern Betrieb / Pflege von JTL-Shop 0
Neu Artikel nicht einstellbar weil angeblich Bilder fehlen... eBay-Anbindung - Fehler und Bugs 1
Neu Bilder Importieren geht nicht JTL-Ameise - Fehler und Bugs 2
Neu Servicedesk - Bilder herunterladen Servicedesk (Beta) 1
Bilder im Format WebP JTL-Wawi 1.6 2
Neu Auswahl der Bilder bei Export mit Ameise JTL Ameise - Eigene Exporte 1
Neu Bilder aus EINEM Onlineshop vor Import entfernen JTL-Ameise - Ideen, Lob und Kritik 0
Neu Alle Bilder EINER Plattform entfernen User helfen Usern - Fragen zu JTL-Wawi 3
In Diskussion Bilder in JTL-POS löschen. Allgemeine Fragen zu JTL-POS 1
Bilder auf Startseite mit Shoppen Button Einrichtung JTL-Shop5 2
Neu nach Wawi 1.6.44.0 Update Die Nummerierung der eBay Bilder fehlen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Haken bei Bilder für bestimmte Plattform via SQL-Befehl bei Kindartikel entfernen User helfen Usern - Fragen zu JTL-Wawi 3
Neu Bilder skalieren und konvertieren Arbeitsspeicher läuft voll JTL-Wawi - Fehler und Bugs 0
Neu Preisliste - Kategorie - Eigene Felder und Bilder Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu DFI Bilder importieren JTL-Ameise - Ideen, Lob und Kritik 1
Workflow - Bilder von Artikel auslesen JTL-Wawi 1.6 3
Neu Ebay Kategorien dauern sehr lange bis sie in der Ebayvorlage geladen werden eBay-Designvorlagen - Fehler und Bugs 0
Attribute - Werteliste kann nicht erstellt werden JTL-Wawi 1.6 0
Neu Kindartikel - Namensänderung nur Groß/Kleinschreibung werden nicht übernommen (1.6.46.1) JTL-Wawi - Fehler und Bugs 2
Neu Crossselling-Artikel können nicht mehr zugeordnet werden. JTL-Wawi - Fehler und Bugs 0
WAWI 1.6.45.2 english standard language. Keine Artikel werden angezeigt. JTL-Wawi 1.6 0
Neu Artikel einer AMAZON Bestellung können in WAWI gefunden werden Arbeitsabläufe in JTL-Wawi 2
Neu Kunden werden doppelt angezeigt User helfen Usern - Fragen zu JTL-Wawi 1
Neu Importierte Labels werden nicht angezeigt in Listendarstellung User helfen Usern - Fragen zu JTL-Wawi 6
Neu Amazon Prime Etiketten werden nicht gedruckt. User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Fehler Voucher inactive obwohl keine Voucher benutzt werden JTL-POS - Fehler und Bugs 5
Verwiesen an Support Preise werden falsch aufsummiert - bzw. nicht mit berechnet JTL-Workflows - Fehler und Bugs 1
Gelöst [1.5.55] [Liquid] Fehler beim Hinzufügen von Number zu Array ("System.Double" kann nicht in den Typ "System.String" konvertiert werden) JTL-Workflows - Fehler und Bugs 2
Neu Meta Daten immer ausfüllen oder werden diese automatisch generiert? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Angebote werden nicht in den WooCommerceShop übertragen JTL-Wawi 1.5.45.0 WooCommerce-Connector 0
Neu Zahlungsverkehr, EBICS frisch eingerichtet, keine Umsätze werden abgeholt JTL-Wawi - Fehler und Bugs 0
Neu LS-POS Auftrag kann nicht storniert werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Google Shopping unitPricingMeasure und unitPricingBaseMeasure werden nicht übertragen Plugins für JTL-Shop 4

Ähnliche Themen