Neu Bilder werden im Webshop nicht angezeigt, generieren nicht möglich.

8. April 2021
25
2
Hallo, ich habe folgendes Problem.

Die Dateien werden vom WaWi- Worker in den Webshop hochgeladen.

Ich die Bilder werden bei den Artikeln nicht angezeigt.

Wenn ich auf Generieren drücke bekomme ich folgende Fehlermeldung


Bilder konnten nicht generiert werden.


Unable to read image from path (/mnt/web514/a0/25/57318325/htdocs/media/image/storage/1024_610_d8843743e59f3fa60651939f770a859e_e742462e7932da1aa0726a591105

im Ordner /media/image/storage/ existiert die Datei 1024_610_d8843743e59f3fa60651939f770a859e_e742462e7932da1aa0726a5911050bfb74f78ebea8d3865908754a16fb7e226d247f0bf90a5ead325f25a76ab700d07d4d6d6c4df7448bfc106ecf37e63af47a.jpg

Die Ordner besitzen allesamt die Berechtigung 755


Ich hoffe mir kann jemand Helfen.

Vielen Dank und schöne Grüße
 

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.808
944
Hast viele Bilder?

Falls überschauber Anzahl an Bildern, würd ich mal folgendes probieren:
.) check ob der besitzer der gruppe richtig ist (nur bei rootserver)
.) Shopadmin -> kompletten Bildercache mal löschen
.) WaWi -> Komplettabgleich Shop, mit Bildern
.) Shopadmin klick bei den Bildern auf "generieren"
 
  • Gefällt mir
Reaktionen: soeldner-messer.com
8. April 2021
25
2
.) check ob der besitzer der gruppe richtig ist (nur bei rootserver)
.) Shopadmin -> kompletten Bildercache mal löschen
.) WaWi -> Komplettabgleich Shop, mit Bildern
.) Shopadmin klick bei den Bildern auf "generieren"

Sind nicht viele es sind erst 2 Artikel im Shop mit jeweils 3 oder 4 Bildern.

.) Webhosting bei Strato
.) Habe ich bereits gemacht Versuch ich aber nochmal
.) Komplettabgleich schon mehrmals versucht.
.) Beim Klick auf Generieren kommt wie oben beschrieben die Fehlermeldung.


Vielen Dank bis hierhin schonmal für die Hilfe bin gerne noch für Ratschläge offen :)
 

fritz_0815

Gut bekanntes Mitglied
21. März 2012
199
11
Habe das gleiche Problem.
Nur kann man einfach so ohne Probleme von PHP 8 zurück auf PHP 7.4 gehen oder gibt es da was zu beachten ?
 

memo Software

Gut bekanntes Mitglied
10. Oktober 2009
442
1
Was macht man, wenn vom Hoster kein PHP 7.4 mehr angeboten wird? Der Hoster hat ein Zwangsupdate auf PHP 8.0 vollzogen und man hat keine Wahlmöglichkeit mehr.

Ich dachte eigentlich, der JTL Shop 5.15 sei PHP8-kompatibel?

Die Fehlermeldung ist die Geiche:

Bilder konnten nicht generiert werden.

Image source "/is/htdo....../media/image/storage/categories/GrBlatt.jpg" does not exist

Viele Grüße,

Martin
 

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.808
944
Was macht man, wenn vom Hoster kein PHP 7.4 mehr angeboten wird? Der Hoster hat ein Zwangsupdate auf PHP 8.0 vollzogen und man hat keine Wahlmöglichkeit mehr.
Schon jahrelang bekannt, wann 7.4 EOL ist. Das Hoster, aus Sicherheitsgründen, 7.4 abdrehen - ist daher vollkommen nachvollziehbar.

https://guide.jtl-software.de/jtl-w...r-jtl-produkte/#voraussetzungen-fuer-jtl-shop
Shop 5.1.* ist php 8.0 tauglich.

Solang alle deine Plugins auch 8.1 tauglich sind (achtung bei SP die noch immer ioncube loader verwenden), solte es kein Prob geben.
Wegen den Bildern, geh mal in die Shop Admin und generier die neu und schau dir die Bildereinstellungen an.
 

memo Software

Gut bekanntes Mitglied
10. Oktober 2009
442
1
Schon jahrelang bekannt, wann 7.4 EOL ist. Das Hoster, aus Sicherheitsgründen, 7.4 abdrehen - ist daher vollkommen nachvollziehbar.

https://guide.jtl-software.de/jtl-w...r-jtl-produkte/#voraussetzungen-fuer-jtl-shop
Shop 5.1.* ist php 8.0 tauglich.

Solang alle deine Plugins auch 8.1 tauglich sind (achtung bei SP die noch immer ioncube loader verwenden), solte es kein Prob geben.
Wegen den Bildern, geh mal in die Shop Admin und generier die neu und schau dir die Bildereinstellungen an.

Danke für die schnelle Antwort!

Alles, was oben beschrieben wurde, habe ich natürlich ausprobiert, bevor ich diesen Post geschrieben habe. Plugins habe ich gar keine.

Das Ergebnis ist das Gleiche: Bilder konnten nicht generiert werden.
 

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.808
944
/admin/bilder.php
Schau dir mal alle Einstellungen unten an.

Danach
/admin/bilderverwaltung.php
Generier mal, kommt da ne Fehlermeldung, schau dir die Schreibrechte am Server an:
root -> /media/image/product
 

memo Software

Gut bekanntes Mitglied
10. Oktober 2009
442
1
Die Bildereinstellungen sehen aus meiner Sicht ok aus:




bilder1.JPG
bilder2.JPG

Die Bilderverwaltung sieht so aus:

bilder3.JPG
Nach dem Leeren des Cache und Aufräumen (was beides funktioniert), klicke ich auf Generieren und erhalte:

bilder4.JPG

Seltsam dabei ist, dass es den Ordner "storage" gar nicht gibt.

Die Rechte stimmen ansonsten (775).
 

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.808
944
Unbenannt.png
Unbenannt1.png

Im "storage" wird zwischengeparkt, in "product" kommen dann die richtigen rein (unterordner sind die wawi internen schlüssel nummern der jeweiligen ARtikel).
 

memo Software

Gut bekanntes Mitglied
10. Oktober 2009
442
1
Nachdem ich das Verzeichnis 'storage' manuell angelegt hatte, ging es zunächst immer noch nicht. Am nächsten Tag wurden die Bilder aber wieder korrekt angezeigt und alle Dateien waren da, wo sie sein sollten.

Seltsame Geschichte, aber danke für Eure Unterstützung!
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Bilder werden bei bestimmten Produkten nicht übertragen. WooCommerce-Connector 0
Kategorie Bilder werden nach Update von JTl-Shop 4 auf JTL-Shop 5 nicht angezeigt Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Bilder aus JTL Wawi werden nicht in den Shopify Store übertragen Shopify-Connector 5
Neu Bilder werden nicht an JTL Shop übertragen JTL-Shop - Fehler und Bugs 2
Neu Artikel nicht einstellbar weil angeblich Bilder fehlen... eBay-Anbindung - Fehler und Bugs 1
Neu Bilder Importieren geht nicht JTL-Ameise - Fehler und Bugs 2
Neu Servicedesk - Bilder herunterladen Servicedesk (Beta) 1
Bilder im Format WebP JTL-Wawi 1.6 1
Neu Auswahl der Bilder bei Export mit Ameise JTL Ameise - Eigene Exporte 1
Neu Bilder aus EINEM Onlineshop vor Import entfernen JTL-Ameise - Ideen, Lob und Kritik 0
Neu Alle Bilder EINER Plattform entfernen User helfen Usern - Fragen zu JTL-Wawi 3
In Diskussion Bilder in JTL-POS löschen. Allgemeine Fragen zu JTL-POS 1
Bilder auf Startseite mit Shoppen Button Einrichtung JTL-Shop5 2
Neu nach Wawi 1.6.44.0 Update Die Nummerierung der eBay Bilder fehlen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Haken bei Bilder für bestimmte Plattform via SQL-Befehl bei Kindartikel entfernen User helfen Usern - Fragen zu JTL-Wawi 3
Neu Bilder skalieren und konvertieren Arbeitsspeicher läuft voll JTL-Wawi - Fehler und Bugs 0
Neu Preisliste - Kategorie - Eigene Felder und Bilder Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu DFI Bilder importieren JTL-Ameise - Ideen, Lob und Kritik 1
Workflow - Bilder von Artikel auslesen JTL-Wawi 1.6 3
Neu Slider Bilder Upload Betrieb / Pflege von JTL-Shop 1
Neu gleiche Bilder mehrerer Artikel zusammenführen Betrieb / Pflege von JTL-Shop 1
Neu Alternativtexte für Bilder User helfen Usern - Fragen zu JTL-Wawi 3
Neu JTL Shop 5: Kopierschutz für Bilder einrichten Allgemeine Fragen zu JTL-Shop 13
Neu Bilder Abgleich und Ameise PrestaShop-Connector 0
Neu Bilder der Artikel auf allen Ausgabewege Aktivieren User helfen Usern - Fragen zu JTL-Wawi 1
Neu Tickets mit Bilder - Ladezeiten Servicedesk (Beta) 4
Neu Bilder aus Elementsammlung per Formel einbinden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Massenübertragung Bilder Vaterartikel auf Kinderartikel - best practice? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Grundpreise im Shop 5.1.5 werden nicht korrekt angezeigt JTL-Shop - Fehler und Bugs 1
BUG | Kategorieindividuelle Felder kann nicht erstellt werden kaufland.de - Anbindung (SCX) 0
Neu Shopware 6 - Kundendaten-Abgleich hängt in Schleife, immer gleiche Kunden werden importiert Shopware-Connector 3
Neu Blog-Vorschaubilder werden in Blogbeiträgen angezeigt Allgemeine Fragen zu JTL-Shop 0
Neu Wo finde ich die Variablen, die in den Emailvorlagen verwendet werden können? Allgemeine Fragen zu JTL-Shop 1
Neu Wo kann die Variable "Vorgang.Text" bearbeitet werden? WaWi 1.6.44.0 Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Retouren werden direkt auf Retourenplatz gebucht JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 2
Neu 2D Barcode - manuelle Gebühren werden fällig im neuen Prozess “An Amazon senden” Amazon-Anbindung - Fehler und Bugs 0
Neu Amazon Versandgruppe bei Internationalen Amazon Marketplaces können nicht zugeordnet werden Amazon-Anbindung - Fehler und Bugs 1
Neu 1.6.44.0 Sonderpreise werden nicht aktivier JTL-Ameise - Fehler und Bugs 9
Neu Sprachvariablen werden nicht eingesetzt? JTL-Search 0
Neu Artikel aus JTL-Wawi werden nicht oder fehlerhaft an Shopify übertragen Shopify-Connector 0
Neu Fehler beim Ticket erstellen - der Wert NULL kann in die dErstellDatum-Spalte nicht eingefügt werden. Servicedesk (Beta) 1
Neu Woher werden die Daten (Anhänge) genommen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Nach zusammenfassen: Auftragspositionen werden falsch sortiert JTL-Wawi - Fehler und Bugs 1
Variationen werden in laufenden Angeboten auf Ebay nihct angezeigt (Version 1.6.44.0) JTL-Wawi 1.6 0
Neu Vorschläge für Umlagerungen in ein FBA Lager, es werden auch Artikel vorgeschlagen, die aktuell keine FBA Artikel sind JTL-Wawi - Fehler und Bugs 0
NEUE Artikel werden nicht nach kaufland und otto übertragen kaufland.de - Anbindung (SCX) 0
Neu Werte aus Variationen werden nicht angelegt JTL-Wawi - Fehler und Bugs 2
Neu Ebay-Artikel können in Eazyauction nicht aktiviert werden eBay-Designvorlagen - Fehler und Bugs 0
Adress-Chaos: Kunden mit vielen Lieferadressen können nie wieder REadr = LIeferAdr werden JTL-Wawi 1.6 4
Artikel werden nicht den Versandklassen zugeordnet JTL-Wawi 1.6 3

Ähnliche Themen