Neu Warenkorb leitet auf Startseite weiter - [Gelöst]

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

Silverbead

Aktives Mitglied
1. Januar 2016
9
0
#1
Halo alle zusammen,

leider funktioniert unser Warenkorb nicht so wie er soll.

Artikel kann man fleißig hinzufügen zum Warenkorb jedoch wenn man auf den Button "zum Warenkorb" geht bzw. auf www.domail.de/warenkorb wird man auf die Startseite weitergeleitet.
Dies tritt nicht mehr auf wenn man mit einem Konto sich einloggt.

Shop läuft ausschließlich über https

Wäre für Hilfe sehr dankbar!

Edit:
Paar Informationen die eventuell weiterhelfen

Hoster: Strato.de
in der config.JTL-Shop.ini ist die domain als https://www.domain.de angegeben
Automatischer Seitenwechsel zu https an (Einstellung 192)
Unregistrierten Bestellvorgang zulassen auf ja (Einstellung 326)
 
Zuletzt bearbeitet:

Walther

Aktives Mitglied
15. Juli 2015
94
2
#2
Hmm, sowas ähnliches hatte ich auch vor längerer Zeit, falls das hilft:

Ich:
beim eingeloggten Kunden in "Mein Konto" gibt es nun eine seitliche Navigation. Die Verlinkung führt aber zu falschen Seiten.
Verlinkt ist "?bestellungen=1" es muss aber noch das jtl.php davor welches abgeschnitten ist. Somit geht der Link auf "http://MEINEDOMAIN.de/?bestellungen=1" anstelle "http://MEINEDOMAIN.de/jtl.php?bestellungen=1"
JTL:
ab der 4.06 gibt's hierfür auch SEO Namen, z.B. wäre es in diesem Fall MeinKonto. Schauen Sie einmal ob im Backend unter Inhalte > Eigene Seiten > (Kopf oder wo Mein Konto hingeschoben wurde) > Meta/Seo > Suchmaschinenname


Vielleicht irgendwo ein / zu viel oder zu wenig?
meine config
mit slash am ende:
define('PFAD_ROOT', '/DOCROOT/');

ohne slash am ende:
define('URL_SHOP', 'https://www.MEINEDOMAIN.de');


Lizenzdomain in JTL-Kundencenter:
- ohne www
- ohne / am Ende


Automatischer Seitenwechsel zu https an (Einstellung 192)
Backendeinstellung 192:
Ich hab diese auf "Kein automatscher Wechsel". Meiner Meinung nach soll der Shop laufen und kein SEO oder Datenschutz machen.
Dies müsste in der .htaccess bereits verboten worden sein ;). so z.B.:
Code:
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*) https://www.%{HTTP_HOST}/$1 [R=301,L]
 
Zuletzt bearbeitet:
Zustimmungen: Silverbead

Silverbead

Aktives Mitglied
1. Januar 2016
9
0
#3
"Schauen Sie einmal ob im Backend unter Inhalte > Eigene Seiten > (Kopf oder wo Mein Konto hingeschoben wurde) > Meta/Seo > Suchmaschinenname"

Vielen Dank! Da war der Fehler vergraben. Ich hatte dort ebenfalls(vor langer Zeit) den Warenkorb in der Fußzeile zusätzlich plaziert und hatte die SEO angaben mit "Warenkorb" befüllt.
Habs rausgenommen und nun gehts wunderbar!
 
Zuletzt bearbeitet: