Verletzung der UNIQUE KEY Einschränkung

  • Ersteller des Themas Ersteller des Themas Litho
  • Erstellungsdatum Erstellungsdatum

Litho

Gut bekanntes Mitglied
17. Juni 2017
344
23
taucht seit dem Upate auf 1.7.9.0 auf

Unbehandelte Ausnahme #2612187C39B89825 vom Typ System.Data.SqlClient.SqlException in Void OnError(System.Data.SqlClient.SqlException, Boolean, System.Action`1[System.Action])
System.Data.SqlClient.SqlException (0x80131904): Verletzung der UNIQUE KEY-Einschränkung "UQ_dbo_tArtikelbildPlattformSeo_kArtikelbildPlattform_kSprache". Ein doppelter Schlüssel kann in das dbo.tArtikelbildPlattformSeo-Objekt nicht eingefügt werden. Der doppelte Schlüsselwert ist (106364, 1).
Die Anweisung wurde beendet.

Das ganze wenn ich einen Artikel aufmache und speichern will, weil ich z.B. die Beschreibung geändert habe.

Der Fehler kam schon bei älteren Versionen vor, aber ich konnte keine Lösung entdecken.... Es gibt auch Artikel die davon nciht betroffen sind.
 

Litho

Gut bekanntes Mitglied
17. Juni 2017
344
23
Lösung selbst entwickelt/geunden/ausprobiert... alle Bilder des Artikels löschen, und neu anlegen und siehe da vielen Dank für die Extraarbeit aber das funktioniert wohl.
 
  • Wow
Reaktionen: Arne Janson

John

Sehr aktives Mitglied
3. März 2012
4.215
1.088
Berlin
...das haben wir definitiv bei mehreren Artikeln. War jetzt bei uns schon der Dritte.

Gibts eine systematischere Lösung des Problems?
 

IT-WEFA

Gut bekanntes Mitglied
3. April 2019
289
22
Prüft mal ob ihr leere Sprachen in tSpracheUse habt.
Also angelegte Sprache ohne ne ISO
 

JohnFrea

Sehr aktives Mitglied
21. September 2017
975
305
Zitat von JTL Support:
Aktuell haben wir leider noch keine Möglichkeit, dieses Problem für alle Artikel auf einmal zu lösen. Es gibt hierzu ein internes Ticket, durch welches das Problem in einem zukünftigen Update gelöst wird.
Die interne Ticketnummer lautet: WAWI-70489
(...)
Von dem Problem ist nur die WAWI-GUI betroffen, in der Ameise gibt es keine Probleme.

Also vermutlich kein Fehler in der Datenbank sondern ein Problem der Wawi. Bin mal gespannt, wann ob/wann es gelöst wird. Mega nervig.
 
  • Gefällt mir
Reaktionen: Nocoma

Nocoma

Aktives Mitglied
30. April 2021
48
16
Also vermutlich kein Fehler in der Datenbank sondern ein Problem der Wawi. Bin mal gespannt, wann ob/wann es gelöst wird. Mega nervig.
Gleiches Problem auch bei uns. Wir haben ebenfalls ein Support Ticket eröffnet. Hoffe, dem Problem wird mehr Priorität geschenkt, da das Löschen echt übel ist, insbesondere, wenn wir auf unterschiedlichen Plattformen andere Bilder verwenden.

Grüße
Dolli
 

FlorianBL

Aktives Mitglied
19. September 2023
11
1
@Manuel Pietzsch könnt Ihr das nicht bitte mit Prio in der 1.7 fixen? Dauernd Bilder löschen ist doh keine Lösung. Es gibt mindestens das interne Ticket WAWI-70489 dazu.
Besonders, wenn die Bilder nicht alle die gleichen Freigaben (Amazon etc.) haben. Dann muss man sich immer erst notieren, für welche Plattform welches Bild freigegeben ist. Und bei teilweise 10 Bildern pro Artikel ist dies ziemlich zeitintensiv.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
9.218
1.958
Entwickler sind am Ticket dran, genaueres kann ich aber noch nicht sagen. Es ist schwer, den Fehler verlässlich zu reproduzieren.
 

Michael Spaltmann

Moderator
Mitarbeiter
2. November 2010
689
158
Hi,

wir haben ein Aufräumscript zum Update auf die 1.8.10 gebaut welche das Problem endgültig lösen sollte. Nach dem Update auf die 1.8.10 sollte der Fehler nicht mehr auftreten. Ich muss Euch also bitten ggf. ein Update zu machen. Falls der Fehler dann allerdings nochmal auftritt brauchen wir ein DB Backup um das nochmal zu untersuchen, aber die Entwicklung war recht zuversichtlich, dass der Fehler behoben ist.

Viele Grüße Michael
 

Michael Spaltmann

Moderator
Mitarbeiter
2. November 2010
689
158
Hi,

das kann ich nicht rausgeben, mach sonst bitte einen Supportcase im KC auf dann schaut sich unser Support das an.

Viele Grüße Michael
 

Ähnliche Themen