Neu Umzug auf neuen Server Datenbankimport

sys010101

Aktives Mitglied
9. März 2015
5
0
Hallo Leute,

also ich bin am Ende, hab mir schon Kopf zerbrochen und verstehe immer noch nicht was mache ich denn falsch. Also es ist ganz normale Umzug von einem Server zum anderen. Datenbank Export und auf dem neuen Datenbank Import, klingt einfach....
Ganz normal über Wawi Interface geht es nicht es hängt einfach. Dann habe ich über die SQL Studio versucht und hier habe ich folgender Fehlermeldung:

TITEL: Microsoft SQL Server Management Studio
------------------------------

Fehler bei der Wiederherstellung von Datenbank "eazybusiness". (Microsoft.SqlServer.Management.RelationalEngineTasks)

------------------------------
ZUSÄTZLICHE INFORMATIONEN:

System.Data.SqlClient.SqlError: Der Sicherungssatz enthält die Sicherung einer anderen Datenbank als der vorhandenen eazybusiness-Datenbank. (Microsoft.SqlServer.SmoExtended)

Hilfe erhalten Sie durch Klicken auf: http://go.microsoft.com/fwlink?Prod....0+((SSMS_Rel_17_4).181117-0805)&LinkId=20476 - Der Link ist natürlich Tod.

------------------------------
SCHALTFLÄCHEN:

OK
------------------------------
Beim Überprüfen der Medien ist alles ok. Sobald auf Import klicke kommt ´zum Fehler.

wawi.JPG
wawi2.JPG
Wawi Versionen sind gleich...
Hat jemad eine Idee?

P.S. Noch eine Frage:

Kann man es zur Not mit Hilfe von Ameise das Ganze zu übertragen?
 
Zuletzt bearbeitet:

mh1

Sehr aktives Mitglied
4. Oktober 2020
1.873
562
Du hast auf dem neuen Server bereits eine eazybusiness. Und jetzt sagst du dem SQL-Server, er soll die Datenbank eazybusiness aus dem Backup wiederherstellen. Das verweigert er, weil er ja dann die andere eazybusiness überschreiben würde.

Wahrscheinlich hast du dich mit der JTL Datenbankverwaltung schon mal am neuen Server angemeldet und eine neue leere eazybusiness erstellt. Kann das sein?
 

mh1

Sehr aktives Mitglied
4. Oktober 2020
1.873
562
Genau.
Du willst doch nur den Server umziehen von Rechner A auf Rechner B.
Dazu darfst du aber die Wawi auf deinem Client noch gar nicht starten. Weil wenn sich die Wawi mit einem Server verbindet, auf dem es noch keine Eazybusiness gibt, wird automatisch eine neue, leere eatybusiness erstellt und genau das willst du doch gar nicht. Du willlst also zuerst deine die eazybusiness aus der Sicherung auf dem Rechner B wiederherstellen.
 
  • Gefällt mir
Reaktionen: recent.digital

Dealux-GmbH

Sehr aktives Mitglied
5. März 2007
8.676
7
Düsseldorf
Wie Michael schon schreibt sollte auf dem neuen Server keine DB vorhanden sein. Du kannst diese aber auch entfernen und neu einspielen oder ggf. überschreiben. Eine Datenübertragung per Ameise ist nicht so ohne weiteres für alle Daten Möglich.
 

Ähnliche Themen