Neu Produktbilder / Sliderbilder werden im NOVAChild nicht dargestellt

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

ahuebler

Offizieller Servicepartner
SPBanner
6. August 2012
37
1
Hallo,

ich habe mir den aktuellsten Master gezogen und das NOVAChild aus dem Git.
Habe ich das NOVA aktiv, werden die Produktbilder überall sauber angezeigt:

1598531154171.png

Aktiviere ich nun das NOVAChild (komplett unmodifiziert) werden die Produktbilder nicht mehr dargestellt (Slider, MegaMenu, Artikelliste, Artikeldetails):

1598531082258.png
Gilt es da noch etwas zu beachten? Problem besteht auch wenn wir ein eigenes Theme erstellen und kompilieren.
 

ahuebler

Offizieller Servicepartner
SPBanner
6. August 2012
37
1
Ja klar ;)

Fehler ist lokalisiert.

Im criticalCSS fehlt:

.square::before {
content: "";
display: inline-block;
padding-bottom: 100%;
}


Das Beispiel-Nova Child aus dem Gitlab importiert in dessen SCSS Files das Critical aus dem NOVA/themes/base, muss aber eigentlich das aus NOVA/themes/clear nutzen.

Haben es bei unserem Test gerade mal umgebaut und nun funktioniert es wie es soll.
 

deliman

Sehr aktives Mitglied
13. Februar 2016
706
49
Also bei mir funktioniert das Child Template aus dem Gitlab ohne sichtbare Fehler... (habe zum 1. Mal selber ein Childtemplate angelegt und scheinbar alles richtig gemacht:)) Ich habe aber auch gleich eigene Testartikel hochgeladen.
 

ahuebler

Offizieller Servicepartner
SPBanner
6. August 2012
37
1
Ja, da hast Du recht. Das klappt auch. Ist nur wenn man die my-nova_crit.css neu kompiliert aus der enthaltenen SCSS.
 

deliman

Sehr aktives Mitglied
13. Februar 2016
706
49
Wo genau muss der Code eingefügt werden (/httpdocs/templates/NOVA-child-vorlage-master/themes/my-nova und da die my-nova_crit.css)? An welcher Stelle oder Zeile muss er dann rein?
Habe mir die aktuelle Master geladen und installiert und jetzt das selbe Problem.
 

ahuebler

Offizieller Servicepartner
SPBanner
6. August 2012
37
1
Wenn Du das CSS aus dem SCSS kompilierst, dann:

NOVAChild/themes/my-nova/sass/my-nova_crit.scss

Dort
@import '../../../../NOVA/themes/base/sass/clear_crit';

durch

@import '../../../../NOVA/themes/clear/sass/clear_crit';

ersetzen.

Wenn Du Deine Anpassungen nur im CSS vornimmst, dann musst den im 1. Beitrag genannten CSS-Code in die
NOVAChild/themes/my-nova/my-nova_crit.css einfügen.
 

deliman

Sehr aktives Mitglied
13. Februar 2016
706
49
Egal was ich mache, ich bekomme die Bilder nicht rein...

Mein Code in der my-nova/sass/my-nova_crit.scss sieht jetzt so aus:

// Lädt Critical CSS aus dem Nova

// Lädt Core-Funktionen
@import '../../../../NOVA/themes/clear/sass/functions';

// Lädt "my-nova"-Variablen. Hier können Variablen aus Bootstrap und dem clear-Theme überschrieben werden.
@import "variables";

// Lädt kritische Style Angaben
@import "../../../../NOVA/themes/clear/bootstrap/scss/functions";
@import "../../../../NOVA/themes/clear/bootstrap/scss/variables";
@import "../../../../NOVA/themes/clear/bootstrap/scss/mixins";
@import "../../../../NOVA/themes/clear/bootstrap/scss/root";
@import "../../../../NOVA/themes/clear/bootstrap/scss/reboot";
//@import "../../clear/bootstrap/scss/type";
@import "../../../../NOVA/themes/clear/bootstrap/scss/images";
@import "../../../../NOVA/themes/clear/bootstrap/scss/code";
@import "../../../../NOVA/themes/clear/bootstrap/scss/grid";
@import "../../../../NOVA/themes/clear/bootstrap/scss/nav";
@import "../../../../NOVA/themes/clear/bootstrap/scss/navbar";

.square::before {
content: "";
display: inline-block;
padding-bottom: 100%;
}

Nach dem Speichern und Übertragen auf den FTP Server, die Caches im Shop gelöscht und die Seite via F5 neu aufgerufen, trotzdem sind keine Bilder sichtbar...
Unter /httpdocs/media/image/product/... werden schon Ordner mit Bildern angezeigt - eigentlich immer das gleiche Bild laut Dateinamen. Da sind scheinbar einige nicht mehr da, die ich mit den anderen Produkten hochgeladen hatte.
 

ahuebler

Offizieller Servicepartner
SPBanner
6. August 2012
37
1
Wenn Du die SCSS Dateien bearbeitest, musst du diese auch kompilieren, damit Dein CSS Code aktualisiert wird. Das kannst Du entweder über eine IDE (zB phpStorm) oder über das Theme-Editor Plugin von JTL.

Wenn Du da keine Möglichkeit hast, schreib es einfach in die genannte my-nova_crit.css des Childtemplates. Dann sollte das auch klappen :)
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
739
117
Chemnitz
Hi @ahuebler,
da müsste auch die Zeile drin sein
Code:
NOVAChild/themes/my-nova/sass/my-nova_crit.scss

Dort
@import '../../../../NOVA/themes/base/sass/clear_crit';

durch

@import '../../../../NOVA/themes/clear/sass/clear_crit';

ersetzen.
vorallem das clear_crit'; das ja nicht in der Datei vorhanden ist, sei den man trägt es nachträglich noch ein, ( besser beschreiben für uns Leihen, Danke, aus der Sicht des Programmierers sieht es immer einfach aus. )
bei mir sieht es jetzt so aus habe es nachträglich eingefügt und kompiliert, Fotos sind jetzt auch wieder da

Code:
// Lädt Critical CSS aus dem Nova

// Lädt Core-Funktionen
@import '../../../../NOVA/themes/base/sass/functions';
@import '../../../../NOVA/themes/clear/sass/clear_crit';

// Lädt "my-nova"-Variablen. Hier können Variablen aus Bootstrap und dem clear-Theme überschrieben werden.
@import "variables";


// Lädt kritische Style Angaben
@import "../../../../NOVA/themes/base/bootstrap/scss/functions";
@import "../../../../NOVA/themes/base/bootstrap/scss/variables";
@import "../../../../NOVA/themes/base/bootstrap/scss/mixins";
@import "../../../../NOVA/themes/base/bootstrap/scss/root";
@import "../../../../NOVA/themes/base/bootstrap/scss/reboot";
//@import "../../base/bootstrap/scss/type";
@import "../../../../NOVA/themes/base/bootstrap/scss/images";
@import "../../../../NOVA/themes/base/bootstrap/scss/code";
@import "../../../../NOVA/themes/base/bootstrap/scss/grid";
@import "../../../../NOVA/themes/base/bootstrap/scss/nav";
@import "../../../../NOVA/themes/base/bootstrap/scss/navbar";
und diese Variable funktioniert nicht ( datei: _variables.scss im Theme Editor )
Code:
//
// Platz für eigene Variablen in SCSS-Notation
//
// Alle Änderungen hier müssen anschließend mit einem SCSS-Compiler
// (z.B. dem JTL-Theme-Editor Plugin) nach my-nova.css kompiliert werden
// --------------------------------------------------

// my-nova Theme
// Hier können alle Variablen notiert werden, die nur Auswirkungen auf dieses Theme haben
// -------------------Beginn eigene Variablen----------------------------------

:root {

  --primary: #FF6600;
}



// -------------------Ende eigene Variablen----------------------------------

// Lädt clear-Variablen
@import '../../../../NOVA/themes/clear/sass/variables';

// passt die Pfade an
$nova-theme-path:                   "../../../NOVA/themes";
$fa-font-path:                      "../../../NOVA/themes/base/fontawesome/webfonts";
wenn ich im Browser auf Untersuchen schaue, dann zeigt der Browser einen Fehler an, obwohl die Datei da ist und auch kompiliert :)
anbei mal das Foto

primärfarbe.jpg

grüssle MArio
 

M.Stickel

Moderator
Mitarbeiter
9. Februar 2016
286
37
Hi,
seit letzten Donnerstag (27.08) sollte das critical CSS im Novachild drin sein. Dort ist auch der Code zu den Bilder zu finden. Also bitte nochmal das Novachild aktualisieren.

@basteldehs die Variable für die Primärfarbe ist "$primary", dann das theme kompilieren und alles sollte laufen.
 
  • Gefällt mir
Reaktionen: basteldehs

basteldehs

Sehr aktives Mitglied
27. Februar 2017
739
117
Chemnitz
wie lange sollte sich der Lade-Spinner am „Theme kompilieren“-Button aufgehört hat drehen.
er dreht sich gerade schon ca. 3min. wenn ich die einzelnen Datein Kompiliere unten ( Datei kompilieren ) das geht schnell, aber jedoch bei kompletten Theme kompilieren, dauert.

achso und kann ich die Variable auch in meine custom.scss rein tun?
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
132
42
Das ist nicht normal. Ich nehme an, es gibt Fehler in der Entwicklerkonsole? Ist der Theme Editor aktuell? Da gab es vor ein paar Tagen noch fixes..
 

deliman

Sehr aktives Mitglied
13. Februar 2016
706
49
Habe mir die neuen Child Daten noch mal runtergeladen und eingespielt, Theme compiliert und auch eine Farbe geändert, Theme neu compiliert und bei mir dauert es nur jeweils ein paar Sekunden und jetzt sind auch die Produktbilder wieder da.

Was ich mir noch wünsche ist, das die Beschriftung und Inhalte von weiteren Tabs (via Artikellattribute) ab dem 2. zusätzlichen Tab wirklich mehrsprachig nutzbar sind. Aktuell ist nur der 1. zusätzliche Tab mehrsprachig nutzbar - so wie leider bislang im 4er Shop auch (nur).
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
739
117
Chemnitz
also das Child habe ich auch nochmals hochgeladen und installiert.
Jedoch das mit den Themes kompilieren klappt nicht, rödelt und rödelt - die einzelnen Datein kompilieren klappt auch nur eben bei komplett kompilierung

Muss da noch was am Server eingestellt werden ?
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Keine Produktbilder Allgemeine Fragen zu JTL-Shop 9
Neu Kundengruppen Rabatt im Artikel kann nicht gelöscht werden JTL-Wawi - Fehler und Bugs 5
Neu Artikel werden nicht importiert, weil in Aufträgen "reserviert" Schnittstellen Import / Export 1
Neu Webshop Abgleich kann nicht gestartet werden Onlineshop-Anbindung 0
Neu Woocommerce Connector 1.16.x / Bestände werden nicht aktualisiert WooCommerce-Connector 0
In Bearbeitung Kein Initialer Import von Amazon Bestellungen? Nur neue Bestellungen werden abgeholt Amazon-Anbindung - Fehler und Bugs 3
Neu wawi 1.5.37 Achtung, Rechnungen können unter umständen nicht mehr erstellt werden JTL-Wawi - Fehler und Bugs 4
Neu Veränderungen im Grundauftrag eines Abonnements werden nicht übernommen JTL-Wawi - Fehler und Bugs 0
Neu Rechnungs und andere Formulare - Tabelle rechts mit Total kann nicht gut angepasst werden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Kategoriebilder werden nicht angezeigt Einrichtung von JTL-Shop4 1
Gelöst Import ohne Kategorie - Artikel kann nicht bearbeitet oder gelöscht werden JTL-Ameise - Fehler und Bugs 3
Neu Werte der Kattegorie-Attribute (Google Shopping) werden gelöscht - Connector 2.8.5 Shopware-Connector 0
Neu Kundenstammdaten änderungen werden geloggt? Installation von JTL-Wawi 0
Neu Artikel hat neue Bilder, alte werden angezeigt, obwohl Ordner auf FTP nicht exisitiert JTL-Shop - Fehler und Bugs 0
Neu Aufträge dürfen nicht zusammengeführt werden JTL-Wawi - Fehler und Bugs 6
Neu Bilder werden Artikeln nicht zugeordnet Shopware-Connector 4
Verwiesen an Support Diese Bestellung darf nicht geändert werden..... JTL-Workflows - Fehler und Bugs 1
Gelöst Ausgewählte sprachen werden im Shop nicht angezeigt Onlineshop-Anbindung 2
Neu Aus Abonnements erzeugte Aufträge werden sofort als "versandt" markiert JTL-Wawi - Fehler und Bugs 0
Neu Frisch vergebene Rechnungen können nicht per Zahlungsmodul bezahlt werden JTL-Wawi - Fehler und Bugs 0
Neu NOVA: Namen der Unterkategorien werden abgeschnitten Einrichtung von JTL-Shop4 1
Neu Neue Preise werden nicht abgeglichen Shopify-Connector 3
Gelöst Amazon Aufträge werden nicht abgeholt. Server 500 Fehler Amazon-Anbindung - Fehler und Bugs 18
Neu Ebay Angebotsimport - VarKombis können nicht zugeordnet werden eBay-Anbindung - Fehler und Bugs 0
Neu Mail werden nicht versendet JTL-Shop - Fehler und Bugs 5
In Bearbeitung Der Jtl-Shipping Server kann nicht erreicht werden JTL-ShippingLabels - Fehler und Bugs 2
Neu Bilder werden nicht mehr übertragen WooCommerce-Connector 0
Neu Artikelnummern werden nicht fortlaufend vergeben (Update 08.01. 10:14) User helfen Usern - Fragen zu JTL-Wawi 0
Neu Position auf Pickliste. Kann nicht gelöscht werden ! Arbeitsabläufe in JTL-Wawi 8
Neu Rechnungskorrekturen werden seit November nicht mehr von Amazon abgeholt Amazon-Anbindung - Fehler und Bugs 17
Neu Paypal Zahlungen werden nicht mehr übertragen Shopware-Connector 0
Neu Hilfe, Artikeldaten werden nicht mehr aktualisiert Shopware-Connector 14
Neu Artikelbilder werden nicht angezeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Verkaufseinheiten / Maßeinheiten werden nicht übernommen Shopware-Connector 0
Neu Stückliste mit Artikel die nicht angezeigt werden JTL-Wawi - Ideen, Lob und Kritik 2
Neu Auslands-Adressen werden eigenmächtig von JTL geändert und werden damit unzustellbar [WAWI-43207] JTL-Wawi - Fehler und Bugs 0
Neu Shopkonfiguration - Cross-Sellings etc. werden nicht synchronisiert Shopify-Connector 7
Neu Fokus springt standardmäßig im Warenkorb immer nach oben, wenn z.B. Mengen geändert werden Betrieb / Pflege von JTL-Shop 1
Neu 2 Lager nur 1 darf mit zum Online-Shop synchronisiert werden User helfen Usern - Fragen zu JTL-Wawi 3
Neu geändert Artikelpreise werden nicht zu eBay übertragen eBay-Anbindung - Fehler und Bugs 0
Neu Texte werden nicht aktualisiert (aktuell Attribute) Shopware-Connector 0
Neu Artikel und Unterkategorien werden im Shop nicht anzeigt Allgemeine Fragen zu JTL-Shop 4
Neu Preisliste kann nicht gedruckt werden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Neu WaWi preise geändert aber im Shop werden die alten angezeigt Arbeitsabläufe in JTL-Wawi 3
In Diskussion Großbritannien Label werden nicht gedruckt JTL-ShippingLabels - Fehler und Bugs 2
Neu Artikel Steuersatz Änderungen werden nicht gespeichert JTL-POS - Fehler und Bugs 3
Neu Bilder werden im Shop nicht konvertiert & angezeigt Installation / Updates von JTL-Shop 2
Neu Shop 5: Firmenlogo kann nicht ausgewählt werden JTL-Shop - Fehler und Bugs 2
Neu Bilder werden nicht dargestellt Einrichtung von JTL-Shop4 26
Neu Amazon Angebote werden nicht aktualisiert User helfen Usern - Fragen zu JTL-Wawi 2
Ähnliche Themen