PHP Fehler nach Update - Sitemapexport

schnatz

Aktives Mitglied
9. Februar 2015
49
11
Moin zusammen,

nach dem Update von 4.06 auf 5.0.1 (auf einem Testsystem) bekomme ich ein HTTPERROR 503 mit folgendem Fehler im Log:

PHP Fatal error: Uncaught InvalidArgumentException: Provided link id 135 not found. in /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/Link.php:284
Stack trace:
#0 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/Link.php(1209): JTL\\Link\\Link->load()
#1 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/Link.php(392): JTL\\Link\\Link->buildChildLinks()
#2 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/LinkList.php(100): JTL\\Link\\Link->map()
#3 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/vendor/lstrojny/functional-php/src/Functional/Map.php(31): JTL\\Link\\LinkList->JTL\\Link\\{closure}()
#4 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/LinkList.php(107): Functional\\map()
#5 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/LinkGroup.php(132): JTL\\Link\\LinkList->createLinks()
#6 /var/www/vhosts/matthiasschn in /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/Link.php on line 284

Über die Datenbank, tlink kam ich darauf, dass es sich da um den Link zur sitemap handeln sollte, also habe ich versucht, diese im Backend neu zu erstellen, mit ähnlichem Ergebnis

PHP Fatal error: Uncaught InvalidArgumentException: Provided link id 135 not found. in /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/Link.php:284, referer: https://DOMAIN/admin/sitemapexport.php
Stack trace:, referer: https://DOMAIN/admin/sitemapexport.php
#0 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/Link.php(1209): JTL\\Link\\Link->load(), referer: https://DOMAIN/admin/sitemapexport.php
#1 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/Link.php(392): JTL\\Link\\Link->buildChildLinks(), referer: https://DOMAIN/admin/sitemapexport.php
#2 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/LinkList.php(100): JTL\\Link\\Link->map(), referer: https://DOMAIN/admin/sitemapexport.php
#3 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/vendor/lstrojny/functional-php/src/Functional/Map.php(31): JTL\\Link\\LinkList->JTL\\Link\\{closure}(), referer: https://DOMAIN/admin/sitemapexport.php
#4 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/LinkList.php(107): Functional\\map(), referer: https://DOMAIN/admin/sitemapexport.php
#5 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Sitemap/Factories/Page.php(59): JTL\\Link\\LinkList->createLinks(), referer: https://DOMAIN/admin/sitemapexport.php
#6 /var/www/vhosts/matth in /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Link/Link.php on line 284, referer: https://DOMAIN/admin/sitemapexport.php

Jemand eine Idee, was da los ist?

Danke und Gruß,
Matthias
 

FMoche

Moderator
Mitarbeiter
15. Dezember 2014
941
154
Halle (Saale)
Da scheint bei dir irgendwas mit der Hierarchie nicht mehr zu stimmen.
Kann es sein, dass es einen Kinderlink mit nicht mehr existierendem Vater gibt?

Bekommst du ein Ergebnis, wenn du die Query
Code:
SELECT * FROM tlink WHERE kVaterLink > 0 AND kVaterLink NOT IN (SELECT kLink FROM tlink)
ausführst?
 

schnatz

Aktives Mitglied
9. Februar 2015
49
11
Darauf bekomme ich kein Resultat.
Tatsächlich ist in tlink der klink Eintrag 135 zur Sitemap der einzige, wo in der Spalte kVaterLink nicht 0 steht. Der angebliche Vaterlink 50 verweist auf die Versandinformationen, warum auch immer...
Habe diesen kVaterLink nun mal manuell auf 0 gesetzt, damit verschwindet dieser PHP-Fehler, aber nur um Platz für einen weiteren zu machen:

PHP Fatal error: Uncaught TypeError: Return value of JTL\\Cart\\Cart::getShippingCountry() must be of the type string, null returned in /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Cart/Cart.php:2019
Stack trace:
#0 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/letzterInclude.php(188): JTL\\Cart\\Cart->getShippingCountry()
#1 /var/www/vhosts/DOMAIN/httpdocs/jtl5/wartung.php(13): require('/var/www/vhosts...')
#2 /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/globalinclude.php(127): require_once('/var/www/vhosts...')
#3 /var/www/vhosts/DOMAIN/httpdocs/jtl5/index.php(6): require('/var/www/vhosts...')
#4 {main}
thrown in /var/www/vhosts/DOMAIN/httpdocs/jtl5/includes/src/Cart/Cart.php on line 2019

EDIT:
Bin inzwischen einen Schritt weiter beim nächsten Problem:
Wartungsmodus einmal deaktiviert, Seite lässt sich zum ersten mal laden, dann bin ich wieder in Wartung gegangen, in der Erwartung, wie in 4.06 üblich den Shop trotzdem zu sehen, solang ich im Backend als admin eingeloggt bin. Das scheint aber nicht zu klappen!?
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu Variationen nicht wählbar (io.php error) JTL-Shop - Fehler und Bugs 1
Neu /admin/bestellungen.php weiß JTL-Shop - Fehler und Bugs 1
Neu PHP 8 nicht kompatibel? WooCommerce-Connector 0
Neu bildverwaltung.php funktioniert nicht. (Shop 5) Einrichtung von JTL-Shop4 0
Neu Welche PHP-Version mindestens notwendig? Shopware-Connector 1
Neu Shipping Fehler: An item with the same key has already been added. JTL-ShippingLabels - Fehler und Bugs 1
Neu eBay Upload Fehler XML error eBay-Anbindung - Fehler und Bugs 0
Neu Fehler in Leitcodierung - Falsche PLZ User helfen Usern - Fragen zu JTL-Wawi 0
Installation erfolgreich, aber OnpageComposer gibt nur Fehler aus Einrichtung JTL-Shop5 1
Beantwortet Amazon Abgleich - Fehler [Gelöst] Amazon-Anbindung - Fehler und Bugs 1
Neu JTL Shop5 - Wawi Anbindung Fehler Onlineshop-Anbindung 0
Neu Login Fehler WaWi User helfen Usern - Fragen zu JTL-Wawi 5
Neu Amazon - Variante konnte der SKU des übergeordneten Artikels nicht zugeordnet werden Fehler: 8801 Amazon-Lister - Fehler und Bugs 0
Gelöst Fehler größer als JTL-Workflows - Fehler und Bugs 3
Neu WAWI DB Update Fehler eines Mandanten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Abgleich JTL nach WooCommerce User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Abgleich: Der Remoteserver hat einen Fehler zurückgegeben: (504) Gatewaytimeout. WooCommerce-Connector 0
Neu Fehler bei Datenbanksicherung JTL-Wawi - Fehler und Bugs 1
Neu Kunden Login Fehler Undefined index: kundenlogin_max_loginversuche in ... JTL-Shop - Fehler und Bugs 1
Neu Fehler beim Abgleich: Exception: Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded WooCommerce-Connector 5
In Bearbeitung Datevconnect Rechnungsdatenservice: Fehler beim erstellen des XML übertragungsformates [WAWI-51803] Schnittstellen Import / Export 2
In Bearbeitung Undefinierter Fehler / Absturz bei Bon starten JTL-POS - Fehler und Bugs 7
Gelöst TSE Anbindung TM-30 Fehler "TSE1_ERROR_SIG_ERROR" Einrichtung / Updates von JTL-POS 1
Beantwortet LS POS 2.0.0 Fehler - keine Kassen-OID Fragen rund um LS-POS 1
Abgelehnt Unexpected character encountered FEHLER Gelöste Themen in diesem Bereich 1
Neu Unexpected character encountered FEHLER JTL-ShippingLabels - Fehler und Bugs 2
Neu 500 Remote Server Fehler Amazon-Anbindung - Fehler und Bugs 7
Neu EBAY FEHLER Die datediff-Funktion hat zu einem Überlauf geführt. Die Anzahl von datepart-Werten, die zwei Datums-/Uhrzeitinstanzen trennen,ist zu groß JTL-Wawi - Fehler und Bugs 2
Neu Exportdokumente Fehler bei Auftragswert 0 für DHL und Warenpost International User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim hochladen mit der Ameise JTL-Ameise - Fehler und Bugs 10
Gelöst Fehler beim Mailversand JTL-Shop - Fehler und Bugs 1
Neu Internetmarke Fehler Code 9000003 JTL-ShippingLabels - Fehler und Bugs 5
Neu Fehler 0 in Kategoriebeschreibung Onlineshop-Anbindung 0
Neu Wawi Print Log Beim Exportieren ist ein Fehler aufgetreten Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Fehler bei erster Anbindung eBay-Anbindung - Fehler und Bugs 2
Neu Fehler bei der Installation + Datenbank Installation von JTL-Wawi 4
Neu Fehler beim Abgleich neu eingestellter Produkte. JTL-Wawi - Fehler und Bugs 0
In Bearbeitung Fehlercode 6039 und SKU / GCID Fehler Amazon-Anbindung - Fehler und Bugs 6
JTL Shop 5 unter "localhost" Fehler beim Setzen des Cookies Einrichtung JTL-Shop5 0
In Bearbeitung Es ist ein Fehler aufgetreten! JTL-muss beendet werden.1.0.3.12 (3573) Einrichtung / Updates von JTL-POS 1
Neu Shop 5.0.1: Artikel in 1. Kat führt zu Fehler 500 JTL-Shop - Fehler und Bugs 5
Neu Product-Stream Fehler nach dem Sliden JTL-Shop - Fehler und Bugs 1
Neu Fehler Shopabgleich WooCommerce-Connector 0
Neu Shop 5 - Nova Template Umlaute/Sonderzeichen Fehler im Kundenmenü/Registrierung Templates für JTL-Shop 8
In Bearbeitung Fehler in JTL-POS-Display App JTL-POS - Fehler und Bugs 1
Neu 5.0.1 - Fehler OnPage Composer JTL-Shop - Fehler und Bugs 0
Neu IDU Upload Fehler Schnittstellen Import / Export 9
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 2
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 0

Ähnliche Themen