Neu PayPal Namenszuweisung seit WAWI 1.5.9.0 nicht mehr vorhanden

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

3po

Sehr aktives Mitglied
30. August 2011
2.506
70
Gestern haben wir das Update auf die WAWI Version 1.5.9.0 gemacht, seither stimmen die Zuweisungen der Namen nicht mehr, bzw. es findet keine mehr statt, alles heißt wie in SW intern "SwagPaymentPayPalUnified". Es wird nicht mehr automatisch auf "PayPal-Plus" oder "PayPal Express" geändert.

Es ist zwar im Zahlungs-Fenster (in den Auftrag Details) unter Name noch der richtige Name drin, aber nicht als Zahlungsart und auch nicht in den Auftrag-Details als Zahlungsart, dort steht beides mal "SwagPaymentPayPalUnified" und das wird dann auch so auf die Rechnung gedruckt :(
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
943
201
Hallo @3po,

grundsätzlich sollten Paypal Zahlungen ordentlich im Connector gemapped werden. Kannst du mir einen RPC- Log oder Onlineshop Abgleich-Log mit einer solchen Zahlung per PM zuschicken?
 

tiroled

Gut bekanntes Mitglied
27. Dezember 2015
204
20
Wir können diesen Fehler auch in der 1.5.10.0 reproduzieren.

Man kann zwar den Namen in der Einstellung ändern, aber bei der nächsten Synchronisierung wird immer automatisch eine neue Zahlungsart "SwagPaymentPayPalUnified" erstellt.

Hallo @3po,

grundsätzlich sollten Paypal Zahlungen ordentlich im Connector gemapped werden. ...
Wo genau kann man das Mapping für die Zahlungsarten einstellen?

WaWi 1.5.10.0 / Connector 2.2.4 / SW 5.6.2
 

vicalbert

Aktives Mitglied
28. März 2017
5
0
Wir haben dieses Problem auch. Seit Update auf 1.5.9.0 werden alle Zahlungsarten nicht mehr gemappt. Gleiches Problem übrigens auch mit dem Oxid Connector.
 

3po

Sehr aktives Mitglied
30. August 2011
2.506
70
Ich habe aktuell keine Zeit Logs zu erstellen und zu senden da ich auf Schulung bin, das Problem existiert aber immer noch 1.5.10 und muss dringend gefixt werden. Aktuell muss JEDE Bestellung händisch nachgearbeitet werden, per Workflow ist ein ändern nicht möglich das der Name nicht als Variable bei den Zahlungen verfügbar ist.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
943
201
Wichtig für uns ist zu wissen ob die falsche Bezahlart durch Bestell- oder Zahlungs-Import in die Wawi gelangt. Daher wäre ein Onlineshop Abgleich Log mit entsprechenden Daten schon sehr hilfreich.
 

vicalbert

Aktives Mitglied
28. März 2017
5
0
Also ein komplettes Log um Kundendaten zu bereinigen fehlt mir auch die Zeit. Zum Log Inhalt kann ich beitragen:
Beim Bestellimport /customer_order.pull) sind zumindest noch beide Bezeichnungen vorhanden: "key":"swagPaypalUnifiedPaymentType","value":"PayPalExpress" und zudem "paymentModuleCode":"pm_paypal_plus"
Der Import der Zahlung kennt nur "paymentModuleCode":"SwagPaymentPayPalUnified" (passt nicht zum ModuleCode aus dem Bestellimport, falls das eine Rolle spielt).

Wie bereits erwähnt haben wir das gleiche Problem beim Import aus Oxid. Daher denke ich, dass das Problem bei JTL nachstellbar sein sollte.
 

3po

Sehr aktives Mitglied
30. August 2011
2.506
70
Error
Unable to update "jtlconnector", an unknown error occured.

EDIT: Nach der Fehlermeldung hat sich das Plugin deaktiviert! Ich habe es händisch wieder aktiviert, hoffe es kommt hier nicht zu weiteren Fehlern. Es lässt sich also derzeit nicht aktualisieren.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
943
201
Da war tatsächlich ein Fehler im Update Vorgang. Wir haben das Problem behoben, das Connector Update sollte nun funktionieren.
 
Zuletzt bearbeitet:

3po

Sehr aktives Mitglied
30. August 2011
2.506
70
Ok update ging jetzt wieder und die ersten PayPal Bestellungen mit richtiger Zuweisung sind auch schon da :)
 

vicalbert

Aktives Mitglied
28. März 2017
5
0
Die Namenszuweisung hat nun auch bei uns funktioniert, allerdings hat der Connector nun ein Problem mit bestehenden Kundenstammdaten: Kunde xy hat bereits bestellt und es existiert ein Stammdatensatz in Shopware (Schnellbesteller ohne Kundenlogin). Der Kunde bestellt nun erneut und Shopware legt einen neuen Stammdatensatz an (weil wieder Schnellbesteller ohne Kundenlogin). Der Connector arbeitet sich nun ewig mit dem customer.pull an beiden Kunden-Datensätzen ab (warum auch immer der vorherige Kundendatensatz nochmals übermittelt wird) und legt den ganzen Shop lahm, ohne das Daten in die Wawi übermittelt werden.
Im Log erscheinen endlos und immer wieder die gleichen Einträge zu den beiden Stammdatensätzen.
Bsp. eines solchen customer.pull:
<<< customer.pull: {"result":[{"customerGroupId":["1",0],"id":["123",0],"accountCredit":0,"birthday":null,"city":"xx","company":"","countryIso":"DE","creationDate":"2019-11-11T00:00:00+0100","customerNumber":"xy","deliveryInstruction":"","discount":0,"eMail":"xxx","extraAddressLine":"","fax":"","firstName":"xxx","hasCustomerAccount":false,"hasNewsletterSubscription":false,"isActive":true,"languageISO":"ger","lastName":"xx","mobile":"","note":"","origin":"","phone":"","salutation":"m","state":"","street":"xxx","title":"","vatNumber":"","websiteUrl":"","zipCode":"xxx","attributes":[]}],"error":null,"jtlrpc":"2.0","id":"xy"}
(208,8458 milliseconds)
<<< core.connector.ack: {"result":true,"error":null,"jtlrpc":"2.0","id":"xy"}
(193,0308 milliseconds)

Ich habe nun wieder die vorherige Connector Version installiert, da gibt es dieses Problem nicht. Grundsätzlich verstehe ich das Connector Update auch nicht ganz, denn das Problem ist mit dem Update der Wawi aufgetaucht und besteht somit beim Oxid Connector weiterhin.
 

vicalbert

Aktives Mitglied
28. März 2017
5
0
@vicalbert Wie hast Du das vorherige plugin installiert? Gab es keine Probleme?
Im Shop das alte Plugin deinstallieren (ggf. vorher die Einstellung im Plugin ändern, damit die Linking Tabellen nicht gelöscht werden). Die alte Version habe ich dann über den Shopware Account in der Shop Verwaltung herunterladen können. Bei mir gab es keine Probleme (obwohl ich versehentlich die o.g. Linking Tabellen geleert hatte)
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
In Diskussion Paypal Erstattung per Workflow JTL-Workflows - Ideen, Lob und Kritik 0
Issue angelegt Paypal Problem mit Versandart Plugins für JTL-Shop 4
Neu PayPal Transaktions-ID auf Rechnung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Paypal Plus Plugin, welche Daten werden bei Zahlungsart an Paypal übertragen? Plugins für JTL-Shop 1
Neu Zuordnung Paypal Zahlungen User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Paypal und Shopname Plugins für JTL-Shop 2
Beantwortet Zahlung per PayPal Plus Plugins für JTL-Shop 4
Neu JTL PayPal doppelte Buchungen Plugins für JTL-Shop 2
Neu PayPal Zahlung nicht geklappt. Wie geht es dann weiter? Allgemeine Fragen zu JTL-Shop 8
Neu Bei PayPal Zahlungen wird falsch gerundet z.B. -0,01 Zahlung offen JTL-Shop - BETA - Feedback und Bugmeldungen 11
Neu Paypal Plus Plugins für JTL-Shop 3
Neu PayPal Integration User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Paypal Plugin JTL-Shop - BETA - Feedback und Bugmeldungen 19
Gelöst PayPal Express - Fehler im Log Plugins für JTL-Shop 2
Neu Plötzlich kein Paypal Plus mehr Allgemeine Fragen zu JTL-Shop 3
Gelöst JLT-Paypal: Express-Button legt Artikel in Warenkorb statt zu PP weiterzuleiten Plugins für JTL-Shop 0
Neu Paypal Zahlungsart unterscheiden Individuelle Listenansichten in der JTL-Wawi 0
Neu PayPal Zahlungen fehlerhaft (Name fehlt) Smalltalk 0
Neu Paypal QR Code teilweise in US$ Statt in € Arbeitsabläufe in JTL-Wawi 3
Neu Auftrag per Paypal bezahlt wird aber nicht in der Wawi zugeordnet User helfen Usern - Fragen zu JTL-Wawi 3
Neu LS-Pos und PayPal Fragen rund um LS-POS 2
In Bearbeitung Paypal erstatten funktioniert nicht mehr JTL-Wawi - Fehler und Bugs 2
Neu Zahlungsart auf Rechnung zeigt Paypal-Text, soll aber Überweisungstext anzeigen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 5
Neu Paypal + Überweisung Zahlungslink (QR Code) auch auf Auftrag anzeigen lassen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Gelöst Theme Editor und Paypal Plugin JTL-Shop - BETA - Feedback und Bugmeldungen 15
Issue angelegt Seit Update auf 1.5.34.0 funktioniert Auftragimport nicht mehr Gelöste Themen in diesem Bereich 1
Neu Hilfe! Seit gestern kein Labeldruck mit DHL und Warenpost möglich - "Der JTL-ShippingLabelsServer kann nicht erreicht werden, bitte versuchen Sie..." User helfen Usern - Fragen zu JTL-Wawi 6
Gelöst Amazon Abgleichsfehler seit 5:27, bei noch jemanden? eBay-Anbindung - Fehler und Bugs 1
Neu Neue Bilder werden seit 1.5.31.0 nicht mehr (immer) gedruckt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
In Bearbeitung Seit dem Update ..... keine automatische Rechnung / Versandlabel Erstellung mehr JTL-Wawi - Fehler und Bugs 2
Neu Amazon Sendungsnummer wird seit dem 2.11.2020 nicht mehr übertragen Amazon-Anbindung - Fehler und Bugs 5
In Bearbeitung Aufträge landen seit neuem alle in "offene" JTL-Wawi - Fehler und Bugs 5
Neu Aufträge aus POS fehlen seit 2 Tagen Gelöste Themen in diesem Bereich 6
Neu Wunschpaket Bug seit Anfang August bekannt Plugins für JTL-Shop 0
Neu Die Funktion "Versanddaten exportieren" geht seit dem Oktoberwochendende nicht mehr JTL-ShippingLabels - Fehler und Bugs 1
Neu Synchronisation beendet sich nicht mehr seit Update auf 1.5.30.3 Shopify-Connector 2
Gelöst E-Mail Adresse bei Kunden seit neuestem xxx@members.ebay.com eBay-Anbindung - Ideen, Lob und Kritik 4
Neu Harmonized Label lässt sich seit 1.5.30.2 nicht mehr drucken JTL-ShippingLabels - Fehler und Bugs 1
Gelöst Ihr seit die Besten :-) Gelöste Themen in diesem Bereich 5
Neu Brutto/Netto bei Versand falsch seit Update auf 1.12 - gelöst WooCommerce-Connector 0
In Bearbeitung Teilweise doppelt erstellte Aufträge in der Wawi seit 1.0.2.1 JTL-POS - Fehler und Bugs 18
In Bearbeitung Kein abgleich mehr seit gestern 01.09.20 JTL-Repricer für JTL-Wawi und Web 6
In Bearbeitung 3 neue Problemchen seit 1.0.2.0 JTL-POS - Fehler und Bugs 11
In Bearbeitung Immer wieder Überverkäufe seit Wawi 1.5.26.0 bei Ebay eBay-Anbindung - Fehler und Bugs 4
Gelöst DHL Absender alternativ Adresse von Geschäftskundenportal wird seit heute nicht mehr übernommen Gelöste Themen in diesem Bereich 3
Ähnliche Themen