Nach Update auf Shop 5 kommt HTTP ERROR 500

Bastian Weber

Gut bekanntes Mitglied
27. Juni 2017
124
18
Hallo zusammen,

ich habe eben das Update von Shop 4 auf 5 gemacht.
Komplett so, wie es im Guide beschrieben ist.
Jetzt erhalte ich lediglich die Info

Diese Seite funktioniert nicht​

madyes.com kann diese Anfrage momentan nicht verarbeiten.​

HTTP ERROR 500

Sowohl auf der Hauptseite, als auch bei der /admin, um mich ins Backend einzuloggen.

Ich habe vorher Shop und Wawi aktualisiert, von allem ein Backup erstellt und bin wie gesagt, genau nach Anleitung vorgegangen.
Jemand eine Ahnung, woran es liegen kann?
 

Bastian Weber

Gut bekanntes Mitglied
27. Juni 2017
124
18

Camping123

Aktives Mitglied
18. Februar 2011
13
0
Da hier nicht mehr geantwortet wurde, hier die Lösung, welche bei mir geholfen hat.
Mir wurde ebenfalls der 500er Fehler angezeigt.
Ich habe im Backend den Template und Objekt Cache gelöscht.
Problem gelöst.

Ich hoffe, dass ich weiterhelfen konnte.
 

Bastian Weber

Gut bekanntes Mitglied
27. Juni 2017
124
18
Die Frage war wird angezeigt wenn das error_reporting aktiviert wird.
Das Problem ist zum Glück gelöst. Jetzt habe ich das Update auf 5.2.2 gemacht (Drama). Jetzt habe ich im Backend diese Fehlermeldungen:


Deprecated: JTL\ShopBC::getConfig is deprecated - use JTL\Shop::getSettings() instead. in /www/htdocs/w0179d00/madyes.com/includes/src/ShopBC.php on line 296

Warning
: session_name(): Session name cannot be changed after headers have already been sent in /www/htdocs/w0179d00/madyes.com/includes/src/Router/Middleware/UpdateCheckMiddleware.php on line 54

Warning
: session_id(): Session ID cannot be changed after headers have already been sent in /www/htdocs/w0179d00/madyes.com/includes/src/Router/Middleware/UpdateCheckMiddleware.php on line 55

Warning
: session_start(): Session cannot be started after headers have already been sent in /www/htdocs/w0179d00/madyes.com/includes/src/Router/Middleware/UpdateCheckMiddleware.php on line 56

Warning
: session_name(): Session name cannot be changed after headers have already been sent in /www/htdocs/w0179d00/madyes.com/includes/src/Router/Middleware/UpdateCheckMiddleware.php on line 61

Warning
: session_id(): Session ID cannot be changed after headers have already been sent in /www/htdocs/w0179d00/madyes.com/includes/src/Router/Middleware/UpdateCheckMiddleware.php on line 62

Warning
: session_name(): Session name cannot be changed after headers have already been sent in /www/htdocs/w0179d00/madyes.com/includes/src/Session/AbstractSession.php on line 34

Warning
: session_start(): Session cannot be started after headers have already been sent in /www/htdocs/w0179d00/madyes.com/includes/src/Session/AbstractSession.php on line 116

Warning
: Cannot modify header information - headers already sent by (output started at /www/htdocs/w0179d00/madyes.com/includes/src/ShopBC.php:296) in /www/htdocs/w0179d00/madyes.com/includes/src/Session/AbstractSession.php on line 105
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.658
2.710
Berlin
Firma
css-umsetzung
Einfach wieder alles auf 0 setzen

https://guide.jtl-software.de/jtl-s...-jtl-shop-abgleich-angezeigt-was-soll-ich-tun
Code:
//enables printing of warnings/infos/errors for the shop frontend
define('SHOP_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the dbeS sync
define('SYNC_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the admin backend
define('ADMIN_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the smarty templates
define('SMARTY_LOG_LEVEL', 0);
//excplicitly show/hide errors
ini_set('display_errors', 0);
 

Bastian Weber

Gut bekanntes Mitglied
27. Juni 2017
124
18
Einfach wieder alles auf 0 setzen

https://guide.jtl-software.de/jtl-s...-jtl-shop-abgleich-angezeigt-was-soll-ich-tun
Code:
//enables printing of warnings/infos/errors for the shop frontend
define('SHOP_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the dbeS sync
define('SYNC_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the admin backend
define('ADMIN_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the smarty templates
define('SMARTY_LOG_LEVEL', 0);
//excplicitly show/hide errors
ini_set('display_errors', 0);
Besten Dank. Das sieht jetzt alles schon mal wieder so aus, wie es soll. Hoffe es kommen nicht noch weitere Probleme. Das Update auf 5.2.2 hat nicht wirklich Freude bereitet 😉 Danke dir für die Mühe!
 

mr.youngchicken

Gut bekanntes Mitglied
12. Dezember 2016
127
2
Hallo, hatte heute das gleiche Problem. Nach langem Suchen ist mir aufgefallen, dass die EVO Templates beide noch im Backend stehen. Das Child Template war noch aktiviert. Nach Aktivierung des NOVA Templates funktioniert alles wie es soll.
 

Ingo-Jose

Aktives Mitglied
1. September 2015
16
1
Hilfe,
nach Plugin Installation bekomme ich folgende Fehlermeldung.
Komme weder in Backend, noch sonst irgendwo hin.

Fatal error: Uncaught Error: Call to undefined function verifyGPDataString() in /var/www/vhosts/ersatzteilhandel-ingo-jose.de/httpdocs/includes/plugins/jtl_search/version/112/frontend/manualExport.php:7 Stack trace: #0 /var/www/vhosts/ersatzteilhandel-ingo-jose.de/httpdocs/includes/src/Plugin/HookManager.php(87): include() #1 /var/www/vhosts/ersatzteilhandel-ingo-jose.de/httpdocs/includes/src/Events/Dispatcher.php(82): JTL\Plugin\HookManager->JTL\Plugin\{closure}() #2 /var/www/vhosts/ersatzteilhandel-ingo-jose.de/httpdocs/includes/src/Plugin/HookManager.php(108): JTL\Events\Dispatcher->fire() #3 /var/www/vhosts/ersatzteilhandel-ingo-jose.de/httpdocs/includes/defines.php(318): JTL\Plugin\HookManager->executeHook() #4 /var/www/vhosts/ersatzteilhandel-ingo-jose.de/httpdocs/includes/globalinclude.php(98): executeHook() #5 /var/www/vhosts/ersatzteilhandel-ingo-jose.de/httpdocs/index.php(5): require('...') #6 {main} thrown in /var/www/vhosts/ersatzteilhandel-ingo-jose.de/httpdocs/includes/plugins/jtl_search/version/112/frontend/manualExport.php on line 7
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.658
2.710
Berlin
Firma
css-umsetzung
Geh in das /plugins/ Verzeichnis und benenne das Verzeichnis jtl_search um
wenn das nicht ausreicht dann benenne auch das die Datei Bootstrap.php in dem Verzeichnis um.

dann solltest du das Plugin über Meine Käufe aktualisieren.

Wenn das alles nicht geht hol dir Hilfe
 
  • Gefällt mir
Reaktionen: Ingo-Jose

Ingo-Jose

Aktives Mitglied
1. September 2015
16
1
Geh in das /plugins/ Verzeichnis und benenne das Verzeichnis jtl_search um
wenn das nicht ausreicht dann benenne auch das die Datei Bootstrap.php in dem Verzeichnis um.

dann solltest du das Plugin über Meine Käufe aktualisieren.

Wenn das alles nicht geht hol dir Hilfe
Hallo,
erstmal vielen, vielen Dank für die schnelle Antwort.
Nach Umbennung des jtlsearch-Verzeichnisses, ist die Website wieder erreichbar, nur ins Backend komme ich immer noch nicht.
Diese Bootstrap.php finde ich nicht 🙁((. was mache ich falsch?
Könntest Du mir nochmal helfen?
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.658
2.710
Berlin
Firma
css-umsetzung
Niemand sprach vom /includes/plugins Verzeichnis 🙂



OK, also dann benenne mal das gesamte /includes/plugins/ Verzeichnis um.

Dieses Verzeichnis ist veraltet, da sollten im Idealfall keine Plugins mehr sein, es sei denn sie sind zu 100% kompatibel (was du vergessen kannst).
Der 5er Shop arbeitet mit dem /plugins/ Verzeichnis im Hauptpfad.
 
  • Gefällt mir
Reaktionen: Ingo-Jose

Ingo-Jose

Aktives Mitglied
1. September 2015
16
1
Niemand sprach vom /includes/plugins Verzeichnis 🙂



OK, also dann benenne mal das gesamte /includes/plugins/ Verzeichnis um.

Dieses Verzeichnis ist veraltet, da sollten im Idealfall keine Plugins mehr sein, es sei denn sie sind zu 100% kompatibel (was du vergessen kannst).
Der 5er Shop arbeitet mit dem /plugins/ Verzeichnis im Hauptpfad.
Bester Mann, jetzt bin ich wieder im Backend.
Dann sollte ich jetzt wohl die Fehlerhaften Plugins deinstallieren und löschen, oder???^^
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.658
2.710
Berlin
Firma
css-umsetzung
Du wirst die vermutlich nicht einfach so deinstallieren können, das musst du ausprobieren, wenn das gehen sollte dann kannst du das Verzeichnis danach über den ftp leeren, bzw. lass das Verzeichnis so und erstelle ein neues, leeres plugins/ Verzeichnis
falls da irgendwas unerwartetes passiert, hast du dann noch die alten und einer der Ahnung hat kann dich retten.
 
  • Gefällt mir
Reaktionen: Ingo-Jose

Ähnliche Themen