Neu Nach Shopupdate auf 4.06 gehen E-Mail Berichte und Aufgabenplaner per Cron nicht mehr

Lavorian

Aktives Mitglied
6. Mai 2016
18
0
Nach einem Shopupdate auf 4.06.9 (von 4.05.2) funktionieren die E-Mail Berichte nicht mehr. Vorher lief das prima.

Ich verwende das alte Child-Template 4.05, da es für 4.06 kein neues Child-Template gibt. Im Template ist die Aufgabenplaner-Blindgrafik aktiviert und auf ja gesetzt.

Ein manueller Aufruf von /includes/cron_inc.php bewirkt gar nichts. Hier erscheint nur ein weißer Bildschirm und nichts weiter passiert.

PHP Version ist 7.3

Auch über den Aufgabenplaner geschieht beim drücken des Buttons cron manuell anstoßen nichts. Egal welches Exportformat ich auswähle. Hier wird nur die admin/exportformat_queue.php geöffnet und das sieht man wieder einen weißen Bildschirm.

Wer hat hier eine Idee woran das liegen könnte?

Wenn ich auf den Button "E-Mail-Berichte jetzt senden" klicke wird eine Status E-Mail versandt. D.h. die E-Mail Konfiguration funktioniert nur der cron nicht.
 

Anhänge

  • email_berichte.png
    email_berichte.png
    21,6 KB · Aufrufe: 19
  • aufgabenplaner_blindgrafik.png
    aufgabenplaner_blindgrafik.png
    2,2 KB · Aufrufe: 18
Zuletzt bearbeitet:

Xantiva

Sehr aktives Mitglied
28. August 2016
1.795
316
Düsseldorf
Kommst Du an das error.log des Servers? Das sollte dann Hinweise auf PHP-Fehler enthalten. Ist der Shop 4.06 bereits für PHP 7.3 freigegeben? Hast Du mal Versucht auf 7.1 oder 7.2 umzustellen?
 

Lavorian

Aktives Mitglied
6. Mai 2016
18
0
Danke. Ich habe bereits auf 7.2 umgestellt. Ja ich komme auf das error.log. Dort steht nichts besonderes zumindest erkenne ich da nichts auffälliges.
 

Xantiva

Sehr aktives Mitglied
28. August 2016
1.795
316
Düsseldorf
Wenn Du Dir die Datei anschaust und den letzten Eintrag merkst - dann den Cron manuell anstößt, der die weiße Seite verursacht - wenn die Log-Datei dann neue Zeilen beinhaltet, dann könntest Du diese mal posten.
 

omni-handel

Gut bekanntes Mitglied
12. September 2011
105
6
14532 Stahnsdorf
das kommt bei uns : Warning: gethostbyaddr(): Address is not a valid IPv4 or IPv6 address

soll:

$_SERVER['REMOTE_ADDR'] anstelle von $REMOTE_ADDR.


aber wo?
 

omni-handel

Gut bekanntes Mitglied
12. September 2011
105
6
14532 Stahnsdorf
nein - php 7.2 - liegt aber nicht daran -

Strato sagt es liegt an JTL und JTL sagt es liegt an Strato
... Bei strato laufen aber 2 Shops schon sauber - nur dieser hier zickt seit dem update 3.17 auf 4.6

Der Aufgabenplaner und Newsletter laufen nicht ....
;-( ---- Newsletter Kunden kann man auch nicht aus dem JTL-Shop exportieren

Ich hoffe, dass es nicht an irgendein Komma oder Punktfehler in einer Datei ist ...
 

david

Administrator
Mitarbeiter
16. Juli 2010
2.310
170
Hi,
ich hatte das Minimal-Testscript geschrieben, das in deinem Shop durch unseren Support eingespielt wurde.
Die PHP-Funktion flock liefert bei dir im Shop immer false zurück. Laut PHP-Doku wird eigentlich nur im Fehlerfall false zurückgegeben: https://www.php.net/manual/en/function.flock.php
Das bedeutet, auf diesem Webhosting liegt ein permanenter Fehlerfall vor (unabhängig von JTL-Shop), den ich sonst mit diesem Script aber auf keinem anderen Webhosting nachstellen kann.
Auf den Strato-Servern läuft SunOS. Ich kann nur vermuten, dass hier ein Zusammenhang besteht, denn die Implementierung von flock ist Sache des Betriebssystems.
Wäre schön, wenn sich dein Hoster dazu äußern könnte. Das Minimalbeispiel in Form des Scripts ist ja vorhanden.

Dass es nun erst nach Update auf 4.06 auftritt, das liegt daran, dass vor 4.06 kein sicherer File-Lock-Mechanismus implementiert war, siehe https://issues.jtl-software.de/issues/SHOP-1076
 
Zuletzt bearbeitet:

Ähnliche Themen