Neu Mehrfachauswahl, weitere Merkmale verschwinden nicht?

Neuling88

Aktives Mitglied
15. Januar 2016
97
4
Hallo,
ist es so gewollt oder finde ich die entsprechende Einstellung nicht? Ich versuche es mal einfacher zu erklären (mit anderen Artikeln als wir haben),
damit es allgemein besser verständlich ist. Ich habe also PULLOVER, TSHIRTS und UNTERHOSEN.

PULLOVER ROT
PULLOVER BLAU
PULLOVER GELB

TSHIRT ROT
TSHIRT BLAU

UNTERHOSE BLAU
UNTERHOSE GELB

Mein 1. Filtermerkmal (mit Mehrfachauswahl an) ist nun "Kleidungsstück" und da wähle ich TSHIRT. Nun steht unten aber immer noch GELB (0) zur Auswahl. Wenn es nur die 3 wären, wäre es mir egal.
Aber wir haben bei "Pullover" halt 100 Stück und bei "Farben" auch 100 Stück. Da bleiben dann natürlich einige offen mit (0) und das Teil ist ewig lange. Cool wäre wenn (trotz Mehrfachauswahl) dann natürlich
alle nicht verfügbaren Farben verschwinden würden. Kann ich diese Option irgendwo setzen, also die 0er ausblenden?
 

Neuling88

Aktives Mitglied
15. Januar 2016
97
4
Hat den niemand dieses Problem? Da wird doch der Hund in der Pfanne verrückt. Das kann doch niemand für normal halten.
Pushi
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
5.260
398
Man kann dies im Backend einstellen, aber JTL gibt dazu bereits eine Warnung an, dass dies performancelastig ist.

Mit 1-2 gewählten Merkmalen geht das evtl noch, aber dann geht der Shop in die Knie ... da sollte der Shop einen guten Server und REDIS haben. damit die Seiten vorgecacht sind.
Für uns (unser Shop wird eigentlich mit Merkmalen gesteuert, ohne Kategorien) ist das von JTL leider sehr schlecht im Shop gelöst, es gibt andere Shopsystem die das sehr gut können.

Haben wir schon paar mal angesprochen, ist aber so und kann man nichts machen.

Also Einstellung mal testen (suchen nach "Merkmale") und ggfls. fetten Server dazu anmieten.
 

Neuling88

Aktives Mitglied
15. Januar 2016
97
4
Man kann dies im Backend einstellen, aber JTL gibt dazu bereits eine Warnung an, dass dies performancelastig ist.

Mit 1-2 gewählten Merkmalen geht das evtl noch, aber dann geht der Shop in die Knie ... da sollte der Shop einen guten Server und REDIS haben. damit die Seiten vorgecacht sind.
Für uns (unser Shop wird eigentlich mit Merkmalen gesteuert, ohne Kategorien) ist das von JTL leider sehr schlecht im Shop gelöst, es gibt andere Shopsystem die das sehr gut können.

Haben wir schon paar mal angesprochen, ist aber so und kann man nichts machen.

Also Einstellung mal testen (suchen nach "Merkmale") und ggfls. fetten Server dazu anmieten.
Das habe ich an, das läuft auch... aber das zeigt nur die Anzahl. Schön und gut. Aber wenn ich oben 1 Kategorie wähle, bleibt unten alles offen mit 0,0,0,0,0,0 . Wenn ich doch ein TSHIRT nur in SCHWARZ habe. Warum sehe ich dann (WENN ICH SCHON TSHIRT GEWÄHLT HABE) noch grün (0), blau (0), lila (0), regenbogenfarben (0), rot (0), orange (0) usw. x 100 . WARUM? Warum kommt dann als 2. nicht einfach SCHWARZ (2) z.B. so war es im 4rer Shop immer. So ist es auch wenn ich manuelle Fragen mit dem Auswahlassistent stelle. Wenn ich da die Frage stelle "Was suchen Sie" und man drückt "Tshirt" gibts in der 2. Frage WELCHE FARBE SUCHEN SIE? nur noch -> Schwarz(2) zur Auswahl. Thats it. und das halte ich auch für richtig. Verstehst du wie ich es meine?
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
5.260
398
Sorry, die Nullen haben wir uns weg programmieren lassen, aber auch das ist ein Fehler / Denkfehler / Schönheitsfehler wie auch immer von JTL.
 

Ähnliche Themen