kostenloses responsive Design "Neapel" (nur Wawi 1.0+) - für ebay 2017

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

deliman

Sehr aktives Mitglied
13. Februar 2016
683
46
An den css Dateien aus dem letzten Download habe ich nichts verändert. Wenn ich die neue Vorlage in die Wawi lade, wird standardmäßig auf die theme-blu-v2.css verwiesen. Wenn ich daraus einfach z.B. theme-red-v2.css mache um mir das Template halt im Standardrot von Nina anzusehen, dann ist das Template komplett zerschossen.

Wenn ich nur die Standardthemes verwenden will, dann sollten die doch korrekt angezeigt werden. Klar kann ich die Farbwerte in der blue css entsprechend anpassen aber ich wollte halt mal wissen ob es da evt. einen Fehler in den Templates/css gibt oder ich einen Fehler gemacht habe. (Installation nach Anleitung - da kann man eigentlich noch nicht so viel falsch machen.)

Hier mal die Screenshots dazu. blue = Zustand direkt nach der Installation, red = nach Änderung des Verweises auf theme-red-v2.css

OK, dann hat sich das hier gerade erledigt....
 

Anhänge

dc-nico

Sehr aktives Mitglied
Da wir schon beim Thema sind, wie kann man noch ein mal die Galerie auf Ähnliche Artikel stellen (also so, dass beim aufrufen des Angebots anstatt "Mehr aus dieser Warengruppe" "Ähnliche Artikel") angezeigt werden?
Habe da nämlich bei einigen Angeboten die Warengruppe nicht zugeordnet, was dann zu einer leeren Galerie führt.

Gruß

NICO
 

nmueller

Sehr aktives Mitglied
5. April 2011
1.270
83
Saarland
@deliman

die HTML/CSS liegen alle in einem einzigen Verzeichnis. Man sollte also, um einzelne farben einzulesen, die Html/Css sowie den gfx in jeweils eigene Ordner aufteilen. Immer

-gfx
-index..blue.html
-theme-blue..css

in einen eigenen ordner packen.

Sonst läd die Wawi immer die erste html / css die sie findet, weil im download verzeichnis alle drin sind - und das ist dann gem. alphabet "blue"
 

deliman

Sehr aktives Mitglied
13. Februar 2016
683
46
@nmueller OK, klappt jetzt. Nur noch 1 "Probleme" habe ich:
Im alten Template wird ein großes Bild angezeigt und darunter eine kleine Galerie bei weiteren Bildern (nebeneinander). Aktuell werden ALLE Bilder groß und klein untereinander angezeigt. Ist das so gewollt bzw. an welcher Stelle kann man auf die "alte" Darstellung umstellen ohne das man dabei etwas anderes (wichtiges) ändert?
 
Zuletzt bearbeitet:

deliman

Sehr aktives Mitglied
13. Februar 2016
683
46
Danke, passt jetzt aber wo kann man den Zeilenabstand in der featureList verkleinern? Habe schon an verschiedenen Stellen in der css Werte geändert ohne den passenden zu finden.
 

nachtwaechter7

Aktives Mitglied
30. August 2016
25
1
Hi Nina,

ich habe die Artikelbeschreibung dank eines Tipps von dir unter die Galerie legen können durch Löschen von nmb-col-md-6 an folgender Stelle:

HTML:
<div class="nmb-col-md-9 nmb-col-md-push-3">
<div class="nmb-row">
<div class="nmb-col-md-6 nmb-col-xs-12">
{{ GlobaleTexte.eBay- Designvorlagen.NMB-Artikelbilder | Render }}
</div>
<div class="nmb-col-md-6 nmb-col-xs-12">
<div id="nmb-descBox">

Jetzt nach dem Update vom Globaltext NMB-Artikelbilder wird das Bild auf Desktopmonitoren arg groß angezeigt. Wie könnte ich die Größe begrenzen, sodass die Artikelbeschreibung etwas nach oben rutscht?
 
Zuletzt bearbeitet:

bellavib

Gut bekanntes Mitglied
24. März 2015
270
9
Hanau
Hallo,
Bei ebay wird die Vorlage mit einer Scrollbar angezeigt. Sieht sehr unschön aus. Wie kann man das Problem lösen?

Viele Grüße
Robert
Laut Aussage von JTL ist es ein CSS Problem, es hat wohl etwas mit den unterschiedlichen Browsern zutun. In Chrome wird es teilweise korrekt dargestellt, in Firefox und IE bspw. nicht.
Lässt sich dieses Problem schnell beheben? Freue mich über eine Lösung.

Grüße
Robert
 

nmueller

Sehr aktives Mitglied
5. April 2011
1.270
83
Saarland
Laut Aussage von JTL ist es ein CSS Problem
Ohne das von JTL nachträglich eingefügte Logo am Seitenende tritt das Problem nicht auf. Muss ich untersuchen, passiert nämlich nur und erst, wenn JTL ihr Logo einfügt - dann wird das iFrame von ebay nicht mehr korrekt erweitert und der Scrollbalken taucht auf.

Nachtrag: schon gefunden.. gut, kann man sich jetzt drüber streiten, ob das so gut ist.

Bitte im HTML folgendes:

Code:
    <meta name="viewport" content="width=device-width, initial-scale=1">
ändern in

Code:
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no">
Hintergedanke: ich arbeite bzw wollte nicht mit user-scalable=no arbeiten, da ich dem Nutzer nicht die Möglichkeit verwehren möchte, in einen Content, den er vlt. schlecht lesen kann, "hinein zu zoomen".

Da man aber neuerdings wohl einen hässlichen Scrollbalken bekommt, wenn JTL sein Logo nachträgt und die User Zoom Option nicht deaktiviert ist, muss es nun wohl rein. In der nächsten Revision meiner Vorlagen ist es dann enthalten.
 
Zuletzt bearbeitet:

EricW

Mitglied
18. April 2018
1
0
Hallo Nina,

ich habe für die Artikel eine unterschiedliche ANzahl an Bildern hinterlegt, wie kann ich einstellen, dass die kleinen Bilder (die unten in der Gallerie angezeigt werden) je nach Anzahl der Abbildungen zentriert werden?
Derzeit ist es immer linksbündig?

Danke

Eric
 

Anhänge

nmueller

Sehr aktives Mitglied
5. April 2011
1.270
83
Saarland
Hallo Nina,

ich habe für die Artikel eine unterschiedliche ANzahl an Bildern hinterlegt, wie kann ich einstellen, dass die kleinen Bilder (die unten in der Gallerie angezeigt werden) je nach Anzahl der Abbildungen zentriert werden?
Derzeit ist es immer linksbündig?

Danke

Eric
Hallo Eric,

die sind eigentlich nicht immer zentriert, aber dein Screenshot bezieht sich auf die nicht- Wawi-Version der Vorlage - soll das so sein? Immerhin stellst du Fragen im JTL-Forum und die Wawi-Version der Vorlag weißt in Abhängigkeit der Bildmenge unterschiedliche Klassen zur Darstellung zu. Ab 5 wird wie im Screen angezeigt (weil eben 5 Bilder vorhanden sind und das in eine Reihe passt), bei anderen Bildmengen ändert sich die Class. Bei der Nicht-Wawi-Vorlage muss man das händisch machen, steht auch in der beiliegenden Anleitung.
 

dc-nico

Sehr aktives Mitglied
Hallo,

kann es sein, dass Youtube Videos jetzt auch mit der HTML-5 Methode nicht mehr funktionieren?
Entweder hat Youtube hier etwas geändert, oder bei Ebay ist wieder etwas neues geschehen.
Wöre schön, wenn jemand ein mal Rückmeldung geben könnte.

Gruß

NICO
 

nmueller

Sehr aktives Mitglied
5. April 2011
1.270
83
Saarland
HTML5 geht, soweit mir bekannt, bei eBay nach wie vor.
Poste mal deinen Video-Quellcode oder schick mir eine PN mit einem Angebotslink (es gibt einige "youtube to html5 converter" im Netz, soweit ich die gesehen habe sind die aber alle nicht Scriptfrei bzw. enthalten Codeteile, die bei eBay nicht erlaubt sind).
 

dc-nico

Sehr aktives Mitglied
Hallo,

also ich habe damals auch einen Converter für die Einbindung genutzt und alle Videos liefen.
Jetzt hatte ich da überall den Hinweis, dass man direkt auf Youtube gehen sollte.
Mit einem anderen Converter habe ich die Videos nun wieder zum laufen bekommen.
Frage mich nur, wie sich das von allein geändert haben kann.
Wenn ich noch den alten Quellcode finde, werde ich ihn mal posten.

Gruß

NICO
 

dc-nico

Sehr aktives Mitglied
Nach der Änderung laufen alle Videos wieder.
Was ich nicht verstehen ist, weshalb in der Galerie unten in der Auswahl "Mehr dieser Warengruppe" nichts angezeigt wird.
Früher hatten wir dort auch Angebote.
Gegebenenfalls müsste man als Standard Anzeige die Auswahl "Ähnliche Artikel" als Standartanzeige deklarieren.
Da sind Artikel vorhanden.

Gruß

NICO
 

nmueller

Sehr aktives Mitglied
5. April 2011
1.270
83
Saarland
Was ich nicht verstehen ist, weshalb in der Galerie unten in der Auswahl "Mehr dieser Warengruppe" nichts angezeigt wird.
Früher hatten wir dort auch Angebote.
Gegebenenfalls müsste man als Standard Anzeige die Auswahl "Ähnliche Artikel" als Standartanzeige deklarieren.
Da sind Artikel vorhanden.

Gruß

NICO
Das ist aber eher untypisch. Aus meiner Erfahrung sind Warengruppen (mehr in dieser Warengruppe = Bestseller WG) mit viel höherer Wahrscheinlichkeit gepflegt als Attribute/Merkmale (ähnliche Artikel).
Die besten Ergebnisse liefern gemeinhin "Gleiche Kategorie", "Bestseller nach Warengruppe", "Gleicher Hersteller", "Bestseller (allgemein)".

Ist natürlich immer abhängig von der eigenen Datenbank - aber mit den o.g. fahre ich am "supportärmsten". Alle anderen Selektionen (Kunden kauften auch, XSeller, Ähnliche Artikel) haben die höchste "Ihr Cross-Selling geht nicht"-Supportrate ;)

Von daher bleibe ich bei meinen "üblichen Konsorten" - da in meiner Anleitung aber beschrieben ist, wie's geht und die zusätzlichen XSeller in den aktuellen Vorlagengenerationen auch immer im Code bereits vorbereitet sind, kann sich das jeder wahrscheinlich problemlos selbst umstellen.
 

nachtwaechter7

Aktives Mitglied
30. August 2016
25
1
Kann man eigentlich eine Aussage zur Ladegeschwindigkeit des Templates treffen? Mir ist jetzt ein paar Mal aufgefallen, dass es sich recht langsam aufbaut.
Habe dann bei google Pagespeed meine Artikel mal mit anderen Artikeln mit verschiedenen Templates verglichen und im Schnitt waren meine Artikel auf dem Desktop 20 Punkte langsamer. Gibt es hier Optimierungsmöglichkeiten? Könnte man evtl. nur ein Artikelbild in der Artikelbeschreibung laden?
 
Zuletzt bearbeitet: