Neu kein Abspeichern der Konfigurtion möglich

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

InaMuders

Neues Mitglied
20. Oktober 2020
1
0
Hallo,

leider habe ich immer noch das Problem mit dem Connector, dass ich
Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /.../jtlconnector/install/index.php:1) in phar:///...../jtlconnector/index.php/src/jtl/Connector/ Modified/Installer/Installer.php on line 24
erhalte.
Ich habe hier schon Hinweise gefunden, Shop neu installiert, statt 2.0.5.1 auf 2.0.5.0 und die PHP Version auf 7.0. runter stufen lassen, der Fehler bleibt, es kommt sogar ein weiterer Fehler, wenn ich die PHP Version auf 7.0. nutze.
zweite Fehlermeldung:
Warning: Cannot modify header information - headers already sent by (output started at /.../jtlconnector/install/index.php:1) in phar:///.../jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 82
Es gibt keine Fehler in der Connectoranzeige System Check, alles grün, nur Abspeichern ist ja so nicht möglich.
Ich habe mich ein und ausgeloggt, wegen session, alles gelöscht, ich bin jetzt seit Freitag dran und mir fällt leider nichts mehr ein. Der Connector kann auf die DB zugreifen, habe den Mehrwertsteuerstaz geändert und er hat es mir direkt richtig angezeigt. Habe den ADMIN-ordner mit Namen admin gelassen, weil ich dachte, evtl. bekommt der Connector deshalb Probleme, da wir diesen ja jetzt umbenennen sollten...

Es nützt alles nichts und mehr Infos habe ich leider nicht gefunden.

Schon mal Danke für weitere Tipps
 

Girahlutions

Aktives Mitglied
12. April 2017
1
0
Hallo,

ich habe genau dasselbe Problem. Bin hier auch seit Tagen am verzweifeln und finde keine Lösung. Bei mir war beim System Check auch alles grün.
Ich bekomme immer folgende Meldung:

Warning: session_start(): Cannot start session when headers already sent in phar:///...../jtlconnector/index.php/src/jtl/ Connector/ Modified/Installer/Installer.php on line 24

Warning: count(): Parameter must be an array or an object that implements Countable in phar:///......../jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 59

Warning: Cannot modify header information - headers already sent by (output started at /...../jtlconnector/install/index.php:1) in phar:///www/htdocs/w01b161e/jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 66

In der Wawi wird alles erkannt und wohl auch Varkombis übertragen. Aber irgendwie scheint hier in der Datenbank eine Tabelle im Connector zu fehlen, denn im Shop wird nichts angezeigt.

Wäre toll, wenn hier jemand helfen könnte. Vielen Dank.
 

vapish

Aktives Mitglied
11. März 2018
15
1
schließe mich dem Problem an, erhalte die gleichen Fehlermeldungen.

Warning: session_start(): Cannot start session when headers already sent in phar:///homepages/21/d722802352/htdocs/jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 24

Warning
: count(): Parameter must be an array or an object that implements Countable in phar:///homepages/21/d722802352/htdocs/jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 59

Warning
: Cannot modify header information - headers already sent by (output started at /homepages/21/d722802352/htdocs/jtlconnector/install/index.php:1) in phar:///homepages/21/d722802352/htdocs/jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 66
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
946
201
Hallo,

tritt das Problem bei allen Connector Versionen auf oder nur bei einer bestimmten Version?

Es wurde irgendetwas ausgegeben, bevor die Session gestartet wurde. Die Frage wäre hier, was genau wurde ausgegeben?
 

fw_

Aktives Mitglied
7. Dezember 2016
1
0
Hallo,

hier unsere schnelle Analyse bzgl. des Warning zur Session:
/jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 24

In einer neueren Version der Klasse jtl/Connector/Modified/Installer/Installer.php wurde in session_start(); hinzugefügt, das war vorher nicht da. Anbei der Link zu GitHub mit den Änderungen:
https://github.com/jtl-software/connector-modified/commit/94b192d722dd06edfca31f99a148bf035943a9b0

Nun passiert aus unserer Sicht aber folgendes:
1. /install wir aufgerufen.
2. /install/index.php wird von PHP ausgeführt.
3. Da kommt am Anfang aber erst einmal viel HTML Code, der vom Server an den Client gesendet wird.
4. Erst in Zeile 61 wird new \jtl\Connector\Modified\Installer\Installer(); ausgeführt.
5. Bis dahin wurde aber schon sehr viel HTML (somit auch der Header) an den Client ausgespielt.
6. Im Constructor von \jtl\Connector\Modified\Installer\Installer() wird dann session_start(); ausgeführt.
7. Und das Warning wird ausgegeben.

In den älteren Versionen ist das nicht passiert, weil nicht session_start(); an der eben erwähnten Stelle im Code ausgeführt wurde.

Ich hoffe das hilft vielleicht weiter, wir haben uns da nicht weiter im Detail mit beschäftigt.

Mit besten Grüßen
Robin von first-web.de
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Nach Update auf Shopware 5.6.9 kein Abgleich Shopware-Connector 0
Neu Kartenzahlung kein Kundenbeleg auf Bon Allgemeine Fragen zu JTL-POS 0
Neu Amazon VCS kein Upload von Rechnungen möglich?! Amazon-Anbindung - Fehler und Bugs 2
Neu Kein Folgeabgleich zw. WAWI und POS JTL-POS - Fehler und Bugs 3
Neu Hilfe! Seit gestern kein Labeldruck mit DHL und Warenpost möglich - "Der JTL-ShippingLabelsServer kann nicht erreicht werden, bitte versuchen Sie..." User helfen Usern - Fragen zu JTL-Wawi 6
Neu Kein Kategorie Übertrag an woocommerce WooCommerce-Connector 3
Neu Artikelbilder importieren, wenn kein Bild vorhanden User helfen Usern - Fragen zu JTL-Wawi 4
Gelöst Kein Export der Artikel ohne Bilder möglich JTL-Ameise - Fehler und Bugs 2
Gelöst ebay kein abgleich - Accountdaten sind gültig - Fehler "Returncode: 502 eazyauction.de/ebayInterface/testEbayUser.php eBay-Anbindung - Fehler und Bugs 3
In Bearbeitung Kein Abgleich - Objektverweis eBay-Anbindung - Fehler und Bugs 33
In Bearbeitung Importvorlage enthält kein VK Mod. JTL-Ameise - Fehler und Bugs 0
Neu Zu Auftrag xxxx konnte kein Kunde ermittelt werden. Shopware-Connector 4
Neu CSV Artikel Im- und Export - kein Feld für Kurzbeschreibung vorhanden Einrichtung / Updates von JTL-POS 1
In Bearbeitung JTL 1.5.30.3 Fehler: "Kein gueltiges Bild hinterlegt." User helfen Usern - Fragen zu JTL-Wawi 3
Gelöst Kein Export von Varkombis + Preis aus eBay möglich? JTL-Ameise - Fehler und Bugs 0
Neu Plötzlich kein Paypal Plus mehr Allgemeine Fragen zu JTL-Shop 3
Gelöst Prime, kein Label Export, InternalError; Gelöste Themen in diesem Bereich 1
Gelöst Kein Datenexport an DHL Gelöste Themen in diesem Bereich 1
Neu One Drive vom Client Packtisch ansteuern - Fehlende Rechte Kein Zugriff gewährt Installation von JTL-Wawi 4
Neu Kein Import von Gewichten bei FFN-Wawi-Kunden möglich? Manueller Eintrag aber erlaubt? JTL-Ameise - Fehler und Bugs 3
Neu Kein Text zur Zahlart auf der Rechnung Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 5
Neu Kein drucken über DHL Geschäftskundenportal möglich Allgemeine Fragen zu JTL-Shop 1
Gelöst TSE nach Start von JTL-POS App (1.0.2.4) nicht verfügbar, auch kein Icon da Gelöste Themen in diesem Bereich 1
Neu JTL - DHL Schnittstelle - Versand an Postfiliale - Kein Name auf Versandetikett JTL-ShippingLabels - Fehler und Bugs 2
Neu Kann kein Angebot erstellen Installation von JTL-Wawi 6
Neu Kein Artikel Abgleich von Prestashop PrestaShop-Connector 2
Gelöst novachild-master kein CSS Gelöste Themen in diesem Bereich 4
Gelöst Kein ebay Abgleich - Verbindung mit eazyauction defekt Gelöste Themen in diesem Bereich 1
In Diskussion Kein Paketgewicht beim Versanddaten-Export JTL-ShippingLabels - Fehler und Bugs 1
Neu Kein Zugriff auf Datenbank Installation von JTL-Wawi 20
Neu Internes Kundendisplay zeigt kein Betrag JTL-POS - Fragen zu Hardware 4
Neu Kundenattribute aus Shopware > Wawi = Fehler wenn Feld kein String Shopware-Connector 1
In Bearbeitung Produktart mit Leerzeichen -> Kein update zu eBay eBay-Anbindung - Fehler und Bugs 1
In Bearbeitung Kein abgleich mehr seit gestern 01.09.20 JTL-Repricer für JTL-Wawi und Web 6
In Bearbeitung Es konnte kein Kategorie-Standardname für den ISO-Code 'ger' ermittelt werden Shopware-Connector 1
Neu Kein Update des Zahlstatus bei Zahlungsart Vorkasse (manuelle Zahlungsmethode) Shopify-Connector 15
Offen Workflow Re erstellung abspeichern JTL-Workflows - Fehler und Bugs 13
Neu Keine Verbindung von der Wawi zum Shop 5 JTL-Shop - Fehler und Bugs 0
Neu Connector überträgt keine Kategorien bzw löscht beim Abgleich die Kategorien der bestellten Artikel Shopware-Connector 0
Neu Vorschlag: Anzeige der Gesamtsumme in Einkaufsrechnungsübersicht JTL-Wawi - Ideen, Lob und Kritik 0
Neu Falsche Preise in der Artikel Listenansicht JTL-Shop - BETA - Feedback und Bugmeldungen 4
Neu Artikelmport von CSV-Datei mit Kategorien/Subkategorien in bestimmte Unterkategorie in der Wawi JTL-Ameise - Ideen, Lob und Kritik 1
Neu Merkmale aus den Variationen (Kinderartikel) werden nicht aus der Wawi in die Ebay Attribute automatisch übernommen eBay-Anbindung - Fehler und Bugs 0
Neu Positionen auf der Lieferantenrechnung mit Positionen auf Bestellung abgleichen Schnittstellen Import / Export 0
Neu Import EK Preise, Ameise, Änderung der Währung des Lieferanten. User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst WMS Mobile App- Erhöhung der Anzahl durch mehrfachscan möglich ? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Problem mit der Übermittlung der Kundengruppenpreise Shopware-Connector 3
Neu Zwei Lieferanten (sind der selbe Lieferant) in der WAWI zusammenführen Arbeitsabläufe in JTL-Wawi 0
Neu Wo liegen die Attribute der Produkte in Woocommerce MySQL? WooCommerce-Connector 1
Neu News-Beitrag, der auf "Aktiv: Nein" steht, ist dennoch erreichbar JTL-Shop - Fehler und Bugs 0
Ähnliche Themen