Neu JTL Zahlungsarten Fatal Error

Björn Albersmeier

Aktives Mitglied
1. Februar 2018
7
3
Minden
Nach der Aktualisierung auf JTL Shop 5.0 wird mir folgender Fehler angezeigt, sobald ich Zahlungnsarten einrichten möchte.

Fatal error: Uncaught InvalidArgumentException: Cannot find plugin with ID 9 in /"ADRESSE"/includes/src/Plugin/LegacyPluginLoader.php:79 Stack trace: #0 /"ADRESSE"/admin/zahlungsarten.php(384): JTL\Plugin\LegacyPluginLoader->init(9) #1 {main} thrown in /"ADRESSE"/includes/src/Plugin/LegacyPluginLoader.php on line 79

Leider komme ich nicht weiter. Alle Plugins waren beim Updaten deaktiviert.
 

3jojojo

Sehr aktives Mitglied
20. Januar 2016
783
45
Ich habe einen ähnlichen Fehler bei mir bleibt die Seite einfach weiß 🙁 Auch nach einem Update auf JTL Shop 5. Die Plugins vor allem Paypal war vorher deaktiviert
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Ich vermute ihr habt Zahlungsartleichen. Der Fehler bedeutet, dass eine Funktion auf ein nicht existentes (nicht etwa ein nur deaktiviertes) Plugin zugreifen will. Da müssen wir in die Datenbank schauen. Wenn ihr entweder Tickets eröffnet und da direkt die Zugangsdaten zu Backend und Datenbank in das dafür vorgesehene Feld (nicht in die Ticketbeschreibung!) setzt, dann können wir uns das angucken. Wenn ihr kein JTL-Shop Ticket erstellen könnt schreibt mich bitte einmal hier im Forum via PM an und ich schicke euch einen OTL-Link für die Zugangsdaten.
 
  • Gefällt mir
Reaktionen: Björn Albersmeier

3jojojo

Sehr aktives Mitglied
20. Januar 2016
783
45
Ich vermute ihr habt Zahlungsartleichen. Der Fehler bedeutet, dass eine Funktion auf ein nicht existentes (nicht etwa ein nur deaktiviertes) Plugin zugreifen will. Da müssen wir in die Datenbank schauen. Wenn ihr entweder Tickets eröffnet und da direkt die Zugangsdaten zu Backend und Datenbank in das dafür vorgesehene Feld (nicht in die Ticketbeschreibung!) setzt, dann können wir uns das angucken. Wenn ihr kein JTL-Shop Ticket erstellen könnt schreibt mich bitte einmal hier im Forum via PM an und ich schicke euch einen OTL-Link für die Zugangsdaten.
habe gerade schon ein Ticket erstellt. Wenn es am Plugin liegt dann solltet Ihr in die Update Beschreibung mit dazu schreiben das man die Plugins wirklich komplett löschen muß. Nicht das das nicht noch häufiger passiert.
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Ne, das hast du falsch verstanden. Meine Vermutung ist, dass es noch Zahlungsarten in der Datenbank gibt, dessen Plugin nicht existiert. Das heisst: Schon vorher wurde ein Plugin vom Webspace gelöscht OHNE es zu deinstallieren ODER die Plugin-Deinstallation hat nicht alles aus der Datenbank gelöscht und dann wurde es vom Webspace entfernt.
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Läuft jetzt wieder bei dir @3jojojo
Das waren leider wohl von älteren PayPal Plugin-Versionen ganze 6x Ratenzahlung-Leichen. Sprich: Ratenzahlungsarten zu Plugininstallationen die nicht mehr existieren (hat also nichts mit dem Vorhandensein auf dem Webspace zu tun in dem Fall). Ich bespreche da auch mal mit der Entwicklung, ob wir das irgendwie abfangen können.
 

3jojojo

Sehr aktives Mitglied
20. Januar 2016
783
45
Läuft jetzt wieder bei dir @3jojojo
Das waren leider wohl von älteren PayPal Plugin-Versionen ganze 6x Ratenzahlung-Leichen. Sprich: Ratenzahlungsarten zu Plugininstallationen die nicht mehr existieren (hat also nichts mit dem Vorhandensein auf dem Webspace zu tun in dem Fall). Ich bespreche da auch mal mit der Entwicklung, ob wir das irgendwie abfangen können.
Ich habe noch nen anderen Fehler. Kannst du mal auf der Seite ganz unten schauen. Ist was im Footer. Eine Box ist es aber nicht da habe ich bis auf die Hersteller alles rausgeworfen.
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Ich habe noch nen anderen Fehler. Kannst du mal auf der Seite ganz unten schauen. Ist was im Footer. Eine Box ist es aber nicht da habe ich bis auf die Hersteller alles rausgeworfen.
Das liegt daran, dass du keine Spezialseite "Informationen zum Versand" hast. Deine Versandseite ist eine mit "eigenen Inhalt". Wenn du das umstellst ist der Fehler weg. Dein eigener Inhalt sollte trotzdem noch angezeigt werden.
 
  • Gefällt mir
Reaktionen: 3jojojo

Björn Albersmeier

Aktives Mitglied
1. Februar 2018
7
3
Minden
Ich vermute ihr habt Zahlungsartleichen. Der Fehler bedeutet, dass eine Funktion auf ein nicht existentes (nicht etwa ein nur deaktiviertes) Plugin zugreifen will. Da müssen wir in die Datenbank schauen. Wenn ihr entweder Tickets eröffnet und da direkt die Zugangsdaten zu Backend und Datenbank in das dafür vorgesehene Feld (nicht in die Ticketbeschreibung!) setzt, dann können wir uns das angucken. Wenn ihr kein JTL-Shop Ticket erstellen könnt schreibt mich bitte einmal hier im Forum via PM an und ich schicke euch einen OTL-Link für die Zugangsdaten.
Ticket ist erstellt
 

ogele

Aktives Mitglied
5. August 2017
51
4
Hallo,
nach dem Update auf JTL Shop 5 habe ich beim Aufrufen der Zahlungsarten auch eine weiße Seite. Wenn ich die Versandarten bearbeiten möchte kommt auch eine weiße Seite. Gibt es da auch eine Verknüpfung mit den Zahlungsarten Plugins?
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Hallo,
nach dem Update auf JTL Shop 5 habe ich beim Aufrufen der Zahlungsarten auch eine weiße Seite. Wenn ich die Versandarten bearbeiten möchte kommt auch eine weiße Seite. Gibt es da auch eine Verknüpfung mit den Zahlungsarten Plugins?
Wird ein ähnliches Problem sein. Zusätzlich wirst du die Zahlungsartleichen irgendwelchen Versandarten zugeordnet haben.
Bitte Ticket mit Datenbank-Zugangsdaten oder PM an mich.
 

Holger.D

Aktives Mitglied
27. Dezember 2017
91
2
Wir nutzen Amazon-Pay und wollten das auch immer noch tun. Folgender Fehler kam ob wohl alle Plug-Ins deaktiviert sind:

Warning: require_once(/var/www/vhosts/h057655.server13.campusspeicher.de/fenstergitter.biz/includes/libs/vendor/jtlshop/xtea/xtea.class.php): failed to open stream: No such file or directory in /var/www/vhosts/h057655.server13.campusspeicher.de/fenstergitter.biz/includes/plugins/s360_amazon_lpa_shop4/version/118/frontend/lib/lpa_includes.php on line 15

Fatal error
: require_once(): Failed opening required '/var/www/vhosts/h057655.server13.campusspeicher.de/fenstergitter.biz/includes/libs/vendor/jtlshop/xtea/xtea.class.php' (include_path='.:/opt/plesk/php/7.3/share/pear') in /var/www/vhosts/h057655.server13.campusspeicher.de/fenstergitter.biz/includes/plugins/s360_amazon_lpa_shop4/version/118/frontend/lib/lpa_includes.php on line 15

erst nachdem ich Amazon Pay deinstalliert hatte ging es
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Da hab ich dir ja schon im anderen Thread drauf geantwortet. Neue Version ausprobieren.
 

Oranje

Aktives Mitglied
21. Oktober 2013
36
1
Hallo,
Auch bei mir gibt es Probleme mit "Zahlungsarten"
Habe soeben Ticket erstellt.
Vielen Dank!
 

_Peter_

Aktives Mitglied
16. September 2011
4
1
Hallo Leute,
nach dem Update auf Shop 5, läuft alles bis auf die Seite "Zahlungsarten", dort bekomme ich "Diese Seite funktioniert im Moment nicht. Http Error 500"

Ich vermute auch so eine Zahlungsartenleiche.

Kann jemand helfen?
 

salepix.de

Offizieller Service Partner
SPBanner
17. Januar 2013
532
62
Monheim / Köln
Firma
SALEPIX GmbH
@JulianG wäre es denn möglich hier eine Lösung zu posten? Der Kundenshop steht gerade still, wenn man im Release so einen Fehler hat...

Fatal error: Uncaught InvalidArgumentException: Cannot find plugin with ID 3 in /var/customers/webs/XXX/includes/src/Plugin/LegacyPluginLoader.php:79 Stack trace: #0 /var/customers/webs/XXX/admin/zahlungsarten.php(384): JTL\Plugin\LegacyPluginLoader->init(3) #1 {main} thrown in /var/customers/webs/XXX/includes/src/Plugin/LegacyPluginLoader.php on line 79

In welcher Tabelle muss was entfernt werden. Möchte mir die lange Suche ersparen, wenn der Lösungsweg bereits bekannt ist.

Parallele Frage: gibt es bereits für solche Probleme schnelle Build-fixes?
 

Ähnliche Themen