Neu JTL-Shop5 Bugs

Green

Gut bekanntes Mitglied
11. August 2015
157
7
Köln
Guten Tag,

sobald man auf Datenschutz, Impressum or what ever klickt, wirft er mir eine 404 Meldung raus.
(Konnte gelöst werden. JTL-Shop mag wohl kein richtiges NGINX, sondern muss nginx proxy aktivieren damit es funktioniert. Schade.

Aktiviert man Pagespeed auf dem Server, verschiebt sich das ganze Template.

Aktiviert man CSS Komprimierung, verschiebt sich auch hier alles.

Code:
2021/01/22 13:44:50 [error] 355534#0: *6762 openat() "/var/www/vhosts/xy.de/httpdocs/media/image/opc/lg/pakete.png" failed (2: No such file or directory), client: 37.201.192.7, server: xy, request: "GET /media/image/opc/lg/pakete.png HTTP/2.0", host: "xy", referrer: "https://xy.de/"
2021/01/22 13:44:55 [error] 355534#0: *6762 openat() "/var/www/vhosts/xy.de/httpdocs/Datenschutz" failed (2: No such file or directory), client: 37.201.192.7, server: xy, request: "GET /Datenschutz HTTP/2.0", host: "xy.de", referrer: "https://xy.de/"
2021/01/22 13:52:33 [error] 355534#0: *6784 openat() "/var/www/vhosts/xy.de/httpdocs/media/image/opc/lg/pakete.png" failed (2: No such file or directory), client: 37.201.192.7, server: xy, request: "GET /media/image/opc/lg/pakete.png HTTP/2.0", host: "xy.de", referrer: "https://xy.de/"
2021/01/22 13:52:35 [error] 355534#0: *6784 openat() "/var/www/vhosts/xy.de/httpdocs/Wir-ueber-uns" failed (2: No such file or directory), client: 37.201.192.7, server: xy, request: "GET /Wir-ueber-uns HTTP/2.0", host: "xy", referrer: "https://xy.de/"
 
Zuletzt bearbeitet:

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.881
529
Halle
Hallo,
das sind ja wohl keine JTL-Shop-Bugs!
- nginx wird von uns nicht offiziell unterstützt. Die Umsetzung der Rewrite-Rules für SEO-URLs, Bilder, Wawi-Sync, etc. müssen also selbst in der nginx-Konfiguration nachgepflegt werden.
- mod_pagespeed verändert in der Standard-Konfiguration die Ladereihenfolge der JS- und CSS-Resourcen. Da kann ja nunmal JTL-Shop5 nichts dafür. Das Laden von Ressourcen wurde in Shop5 mit Nova-Template - soweit es standardmässig geht - bereits für Pagespeed optimiert. Eine weitere "Optimierung" erfordert sicher eine gewisse (nhafte) Konfiguration.
- was meinst du genau mit "CSS Komprimierung" und was verschiebt sich dann? Können mglws. die komprimierten dateien nicht geschrieben werden oder fehlen auch hierfür die angepassten nginx-Rewrites?
 

deliman

Sehr aktives Mitglied
13. Februar 2016
1.069
132
Hallo,

bei Timme Hosting, wo wir den 5er letzten Herbst als Testshop haben hosten lassen, hat das mit den nginx Standardeinstellungen für JTL Shop (4) beim 5er auch nicht mehr hingehauen und die Regeln mussten per Hand angepasst und eingetragen werden. Was genau geändert wurde, weis ich nicht, hat der Timme Support gemacht. Seit dem läuft es aber.
 

Ähnliche Themen