Neu Inhalte in Datenzeile werden nicht angezeigt / leidiges Thema Versanddatum auf Rechnung

BBQ-Schmiede

Mitglied
17. Oktober 2019
1
0
Hallo zusammen,
Corona sei Dank sitze ich seit zwei Tagen an der Neugestaltung meiner Dokumente für den Onlineshop.
Vorher nie etwas mit diesem Programmierkram zu tun gehabt klappt es aber doch erfreulich gut und durch Lieferschein und Auftragsbestätigung habe ich mich bereits durchgeschummelt und es funktioniert nun.
Die Rechnung funktioniert an sich auch allerdings habe ich kurz vorm Ziel ein Problem, welches schon eine Tastatur auf dem Gewissen hat :)

Kurz Beschreibung: Es soll drei verschiedene Rechnungstexte unter der Artikelliste geben je nach Versand bzw Zahlungsart.
Hierfür habe ich bei den Aufträgen die Benutzervariablen kennengelernt und dort auch erfolgreich umgebastelt.

In der Rechnung wollte ich die nun wieder einsetzen.
Das erstellen funktioniert auch und in der Layoutvorschau werden sie angezeigt.
ich habe im Layout unter der Positionsliste Zeilen angefügt in denen ich dann die Bereichsvariablen mit @angegeben habe. Bei der Darstellung dieser Zeilen habe ich die entsprechende Versandart als Bedingung angegeben. Leider kommt das ergebnis am Ende nicht aufs Papier. Gehe ich jetzt aber in dieser entsprechenden Zeile hin und lösche die @bereichsvariable und schreibe beispielsweise einen text "123" dann wird es sofort dargestellt und funktioniert auch mit den entsprechenden Darstellungsbedingungen.

Ich hoffe ich habe es verständlich erklärt. Gerne könnte man auch mal ne Sitzung via Teams machen um sich das mal live anzuschauen.

Ich habe mir nun so beholfen dass ich in die Zeilen anstatt der Bereichsvariablen direkt die Inhalte aus den Bereichsvariablen eingefügt habe. Wenn ich den gesamten Inhalt in eine Zeile packe wird es auch wieder nicht angezeigt. Teile ich den Inhalt in zwei Zeilen wird es so angezeigt wie ich es mir vorstelle. Klar so gehts aber warum funktioniert das nur mit solch einer "Krücke"?

Zweites Problem:

Auf der Rechnung soll neben der Versandart auch das Versanddatum angegeben werden. Leider gibt es hier ohne weiteres nur das voraussichtliche Versanddatum was ja irgendwie immer eine fixe Anzahl an Tagen nach dem Erstelldatum des Auftrags angegeben wird. Händisch ändern ist keine Option, das geht nach 2 Tagen vergessen.
Der veraltete Vorgang mit "Vorgang._Veraltet_.Auftrag.Versanddatum" ergibt leider immer Datum 01.01.1900. Ich habe auch schon gelesen dass jemand mit einem selbstgenerierten Workflow diese voraussichtliche Lieferdatum aus dem Bearbeiten/Versenden generiert hat. Dazu fehlt mir aber auf jeden Fall das Wissen zu.
Das Erstelldatum des Lieferscheins würde mir schon reichen da wir nur die Lieferscheine erstellen die wir auch direkt verschicken.

Ich hoffe meine Probleme sind so noch nicht irgendwo behandelt worden, nach nunmehr 10 Stunden suchen probieren und ärgern sehe ich wohl den Wald vor lauter Bäumen nicht mehr.


Ich freue mich auf Rückmeldung.

Beste Grüße
Stefan
 

Shopworker.de

Offizieller Servicepartner
SPBanner
4. Januar 2011
3.593
400
Arnsberg, Sauerland
Ohne mir jetzt deinen Text im Detail durchgelesen zu haben gibt es denke ich 2 Punkte die du beachten solltest:

Bei Erstellung der Rechnung gibt es nicht zwingend einen Lieferschein und damit auch nicht zwingend ein Versanddatum. Uns selbst wenn kann es nicht nur einen sondern beliebig viele Lieferscheine mit unterschiedlisten Versanddaten geben.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Im Popup "Versand" keine Inhalte aus OPC JTL-Shop - Fehler und Bugs 2
Neu Track & Trace Pakete werden nicht angezeigt bzw. erhalten keinen neuen Status - wie ist eure Erfahrung ? JTL-Track&Trace - Fehler und Bugs 0
Neu Verfügbarkeitsbenachrichtigungen werden scheinbar beliebig verschickt Allgemeine Fragen zu JTL-Shop 2
Neu 1.5.44.0 Mahnung Vorlage, Spalte Firma kann nicht eingeblendet werden JTL-Wawi - Fehler und Bugs 0
Neu Anrede und Land des Kunden werden auf Lieferschein und Rechnung nicht auf Englisch ausgegeben User helfen Usern - Fragen zu JTL-Wawi 2
Neu Englische Artikel werden nicht in Deutsche Wawi importiert WooCommerce-Connector 0
Neu Amazon Customdaten werden nicht abgeholt JTL-Wawi - Fehler und Bugs 2
Offen Warum Fehlerton, wenn Seriennummern gescannt werden sollen? JTL-WMS / JTL-Packtisch+ - Ideen, Lob und Kritik 2
Neu Shop 5 Attribute werden im Shop nicht mehr angezeigt Allgemeine Fragen zu JTL-Shop 2
Neu Bestände aus Woo Commerce werden nicht in die JTL Wawi synchronisiert Onlineshop-Anbindung 0
Beantwortet Erstellen von Mahnvorlagen nicht möglich, da Designobjekt nicht bezogen werden kann Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 14
Neu Amazon FBA Splitversand - Rechnungskorrekturen werden nicht automatisch erzeugt JTL-Wawi - Fehler und Bugs 0
Neu Die Verbindung zum Remoteserver kann nicht hergestellt werden Response empty Modified eCommerce-Connector 1
Neu Warnungen: Varkombi-Kind ohne Vater: '' kann nicht importiert werden. Gambio-Connector 2
Neu Artikeldatenexport - Filter -> Hersteller - Wenn "Leer" werden Artikel ignoriert JTL-Ameise - Fehler und Bugs 0
Neu CSV Datei kann nicht eingelesen werden JTL-Ameise - Fehler und Bugs 4
Neu Artikel werden nicht entfernt JTL-Ameise - Fehler und Bugs 14
Neu Versandkosten werden nur noch für neu angelegte Artikel berechnet Onlineshop-Anbindung 1
Gelöst Artikeln werden tatsächlich nicht importiert User helfen Usern - Fragen zu JTL-Wawi 2
Neu Paypal Express - werden Versandkosten hier nicht berücksichtigt? Plugins für JTL-Shop 0
Neu Artikelbilder werden nach erfolgreichem Abgleich nicht angezeigt. WooCommerce-Connector 1
Neu Versandgewicht bei DHL Sendungen nach UK werden doppelt hinterlegt JTL-ShippingLabels - Fehler und Bugs 0
Neu [AUFTRAGSLISTE] WAWI 1.5440 -> Amazon-Rechnungsnummern werden nicht mehr angezeigt JTL-Wawi - Fehler und Bugs 0
Neu Apple Mac über RDP: Umlaute werden in Druckvorlagen nicht ausgegeben Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Gelöst Es werden Artikelmerkmalboxen angezeigt die so nie angelegt wurden. Was ist das ?!? Einrichtung von JTL-Shop4 0
Neu Artikeletiketten für gesamten Lagerbestand drucken - nicht alle Labels werden gedruckt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu UstId bei Shop-Bestellungen werden nicht an Wawi übertragen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Variationspreise werden falsch angezeigt JTL-Shop - Fehler und Bugs 9
Neu Bundesstaaten werden nicht an JTL übermittelt (Showare 5 - JTL 1.5.35.2) Arbeitsabläufe in JTL-Wawi 0
Neu Multishop Abgleich - Bestellungen werden aus einem Shop immer dem gleichen Kunden zugeordnet Gambio-Connector 0
Neu Von Client Computer werden keine Emails verschickt JTL-Wawi - Fehler und Bugs 4
Neu [JTL SHOP 5] Sitemap kann nicht automatisch erstellt werden JTL-Shop - Fehler und Bugs 3
Neu JTL-POS-Aufträge mit Rechnung werden nicht mehr in JTL-Wawi angelegt JTL-Wawi - Fehler und Bugs 1
Neu Korrekturen im Vaterartikel werden trotz Aktualisierung der Kinder nicht in den Shop übernommen Modified eCommerce-Connector 0
In Bearbeitung Filter Einstellungen werden nie übernommen JTL-Wawi - Fehler und Bugs 1
Neu jtl shipping server kann nicht erreicht werden JTL-ShippingLabels - Fehler und Bugs 0
Neu Amazon - Variante konnte der SKU des übergeordneten Artikels nicht zugeordnet werden Fehler: 8801 Amazon-Lister - Fehler und Bugs 0
Neu Attributtexte in UTF8 Format wo Umlaute richtig in den Spalten stehen werden beim Import in unleserliche Zeichen korrigiert JTL-Ameise - Fehler und Bugs 4
Neu Mahnunge konnte nicht erstellt werden. User helfen Usern - Fragen zu JTL-Wawi 1
Neu Datev Export - Schweizer Bestellungen werden nicht mit exportiert User helfen Usern - Fragen zu JTL-Wawi 2
Neu Hersteller werden nur teilweise in Pickliste übernommen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Datei-Anhänge werden nicht ausgetauscht JTL-Wawi - Fehler und Bugs 1
In Bearbeitung Aufträge werden in POS nicht ausgeliefert JTL-POS - Fehler und Bugs 2
Neu Amazon Inventardaten (Bestände) werden nicht geändert. Amazon-Anbindung - Fehler und Bugs 0
Neu Variationsartikel / Mengen bei eBay werden nicht aktualisiert / JTL 1.5.42.0 Einrichtung und Installation von JTL-eazyAuction 2
Beantwortet Neue Lagerplätze- Aufträge werden nicht zugewiesen Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu Bilder werden im Webshop nicht angezeigt, generieren nicht möglich. Einrichtung von JTL-Shop4 3
Neu Bisherigen Druckvorlagen (nun "veraltet") werden nicht mehr korrekt ausgegeben. Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu ebay Gebüren werden teilweise nicht zurückerstattet User helfen Usern 4
Neu Sendungsnummern werden nicht an AMZ gesendet Amazon-Anbindung - Fehler und Bugs 6

Ähnliche Themen