Neu In Wawi gelöschte Kategorie noch im Shop sichtbar

Baltazar80

Gut bekanntes Mitglied
18. Januar 2014
279
17
Hallo,

wir haben ein Problem, und zwar haben in der Wawi eine Kategorie gelöscht, und diese wird weiterhin im Shop angezeigt.

Folgendes habe ich schon probiert:
- neues Komplettabgleich
- Cache gelöscht

Die Kategorie bleibt aber weiterhin bestehen.

Jetzt habe ich der Datenbank unter "tkategorie" die Kategorie gefunden, kann ich dort einfach so löschen?
Oder welchen anderen Weg gibt es denn da noch, die Kategorie enthültig vom Shop zu entferenen?
 
3. November 2018
22
1
Hallo Baltazar80,

meiner Meinung nach ist es ratsam, erst die mögliche Ursache dafür zu finden, warum ein Abgleich gescheitert ist.

Mein Tipp:
Prüfe davor, ob Dein JTL-Worker läuft und keine Fehlermeldung produziert hat, z.B. weil die MS SQL- Datenbank über eine gewisse Zeit nicht erreichbar war.

Falls es eine Fehlermeldung produziert hat, kannst Du Dein JTL-Worker neustarten.

Für den Fall, dass Du keinerlei Probleme feststellst, solltest Du Dir die in JTL-Wawi festgelegten Einstellungen für Deinen JTL-Worker anschauen und mit den Einstellungen Deines PHP Servers vergleichen. Wichtig ist hierbei, dass die Rechnung aufgeht. In der Regel reichen die Werkeinstellungen für eine reibungslose Übertragung aus.

Viele Grüße

Erhan
 

Baltazar80

Gut bekanntes Mitglied
18. Januar 2014
279
17
Danke für die Hilfe.

Wir haben ein Hosting bei Modernsolution und die nutzen da einen eigenen Worker.
Welche Einstellungen gibt es denn da zu machen beim PHP-Server?

Es könnte schon möglich sein, dass da mal ein Worker Fehler war, kam schon mal vor.
Kann es dass es dadurch nicht übertragen, also gelöscht wurde, und jetzt kann ich es nicht mehr entfernen, weil ja die Kategorie in der Wawi schon weg ist?
 
3. November 2018
22
1
Gerne.

Mit Modernsolution kenne ich mich derzeit nicht aus.
Wir hosten selbst auf eigenen Servern.

Versuch dein Glück wie folgt:

Mein allgemeiner Tipp

In JTL Wawi
Oben in der Registerkarte "Onlineshop" wählen​
Shop in der ListView (Liste) markieren​
Den Button "JTL-Shop übertragungs-Parameter anpassen" drücken​
Werte senken​
JTL Worker neustarten - Leider weis ich in Deinem Fall nicht wie Du den Worker neustarten kannst. | Evtl. den Support von Modernsolution kontaktieren und bitten deinen JTL Worker neuzustarten.​
Hast Du dort ein Windows V-Server? Dann kannst Du Dich per Remote einloggen und den JTL-Worker selbst neustarten.​
PHP - Server
Speicherlimit sowie Ausführungszeit von Skripten bei Bedarf modifizieren.
Wg. Deiner Erreichbarkeit sowie sporadischen Verbindungsunterbrechungen

Wie wird dein MS SQL Server angesprochen? Interner Netzwerk via localhost / Virtueller Server, statische IP Adresse / Domain + Port, DynDNS + Port?
=> Findest Du heraus, indem Du die JTL-Wawi aufmachst, zu den Einstellungen wechselst und dein Profil aufrufst.

Evtl. kann auch ein IP oder Port Problem zur Nichterreichbarkeit führen.
Bei den Port Angaben ist es meiner Meinung nach wichtig, dass dieser Fix hinterlegt ist und in der Firewall freigeschalten sowie vom Router an den richtigen Rechner weitergeleitet worden ist.
Mein Tipp: Keine dynamischen Ports verwenden.

Kannst Du mit Deinem SQL Server Configuration Manager nachrecherchieren.
Pfad => C:\Windows\SysWOW64\SQLServerManagerXX | Wobei XX für die SQL Server Basis Version steht z.B. 14 für 2016 sowie 2017, falls ich mich nicht täusche.

Persönlicher Hinweis

Der Worker kann die Ursache sein, muss es aber nicht.
Genauso die Erreichbarkeit des MS SQL Servers.

Interessant wären hierbei die Fehlerprotokolle aus der Ereignisanzeige des Windows-Rechners, wo der SQL Server installiert ist.
 
3. November 2018
22
1
Es erfolgte kein weiteres Feedback vom Fragesteller. Ich hoffe, dass das Problem hier in der Zwischenzeit anderweitig gelöst werden konnte. Um künftig weiteren Shop-Betreibern den Ärger zu ersparen und direkte Eingriffe auf die Datenbank zu vermeiden, folgt heute nun ein Tipp:

Im Admin-Bereich des Shops den Menüpunkt System => Wartung => Zurücksetzen wählen. Hier Artikel, Kategorien, Merkmale löschen wählen und Shop per Klick zurücksetzen lassen. Die Daten werden beim nächsten Abgleich wieder aufgefüllt. Bis dahin gilt potenzieller Umsatzverlust sowie verärgerte Kunden und Crawler (404). [Shopversion 4.05]

Die Vorgehensweise dient lediglich zum Aufheben des Fehlers, jedoch nicht zur (Herkunfts-)Analyse des Fehlers.
 

Ähnliche Themen