Neu Hilfe, Artikeldaten werden nicht mehr aktualisiert

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

infuu

Aktives Mitglied
4. Januar 2011
27
0
Hallo,
ich bitte um Hilfe.

Wawi-Version : 1.5.36.2
Shopware-Version : 5.6.9
Connector-Version : 2.8.3

Seit heute werden die Artikeldaten wie Beschreibung, Preis usw. nicht mehr aktualisiert. Habe die neusten Updates ausgeführt und JTL neu gestartet.
Im Shopware Backend sind die Änderungen auch nicht sichtbar, Cache geleert.

Fehler nach Sync:
Fehler:
Exception: Argument 1 passed to jtl\Connector\Shopware\Utilities\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in /var/www/web29558275/html/engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/ Shop.php on line 42
Argument 1 passed to jtl\Connector\Shopware\Utilities\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in /var/www/web29558275/html/engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/Shop.php on line 42
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Argument 1 passed to jtl\Connector\Shopware\Utilities\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in /var/www/web29558275/html/engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/Shop.php on line 42

Argument 1 passed to jtl\Connector\Shopware\Utilities\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in /var/www/web29558275/html/engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/Shop.php on line 42

Response: {"result":null,"error":{"code":0,"message":"Argument 1 passed to jtl\\Connector\\Shopware\\Utilities\\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in \/var\/www\/web29558275\/html\/engine\/Shopware\/Plugins\/Community\/Frontend\/jtlconnector\/src\/Utilities\/Shop.php on line 42","data":"Exception 'TypeError' (Code: 0) with message 'Argument 1 passed to jtl\\Connector\\Shopware\\Utilities\\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in \/var\/www\/web29558275\/html\/engine\/Shopware\/Plugins\/Community\/Frontend\/jtlconnector\/src\/Utilities\/Shop.php on line 42' in \/var\/www\/web29558275\/html\/engine\/Shopware\/Plugins\/Community\/Frontend\/jtlconnector\/src\/Utilities\/Locale.php:59"},"jtlrpc":"2.0","id":"unknown"}
Exception bei product.push: Argument 1 passed to jtl\Connector\Shopware\Utilities\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in /var/www/web29558275/html/engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/Shop.php on line 42

Argument 1 passed to jtl\Connector\Shopware\Utilities\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in /var/www/web29558275/html/engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/Shop.php on line 42

Response: {"result":null,"error":{"code":0,"message":"Argument 1 passed to jtl\\Connector\\Shopware\\Utilities\\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in \/var\/www\/web29558275\/html\/engine\/Shopware\/Plugins\/Community\/Frontend\/jtlconnector\/src\/Utilities\/Shop.php on line 42","data":"Exception 'TypeError' (Code: 0) with message 'Argument 1 passed to jtl\\Connector\\Shopware\\Utilities\\Locale::extractLanguageIsoFromLocale() must be of the type string, null given, called in \/var\/www\/web29558275\/html\/engine\/Shopware\/Plugins\/Community\/Frontend\/jtlconnector\/src\/Utilities\/Shop.php on line 42' in \/var\/www\/web29558275\/html\/engine\/Shopware\/Plugins\/Community\/Frontend\/jtlconnector\/src\/Utilities\/Locale.php:59"},"jtlrpc":"2.0","id":"unknown"}
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.QaPdKhGTkfG(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.UkbdKz291r2(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.QaPdKhGTkfG(String , Object , Boolean , NetworkCredential )


Vielen Dank!
 

JPM

Aktives Mitglied
29. Dezember 2017
3
0
Wir haben das gleiche Problem. Sehr ungünstig gerade jetzt nach der MwSt-Umstellung. Preise können im Shop nicht aktualisiert werden.
Der trat übrigens erstmals nach dem JTL-Update auf 1.5.36.2 auf. Der Connector war da noch nicht der aktuelle. Aber Update auf 2.8.3 brachte keine Besserung.
 
Zuletzt bearbeitet:

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.113
236
Hallo,

wir wollen das Problem schnellstmöglich analysieren und beheben. Dafür benötigen wir einen Onlineshop-Abgleich Log von einem fehlgeschlagenen Abgleich. Den könnt ihr mir gerne per PM schicken.
 

PJone

Aktives Mitglied
20. Oktober 2017
30
1
Hallo,

wir haben ein ähnliches Problem:

Viele Artikel werden nicht mehr in Shopware Aktualisiert.

Ich habe mal eines dieser Artikel in Shopware gelöscht und versucht diese dann nochmal mit der Wawi abzugleichen.
Dieser Artikel wird nun nicht mehr an Shopware übertragen.

Seltsamerweise ist das nicht bei allen Artikeln, obwohl die Einstellungen und Kategorien gleich sind.
Das Problem tritt erst seit MwSt Änderung (zurück auf 19%) auf. Diese haben wir nach Eurer Anleitung durchgeführt und war erfolgreich.

Des Weiteren können wir uns keine Changelog anzeigen lassen.
Wir möchten die Wawi von 1.5.29.3 auf 1.5.36.2 aktualisieren.

Hinweis: Sie führen ein Update auf eine Pilotversion von JTL-Wawi durch. Für Pilotversionen sind leider keine Changelogs verfügbar.

Was bedeutet das?

Viele Grüße
 

infuu

Aktives Mitglied
4. Januar 2011
27
0
Das Löschen von Artikeln funktioniert jedenfalls.

Ich möchte den Hotfix testen, hab dir PM geschickt.
 

PJone

Aktives Mitglied
20. Oktober 2017
30
1
Nun lassen sich gar keine Artikel mehr aktualisieren oder hinzufügen.
Leider erstellt die Wawi auch keine Worker Log Datei obwohl dies eingestellt ist.

Der Worker ist aktiv und Bestellungen werden übertragen.
Nur eben keine Produktänderungen mehr.

Heute morgen konnten zumindest noch ein paar Produkte aktualisiert werden.

Habt Ihr vielleicht eine Idee?
 

SHAAN

Aktives Mitglied
26. August 2020
201
41
Also bei mir werden keine Bilder bei neuen Produkten übertragen.
Kann es bestätigen. Wir haben heute rund 50 Artikel bearbeitet (keine neuen Artikel), denen wir Bilder hinzugefügt haben (Artikel hatten zuvor noch keine Bilder). Diese sollen laut JTL-Artikeldaten Info abgeglichen worden sein. In Shopware sind diese nicht angekommen (auch im Backend nachgesehen).

Alles auf dem neusten Stand.
 

thomashummer

Neues Mitglied
4. März 2020
4
0
Muss den Thread nochmals aufwärmen. Haben bei einem Kunden ebenfalls das Problem dass z.B. Bilder nicht im Shopware-Backend ankommen. Connector- Log zeigt keine Fehler. Alle Komponenten auf dem neuesten Stand.
Hat jemand ebenfalls Probleme mit dem Artikeltransfer?
 

lumbert

Gut bekanntes Mitglied
2. April 2009
317
11
@Immanuel

Ich habe Kundenrückmeldungen, das dieses Problem weiterhin auftritt wenn man einen Artikel in der Wawi dupliziert und dabei auch die Bilder mitnimmt. Dupliziert man einen Artikel in der Wawi ohne Bildübernahme und fügt diese danach manuell dazu, funktioniert der Transfer in den Shop.

Wawi & Connector jeweils die neuste Version.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Hilfe zu Automatisierungs-Schritte: Ist es möglich aus einer Lieferantenbestellung die Erstellung eines Auftrages zu automatisieren? Arbeitsabläufe in JTL-Wawi 0
Neu Doppelbedingungen in Formular - Formel kreiert je Währung - Bitte um Hilfe! Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu DRINGEND HILFE --> Versanddatenexport "aus versehen" / Rückgängig machen User helfen Usern - Fragen zu JTL-Wawi 6
Neu neues Produkt von Shopify >> zu JTL ! Hilfe ?? Shopify-Connector 1
Neu Wir suchen dringend praktische Hilfe für unseren JTL-Webshop Dienstleistung, Jobs und Ähnliches 1
Neu Workflow: brauche dringend Hilfe bei WF User helfen Usern 17
Neu Packtisch + interne Buchung von Hauptlager an Ladenlokahl - HILFE!!!! User helfen Usern - Fragen zu JTL-Wawi 1
Neu HILFE!!! Datumsformat bei Auftrags-Importen mit der Ameise User helfen Usern - Fragen zu JTL-Wawi 1
In Diskussion Hilfe ! WaWi wie wo kann ich die DHL Lable ausdrucken JTL-ShippingLabels - Ideen, Lob und Kritik 3
Neu Hilfe für den nächsten Schritt Dienstleistung, Jobs und Ähnliches 2
Neu Hilfe bei Fehlersuche JTL-Wawi - Fehler und Bugs 2
Neu Hilfe UpDate shop 4 auf 5 JTL-Shop - Fehler und Bugs 2
Neu Bitte um Hilfe bei Lagerbuchungen Arbeitsabläufe in JTL-Wawi 7
Neu Hilfe - Ich habe wohl ein inkompatibles Plugin erwischt und nun? JTL-Wawi - Fehler und Bugs 5
Neu Arbeiten nicht mit Staffelpreisen! JTL nimmt sich aber diese Preise! Was TUN HILFE??? JTL-Wawi - Fehler und Bugs 1
Neu Hilfe für Shop Einrichtung gesucht Dienstleistung, Jobs und Ähnliches 1
Neu Hilfe im Html Editor JTL-Wawi - Fehler und Bugs 5
Neu Hilfe mein Warenkorb hat die Macht übernommen. Einrichtung von JTL-Shop4 3
Neu Hilfe mit JTL Automatisierung Dienstleistung, Jobs und Ähnliches 1
Neu Shop 5 sendet Verfügbarkeitsbenachrichtigung, wenn Artikeldaten verändert werden JTL-Shop - Fehler und Bugs 4
Neu Fehlerhaftes Kassenbuch-Rabatte aus Wawi werden nicht berücksichtig JTL-POS - Fehler und Bugs 0
Neu Bearbeitete Vorlagen werden nicht gespeichert Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Ebay Artikel werden neu eingestellt? eBay-Anbindung - Fehler und Bugs 13
Beantwortet Merkmal-Änderungen werden nicht übernommen User helfen Usern - Fragen zu JTL-Wawi 1
Neu Positionen werden doppelt angezeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Es werden Keine Paypalzahlungen mehr an die WaWi übertragen JTL-Shop - Fehler und Bugs 0
Neu Hintergrund kann nicht geändert werden Templates für JTL-Shop 2
Neu Eingangsrechnng kann nicht erstellt werden Alle Position nur geliferte Positionen grau Arbeitsabläufe in JTL-Wawi 1
Neu Angebote werden erstellt obwohl verfügbarer Bestand = 0 eBay-Anbindung - Fehler und Bugs 2
Neu Ebay ie/es/it/fr Angebote können nicht hochgeladen werden eBay-Anbindung - Fehler und Bugs 2
Neu Artikel werden aus der Wawi nicht in der POS aktualisiert. Allgemeine Fragen zu JTL-POS 1
Neu SEO : Bilder aus OPC werden nicht richtig übernommen Allgemeine Fragen zu JTL-Shop 0
Neu Lieferzeiten aus der Wawi werden bei Stücklisten nicht übernommen JTL-Shop - Fehler und Bugs 1
Neu Variationen können nicht geändert werden Gambio-Connector 0
Neu Datenbank kann nicht geöffnet werden. Sie wird zurzeit wiederhergestellt. Installation von JTL-Wawi 0
Neu HTML Icons in Beschreibung werden zerhauen Onlineshop-Anbindung 0
Neu Textbausteine werden nicht gesendet Servicedesk (Beta) 1
Neu Aktualsierungen am Titel oder Beschreibungen werden nicht übermittelt Shopify-Connector 2
Onpage Composer Änderungen werden nicht veröffentlicht Upgrade JTL-Shop4 auf JTL-Shop5 7
Neu Dropshipping Bestellungen werden unregelmässig nicht gemailt Arbeitsabläufe in JTL-Wawi 0
Neu Kinder komplett kopieren, jedoch alle Zuordnungen zum Vater werden aufgehoben. Arbeitsabläufe in JTL-Wawi 4
Neu Angebote / TOP-Artikel werden nicht Übertragen - Angezeigt Gambio-Connector 0
Neu Offene Posten werden nicht angezeigt User helfen Usern - Fragen zu JTL-Wawi 0
Neu fontawesome Schriften werden doppelt geladen Templates für JTL-Shop 0
Neu Beim Anlegen der Lieferadresse eines Kunden kann die "Anrede" nicht individuell eingegeben werden. Arbeitsabläufe in JTL-Wawi 0
Neu Artikel mit dem Zustand „Vom Hersteller generalüberholt“ werden beendet. eBay-Anbindung - Ideen, Lob und Kritik 0
Neu Artikel werden auf Pickliste nicht angezeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Fehler ebay Massenupdate - Artikel kann nicht zurückgegeben werden eBay-Anbindung - Fehler und Bugs 0
Neu Online-Artikel können x-mal gekauft werden, trotz Lagerbestand 0 oder 1?! Einrichtung JTL-Shop5 3
Neu 5.0.1 - Artikelbilder werden nicht angezeigt JTL-Shop - Fehler und Bugs 4
Ähnliche Themen