Gelöst Gutscheine werden nicht von der POS erkannt - und dann doch wieder

Predpray

Sehr aktives Mitglied
26. Oktober 2018
294
33
Zehdenick
Firma
Born-Store
Hallo liebe JTLer,

also ich schätze mal mit eins zwei Sätzen ist das hier nicht zu machen. Gestern habe ich mich dazu entschlossen JTL-Vouchers zu nutzen. Ich habe im Laden immer wieder Kunden, die gerne einen Gutschein verschenken wollen.
Was habe ich gemacht:
Ich habe JTL-Vouchers gebucht (19,99 netto) und dann unter https://vouchers.jtl-software.com/#/dashboard alles eingerichtet. Außerdem habe ich die Anleitungen abgearbeitet und die WAWI 1.6.47.2 sowie die POS mit dem Gutscheintool verbunden. Die Beschreibungen sind teilweise derart konfus, dass ich nicht mehr weiß wo ich gerade bin. Man hat das Gefühl es gibt kein Anfang und kein Ende.

In der WAWI habe ich einen neuen Verkausfkanal angelegt und dort dann die Zahlungsart "Gutschein" sowie einen Gutscheinartikel Digital. Dieser übernimmt aber keine "Seriennummern" aus dem Vouchers Dashboard. Was soll denn bei Seriennummer rein? Da steht aktuell #$KEINE$#.
Müssen hier für 1000 Gutscheine die Gutscheinnummern rein oder der Gutscheincode? Oder wird das automatisch generiert? Nirgends findet man dazu eindeutige Anleitungen.
Unter KASSEN habe ich den Gutscheindrucker eingestellt. Bei einem ersten Test, hat dieser auch meinen "verkauften" Gutschein gedruckt. Bei Versuch eben diesen dann wieder einzulösen, meint die POS der Code sei ungültig!

Ich könnte hier wirklich mal Hilfestellung gebrauchen.

Ich danke schon mal und trinke entnervt ein Wasser.
Gruß Predpray
 

Predpray

Sehr aktives Mitglied
26. Oktober 2018
294
33
Zehdenick
Firma
Born-Store
UPDATE

Nach wiederholten Versuchen klappt nun - warum auch immer - die Übergabe an den Drucker aus der POS und der Code wird nun auch erkannt und kann genutzt werden. Nun steht das nächste Thema an. Die eigenen Karten mit den Infos bedrucken. Dafür muss ich wohl eine Vorlage anlegen. Dafür mache ich wahrscheinlich einen eigenen Thread auf.
 
  • Gefällt mir
Reaktionen: recent.digital

Predpray

Sehr aktives Mitglied
26. Oktober 2018
294
33
Zehdenick
Firma
Born-Store
JA - Da habe ich mich wohl zu früh gefreut? Aktuell habe ich für eine telefonische Kundenbestellung einen Auftrag für einen Gutschein in der WAWI angelegt und versendet. Der Gutschein wurde mit dem richtigen Wert ausgedruckt und in der Cloud als aktiv angezeigt.
Gehe ich jetzt an meine Kasse und möchte den Wert aulesen bekomme ich ein " Der Gutscheinwert ist ungültig". Diesen Gutschein kann ich so ja nicht versenden.

Was läuft denn nun falsch?
 
Zuletzt bearbeitet:

Predpray

Sehr aktives Mitglied
26. Oktober 2018
294
33
Zehdenick
Firma
Born-Store
Hallo
Mache mir weiterhin Gedanken, wie ich nun der Misere wieder entkomme. Der Kunde hat den Auftrag bereits bezahlt. Der dafür generierte Gutschein lässt sich aber über die POS nicht einlesen. Also nicht versendbar. Was kann ich daraus schließen?
Gutscheine die in der WAWI mittels Auftragerstellung generiert werden, lassen sich nicht in der POS bearbeiten? Kann man diese Gutscheine nur in der WAWI einlösen wenn Sie dort erstellt werden? Macht irgendwie wenig Sinn.

Um dem Kunden nun einen funktionierenden Gutscheincode zukommen zu lassen, würde ich jetzt in der POS einen neuen 50 Euro Gutschein anlegen, diesen virtuell als bar bezahlt markieren und dann ausdrucken. Oder wie würdet Ihr das jetzt machen? Und wie kann ich das Buchhalterisch lösen?

Ich brauche hier drindend den Rat von Vouchers-Versteher (Entwickler). Möchte ungerne ein Ticket eröffnen.

Gruß Frank
 

Predpray

Sehr aktives Mitglied
26. Oktober 2018
294
33
Zehdenick
Firma
Born-Store
UPDATE
Heute habe ich dann mal in der Cloud einen digitalen Gutschein mit festem Wert erzeugt. Den gleichen dann in der WAWi angelegt. In der WAWi dann einen Auftrag erzeugt und diesen Gutschein verkauft. Bezahlt und ausgeliefert. Der Druck funktioniert wie bestellt. Der erst Gutscheincode wurde wieder nicht von der Kasse erkannt. Also noch einmal alles durch gegangen und beim zweiten Gutscheincode hat es dann geklappt. Donnerwetter. Ich hoffe wir finden dafür eine Lösung. Das ist irgendwie Beta.
Morgen hab ich einen Termin mit dem Support. Mal schauen ob es etwas hilft.
 

Predpray

Sehr aktives Mitglied
26. Oktober 2018
294
33
Zehdenick
Firma
Born-Store
Hallo @Predpray ,

konnte dein Problem gelöst werden?
Grüße
Hallo,
beim Support hat natürlich alles funktioniert. Da konnten wir rein garnicht fixen. Wir denken das es eventuell ein Latenzproblem sein könnte. Cloud kurzfristig überlastet. Meine Wawi liegt auch in der Cloud. Wir wissen es nicht und beobachten das ganze.
NACHTRAG: Eure Vouchers sind ja in der Gültigkeit frei einstellbar. Ich wollte dies auch auf 24 Monate begrenzen. Da ich meine AGBs von einem bekannten Plugin erstellen lasse, bin ich ins Backend und wollte diese anpassen. Geht aber nicht. 3 Jahre und Punkt. Da habe ich den RA angeschrieben und dieser hat mir geantwortet. siehe Bild.

Screenshot_20231029_122111_Email.jpg

Wie ist denn nun rechtlich. Demzufolge müssten ALLE Gutscheine 36 Monate gültig sein.

Gruß und einen schönen Sonntag
 

recent.digital

Offizieller Servicepartner
SPBanner
8. Juli 2015
1.421
420
Wuppertal
Was technisch möglich ist und was rechtliche Relevanz hat sind zwei Aspekte; merkt man auch hier im Forum immer wieder bei rechtlichen Neuerungen. Wir kennen den genauen Hintergrund nicht, aber ggf. möchte man Gutscheine mit begrenzter Gültigkeit ausstellen, die man verschenkt - das könnte einen anderen rechtlichen Rahmen haben und die Software soll da nicht der limitierende Faktor sein. Alles Spekulation - und Rechtsberatung schon dreimal nicht :)
 

Predpray

Sehr aktives Mitglied
26. Oktober 2018
294
33
Zehdenick
Firma
Born-Store
Hallo,
noch einmal abschließend zur Fehlersuche. Dieses Mal war es nicht die POS. Es war der Scanner. Dieser hatte eine englische Grundeinstellung, was bei Zahlen ja unerheblich ist. Aber immer wenn bei einem Gutscheincode ein "Z" war, gab der Scanner ein "Y" aus. Deshalb auch sporadisch. Da muss man mal drauf kommen. Ich habe dann auf DEUTSCH umgestellt und nun wird auch ein "Z" ausgegeben. Vielleicht hilfreich das mit ins HowTo aufzunehmen.
Gruß
 
  • Gefällt mir
Reaktionen: .:steven:.
Ähnliche Themen
Titel Forum Antworten Datum
Neukunden Gutscheine werden immer abgezogen Einrichtung JTL-Shop5 0
Neu Gutscheine mit Anzahl und Code erstellen ? Allgemeine Fragen zu JTL-Shop 1
Versandkostenfrei für Gutscheine? JTL-Wawi 1.8 7
Neu Ebay Artikel - bei Umstellung auf Designvorlagen werden Beschreibungen verändert User helfen Usern - Fragen zu JTL-Wawi 1
Neu Es werden unterschiedliche Warenkorbansichten gezeigt JTL-Shop - Fehler und Bugs 1
Neu Inaktive Artikel werden mit 404 Fehler bei Google Search angezeigt Allgemeine Fragen zu JTL-Shop 2
Neu Download-Arikel werden im Backend des Kunden nicht angezeigt JTL-Shop - Fehler und Bugs 1
[JTL-WAWI API] Nettopreise werden nicht gespeichert JTL-Wawi 1.8 0
Neu Amazon Lister übergibt nur das Hauptbild an Amazon, weiter Bilder werden nicht übertragen Amazon-Lister - Fehler und Bugs 0
Neu Artikel werden nicht mehr aktualisiert, wenn sie sich auf Pickliste befinden JTL-Ameise - Fehler und Bugs 1
Neu syntaxfehler report.invoicebilltoaddress.country kann nicht interpretiert werden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu webp-Bilder werden nicht mehr generiert JTL-Shop - Fehler und Bugs 0
Neu Artikelbilder werden im Shop verzerrt angezeigt JTL-Shop - Fehler und Bugs 4
Neu Warum werden Filter nach Auswahl in der Sidebar ausgeblendet? Allgemeine Fragen zu JTL-Shop 3
Neu Beim duplizieren von Aufträgen werden alte Daten übernommen Arbeitsabläufe in JTL-Wawi 10
Otto externe Rechnungen werden mit falschem Datum erstellt Otto.de - Anbindung (SCX) 3
Neu TSE Modul wird nicht mehr erkannt, kann auch nicht wieder aktiviert werden, diverse Fehlermeldungen JTL-POS - Fehler und Bugs 0
Neu Easyshipping Amazon-Aufträge werden nicht abgeholt JTL-Wawi - Fehler und Bugs 2
Neu PayPal Checkout - Bestellungen werden nicht übertragen! User helfen Usern - Fragen zu JTL-Wawi 0
Variablen werden nicht mehr in die verschiedenen Vorlagen übertragen JTL-Wawi 1.8 0
In Diskussion Preise werden falsch aufsummiert - bzw. nicht mit berechnet JTL-Workflows - Fehler und Bugs 2
Neu Bilder werden teilweise in verschiedenen Browser falsch dargestellt Gelöste Themen in diesem Bereich 3
Neu Versandkosten im Warenkorb werden als Artikel angezeigt Allgemeine Fragen zu JTL-Shop 6
Neu Artikel werden nicht übertragen Shopify-Connector 0
Neu Der mehrteilige Bezeichner "AlleAttributeMitWerten.Gruppe" konnte nicht gebunden werden JTL-Wawi - Fehler und Bugs 2
Neu Kategorien werden nicht abgeholt Shopware-Connector 0
Neu Es werden keine Variationen angezeigt JTL-Shop - Fehler und Bugs 1
Rechnung werden nicht auf Kaufland hochgeladen kaufland.de - Anbindung (SCX) 0
Neu Geschäftskundenpreise werden auf den Artikelseiten für jeden angezeigt JTL-Wawi - Fehler und Bugs 0
In Bearbeitung Kasse aktualisiert keine Produkte / Verkäufe werden jedoch in WAWI angezeigt JTL-POS - Fehler und Bugs 4
Neu Kategoriebilder werden immer mit großem leeren Platz (wie für das 2.Bild) angezeigt Allgemeine Fragen zu JTL-Shop 6
JTL-WMS und JTL-Packtisch+ Es können nun einzelne Artikel im Versand gewogen werden Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Neu Woocommerce Upsells und Cross-Sells werden af JTL Shop angezeigt. JTL-Wawi - Fehler und Bugs 0
Neu Umlaute werden nicht mehr richtig in der Wawi dargestellt. (Artikelname) JTL-Wawi - Fehler und Bugs 0
Neu Kategoriebilder werden nicht angezeigt / RSS.xml nicht beschreibbar JTL-Shop - Fehler und Bugs 0
Wo ist der JTL Worker bei der 1.8.10.0 wird nicht installiert Crash Windwos Server. Bestellungen werden nicht abgeholt JTL-Wawi 1.8 38
Neu Änderungen im Spalteneditor werden nicht übernommen JTL-Wawi 1.7 1
Cross Selling Artikel können nicht gelöscht bzw. hinzugefügt werden JTL-Wawi 1.8 2
Neu Nicht alle Unterkategorien werden angezeigt Betrieb / Pflege von JTL-Shop 0
Neu Wawi läuft, aber ein Rechner hat den Pfad zur Datenbank verloren, Mandant kann nicht ausgewählt werden User helfen Usern - Fragen zu JTL-Wawi 3
Aufträge werden nicht mit korrektem Kaufdatum/Uhrzeit importiert JTL-Wawi 1.8 0
Optionen bei Kaufland werden von alleine angelegt? kaufland.de - Anbindung (SCX) 1
Neu Versandart kann nicht gelöscht werden User helfen Usern - Fragen zu JTL-Wawi 0
Mahnung(en) konnte(n) nicht erstellt werden. JTL-Wawi 1.8 4
Neu DHL Sendungsnummer werden nicht zu Amazon (Italien & Spanien) übertragen JTL-ShippingLabels - Fehler und Bugs 7
Neu Track & Trace - wie lange werden Logs gespeichert? JTL-Track&Trace - Ideen, Lob und Kritik 1
Neu Amazon.de hinzufügen nicht möglich URL konnte nicht gefunden werden Amazon-Anbindung - Fehler und Bugs 1
Neu Artikel können nicht geöffnet werden (Geisterartikel) update: Problem gelöst User helfen Usern - Fragen zu JTL-Wawi 0
Neu Zulange Adressen werden nicht automatisch gekürzt, bekanntes Problem? JTL-ShippingLabels - Fehler und Bugs 0
Beantwortet Lizenzen werden nicht erneuetr. Shop in JTL deaktiviert und keine neuen Bestellungen kommen ins System Gelöste Themen in diesem Bereich 2

Ähnliche Themen