Neu Formulardesigner und Abfrage der Zahlungsbedingungen

M'o

Aktives Mitglied
7. März 2009
52
3
Hallo zusammen,

ich habe folgendes Problem, was ich mir nicht erklären kann. Die Bedingung für die Anzeige der Zahlungsbedingungen im Beleg ist Folgende. Bei Barzahlung:

Report.OpenGrossPrice > 0 AND Report.InvoicePaymentInformation.PaymentMethodType <> 'Überweisung'

oder bei Überweisung:

Report.OpenGrossPrice > 0 AND Report.InvoicePaymentInformation.PaymentMethodType <> 'Bar'

Weitere Zahlungsbedingungen finden keine Verwendung, sind daher nicht berücksichtigt. Die Werte stehen so auch in der Datenbanksicht "Report.Invoice" so drin:

1579968526266.png

Trotzdem klappt die Abfrage nicht. Gebe ich das Feld im Beleg direkt aus, so steht jedes Mal "INVOICE" drin. Was geht hier schief oder hat die JTLWawi (1.15.13.1) / der Editor einen Bug? Danke für einen Tipp!
 

Notebookpartstore

Gut bekanntes Mitglied
17. März 2013
162
4
Hi M'o
was hast Du denn bei den Zahlungsbedingungen für diesen Auftrag/Rechnung/Kunde hinterlegt?

Habe es mal bei mir nachgestellt und dort taucht eben auch Amazon und Paypal mit auf.
Schau mal im Auftrag ob dort keine Zahlungsart hinterlegt ist.

Grüße
Fabian
 

M'o

Aktives Mitglied
7. März 2009
52
3
Hi Fabin,

danke für den Hinweis. Die Zahlungsbedingung im Auftrag ist natürlich Bar bzw. Überweisung. Sie wurde auf dem Kundendatensatz in den Auftrag und dann ff. auch in die Rechnung übernommen.
Die anderen ZBeds sind auch vorhanden, kommen aber nicht zum Einsatz.