Gelöst Fehler beim Aktualisieren der Datenbank

  • Ersteller des Themas Ersteller des Themas SP-BB
  • Erstellungsdatum Erstellungsdatum

SP-BB

Aktives Mitglied
23. Juni 2015
3
0
Hallo zusammen,

wir wollten testweise von der Version 099923 auf die 099960 updaten. Dabei kam es während der Aktualisierung der Datenbank zu insgesamt 72 Fehlern und das Update wurde abgebrochen.

Im Log-File steht z.B. folgende Fehlermeldung drin:

"Löschen des Index-Objekts 'dbo.tartikel.IX_ArtikelName' ist nicht möglich, weil das Objekt nicht vorhanden ist oder Sie nicht die erforderliche Berechtigung haben."

Diesen Index gibt es tatsächlich in unserer DB der Version 099923 nicht. Wie kann das sein? Selbstverständlich haben wir keine Indizes in der alten DB gelöscht.

Im Logfile stehen noch jede Menge ähnliche Fehlermeldungen drin, in denen Objekte gelöscht werden sollen, die bei uns aber gar nicht vorhanden sind, z.B.
"Löschen des Index-Objekts 'dbo.tartikel.IX_Artikelnr' ist nicht möglich, weil das Objekt nicht vorhanden ist oder Sie nicht die erforderliche Berechtigung haben."
"Löschen des Index-Objekts 'dbo.tartikel.IX_Barcode' ist nicht möglich, weil das Objekt nicht vorhanden ist oder Sie nicht die erforderliche Berechtigung haben."

Ich bin hier ziemlich ratlos. Kann uns jemand helfen?

Danke und Grüße,

Bettina
 

MartinK

Moderator
Mitarbeiter
5. Dezember 2013
79
14
AW: Fehler beim Aktualisieren der Datenbank

Hallo,

die Struktur der Datenbank scheint hier beschädigt zu sein. Für ein Update muss sie durch den Support korrigiert werden. Bitte an den Support wenden mit der Bitte um eine Datenbankreparatur.
 

SP-BB

Aktives Mitglied
23. Juni 2015
3
0
AW: Fehler beim Aktualisieren der Datenbank

Hallo,

vielen Dank! Dann werde ich ein Ticket erstellen.

Danke + Grüße,
Bettina
 

Ähnliche Themen