Neu Fehler beim Abgleich, Category | hostId = 75 | Resource "custom_collections" | The Shopify server responded with the status 422

Dano

Gut bekanntes Mitglied
30. Oktober 2016
140
18
Hallo,

es tritt ein Fehler beim Abgleich ab.

Der Abgleich startet mit dem Schritt "Kategorien senden" und bricht darauf hin ab.
Daher können wir uns den Fehler nicht erklären. In Shopify gibt keine automatischen Kategorie, lediglich manuelle Kategorien.
Habt ihr eine Idee?

JTL Wawi Version 1.4.35

"
Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für ''.

Hinweis: Artikel werden mit der Einstellung <Eingeschränkt> hochgeladen. Dadurch werden keine neu angelegten Artikel zum Shop geschickt, sondern nur Preise und/oder Bestände von bereits im Shop vorhandenen Artikeln.

Onlineshop-Abgleich beendet für ''.


Fehler:
Exception: Category | hostId = 75 | Resource "custom_collections" | The Shopify server responded with the status 422 and the following error: "handle => has already been taken"
Category | hostId = 75 | Resource "custom_collections" | The Shopify server responded with the status 422 and the following error: "handle => has already been taken"
Kategorien-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei category.push: Category | hostId = 75 | Resource "custom_collections" | The Shopify server responded with the status 422 and the following error: "handle => has already been taken"

Category | hostId = 75 | Resource "custom_collections" | The Shopify server responded with the status 422 and the following error: "handle => has already been taken"

Response: {"result":null,"error":{"code":422,"message":"Category | hostId = 75 | Resource \"custom_collections\" | The Shopify server responded with the status 422 and the following error: \"handle => has already been taken\"","data":null},"jtlrpc":"2.0","id":"4b78c17c0bd140e8b0c37d17ff6bc91f"}
Exception bei category.push: Category | hostId = 75 | Resource "custom_collections" | The Shopify server responded with the status 422 and the following error: "handle => has already been taken"

Category | hostId = 75 | Resource "custom_collections" | The Shopify server responded with the status 422 and the following error: "handle => has already been taken"

Response: {"result":null,"error":{"code":422,"message":"Category | hostId = 75 | Resource \"custom_collections\" | The Shopify server responded with the status 422 and the following error: \"handle => has already been taken\"","data":null},"jtlrpc":"2.0","id":"09f91af9d5a648598615700c33a538a2"}
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.ONcizS2jjYv(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.sNYlwLgCBrx(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.ONcizS2jjYv(String , Object , Boolean , NetworkCredential )

Warnungen:
Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.
"
 
Zuletzt bearbeitet:

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
329
Hallo @Dano,

die Fehlermeldung besagt, dass versucht wird eine Kategorie im Shop anzulegen, mit einem "handle", welches schon eine andere Kategorie im Shop besitzt. Ich würde vermuten, dass du in der Vergangenheit die Daten aus dem Shop (Custom Collections + Artikel) mal in die Wawi importiert hast und danach irgendwann der Connector zurück gesetzt worden ist. Ich würde Artikel und Kategorien einfach erneut in die Wawi importieren. Damit sollten bestehende Daten zusammengeführt und das Problem dadurch auch gelöst werden. Vorher aber schön ein Backup der Daten machen.^^

Falls du herausfinden möchtest welche Kategorie dafür verantwortlich ist, dann suche in der Wawi nach der Kategorie mit dem "internen Schlüssel" 75. Diese Kategorie sollte ein Attribut "handle" besitzen.
 
  • Gefällt mir
Reaktionen: Karl V.

Dano

Gut bekanntes Mitglied
30. Oktober 2016
140
18
Hallo @Immanuel

super! Hab vielen Dank!

Nachdem wir die besagte Kategorie in JTL gelöscht hatte, hat der Abgleich wieder funktioniert.
 
  • Gefällt mir
Reaktionen: Immanuel

Ähnliche Themen