Neu Fehler bei Update DB Shop 4 auf Shop 5

world´s_end

Aktives Mitglied
11. April 2017
6
0
Hallo,

beim Update der DB wird mir folgender Fehler angezeigt.

" Fehler in

update/migrations/20180522105000_new_linkgroup_associations.php



Update auf Migration: Removes keywording admin menu entry erfolgreich Fehler bei Update: "SQLSTATE[42000]: Syntax error or access violation: 1075 Incorrect table definition; there can be only one auto column and it must be defined as a key" in:

..... update/migrations/20180522105000_new_linkgroup_associations.php "

Weis da jemand weiter?
 

waldemar.p

Moderator
Mitarbeiter
6. Januar 2016
111
17
Hm anhand der Fehlermeldung ist leider schwierig zur deuten welche SQL Abfrage in der Datei betorfen ist.
Es könnte z.B. an den ersten Abfragen liegen, das ggf. die Tabellen bereits modifiziert sind so dass beim Update nicht mehr vom Ursprung ausgegangen werden kann.
https://gitlab.com/jtl-software/jtl...0522105000_new_linkgroup_associations.php#L29

Da muss man am besten diese über phpMyAdmin versuchen abzusetzen und zu prüfen ob diese wirklich das Problem verursachen.

Am besten erstellst du ein Support Ticket dann können wir das genauer prüfen.
 

Ähnliche Themen