Neu Fehler bei Datenbankoptimierung von 1.7.15.3 auf 1.8.7.4

m_haen

Neues Mitglied
7. November 2023
5
2
Guten Abend zusammen,

aktuell habe ich beim Upgrade auf die Version 1.8 folgenden Fehler beim Datenbankupgrade. Das Update wird direkt auf dem Server als Administrator ausgeführt.
Die Update-Datei wurde zwei Mal direkt von der Website heruntergeladen. Woher "Fehler in der Version 1.8.6.0" kommt, kann ich mir nicht so recht erklären.

Code:
07:00:12 Fehler in der Version 1.8.6.0 beim Befehl:
==============================================IF(EXISTS(
    SELECT 1
    FROM sys.columns
    JOIN sys.tables ON tables.object_id = columns.object_id
    JOIN sys.schemas ON schemas.schema_id = tables.schema_id
    WHERE sys.schemas.name = 'PParams'
    AND OBJECT_NAME(sys.tables.object_id) = N'tProcessParameter'
    AND sys.columns.name = 'cId'
))
BEGIN
    ALTER TABLE [PParams].[tProcessParameter] ALTER COLUMN cId NVARCHAR(100) NULL
END
==============================================
FEHLER:
Index "UQ_PParams_tProcessParameter_cId" ist von Spalte "cId" abhängig.
Fehler bei ALTER TABLE ALTER COLUMN cId, da mindestens ein Objekt auf diese Spalte zugreift.


07:00:12 Fehler in der Version 1.8.6.0 beim Befehl:
==============================================CREATE UNIQUE INDEX UQ_PParams_tProcessParameter_cId ON PParams.tProcessParameter (cId) WHERE cId IS NOT NULL==============================================
FEHLER:
Fehler bei dem Vorgang, weil ein Index oder eine Statistik mit dem Namen "UQ_PParams_tProcessParameter_cId" für "PParams.tProcessParameter" (Tabelle) bereits vorhanden ist.

Hat jemand einen ähnlichen Fehler und konnte diesen beheben?
 
Zuletzt bearbeitet:

Verkäuferlein

Sehr aktives Mitglied
29. April 2012
2.314
822
Sind alle anderen Verbindungen auf dem Wawi-Server und nach außen ( Worker aus?) getrennt?

Ansonsten mach mal ein Ticket bei JTL auf, irgendwas scheint da ja eine Tabelle in der DB zu sperren.
 
  • Gefällt mir
Reaktionen: Arne Janson

m_haen

Neues Mitglied
7. November 2023
5
2
Soweit sind alle Verbindungen nach außen getrennt, der Worker ist ebenfalls aus. Sicherheitshalber habe ich die DB auch kurz offline genommen, um das sicherzustellen.

Ticket wurde soeben erstellt. Ich berichte, sobald ich eine Lösung habe.
 
  • Gefällt mir
Reaktionen: Arne Janson

Enrico W.

Administrator
Mitarbeiter
27. November 2014
8.165
1.591
Eine Frage, um eine Vermutung zu untermauern:
Es ist euer erstes Update überhaupt, korrekt? Die Tatsache, dass ihr relativ neue Mitglieder seid, scheint das noch zu unterstreichen.
 

Senner99

Neues Mitglied
26. September 2023
2
1
Eine Frage, um eine Vermutung zu untermauern:
Es ist euer erstes Update überhaupt, korrekt? Die Tatsache, dass ihr relativ neue Mitglieder seid, scheint das noch zu unterstreichen.
Jein. Relativ neu ja, habe allerdings auch schon erfolgreich ein Update vor ca. 1 Monat durchgeführt. Kann natürlich auch sein, dass das ein Glückstreffer war und wir hier alle einen "Anfängerfehler" machen. :)
 
  • Gefällt mir
Reaktionen: Enrico W.

Enrico W.

Administrator
Mitarbeiter
27. November 2014
8.165
1.591
Nein, macht ihr nicht, da bin ich recht sicher. :cool:

select * from tUpdateMigration

Könnt ihr mal schauen, ob da in der Tabelle was drin steht?
 

vk-ecommerce

Neues Mitglied
8. November 2023
9
2
hab die abfrage eben gestartet:

select * from tUpdateMigration

die tabelle ist leer. ich habe die datenbank aber bereits zurückgespielt und die alte wawi version installiert, damit ich jtl starten kann
 
  • Gefällt mir
Reaktionen: Enrico W.

FML

Neues Mitglied
4. November 2023
8
2
Ich habe, wenn ich mich nicht täusche, auch schon ein Update gemacht. Ich kann aber die Frage, ob wir bereits ein Update gemacht haben oder nicht, nicht verstehen. Ich habe in einem anderen Umfeld bereits mehrere Updates, auch von deutlich älteren, Versionen gemacht und dort ist nie ein solches Problem aufgetreten. Ich habe das Update auf 2 verschiedenen Servern probiert, immer mit dem gleichen Ergebnis.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
8.165
1.591
@FML, ja, das kann durchaus sein. Wichtig ist aber, mit welcher Version die DB erstellt wurde, um auf diesen Fehler zu kommen. Wir werden dafür in Kürze eine neue Version bereitstellen.
 
  • Gefällt mir
Reaktionen: FML

LarsL

Aktives Mitglied
13. Juli 2020
5
0
@FML, ja, das kann durchaus sein. Wichtig ist aber, mit welcher Version die DB erstellt wurde, um auf diesen Fehler zu kommen. Wir werden dafür in Kürze eine neue Version bereitstellen.
Hallo zusammen,
ich reihe mich ein: JTL DB erstellt mit 1.7.14.0 - direktes Update auf 1.8.7.4 fehlgeschlagen. Jetzt erstmal auf 1.7.15.3 aktualisiert.

Viele Grüße,
Lars
 

dirkr

Neues Mitglied
18. Oktober 2023
26
3
Deidesheim
Firma
KTW GmbH & Co. KG
gleiches bei mir auch.
Das ist auch mein erstes Update.
Ich habe jetzt von der Version 1.7.15.2 auf 1.7.15.3 ohne Probleme das Update installiert.
Aber auf die 1.8 will er einfach nicht
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu SQL-Fehler bei Volltextsuche und Sonderzeichen JTL-Shop - Fehler und Bugs 0
Neu Inaktive Artikel werden mit 404 Fehler bei Google Search angezeigt Allgemeine Fragen zu JTL-Shop 2
Neu Fehler SQL-Schema importieren bei Neuinstallation Installation / Updates von JTL-Shop 5
Neu Fehler bei Update von 1.5.55.8 auf jede weitere Version bis einschließlich 1.8.11.0 Gelöste Themen in diesem Bereich 3
Lieferstatus händisch ändern nach Fehler bei Versanddatenexport JTL-Wawi 1.8 2
Fehler bei Kategorien löschen JTL-Wawi 1.8 0
Beantwortet Fehler bei Synchronisation [PHP Fatal Error] Gelöste Themen in diesem Bereich 2
Neu Plugin Entwicklung fehler bei isEditMode() Funktion Technische Fragen zu Plugins und Templates 0
Neu Fataler Fehler bei Installation WooCommerce-Connector 7
Neu Fehler bei Lieferantenbestellung CSV Export User helfen Usern - Fragen zu JTL-Wawi 7
Neu Fehler bei Übermittlung Sendungsnummer an Shopify User helfen Usern - Fragen zu JTL-Wawi 0
Fehler bei Übermittlung Sendungsnummer an Shopify JTL-Wawi 1.7 0
Gelöst Fehler bei der Artikelbearbeitung über die Suchleiste - iMin Swan JTL-POS - Fehler und Bugs 1
JTL-Voucher - Fehler bei PIN eingabe Einrichtung / Updates von JTL-Vouchers 1
Neu JTL-Shopify Connector UNIQUE KEY Fehler bei Aufträgen. Wie gehe ich am besten vor? User helfen Usern - Fragen zu JTL-Wawi 0
Umzug Datenbank Fehler aufgrund unterschiedlicher Versionen Einrichtung JTL-Shop5 1
Neu E-Mail mit Strato - Fehler normal? Betrieb / Pflege von JTL-Shop 0
Neu jtl wawi Versanddatenexport Originalmeldung: In der Sendung trat mindestens ein harter Fehler auf. Code: 1101 Schnittstellen Import / Export 1
Neu 21916639, 21916585, 21916664 Fehler Gelöste Themen in diesem Bereich 4
Neu Fehler Übertragung Sendungsnummern an eBay JTL-Wawi 1.7 2
Was bedeutet dieser Fehler? - Jtlwa wai update to 1.8.11 JTL-Wawi 1.8 2
Workflow: Mahnungen - Fehler JTL-Wawi 1.8 5
Bug? Fehler EAN (Kaufland.cz) auf Kaufland.de aber korrekt kaufland.de - Anbindung (SCX) 1
Neu Fehler nach Serverumzug Gelöste Themen in diesem Bereich 3
Neu Datenbank Upgrade Fehler(#7110FFD83C0136E0) JTL-Wawi - Fehler und Bugs 0
Neu Webp Bild aufruf Fehler beim ersten mal laden JTL-Shop - Fehler und Bugs 2
RLIMIT_NPROC is exceeded & fehler 503 beim Abgleich und beim Bestellabschluss Einrichtung JTL-Shop5 0
Neu ebay- Angebote-laufende Angebote: Fehler beim Laden der Daten, der mehrteilige Bezeichner "Custom-fWawiArtikelpreisBrutto" konnte nicht gebunden werde JTL-Wawi - Fehler und Bugs 2
Neu Fehler beim Update von Exportformat Google Shopping JTL-Shop - Fehler und Bugs 1
Neu Frage: Email Adressen Validator Fehler Allgemeine Fragen zu JTL-Shop 0
Neu [Gelöst] IT Rechtskanzlei AGB Plugin Fehler "Plugin wurde nicht gefunden" Plugins für JTL-Shop 4
Neu Update 5.1.2 auf 5.2.4 Struktur-Migration Fehler in 320 Tabellen, PHP 8.2.14 Gelöste Themen in diesem Bereich 3
Fehler beim Artikelupload nach Ebay 21917328, 21916619, 21916970, 21919420 JTL WAWI 1.7.12.1 JTL-Wawi 1.7 0
Neu Fehler 1.7.15.3 : EMail Datum JTL-Wawi - Fehler und Bugs 2
Packtisch + / Versandgewicht Fehler JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 4
Neu On page composer veröffentlichen / Zeitraum auswählen in Zukunft / FEHLER Allgemeine Fragen zu JTL-Shop 0
Neu Kaufland Carriercode Fehler- Rechnung wird übertragen - Versand nicht kaufland.de - Anbindung (SCX) 1
Neu Ameise Import manuell ausgeführt funktioniert, der gleiche Import über Batch Planung gestartet hat Fehler JTL-Ameise - Fehler und Bugs 2
Neu Wawi Update Fehler JTL-Wawi - Fehler und Bugs 0
Neu Packtisch "Fehler beim verpacken" von Artikel mit Seriennr. JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
In Diskussion Fehler nach Bon duplizieren JTL-POS - Fehler und Bugs 3
Neu Fehler beim Bilderabgleich WooCommerce-Connector 6
Neu Fehler beim Zahlungsabgleich Wawi 1.7.15.4 JTL-Wawi - Fehler und Bugs 0
Neu JTL Connector Abgleich mit WooCommerce Fehler WooCommerce-Connector 13
Neu Fehler beim Update von JTL-WAWI 1.8.8.2 auf 1.8.9.1 JTL-Wawi - Fehler und Bugs 6
WaWi 1.8.9.1 Rechnung mail Fehler JTL-Wawi 1.8 0
Neu Emailvorlage DotLiquid Fehler Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Update Fehler von 1.8.7.4 auf 1.8.9.1 Gelöste Themen in diesem Bereich 4
JTL-Wawi 1.8.x.x Neue Oberfläche - Fehler Dashboard JTL-Wawi 1.8 1
Vorhandene Variationen überschreiben Fehler : 600004 Otto.de - Anbindung (SCX) 0

Ähnliche Themen