Neu Fehler bei Cronjob: includes/defines.php wird nicht gefunden

  • JTL-Connect 2022: Ihr habt noch kein Ticket? Jetzt schnell sichern! Die PreConnect ist bereits ausgebucht, auch für die After-Show-Party auf der Ocean Diva sind nur noch wenige Plätze verfügbar! HIER geht es zum Ticketverkauf

  • Das Stable Release von JTL-Wawi 1.6 ist startklar: HIER gehts zum Forenbeitrag

ongnamo

Sehr aktives Mitglied
31. März 2013
925
63
Hallo,

möchte meinen 1. Cronjob bei Timmehosting (nginx) aufsetzen. Nach Start des Cronjob erhalten ich diesen Fehler:

PHP Warning: require_once(/var/www/.../webincludes/defines.php): failed to open stream: No such file or directory in /var/www/.../web/includes/globalinclude.php on line 31 PHP
PHP Fatal error: require_once(): Failed opening required '/var/www/.../webincludes/defines.php'

Offensichtlich fehlt ein / im Pfad zwischen web und includes. Doch warum? In der config.JTL- Shop.ini.php steht:

define("PFAD_ROOT", "/var/www/.../web/");

In der aufrufenden globalinclude.php Zeile 31 steht:

require_once PFAD_ROOT . 'includes/defines.php';

Zusammengesetzt würde das aus meiner Sicht einen gültigen Pfad zur Datei defines.php geben. Wo liegt das Problem?
 
Zuletzt bearbeitet:

ongnamo

Sehr aktives Mitglied
31. März 2013
925
63
Update: Habe aufgegeben. Timme und JTL konnten nicht helfen. Lasse den Cronjob nun über cron-job.org ausführen.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Wichtiger Hinweis: Fehler bei Bestandsabgleichen/Amazon-Angebote Amazon-Anbindung - Fehler und Bugs 0
Neu SW6 Connector Fehler bei Konfiguration Shopware-Connector 7
Fehler eBay Vorlage erstellen bei der Kategorie 1 Abteilung / Farbe / Stil es können nicht weniger als 1 Werte ausgewählt werden eBay-Anbindung - Fehler und Bugs 8
Neu Fehler eBay Vorlage erstellen bei der Kategorie 1 Abteilung / Farbe / Stil es können nicht weniger als 1 Werte ausgewählt werden JTL-Shop - Fehler und Bugs 3
Fehler bei Update: "SQLSTATE[42000]: Syntax error or access violation: 1068 Multiple primary key defined" Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Fehler bei Blog speichern Allgemeine Fragen zu JTL-Shop 6
Neu Nullrechnung und Lastschrift - Fehler bei SEPA-Export JTL-Wawi - Fehler und Bugs 0
Neu EVO Template Fehler bei abgeschalteten Kategorien im Megamenü Templates für JTL-Shop 3
Neu Fehler: Lizenz "PlanProduceBase" fehlt bei Var-Kombi Artikeln -> Keine Anzeige der Kindartikel im Shop! JTL-Wawi - Fehler und Bugs 4
In Diskussion POS & Vouchers - Wawi Auftrag Kasseieren - Fehler bei Einlösung von Gutscheinen JTL-POS - Fehler und Bugs 2
Neu Fehler bei Lieferantendaten Arbeitsabläufe in JTL-Wawi 6
Verwiesen an Support POS & Vouchers - Fehler bei 2 Gutscheinen und Restbetrag JTL-POS - Fehler und Bugs 3
Beantwortet JTL-POS Fehler bei SumUP JTL-POS - Fehler und Bugs 4
Neu Gelöst - SQL Direct Query gibt Fehler aus bei Nutzung von Variable User helfen Usern - Fragen zu JTL-Wawi 8
Neu fehler bei UST-idNr Prüfung User helfen Usern - Fragen zu JTL-Wawi 0
Fehler bei Abgleich mit JTL-Shop 5.11/Wawi 1.6.38.2 JTL-Wawi 1.6 2
Neu Fehler Bestandsabgleich FFN JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu VueInstaller.php on line 252 Fehler / Erstinstallation Installation / Updates von JTL-Shop 0
Neu 17.08.2022 Abgleich Fehler (erledigt) eBay-Anbindung - Fehler und Bugs 5
Neu Beim Email versandt Fehler vom Server "bare line feed characters" Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 6
Neu mailen: List & Label fehler Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Neu Fehler beim export der dsfinv-k Daten. JTL-POS - Fehler und Bugs 5
Neu Abgleich Fehler (Allowed memory size...) Shopware-Connector 0
In Diskussion Epson TSE Fehler "Seriennummer stimmt nicht überein" JTL-POS - Fehler und Bugs 1
Neu Ebay Abgleich funktioniert nicht. Fehler: Artikel bereits hinzugefügt was jedoch nicht so ist. User helfen Usern - Fragen zu JTL-Wawi 2
Neu Update 5.1.1 --> 5.1.4: Fehler im Bestellvorgang "unknown tag 'getCountry'" (inc_billing_address_form.tpl) (NOVA) Installation / Updates von JTL-Shop 1
Neu GELÖST - Worker 2.0 bricht den Ableich des Shops mit Fehler ab JTL-Wawi - Fehler und Bugs 2
Neu Sofortüberweisung Classic Plugin Fehler "Die Transaktions-ID ist ungültig." Plugins für JTL-Shop 0
JTL WAWI 1.6.40.0 Bugs & Fehler sowie Anmerkungen JTL-Wawi 1.6 2
Neu Nach Hotfix im Shop 5.1.2 - Fehler in Dateistruktur Installation / Updates von JTL-Shop 6
Gelöst Stückliste speichern Fehler JTL-Wawi - Fehler und Bugs 2
Neu Worker 2.0 Abgleich mit JTL Shop wird mit Fehler beendet JTL-Wawi - Fehler und Bugs 19
Neu JTL Shop Update 5.1.3 - Datenbank Fehler: 1062 Duplicate entry 'COUNTRY_VIEW' for key 'PRIMARY' Installation / Updates von JTL-Shop 6
Neu Online-Fehler(suche) - Webanwendung? User helfen Usern 2
Neu Plugin Installation Fehler Code 3 Installation / Updates von JTL-Shop 1
Neu Fehler beim Amazon Prime Label Drucken JTL-Wawi - Fehler und Bugs 4
Neu klitzekleiner Fehler beim Länderkürzel JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Verkaufskanal anlegen JTL-Wawi - Fehler und Bugs 1
PrintLog Fehler deaktivieren oder Pfad ändern JTL-Wawi 1.6 5
Neu Warenpost International CN22 Fehler. Konfigurationsartikel werden als Einzelartikel aufgelistet. JTL-ShippingLabels - Fehler und Bugs 0
Neu Fehler beim speichern. JTL-Wawi - Fehler und Bugs 5
Neu SQL-Fehlerinformationen: [W10S\JTL200 .Net SqlClient Data Provider] Fehler #544 (Klasse 16) in Zeile 84: Ein expliziter Wert für die Identitätsspalte JTL-Wawi - Fehler und Bugs 0
Neu Update von 5.1.2 -> 5.1.3 Fehler Dateistruktur Installation / Updates von JTL-Shop 0
Neu Update von 5.1.2 auf 5.1.3 SQL Fehler Installation / Updates von JTL-Shop 9
Neu Shopabgleich Aufträge mit digitalen Artikeln werden nicht importiert -Fehler: Lieferland ungültig WooCommerce-Connector 2
Neu Filtern nach eigenem Feld erzeugt Fehler - WAWI 1.6.39.0 JTL-Ameise - Fehler und Bugs 3
Neu Fehler beim erstellen der Rechnung "LLPDF" Fragen rund um LS-POS 1
Neu Konfigurator: Komponenten ohne Preis von der Ameise importiert -> Fehler JTL-Wawi - Fehler und Bugs 1
Neu Fehler beim Bestellvorgang JTL-Shop - Fehler und Bugs 2
Neu JTL Amazon-Account Registrierung Skript Fehler Amazon-Anbindung - Fehler und Bugs 1

Ähnliche Themen