Neu Fehler 500 nach Update auf 5.21

Harald Weingaertner

Sehr aktives Mitglied
2. Oktober 2006
436
135
Hallo, nach dem Update auf Version 5.21 erhalten wir einen Fehler 500. Das konnten wir beheben, indem wir vom NOVAchild auf das NOVA Template gewechselt sind. Jetzt sind aber alle Änderungen weg. (dann braucht man irgendwie auch kein Child-Template, wenn das sowieso nicht geht).

Im Update-Thread wird gesagt: "* Wer mit einem Child-Template des Nova arbeitet muss sich ggf. nochmal das aktuelle Beispiel-Child-Template herunterladen und die Datei NOVAChild/themes/my-nova/sass/my-nova_crit.scss updaten. Dabei sollte natürlich darauf geachtet werden, dass eigene Änderungen an dieser Datei entsprechend übernommen werden. Wir wollen in Zukunft vermeiden, dass dies nötig ist, siehe SHOP-6051"

Wo bekommen wir denn das aktuelle Child-Template für die NOVA Version aus Shop 5.21 her?

Gruß, Harald
 

Harald Weingaertner

Sehr aktives Mitglied
2. Oktober 2006
436
135
Sorry, nach dem Update auf 5.21 lassen sich keine Artikel mehr in den Warenkorb legen.

Die Seite lässt sich mit dem NOVA Template zwar wieder aufrufen, es hakt aber an vielen Stellen.

Bei einigen Artikeln wird eine Warnmeldung gezeigt, dass die übermittelten Formulardaten nicht sicher sind und es wird versucht den Warenkorb via http statt mit https aufzurufen. Bei anderen Artikeln kommt einfach gleich eine Meldung Error 500.

Sporadisch erhalten wir auch eine Meldung, dass "diese Seite nicht sicher wäre", obwohl überall SSL aktiv ist.

Auf dem Server läuft PHP 8.1 und bis vor einer Stunde lief auch alles wunderbar - mit Version 5.01.

Hat noch jemand solche Probleme?
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
1.367
535
Hallo Harald,

dazu
nach dem Update auf 5.21 lassen sich keine Artikel mehr in den Warenkorb legen.
https://forum.jtl-software.de/threads/5-21-fatal-error-sobald-artikel-im-warenkorb.197596/

zu der SSL Problematik kann ich spontan nichts sagen. Ich würde erstmal empfehlen das Warenkorb Problem zu beheben und dann nochmal testen. Ggf. dann ein Support-Ticket öffnen, wenn das SSL Problem weiterhin besteht.

Viele Grüße
Michael
 

Harald Weingaertner

Sehr aktives Mitglied
2. Oktober 2006
436
135
Danke aber ich habe wieder die alte Version eingespielt. Das ist mir noch nichts mit der Version 5.21.

Das Feedback hier im Forum ist ziemlich erschreckend. Hätte ich vorher mal gucken sollen.

Gruß, Harald
 
  • Gefällt mir
Reaktionen: bubu

bubu

Sehr aktives Mitglied
5. November 2013
464
89
Bolken (SO)

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
1.367
535
Hallo,

es gibt mittlerweile die Shopversion 5.2.2, die die shopseitigen Update-Fehler in Bezug auf die Version 5.2.1 behebt.
Das SSL Problem wurde in anderen Shops durch einen falschen Eintrag in der config ausgelöst, die Lösung wäre daher folgende:
schauen Sie bitte einmal in der Datei includes/config.JTL- Shop.ini.php und prüfen Sie, ob dort http statt https steht.
Es müsste auf jeden Fall so in der Art aussehen:

define('URL_SHOP', 'https://meineShopURL');

Viele Grüße
Michael
 

Harald Weingaertner

Sehr aktives Mitglied
2. Oktober 2006
436
135
Hallo Harald
Geht mir genau so! Es ist wirklich ein absolutes Frustupdate.
Hast Du einfach wieder die 5.1 drübergespitzt?
Geht das... datenbankmässig?
Liebe Grüsse, Markus

Ich hatte vorher Datenbank und Dateien gesichert und alles wieder auf den Stand von vorher zurückgespielt. Aber inzwischen hast Du ja scheinbar aktualisiert.
 
  • Gefällt mir
Reaktionen: bubu

Ähnliche Themen