Falsche Bildgrösse nach Update auf JTLSHOP 5

giorgio

Gut bekanntes Mitglied
9. Februar 2007
301
3
86836 Graben/ LLF
Die Bildgrösse nach Update auf JTLSHOP 5 sollte laut Einstellung 320x320 Pixel sein. Tatsächlich haben wir eine Bildgrösse vom 800x800 Pixel als Artikelbild.
Einen Komplett-Abgleich haben wir nach dem Update gemacht.
Da ja die Bilder mit dem Komplett-Abgleich in ein neues Verzeichnis kopiert werden, kann man eigentlich nichts falsch machen. Im Ordner media/image/product finde ich diese Bildgrösse
überhaupt nicht...
Hat einer eine Idee?
Gruss Jürgen
 

Anhänge

  • Bildschirmfoto 2021-01-26 um 18.13.29.png
    Bildschirmfoto 2021-01-26 um 18.13.29.png
    186,3 KB · Aufrufe: 19

giorgio

Gut bekanntes Mitglied
9. Februar 2007
301
3
86836 Graben/ LLF
Im Ordner 792817 gibt es zum Beispiel nur 2 Grössen (lg + md) - zudem geht es eigentlich um das Bild, das im Artikel angezeigt wird. Jetzt ist es die Grösse 800x800. (lg)

Das ist natürlich viel zu gross - in der Vorversion des Shops waren es die 320x320. (md)
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
712
186
Hallo @giorgio

Offopic: Ich weißt nich ob das so gewollt ist, daher erwähne ich es: Im trente.de Shop hast du auf dem Desktop keine Filter, da anscheinend die Sidebar (Linke Seitenleiste) ausgeblendet ist:
Du könntest auch in den Nova-Template Einstellungen unter " Listen- und Gallerieansicht > Filterposition: Eigenes Fenster" einen Button über den Artikellisten anzeigen über diesen kann man dann auch die Filter öffnen und du brauchst weiterhin keine Sidebar.

Die Bildgrößen werden normalerweise automatisch von lazysizes ausgewählt bzw. geladen. Das heißt wenn für das Bild 321px Platz sind wird entsprechend das 800px Bild genommen, statt dem 320px Bild.
Die Bildgrößen werden auch erst generiert wenn sie erstmalig gebraucht werden. D.h wenn die "sm" Version des Bildes noch nie gebraucht wurde. Gibt es den entsprechenden Ordner "sm" auch noch nicht.

Viele Grüße
Michael
 

giorgio

Gut bekanntes Mitglied
9. Februar 2007
301
3
86836 Graben/ LLF
Die Bildgrößen werden normalerweise automatisch von lazysizes ausgewählt bzw. geladen. Das heißt wenn für das Bild 321px Platz sind wird entsprechend das 800px Bild genommen, statt dem 320px Bild.
Die Bildgrößen werden auch erst generiert wenn sie erstmalig gebraucht werden. D.h wenn die "sm" Version des Bildes noch nie gebraucht wurde. Gibt es den entsprechenden Ordner "sm" auch noch nicht.

Und es gibt keine Möglichkeit, die Bildgrösse auf 320x320 Pixel zu erzwingen. Unsere Bilder werde 800x800 Pixel hoch geladen. Da Schmuck aber zum fotografieren in der Regel sehr klein ist, kommt bei 800x800 Pixel
jede Unebenheit raus...
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
712
186
Als erstes könnte man die 800x800 für lg einfach z.b auf 500x500 (oder sogar direkt 320x320) setzen, das wäre für den Desktop allerdings schon sehr klein..
Ansonsten kann man natürlich auch über Template-Anpassungungen an den gewünschten Stellen erzwingen, dass immer die md Größe genommen wird.
 

giorgio

Gut bekanntes Mitglied
9. Februar 2007
301
3
86836 Graben/ LLF
Nachtrag:
Verstehe gar nicht, wenn doch extra eine Seite zum Einstellen der Bildgrössen da ist, warum die Bilder dann nicht nach den eingestellten Grössen dargestellt werden - oder habe ich einen Denkfehler?
Gruss Jürgen
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.568
374
Halle
Hallo Jürgen, es ist genau andersrum... Das Design des Template gibt die Bildgrößen vor. Auf der Einstellungsseite im Backend kann man dann die generierten Größen an die vom Template benötigten Größen anpassen, damit möglichst nichts skaliert werden muss.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Ameise Import Fehler - Falsche Formatierung JTL-Ameise - Fehler und Bugs 3
Issue angelegt Falsche Sortierung im Dashboard beim MHD JTL-Wawi - Fehler und Bugs 1
Neu Falsche VAT Nr bei Versand DE GB mit UK Vat ID JTL-Wawi - Fehler und Bugs 0
In Diskussion Erweiterte Eigenschaft => Die Eingabezeichenfolge hat das falsche Format JTL-Workflows - Ideen, Lob und Kritik 1
Neu HILFE: Falsche Update Version eingespielt Installation von JTL-Wawi 6
In Bearbeitung Falsche Umsatzsteuer beim setzten der Versandart über Workflow JTL-Workflows - Fehler und Bugs 1
Falsche Preise in Wawi Gelöste Themen in diesem Bereich 1
Neu Falsche Anzeige des Lagerbestandes JTL-Wawi - Fehler und Bugs 11
In Bearbeitung Ein-/Auszahlungen: Falsche Konten JTL-POS - Fehler und Bugs 4
Neu Falsche Versanddienstleiser Amazon an JTL WAWI Amazon-Anbindung - Fehler und Bugs 2
Neu Frage zu Ticket 55833 und Umsetzung in 1.5.46.1 - falsche Umsetzung? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Inventurdifferenzbuchung / Inventurbuchung erstellt Falsche Bestände Arbeitsabläufe in JTL-Wawi 0
Neu Sync Wawi nach POS - Fragen Allgemeine Fragen zu JTL-POS 0
Testshop kann nach dem Anlegen nicht geöffnet werden Einrichtung JTL-Shop5 1
JTL-Shop 5: Nach Kaufabschluss Button "Weiter einkaufen" => Möglichkeit andere Seite als Startseite zu verlinken? Einrichtung JTL-Shop5 1
Neu Deaktivierte Länder nach Update auf 5.1 (RE-Adresse) JTL-Shop - Fehler und Bugs 2
Neu Positionen einer Pickliste nach Sortiernummer der Lagerplätz sortieren Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Gelöst Konfigurator - Komponenten Namen werden nicht angezeigt nach Update auf 5.1 JTL-Shop - Fehler und Bugs 3
Neu Nach Update auf 5.1 Springt die Startseite wenn der Cookiebanner noch nicht angeklickt wurde JTL-Shop - Fehler und Bugs 2
Neu Nach Rechnungskorrektur ist Rechnung "Bezahlt am..."-Datum = Ursprungsauftrags-Datum - Warum? JTL-Wawi - Fehler und Bugs 0
Neu Shopversion nach Patch-Update von 5.0.0 auf 5.0.3 weiterhin auf 5.0.0 Installation / Updates von JTL-Shop 8
Gelöst nur leere Seiten nach Abgleich Allgemeine Fragen zu JTL-Shop 5
Neu Je nach Artikel(-Gruppe) automatisch Hinweis auf Pickliste hinzufügen Individuelle Listenansichten in der JTL-Wawi 0
Neu Rechnung nach der letzten Teillieferung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Statistik - Auswertung alle Rechnungen nach EU Ländern User helfen Usern - Fragen zu JTL-Wawi 10
Viele Artikelbilder verschwunden nach Update auf JTL 5 Upgrade JTL-Shop4 auf JTL-Shop5 3
In Bearbeitung Keine Minusbuchung und kein "Versand" nach Zahlung Allgemeine Fragen zu JTL-POS 3
Neu Aufträge stecken nach Absturz bei Auslieferung auf der Pickliste fest JTL-Wawi - Fehler und Bugs 4
In Bearbeitung Wurzelkategorie - Artikel werden nicht nach POS übertragen Allgemeine Fragen zu JTL-POS 1
Weiße Seiten nach Update von 4 auf 5 Upgrade JTL-Shop4 auf JTL-Shop5 3
Keine Verbindung von Wawi zum Shop nach Upgrade Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Automatische Mail nach Lieferung um Feedback einzuholen User helfen Usern - Fragen zu JTL-Wawi 1
Neu Workflow zum Auslesen des Lagerstandes - Anstossen nach Uhrzeit User helfen Usern - Fragen zu JTL-Wawi 0
Neu Steuern der Darstellung eines Bildes nach Plattform Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Netzwerkdrucker nach Update verschwunden JTL-Wawi - Fehler und Bugs 6
Neu Aufträge Bestätigen nach Shop Abgleich Arbeitsabläufe in JTL-Wawi 0
Neu Bilder in SW5 verschwinden nach Anlegen von VarKombis Shopware-Connector 2
Neu Versandarten nach Gewicht und Warenwert gekoppelt zu unterscheiden Allgemeine Fragen zu JTL-Shop 0
Neu Varianten Bearbeitung in SW6 nach JTL Nutzung Shopware-Connector 0
Neu Update Version von 1.5.47.2 nach 1.5.48 (fehler) JTL-Wawi - Fehler und Bugs 3
Gelöst Preiseingabe funktioniert nicht mehr nach Update JTL-POS - Fehler und Bugs 3
Gelöst Preisanzeige nach Kundengruppe JTL-POS - Fehler und Bugs 8
Neu Datev Export nach Kundengruppen JTL-Ameise - Fehler und Bugs 3
Neu Versandetikett nach update auf 1.5.47.4 JTL-Wawi - Fehler und Bugs 0
Neu Amazon Aufträge, Positionen doppelt nach Picklistenlöschung Arbeitsabläufe in JTL-Wawi 6
Gelöst Nach Auftragserfassung prüfen ob externe Auftragsnummer schon vorhanden ist JTL-Workflows - Ideen, Lob und Kritik 2
Neu Nach dem Upgrade Shop4 > Shop5 - Wawi-Syncdaten müssen manuell abgespeichert werden? JTL-Shop - Fehler und Bugs 10
Neu Zugriff auf Datenbank nach Update weg? User helfen Usern - Fragen zu JTL-Wawi 2
Beantwortet Sammelumlagerungen direkt Fehler nach Umbuchung JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu Wer baut Plugin Zahlungsartauswahl nach Lieferstatus Dienstleistung, Jobs und Ähnliches 2

Ähnliche Themen