Neu Dummy-Väter werden teilweise hochgeladen und verbleiben im Shop

novaG

Aktives Mitglied
15. August 2016
24
0
Hallo.
Folgende Konstellation liegt vor:
Ein Shopware 5.69 Shop -> 5 Domains - daher 5 Subshops
4 Themenshops, einer mit gemischtem Sortiment
Bisher haben wir eine andere Middleware genutzt für die Subshops von der wir uns nun aber trennen wollen
Die Middleware hatte den großen Vorteil, dass man die Subshops einzeln anschließen konnte, also Artikelverwaltung sich nicht ins Gehege gekommen sind und Bestellungen einzeln verwaltet werden konnten.
Das Problem mit den Bestellungen haben wir nun über Workflows gelöst, indem Kundengruppe bzw. die Kategorien der Artikelpositionen ausschlaggeben waren.
Die Artikelverwaltung sollte eigentlich kein großes Thema sein, scheint aber das größere Problem zu sein.
Nach der Anbindung des JTL-Connectors werden diverse Phantomartikel angelegt.
In der Shopware-Datenbank ist erkennbar, dass dies die Väter sind, die hier als Hauptvariante hochgeladen werden.
Diese haben jedoch keine zugeordneten configurator_options (logischer Weise).
Der Shop spielt aber an vielen Stellen genau diese Varianten als eigenständige Artikel aus, die sich dann auch nicht aufrufen lassen.
Eigentlich sind diese ja auch mit dem zugehörigen Vater verknüpft.
Ruft man den Artikel über das Shopbackend auf, gelangt man in den Artikel mit den Varianten, die Phantom-Variante existiert in dem Artikel selbst in der Übersicht der Varianten nicht.
Man springt also automatisch in die Hauptvariante.
Das eigentliche Problem ist, dass die Artikel mit im Frontend ausgespielt werden.
Deaktivieren funktioniert in dem Fall auch nicht, weil dann einfach auch der Rest der Varianten nicht mehr angezeigt wird.
Gibt es dafür einen Workaround? Wo übersehe ich den entscheidenden Punkt. Lassen sich im JTL die Väter für den Shop selbst deaktivieren?

PS: wenn ich hier von Varianten spreche, spreche ich natürlich von Variationskombinationen
 
Zuletzt bearbeitet:

novaG

Aktives Mitglied
15. August 2016
24
0
Anders gefragt, einen Reupload der Artikel mittels Connector lässt sich manuell anstoßen? Ein Zurücksetzen des Connectors ist nicht unbedingt gewollt, da wir die Kundendaten kein 3tes mal im System haben wollen.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Variantebilder werden nicht angezeigt / SQL Fehler Shopware-Connector 0
Neu Wie kann sichergestellt werden, dass der eingerichtete Workflow auch wirklich greift? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Ebay: Es werden keine Aufträge mehr abgeholt eBay-Anbindung - Fehler und Bugs 15
Neu USTID-Nr. von Lieferadresse von einem Kunden werden im Auftrag nicht gezogen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Artikel werden beim Upload immer erst gelöscht Shopware-Connector 0
Neu Für die aktuelle Transaktion kann kein Commit ausgeführt werden. / Fehlermeldung JTL-Wawi - Fehler und Bugs 1
Neu NOVA Child: Artikeldetailseite Tabs werden untereinander dargestellt anstatt zu faden Templates für JTL-Shop 2
Neu Artikel können nicht gesendet werden - Call to a member function getIso() on null Shopware-Connector 2
Neu Bestandskunden werden zu Schnellbestellern Shopware-Connector 0
Neu Bilder werden beim Abgleich gelöscht seit 6 Tagen WooCommerce-Connector 0
Gelöst VCS Lite Amazon Rechnungen werden hochgeladen aber nicht in der Wawi erstellt Amazon-Anbindung - Fehler und Bugs 1
Neu SW5 - Nach Connector Update - Bilder werden Artikel nicht zugewiesen Shopware-Connector 2
Neu Lieferscheine werden nicht erstellt JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Es werden keine Aufträge mehr für Verkäufe an der Kasse in der WAWI erstellt Allgemeine Fragen zu JTL-POS 5
Neu Auf das verworfene Objekt kann nicht zugegriffen werden: Objektname: "jtlTextBox". eBay-Anbindung - Fehler und Bugs 1
Neu JTL Shop 4 - Artikel mit Pfand kann nicht in EU verschickt werden Allgemeine Fragen zu JTL-Shop 1
Neu Ältere Rechnungen und Aufträge werden nicht mehr angezeigt User helfen Usern - Fragen zu JTL-Wawi 6
Neu Alle Artikel werden übertragen bei Shopabgleich nach Datenbankumzug JTL-Wawi - Fehler und Bugs 1
Neu Amazon-Bestellungen werden in WaWi nicht übernommen Amazon-Anbindung - Fehler und Bugs 6
Neu Produktdaten für rich snippets werden von Shop5 (NOVA) nicht geliefert Allgemeine Fragen zu JTL-Shop 1
Neu Auftrag kann nicht ausgeliefert werden, obwohl das Häkchen bei "Auslieferung vor Zahlungseingang möglich" gesetzt wurde. User helfen Usern - Fragen zu JTL-Wawi 2
Neu Bilder auf Woocommerce werden nicht dargestellt. WooCommerce-Connector 0
Neu Bilder werden von Amazon nicht richtig erkannt. Amazon-Anbindung - Fehler und Bugs 0
Verwiesen an Support WorkflowAktionId 100 der Auftrag darf nicht verändert werden JTL-Workflows - Ideen, Lob und Kritik 1
Neu Fehlermeldung: "Es sind Steuersätze im Online Shop vorhanden, die keinem Steuersatz in der JTL WaWi zugeordnet werden können" Onlineshop-Anbindung 1
Neu Rechnungen werden nicht hochgeladen (bekanntes Thema...) Amazon-Anbindung - Fehler und Bugs 2
Neu Overlays werden nicht benutzt Templates für JTL-Shop 2
Neu Set-Artikel - bei einer bestimmten, enthaltenen Zeichenfolge soll der TARIC-Code ein- bzw. ausgeblendet werden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Abgelehnt Zahlarten werden in Wawi Auftrag nicht aktualisiert JTL-POS - Ideen, Lob und Kritik 3
Neu JTL-Wawi 1.5.46.0 - Kunde hat Paket im Paketshop nicht abgeholt - Rückläufer soll nach Wareneingang erneut versandt werden, wie vorgehen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Var. Kombinationen werden nicht unterstüzt Gambio-Connector 1
Neu JTL-Vouchers - Closed Beta | Jetzt Pilotkunde werden und aktiv mitentwickeln! Umfragen rund um JTL 0
Neu Shopware 6: HTML-Tags in Attributen werden nicht übertragen? Shopware-Connector 0
Neu Aufträge werden nicht synchronisiert. Shopify-Connector 3
In Bearbeitung Hakt in der Schnittstelle - Amazon-Aufträge werden seit 1.7.'21-0:00Uhr falsch in externe Rechnungen übernommen -> kein Rechnungsdruck mehr möglich! Amazon-Anbindung - Fehler und Bugs 131
Neu Bestimmte Konfigurationsartikel sollen nicht als "Empfohlen" angezeigt werden User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst GLS Labels werden nicht gedruckt Gelöste Themen in diesem Bereich 1
Neu Bilder werden mit falschem Namen von JTL zu Gambio übertragen Gambio-Connector 2
Neu Bilder werden von Gambio nicht an JTL WAWI übertragen Gambio-Connector 1
Neu Änderungen werden nicht übertragen Allgemeine Fragen zu JTL-Shop 0
Neu Lagerbestand bei Stücklistenartikeln werden nicht abgezogen bei Stammartikel JTL-Wawi - Fehler und Bugs 1
Neu Warnungen: Auftrag XYZ ist bereits bezahlt. Zahlungen werden verknüpft. Gambio-Connector 1
Neu Amazon Preise international per Ameise geändert. Automatischer Abgleich!? Preise werden nur auf .de übernommen Amazon-Anbindung - Fehler und Bugs 3
Beantwortet gelöst - JTL SHOP 5 Polnische Sprachvariabeln werden im Bestellvorgang nicht geladen JTL-Shop - Fehler und Bugs 0
Neu Bilder der Var. Kombis werden nicht übertragen? Shopware-Connector 2
Neu Bilder müssen immer wieder neu generiert werden Allgemeine Fragen zu JTL-Shop 1
In Bearbeitung Lagerbestände werden nicht richtig angezeigt. JTL-Wawi - Fehler und Bugs 0
Neu eBay Zahlungen werden automatisch als "Bar" hinterlegt Arbeitsabläufe in JTL-Wawi 0
Neu Berichtscontainer, Artikel sollen vollständig abgebildet werden oder vorher einen Seitenumbruch machen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Seriennummern Artikel kann nicht ausgeliefert werden.kLieferscheinPos = 999999999 JTL-Wawi - Fehler und Bugs 8

Ähnliche Themen