In Bearbeitung Designvorlage: Galerien werden nicht bei allen Artikel angezeigt?

Xantiva

Sehr aktives Mitglied
28. August 2016
1.701
289
Düsseldorf
Hallo zusammen,

ich habe die EVO- Designvorlage angepasst und alle Angebote aktualisiert. Was ich nicht verstehe - die Galerien werden nicht bei allen Artikeln angezeigt?

Hier werden sie wie gewünscht angezeigt: https://www.ebay.de/itm/401961169073
1581193471958.png


Hier werden nur zwei Striche angezeigt? https://www.ebay.de/itm/402078354356

1581193617961.png

Was habe ich gemacht?
Die Galerien GleicheKategorie und GleicherHersteller eingefügt:

Code:
{% comment -%}
### Xantiva ###

Verfügbare Kriterien: AnzahlVerkäufe, AuktionsTitel, Auktionsende, StartPreis, AngebotsTyp, InterneWarengruppennummer, Warengruppe
{% endcomment %}
{% assign GleicheKategorie = Vorgang.Galerien.GleicheKategorie | ConfigureGallery : 'Ähnliche Artikel', 'AnzahlVerkäufe', true, 20 %}\
{% comment %}
Verfügbare Kriterien: AnzahlVerkäufe, AuktionsTitel, Auktionsende, StartPreis, AngebotsTyp, InterneWarengruppennummer, Warengruppe
{% endcomment %}
{% assign GleicherHersteller = Vorgang.Galerien.GleicherHersteller | ConfigureGallery : 'vom gleichen Hersteller', 'AnzahlVerkäufe', true, 20 %}\
{% comment -%}

Und dann - zusammen mit der XSeller Galerie - dem Galeriecontainer zugewiesen:

Code:
{% comment -%}

### Galerie-Container befüllen ###

In den Galerie-Container können Sie nun eine oder mehrere Galerien hinzufügen.
Mit dem Filter "CreateHtmlGallery" wird dann für alle hinzugefügten Galerien
ein Reiter (Tab) erstellt. Suchen Sie unten im Quelltext nach
{{ GalerieContainer | CreateHtmlGallery }}, um zu sehen, an welcher Stelle
die Galerien ausgegeben werden.

{{ GalerieContainer | AddGallery:  XSeller }}\
{{ GalerieContainer | AddGallery:  ÄhnlicheArtikel }}\
{{ GalerieContainer | AddGallery:  Bestseller }}\
{{ GalerieContainer | AddGallery:  EVO-Designvorlage }}\
{{ GalerieContainer | AddGallery:  Sale }}\
{% endcomment -%}
{{ GalerieContainer | AddGallery:  GleicheKategorie }}\
{{ GalerieContainer | AddGallery:  GleicherHersteller }}\
{{ GalerieContainer | AddGallery:  XSeller }}\
\
\
{% comment -%}

Nach den Änderungen hat die Wawi gleich nachgefragt und ich habe alle Designvorlagen in den bestehenden Angeboten ändern lassen.

Muss ich noch irgend etwas anderes machen?

:(
 

Xantiva

Sehr aktives Mitglied
28. August 2016
1.701
289
Düsseldorf
Aussage Support:
Galerien werden zum Zeitpunkt des Abgleiches fest erstellt und können somit nicht dynamisch auf Änderungen von Angeboten in dieser Galerie reagieren. Daher hilft nur ein Update der "Beschreibung" der Angebote über "Bilder/Beschreibung aktualisieren", die diese Galerie verwenden.

So hätte ich das auch erwartet, aber das funktioniert eben nicht bei allen Artikeln. Ich würde erwarten, dass ich die Artikel in der Galerie auch schon in der Angebotsvorlage, bei der gerenderten Ansicht der Designvorlage sehen müsste, aber da fehlen sie bei vielen Artikel auch schon. :(
 

Xantiva

Sehr aktives Mitglied
28. August 2016
1.701
289
Düsseldorf
Nach einigem hin und her mit dem Support habe ich mich mal selber auf die Fehlersuche begeben ...

Ich habe mir die letzten SQL-Queries angesehen, wenn ich mir die Designvorlagen rendern lasse. Nach einigem Debuggen kommt raus: Artikel mit Grundpreis werden von einer der beiden Abfragen ausgeschlossen!

Keine Ahnung warum, ich habe die ausführliche Diagnose dem Support geschickt und hoffe, dass sie das kurzfristig fixen werden.
 

Ilona

Moderator
Mitarbeiter
8. August 2013
276
58
Hallo,

Aufgrund der Tatsache das die Galerien nicht dynamisch sondern statisch sind, hatten wir seinerzeit die Grundpreisausweisung per default deaktiviert.
Sie müssen diese explizit erst noch aktivieren, damit diese dargestellt werden.

Für unsere Entwicklung wurde dazu ein Ticket mit der Nummer WAWI-44053 aufgenommen.
Bei Rückfragen geben Sie uns gerne die Ticket Nr. an, wir geben Ihnen dann zum Stand Auskunft aus.

Vielen Dank.
 
  • Gefällt mir
Reaktionen: Xantiva

Ilona

Moderator
Mitarbeiter
8. August 2013
276
58
Hallo,

ich kann das verhalten bei mir lokal mit der EVO und den Datenänderungen oben, nicht nachstellen.
Einzige Änderung bei mir "'AnzahlVerkäufe', true, 1...", da ich nicht über so viele Käufe verfüge.

Grundpreis.jpg

Grundpreis_1.jpg

Bei mir wird ein Grundpreisangebot angezeigt.
 
Zuletzt bearbeitet:

Xantiva

Sehr aktives Mitglied
28. August 2016
1.701
289
Düsseldorf
@Ilona Danke fürs testen, aber bei mir ist das weiterhin nicht der Fall? Mit welcher Version haben Sie das den getestet? Hat sich dort im Gegensatz zur Version 1.5.24.1 etwas geändert?

Dieser Artikel mit dem Grundpreis hat auch in der Tabelle dbo.tArtikel im Feld nVPE einen Wert ungleich 0? Denn die Einschränkung auf "Artikel.nVPE = 0" sorgt für die Probleme:

SQL:
JOIN dbo.tArtikel AS Artikel ON Artikel.kArtikel = ebayItem.kArtikel AND Artikel.nVPE = 0
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Explode in Designvorlage eBay-Designvorlagen - Ideen, Lob und Kritik 4
Neu Gruppieren von Merkmalen in Ebay Designvorlage eBay-Designvorlagen - Fehler und Bugs 0
Neu Abgleich mit Shopware- Alle Kunden werden importiert Shopware-Connector 9
Neu Artikel werden von der Wawi/Connector nicht im Gambio Shop aktiviert Gambio-Connector 0
Neu Artikelnamen werden in der Kundenmail abgeschnitten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Druckvorlagen für zweite Firma - Firmendaten werden in Rechnungen nicht übernommen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Kategorie Bilder werden nach Update von JTl-Shop 4 auf JTL-Shop 5 nicht angezeigt Upgrade JTL-Shop4 auf JTL-Shop5 2
Zahlungen auf Aufräge werden bei Rechnungen nicht angezeigt JTL-Wawi 1.6 0
Neu Selbsterstellte Produktseiten werden nicht mehr erstellt, Bildfehler Amazon-Anbindung - Fehler und Bugs 1
OTTO Rabattaktionen werden nicht übernommen Otto.de - Anbindung (SCX) 3
Neu E-Mail Adressen von Kunden werden nicht in die WAWI importiert eBay-Anbindung - Fehler und Bugs 5
Neu Artikel mit Variationen - Variationen werden aber nicht in der Rechnung berücksichtigt User helfen Usern - Fragen zu JTL-Wawi 0
Neu SEO Weiterleitungen können nicht als CSV in Shop 5 importiert werden Betrieb / Pflege von JTL-Shop 0
Neu Gutschrift Vorlage, wieso werden die Beträge 3mal ausgegeben? User helfen Usern - Fragen zu JTL-Wawi 0
Kaufland Bestellungen werden nicht eingelesen kaufland.de - Anbindung (SCX) 13
Amazon VCS Daten von Amazon werden fehlerhaft verarbeitet JTL-Wawi 1.6 0
Rechnungen werden gesplittet JTL-Wawi 1.6 1
Rechnungskorrektur konnte nicht erstellt werden JTL-Wawi 1.6 4
Neu Umsatzsteuer-Berechnungsservice von Amazon nutzen. z.B. Rechnungen werden importiert? Amazon-Anbindung - Fehler und Bugs 3
Neu Fehlermeldung Label werden nicht erstellt - Amazon Prime durch Verkäufer DHL Amazon-Anbindung - Fehler und Bugs 0
Neu Größen bzw. Zahlen werden zusätzlich als einzelne Werte importiert WooCommerce-Connector 0
Produktdaten werden bei Kaufland überschrieben kaufland.de - Anbindung (SCX) 2
Neu Vorlagen, die gespeichert oder gemailt werden, lassen sich nicht öffnen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Geringe Zustellungsrate bei Newsletter die an t-online.de Email Adressen versendet werden User helfen Usern 7
Produktdaten werden bei Kaufland überschrieben JTL-Wawi 1.6 2
Beantwortet Fehler: Artikelaktualisierung per Ameise - kann nicht vollständig aktualisiert werden weil er sich auf einer Pickliste befindet User helfen Usern - Fragen zu JTL-Wawi 1
Neu Bilder aus JTL Wawi werden nicht in den Shopify Store übertragen Shopify-Connector 4
JTL Shop 5 Sitemap Konnte nicht abgerufen werden Einrichtung JTL-Shop5 0
Neu Artikelsticker werden nicht unter "Ähnliche Artikel" und "Kunden kauften dazu folgende Artikel" angezeigt. Allgemeine Fragen zu JTL-Shop 0
Neu Ankerpunkt kann nicht richtig gesetzt werden JTL Shop 5 Allgemeine Fragen zu JTL-Shop 2
Neu Keine Angebote werden eingestellt..... eBay-Anbindung - Fehler und Bugs 1
Neu Bestellungen werden nicht mehr automatisch in JTL übernommen Amazon-Anbindung - Fehler und Bugs 4
Neu Artikelbilder werden nicht mehr übertragen Shopware-Connector 8
Neu Bezahlte und korrekte Aufträge -> liegen in -> Aufträge Fehlerhaft und können nicht ausgeliefert werden??? JTL-Wawi - Fehler und Bugs 6
Neu Sonderpreise werden nicht übertragen in modified Shop JTL-Wawi - Fehler und Bugs 1
Neu Bilder werden nicht an JTL Shop übertragen JTL-Shop - Fehler und Bugs 2
Neu Falsche Shop-Rabatte werden beim Artikel angezeigt Fehler und Bugs in JTL-Wawi 0
Beantwortet Zurückgehaltener Auftrag Box geht nicht automatisch in Status "Box kann verpackt werden" JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 6
In Bearbeitung Staffelpreise von Kindartikel werden nur bei manuellem Speichern übernommen JTL-Shop - Fehler und Bugs 1
Warum werden Versandkosten in den Gewinn eingerechnet JTL-Wawi 1.6 31
Neu Kaufland SCX Abgleichfehler - Bilder werden nicht übertragen kaufland.de - Anbindung (SCX) 7
Neu Es werden nicht alle Kunden importiert Shopware-Connector 0
Neu Stücklistenartikel werden nicht auf der Pickliste angezeigt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Menge kann im Warenkorb mit Kommastellen eingegeben werden JTL-Shop - Fehler und Bugs 2
Neu JTL Shop 5 Kategoriestruktur will nicht abgeglichen werden. Allgemeine Fragen zu JTL-Shop 5
Neu Varianten werden im Woocommerce nicht erstellt WooCommerce-Connector 0
Neu Es konnte keine Zahlungsart für folgende Daten gefunden werden - Versand wird nicht angezeigt Allgemeine Fragen zu JTL-Shop 0
Artikel werden nicht übertragen JTL-Wawi 1.6 1
Neu Retoure anlegen - Artikel erscheint nicht und kann auch nicht hinzugefügt werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Merkmale werden nur teilweise angezeigt JTL-Shop - Fehler und Bugs 6

Ähnliche Themen