Neu Bilder

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

nazar_wellness

Neues Mitglied
11. August 2020
13
0
Hallo Leute.
Ich habe ein Problem und hoffe, dass ich es mit Ihrer Hilfe lösen kann. Nach dem Shop Abgleich stammen alle Daten von JTL WAWI, es fehlen jedoch nur Bilder. Bitte hilf mir. Danke im Voraus
 

Anhänge

Condorraptor

Aktives Mitglied
18. September 2018
114
9
Hast du denn die Bilder für den Online Shop markiert bzw. aktiv gestellt? Du kannst auch versuchen nochmal einen Komplettabgleich zu starten :)
 

trennscheibenwelt

Sehr aktives Mitglied
17. März 2017
613
125
Aber die Bilder für den Onlineshop hast du Aktiv oder?
Im Artikel selber gibt es eine Einstellung wo du die Bilder für die Shops und Plattformen freischaltest. Hast du das gemacht?
 

JulianG

Administrator
Mitarbeiter
14. November 2013
881
184
@nazar_wellness Die Bilder sind da, können aber nicht generiert werden.

Beispiel:
https://www.nazar-wellness.com/medi...s-cremet-mangoduft-5x-75-g-bull-kernseife.jpg

Da wird ein 500er erzeugt:

1597135391575.png

2 von einander unabhängige nächste Schritte:

1. Aktiviere display_errors temporär fürs frontend: https://guide.jtl-software.de/jtl-s...-jtl-shop-abgleich-angezeigt-was-soll-ich-tun
also hier:
PHP:
//enables printing of warnings/infos/errors for the shop frontend
define('SHOP_LOG_LEVEL', E_ALL ^ E_NOTICE ^ E_DEPRECATED ^ E_WARNING);
//enables printing of warnings/infos/errors for the dbeS sync
define('SYNC_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the admin backend
define('ADMIN_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the smarty templates
define('SMARTY_LOG_LEVEL', E_ALL ^ E_NOTICE ^ E_DEPRECATED ^ E_WARNING );
//excplicitly show/hide errors
ini_set('display_errors', 1);
Prüfe nach Aufruf meines Links ob dort dann mehr Infos stehen. Wenn ja: Kopieren/Screenshotten und display_errors wieder ausmachen.

2. Prüfe alle Bild-Einstellungen im Shop: Sind bei den Größen überall Pixelwerte hinterlegt? Keine davon sinnfrei z.B. auf 0 ?
 
  • Gefällt mir
Reaktionen: nazar_wellness

nazar_wellness

Neues Mitglied
11. August 2020
13
0
@nazar_wellness Die Bilder sind da, können aber nicht generiert werden.

Beispiel:
https://www.nazar-wellness.com/medi...s-cremet-mangoduft-5x-75-g-bull-kernseife.jpg

Da wird ein 500er erzeugt:

Den Anhang 44195 betrachten

2 von einander unabhängige nächste Schritte:

1. Aktiviere display_errors temporär fürs frontend: https://guide.jtl-software.de/jtl-s...-jtl-shop-abgleich-angezeigt-was-soll-ich-tun
also hier:
PHP:
//enables printing of warnings/infos/errors for the shop frontend
define('SHOP_LOG_LEVEL', E_ALL ^ E_NOTICE ^ E_DEPRECATED ^ E_WARNING);
//enables printing of warnings/infos/errors for the dbeS sync
define('SYNC_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the admin backend
define('ADMIN_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the smarty templates
define('SMARTY_LOG_LEVEL', E_ALL ^ E_NOTICE ^ E_DEPRECATED ^ E_WARNING );
//excplicitly show/hide errors
ini_set('display_errors', 1);
Prüfe nach Aufruf meines Links ob dort dann mehr Infos stehen. Wenn ja: Kopieren/Screenshotten und display_errors wieder ausmachen.

2. Prüfe alle Bild-Einstellungen im Shop: Sind bei den Größen überall Pixelwerte hinterlegt? Keine davon sinnfrei z.B. auf 0 ?

Ich habe diese code drin gelassen. Konnen Sie bitte gucken wo ist die problem. Danke im Voraus
 

JulianG

Administrator
Mitarbeiter
14. November 2013
881
184
Bilder muss drin image/product sein aber in mein Fall bildern liegt drin image/storage und mit ganze lang name und besonderes schlussel.
Nein. Im Storage Verzeichnis werden die Original- Wawi-Bilder gespeichert. Diese werden als Basis genommen für die generierten Bilder, die dann im product-Ordner gespeichert werden.

Da kommt ein 403 Fehler jetzt. Kannst du bitte prüfen, ob dein media-Verzeichnis und alle drunter Schreibrechte haben? Rufe dafür z.B. im Backend unter System->Wartung->Status auf und klicke auf "Verzeichnissrechte". Dort sollten recht weit unten 3 /media/ Verzeichnisse gelistet sein.
 
Zuletzt bearbeitet:

nazar_wellness

Neues Mitglied
11. August 2020
13
0
Nein. Im Storage Verzeichnis werden die Original- Wawi-Bilder gespeichert. Diese werden als Basis genommen für die generierten Bilder, die dann im product-Ordner gespeichert werden.

Da kommt ein 403 Fehler jetzt. Kannst du bitte prüfen, ob dein media-Verzeichnis und alle drunter Schreibrechte haben? Rufe dafür z.B. im Backend unter System->Wartung->Status auf und klicke auf "Verzeichnissrechte". Dort sollten recht weit unten 3 /media/ Verzeichnisse gelistet sein.
Danke Julian
Ich habe verstanden aber alles in ordnung da. Es gibt keine fehler.
Aber meine problem nicht gelost. :(
Was muss nechste schritt sein?
 

JulianG

Administrator
Mitarbeiter
14. November 2013
881
184
Siehe bitte die Unterhaltung die ich mit dir gestartet habe. Ich würde mir das gerne mal selber ansehen.
 

JulianG

Administrator
Mitarbeiter
14. November 2013
881
184
Da muss dein Provider/Serveradmin ran und der sollte mit meinem Bild direkt wissen, wo er auf dem Server spezifisch Hand anlegen muss.
Überprüfen kannst du das Ganze via phpinfo im Backend des Shops mit Aufruf der speziellen URL /admin/systemcheck.php?phpinfo
 

Markus Motion

Neues Mitglied
12. August 2020
4
3
Hallo Julian,

vielen Dank für die schnelle Rückmeldung. Habe den Provider schon benachrichtigt :)

Denke aber das ist nicht das Problem bei mir, da wenn ich die Ordner mit Bildern händisch anlege (Bsp.: ...media/image/product/1/lg/produkt.jpg) bleiben diese nur so lange auf dem Server und werden angezeigt bis ich auf Abgleich gedrückt habe. Dann sind wieder alle Ordner + Bilder gelöscht.

Die Kategoriebilder scheinen weiterhin zu funktionieren und werden auch angelegt (imagemagick scheint zu generieren). Überlege gerade was die Ursache sein kann das die Ordner .../1/lg/... usw. nicht erzeugt werden können auf dem Server. Der Provider hat auch schon die Logs auf dem Server geprüft - keine Fehler.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Bilder Upload Shopware-Connector 0
Neu Bilder Rahmen proportional füllen in List und Label Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
In Diskussion Artikelabgleich - Bilder werden nicht ersetzt, sondern zusätzlich hochgeladen WooCommerce-Connector 2
In Bearbeitung Bilder werden bei Datenabgleich nicht übertragen JTL-POS - Fehler und Bugs 2
Gelöst Bilder zu anderen Auktionen eBay-Anbindung - Fehler und Bugs 2
In Bearbeitung Keine Bilder unter "Mehr dieser Warengruppe" eBay-Designvorlagen - Fehler und Bugs 4
Neu Speichern Bildgrößen unter Storefront->Bilder->Einstellung funktioniert nicht Allgemeine Fragen zu JTL-Shop 0
Neu Bräuchte Hilfe beim Code für Bilder-Slider Technische Fragen zu Plugins und Templates 0
Neu Unterkategorien Bilder werden nur teilweise angezeigt Allgemeine Fragen zu JTL-Shop 8
Abgelehnt Bilder problem beim Onlineshop Abgleichen Onlineshop-Anbindung 2
Gelöst Sync-Job bricht aufgrund fehlender Bilder ab (v1.1.0) Shopify-Connector 15
Neu Bilder Einrichtung von JTL-Shop 2
Neu Bilder im Firmenlogo-Projektbaustein entfernen User helfen Usern - Fragen zu JTL-Wawi 5
Neu Bilder auf Artikelliste einblenden Allgemeine Fragen zu JTL-Shop 14
Neu Shop Artikel Bilder plus Artikel Videos Einrichtung von JTL-Shop 3
Neu Bilder mit .webp Format JTL-Shop - BETA - Feedback und Bugmeldungen 7
Neu Bilder in der Signatur Servicedesk (Beta) 13
In Bearbeitung Bilder verschwunden in jtl wawi 1.5.26 JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Bilder vererben 1.5.26 JTL-Wawi - Fehler und Bugs 10
Neu Bilder/Sliderbreiten im 5er Shop JTL-Shop - BETA - Feedback und Bugmeldungen 0
Neu Bilder falsch dargestellt. - dringend- JTL-Shop - Fehler und Bugs 6
Neu Konfigurationsartikel Bilder vergrößern Betrieb / Pflege von JTL-Shop 6
Neu Bilder im Shop Allgemeine Fragen zu JTL-Shop 3
Neu Bilder werden im Shop nicht immer angezeigt Allgemeine Fragen zu JTL-Shop 2
Neu Dropper / Bilder User helfen Usern - Fragen zu JTL-Wawi 0
Neu Alle Bilder löschen? User helfen Usern - Fragen zu JTL-Wawi 11
Neu Dunkle/schwarze Bilder im Shop User helfen Usern - Fragen zu JTL-Wawi 1
Neu Bilder ohne CSV ? Arbeitsabläufe in JTL-Wawi 11
Neu Shop verliert nach dem Bearbeiten Links und Bilder auf der Startseite Allgemeine Fragen zu JTL-Shop 3
Gelöst Shop verliert nach dem Bearbeiten Links und Bilder auf der Startseite Gelöste Themen in diesem Bereich 3
Neu Bilder von Variationskombinationen werden nicht angezeigt (im Master vom 07.07.) JTL-Wawi - Fehler und Bugs 14
Neu Bilder-Hochskalierung lässt sich nicht abschalten JTL-Shop - BETA - Feedback und Bugmeldungen 6
Offen Online-Shop Abgleich Woocommerce Bilder werden nicht importiert. WooCommerce-Connector 3
Offen Frage zu Bilder WooCommerce-Connector 2
Neu artikebeschreibung Bilder einfügen User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst Bilder upload mit SEO funzt nicht WooCommerce-Connector 2
Neu Wie kann man Bilder von Elementsammlung löschen? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Avast blokiert Bilder auf eBay eBay-Anbindung - Fehler und Bugs 5
Neu Bilder im JTL Shop über Wawi aktualisieren Betrieb / Pflege von JTL-Shop 8
Ähnliche Themen