Neu Bilder werden übetragen aber im Shop nicht angezeigt.

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

zero111181

Gut bekanntes Mitglied
6. Oktober 2009
406
7
hat hier keiner ein Lösungsansatz ich weiß echt nicht wonach ich suchen muss. Laut Wawi ist alles ok aber im Shop wird nichts erstellt, läuft da evtl. das script nicht was die Bilder anpasst und in den verschiedenen Ordnern wie lg oder md rein kopiert. An Zugriffrechte sollte es nicht liegen. Ich habe jetzt auch mal ein komplettabgleich der Bilder im Shop angestossen, mit dem resultat das alle Bilder weg waren ich musste ein Backup des Ordner pruduct wieder einspielen.
 

waldemar.p

Moderator
Mitarbeiter
6. Januar 2016
74
12
Es können unterschiedliche Ursachen haben wenn die Bilder nicht angezeigt werden, da muss man besonders auf Details des Problems achten:

1. Wird beim Artikel ein Dammy Bild "Graue Kamera" angezeigt?
Dann wurde das Bild entweder nicht übertragen oder es fehlt einfach ein einsprechender Datenbank Verknüpfung.
Lösung: Eventuell mal Artikel (über die WaWi) einmal für den Shop deaktivieren, abgleichen und erneut aktivieren und wieder abgleichen. Wenn es viele Artikel Betrift und mit dieser Lösung bei einem erfolgreich behoben werden konnte, so könnte ein Komplettabgleich weiter helfen. Jedoch falls die Artikel per Ameise importiert werden, könnte ggf. dort ein Problem sein das gewisse Datensätze nicht mit oder falsch übertragen werden.

2. Es wird kein Dammy Bild dargestellt sondern einfach ein Zeichen dass die URL des Bildes ins leere führt.
Problem 1: Die ordner media/image/storage/ und media/image/product/ haben falsche Zugriffsrechte bzw. zu niedrig und PHP kann darin keine Bilder ablegen.
Problem 2: Imagick Modul ist zwar auf dem Server aktiviert aber veraltet oder fehl konfiguriert. Falls Ihr Hoster dies nicht beheben kann, gibt es alternative die Möglichkeit GD Modul zu nutzen.
Dabei muss dann Imagick deaktiviert werden. Z.B. kann man dies wie folgt umgehen:
includes/vendor/imanee/imanee/src/ResourceProvider.php
In der Funktion imagickIsLoaded() nach { ein return 0; hinterlegen. Dadurch springt Shop automatisch auf GD um.

3. Shop Cache, Template oder Plugin Problem.
Am besten beim Nachstellen Shop Cache leeren oder besser erstmal deaktivieren. Auch Fremdhersteller Plugins sollten vorüber gehend deaktiviert werden und auf Standard aktuelle Evo Template umgeschaltet werden.
- Falls dadurch das Problem behoben werden konnte muss dann genau untersucht werden an was das genau liegt.
 
Zuletzt bearbeitet:
Ähnliche Themen Forum Antworten Erstelldatum des Themas
In Diskussion Artikelabgleich - Bilder werden nicht ersetzt, sondern zusätzlich hochgeladen WooCommerce-Connector 2
In Bearbeitung Bilder werden bei Datenabgleich nicht übertragen JTL-POS - Fehler und Bugs 2
Neu Unterkategorien Bilder werden nur teilweise angezeigt Allgemeine Fragen zu JTL-Shop 8
Neu Bilder werden im Shop nicht immer angezeigt Allgemeine Fragen zu JTL-Shop 2
Neu Bilder von Variationskombinationen werden nicht angezeigt (im Master vom 07.07.) JTL-Wawi - Fehler und Bugs 14
Offen Online-Shop Abgleich Woocommerce Bilder werden nicht importiert. WooCommerce-Connector 3
Neu Bilder in Variationen Shop und ebay User helfen Usern - Fragen zu JTL-Wawi 9
Neu Alle Bilder aller Väter an alle Kinder vererben JTL-Ameise - Fehler und Bugs 8
Neu Bilder Upload Shopware-Connector 0
Neu Bilder Rahmen proportional füllen in List und Label Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Gelöst Bilder zu anderen Auktionen eBay-Anbindung - Fehler und Bugs 2
Gelöst Keine Bilder unter "Mehr dieser Warengruppe" eBay-Designvorlagen - Fehler und Bugs 4
Neu Speichern Bildgrößen unter Storefront->Bilder->Einstellung funktioniert nicht Allgemeine Fragen zu JTL-Shop 0
Neu Bräuchte Hilfe beim Code für Bilder-Slider Technische Fragen zu Plugins und Templates 0
Abgelehnt Bilder problem beim Onlineshop Abgleichen Onlineshop-Anbindung 2
Gelöst Sync-Job bricht aufgrund fehlender Bilder ab (v1.1.0) Shopify-Connector 15
Neu Bilder Onlineshop-Anbindung 25
Neu Bilder Einrichtung von JTL-Shop 2
Neu Bilder im Firmenlogo-Projektbaustein entfernen User helfen Usern - Fragen zu JTL-Wawi 5
Neu Bilder auf Artikelliste einblenden Allgemeine Fragen zu JTL-Shop 14
Neu Shop Artikel Bilder plus Artikel Videos Einrichtung von JTL-Shop 3
Neu Bilder mit .webp Format JTL-Shop - BETA - Feedback und Bugmeldungen 7
Neu Bilder in der Signatur Servicedesk (Beta) 13
In Bearbeitung Bilder verschwunden in jtl wawi 1.5.26 JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Bilder vererben 1.5.26 JTL-Wawi - Fehler und Bugs 10
Neu Bilder/Sliderbreiten im 5er Shop JTL-Shop - BETA - Feedback und Bugmeldungen 0
Neu Bilder falsch dargestellt. - dringend- JTL-Shop - Fehler und Bugs 6
Neu Konfigurationsartikel Bilder vergrößern Betrieb / Pflege von JTL-Shop 6
Neu Bilder im Shop Allgemeine Fragen zu JTL-Shop 3
Neu Dropper / Bilder User helfen Usern - Fragen zu JTL-Wawi 0
Neu Alle Bilder löschen? User helfen Usern - Fragen zu JTL-Wawi 11
Neu Dunkle/schwarze Bilder im Shop User helfen Usern - Fragen zu JTL-Wawi 1
Neu Bilder ohne CSV ? Arbeitsabläufe in JTL-Wawi 11
Neu Shop verliert nach dem Bearbeiten Links und Bilder auf der Startseite Allgemeine Fragen zu JTL-Shop 3
Gelöst Shop verliert nach dem Bearbeiten Links und Bilder auf der Startseite Gelöste Themen in diesem Bereich 3
Neu Bilder-Hochskalierung lässt sich nicht abschalten JTL-Shop - BETA - Feedback und Bugmeldungen 6
Offen Frage zu Bilder WooCommerce-Connector 2
Neu Rabatte werden in den Exports falsch behandelt. JTL-POS - Fehler und Bugs 0
Neu Adressdaten werden nicht komplett übermittelt Modified eCommerce-Connector 0
In Bearbeitung JTL-POS (1.0.2.4) stürzt ab, wenn Hintergrundbilder für Display gesetzt werden JTL-POS - Fehler und Bugs 1
Neu Warenbestände werden nicht mehr abgeglichen wenn Auftrag direkt in JTL erfasst WooCommerce-Connector 0
Neu FBA Gutschriften werden nicht erstellt Amazon-Anbindung - Fehler und Bugs 0
Neu Wo werden die Druckerzuordnungen gespeichert User helfen Usern - Fragen zu JTL-Wawi 0
Neu Verzugszinsen werden trotz Hinterlegung des Zinssatzes als 0€ anzeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
In Bearbeitung Neue Produkte werden von der Wawi nicht nach POS synchronisiert. JTL-POS - Fehler und Bugs 12
Neu Kann man einen Artikel anlegen, der nur mit einem anderen Artikel zusammen im Shop bestellt werden kann? Arbeitsabläufe in JTL-Wawi 6
Neu Müssen neue Rechnungsvorlagen erstellt werden beim Update auf neuste Version? User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst Sitemap kann gelesen werden, enthält aber Fehler JTL-Shop - BETA - Feedback und Bugmeldungen 10
Neu JTL-POS kann nicht mehr gestartet werden JTL-POS - Fehler und Bugs 3
Neu Artikel ohne Zuweisung werden in Shops übertragen Oxid-Connector 2
Ähnliche Themen