Neu Bilder werden Artikeln nicht zugeordnet

ROKu99

Neues Mitglied
27. November 2020
7
0
Hallo,

leider werden die Bilder nicht mehr den Artikeln zugeordnet. Diese werden zwar zum Shop übertragen (in der Medienverwaltung des Shops sichtbar), aber sämtliche Artikel sind ohne Bilder.

Wawi-Version : 1.5.36.2
Shopware-Version : 5.6.9
Connector-Version : 2.8.4

Was habe ich schon alles getan?
Komplettabgleich wurde schon durchgeführt, nachdem bei einigen Artikeln nur ein Bild angezeigt wurde. Jetzt gar keins mehr.
Redis auf dem Server deinstalliert.
OPCache deaktiviert.
Downgrade von PHP7.4 auf 7.3

Debug in der Wawi und Connector aktiviert.
Connector- Log Image-xxxx.log durchweg ein Eintrag:
Code:
...
[2021-01-11 17:18:47] image.ERROR: Exception 'Exception' (Code: 0) with message 'No translation found' in /home/users/.../engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/I18n.php:56 [] []
[2021-01-11 17:18:47] image.ERROR: Exception 'Exception' (Code: 0) with message 'No translation found' in /home/users/.../engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/I18n.php:56 [] []
[2021-01-11 17:18:48] image.ERROR: Exception 'Exception' (Code: 0) with message 'No translation found' in /home/users/.../engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/I18n.php:56 [] []
[2021-01-11 17:18:48] image.ERROR: Exception 'Exception' (Code: 0) with message 'No translation found' in /home/users/.../engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/I18n.php:56 [] []
[2021-01-11 17:18:51] image.ERROR: Exception 'Exception' (Code: 0) with message 'No translation found' in /home/users/.../engine/Shopware/Plugins/Community/Frontend/jtlconnector/src/Utilities/I18n.php:56 [] []
...
In der Abgleich Debug fällt mir folgender wiederholter Eintrag auf:
Code:
{
      "filename": "831_554_ee0ac5f51b8ad2c66342d3c28aaa6f32_e7ee35ce4a9267c1ca3f3501c117d50b9f6e28377529e9d65fea048b188c1bf60a8e1f6d620ce340a04476b175abaa835aefacd44a4a1215aef309759cf61d35.jpg",
      "remoteUrl": null,
      "name": "",
      "foreignKey": [
        "",
        195283
      ],
      "id": [
        "",
        2878448
      ],
      "relationType": "product",
      "sort": 2,
      "i18ns": []
    }
Die kompletten Logdateien sind mittlerweile zu groß um sie hier anzuhängen. Kann sie bei Bedarf aber gern zur Verfügung stellen.

Vielen Grüße und schon mal vielen Dank.
Ron
 

ROKu99

Neues Mitglied
27. November 2020
7
0
Hallo,

der genannte Fehler wurde zwar behoben. Allerdings werden bei einigen Produkten noch immer keine Artikelbilder angezeigt, obwohl von der Wawi übertragen und auf dem Server vorhanden.
Testweise hab ich bei einem der betroffenen Artikel alle Bilder (5 Stück) zum erneuten Senden eingestellt und den Shopabgleich gestartet. Gemeldet wird auch, dass 5 Bilder hochgeladen wurden.

In der image-xxx. log erscheint folgender Eintrag:
Code:
[2021-01-19 16:55:28] image.ERROR: Exception 'League\Flysystem\FileExistsException' (Code: 0) with message 'File already exists at path: media/image/bc/c3/35/C-Preislisten-productimages-item100962210000-jpg.jpg' in /home/users/.../.../.../vendor/league/flysystem/src/Filesystem.php:405 [] []
Anbei auch noch das Logfile vom Wawi- Connector. weitere Logs kann ich bei Bedarf zur Verfügung stellen.
 

Anhänge

lumbert

Gut bekanntes Mitglied
2. April 2009
320
11
Ich habe Kundenrückmeldungen, das dieses Problem weiterhin auftritt wenn man einen Artikel dupliziert und dabei auch die Bilder mitnimmt. Dupliziert man einen Artikel in der Wawi ohne Bildübernahme und fügt diese danach manuell dazu, funktioniert der Transfer in den Shop.

Wawi & Connector jeweils die neuste VErsion.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Bilder werden im Webshop nicht angezeigt, generieren nicht möglich. Einrichtung von JTL-Shop4 3
Neu SEO : Bilder aus OPC werden nicht richtig übernommen Allgemeine Fragen zu JTL-Shop 0
Neu [Error][Code:20004] EPS-Bilder und selbstverwaltete Bilder können nicht kombiniert werden. [Warning][Code:21919420] eBay-Anbindung - Fehler und Bugs 2
Beantwortet Artikeletikett mit mehreren Bilder Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Woocommerce Connector Abgleich Bilder Kinderartikel WooCommerce-Connector 0
Neu Bilder ersetzen geht nicht mehr Shopware-Connector 4
Neu Swatch Bilder Größe anpassen shop 5 Allgemeine Fragen zu JTL-Shop 1
Neu Wawi-Bilder in den Kanälen meist mehrfach.... JTL-Wawi - Fehler und Bugs 1
Neu Platzhalter für Bilder in Design Vorlage korrekt? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 6 Abgleich Problem Bilder Shopware-Connector 3
Neu Seite mit frei erstelltem Inhalt - Bilder & Verlinkungen Allgemeine Fragen zu JTL-Shop 3
Gelöst Bilder zum Composer hinzufügen Einrichtung JTL-Shop5 0
Neu Alle Bilder der Variationen aktivieren Allgemeine Fragen zu JTL-Shop 4
In Bearbeitung Seperate Bilder für weiteren EbayMarktplatz zb. Ebay.fr Einrichtung und Installation von JTL-eazyAuction 2
In Bearbeitung Konfigurator - Bilder aller Komponenten anzeigen lassen zur Auswahl User helfen Usern - Fragen zu JTL-Wawi 2
Neu JTL Shop 5 mit SSL - Darstellung ohne Bilder und Formatierung Allgemeine Fragen zu JTL-Shop 0
Neu Sehr langsam: Bilder in die HTML Shop Seiten hochladen Allgemeine Fragen zu JTL-Shop 5
Neu Variation -> Bilder löschen per Ameise User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shop nimmt keine Bilder an JTL-Wawi - Fehler und Bugs 1
Neu Hintergrundfarbe von Bilder nicht weiss JTL-Shop - BETA - Feedback und Bugmeldungen 0
Neu Product-Stream im OPC zeigt große JPG-Bilder statt WebP Allgemeine Fragen zu JTL-Shop 0
Neu Bilder bei eBay gebündelt bearbeiten / ersetzen / hinzufügen Einrichtung und Installation von JTL-eazyAuction 0
Neu Artikel Bilder zwecks SEOoptimierung mit original Namen oder mit Artikelnummer hochladen... Modified eCommerce-Connector 0
Neu Bilder mit eingebetteten Metadaten Shopware-Connector 0
Browsercache leeren Pflicht um neue Bilder anzuzeigen? Einrichtung JTL-Shop5 6
Neu Bilder in Beschreibung für Smartphones optimieren Betrieb / Pflege von JTL-Shop 3
Neu Wie empfange ich die Bilder? Technische Fragen zu den JTL-Connectoren 1
Neu Übernimmt Shopware nicht alle Bilder bei langen Artikelnamen? Shopware-Connector 0
Beantwortet Erstellen von Mahnvorlagen nicht möglich, da Designobjekt nicht bezogen werden kann Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 12
Neu Amazon FBA Splitversand - Rechnungskorrekturen werden nicht automatisch erzeugt JTL-Wawi - Fehler und Bugs 0
Neu Die Verbindung zum Remoteserver kann nicht hergestellt werden Response empty Modified eCommerce-Connector 1
Neu Warnungen: Varkombi-Kind ohne Vater: '' kann nicht importiert werden. Gambio-Connector 2
Neu Artikeldatenexport - Filter -> Hersteller - Wenn "Leer" werden Artikel ignoriert JTL-Ameise - Fehler und Bugs 0
Neu CSV Datei kann nicht eingelesen werden JTL-Ameise - Fehler und Bugs 4
Neu Artikel werden nicht entfernt JTL-Ameise - Fehler und Bugs 14
Neu Versandkosten werden nur noch für neu angelegte Artikel berechnet Onlineshop-Anbindung 1
Gelöst Artikeln werden tatsächlich nicht importiert User helfen Usern - Fragen zu JTL-Wawi 2
Neu Paypal Express - werden Versandkosten hier nicht berücksichtigt? Plugins für JTL-Shop 0
Neu Artikelbilder werden nach erfolgreichem Abgleich nicht angezeigt. WooCommerce-Connector 1
Neu Versandgewicht bei DHL Sendungen nach UK werden doppelt hinterlegt JTL-ShippingLabels - Fehler und Bugs 0
Neu [AUFTRAGSLISTE] WAWI 1.5440 -> Amazon-Rechnungsnummern werden nicht mehr angezeigt JTL-Wawi - Fehler und Bugs 0
Neu Apple Mac über RDP: Umlaute werden in Druckvorlagen nicht ausgegeben Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Gelöst Es werden Artikelmerkmalboxen angezeigt die so nie angelegt wurden. Was ist das ?!? Einrichtung von JTL-Shop4 0
Neu Artikeletiketten für gesamten Lagerbestand drucken - nicht alle Labels werden gedruckt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu UstId bei Shop-Bestellungen werden nicht an Wawi übertragen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Variationspreise werden falsch angezeigt JTL-Shop - Fehler und Bugs 9
Neu Bundesstaaten werden nicht an JTL übermittelt (Showare 5 - JTL 1.5.35.2) Arbeitsabläufe in JTL-Wawi 0
Neu Multishop Abgleich - Bestellungen werden aus einem Shop immer dem gleichen Kunden zugeordnet Gambio-Connector 0
Neu Von Client Computer werden keine Emails verschickt JTL-Wawi - Fehler und Bugs 4
Neu [JTL SHOP 5] Sitemap kann nicht automatisch erstellt werden JTL-Shop - Fehler und Bugs 3

Ähnliche Themen