Gelöst Beta akzeptiert bei Installation den SQL-Server nicht.

dc-nico

Sehr aktives Mitglied
17. März 2011
2.969
249
Brandenburg an der Havel
Hallo,

ich habe mich heute wieder an den PC gesetzt und versuche seit Stunden die Beta zu installieren.
Da das Update auf SQL-Server 2012 nichts gebracht hat (WAWI sieht immer noch SQL Server 2005), habe ich jetzt den SQL 2005 komplett deinstalliert.
Nun erstellt die Beta aber beimStart nicht die neue DB.
Ich komme hier nicht weiter.
Die WAWI-Datenbankverwaltung installiert mir SQL Server 2014.
Wie bekommt man denn den JTLWAWI Server wieder installiert?

Das Problem werde ich ja auch bei der Finale haben, da der Server einfach nicht passt.

Gruß

NICO
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Die WAWI-Datenbankverwaltung installiert mir SQL Server 2014.
Hallo,

installiere einfach diesen.
Man kann sich hier auch an die Anleitung von 2012 halten:
Kategorie:JTL-Wawi:Installation ? JTLWiki

Die Datenbank wird dann autom. bei Wawi Start angelegt.

Wichtig ist das der SQL Server noch keine eayzbusienss Datenbank hatte. Sonst muss man die Datenbank Dateien eazybusienss.xxx umbenennen.
 

dc-nico

Sehr aktives Mitglied
17. März 2011
2.969
249
Brandenburg an der Havel
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Hallo,

danke für den Tipp.

Ich deinstalliere jetzt erst ein mal alle SQL-Server und Komponenten.
Sonst hat die WAWI immer Problememit Pfaden usw.
Wenn es dann immer noch Probleme geben sollte melde ich mich.

Gruß

NICO
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Man muss die alten nicht deinstallieren, da jeder SQL - Server eigenen Instancenamen hat.
Dieser wird von der Wawi für die Verbindung benötigt.

Ich nutze 5 versch. SQL-Server auf meinem Rechner und kann die Prima steuern.
 

dc-nico

Sehr aktives Mitglied
17. März 2011
2.969
249
Brandenburg an der Havel
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Dann muss ich jetzt alles deinstallieren und mit der alten Wawi neu anfangen, da ich bei der Deinstallation des SQL Servers 2005 auch die Instancen gelöscht habe.
Ich habe nur die DB Sicherung vorliegen.

Gruß

NICO
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Wenn SQL-Server weg, dann neuen installieren wie in der Anleitung.
Es muss ohne Fehler durchlafen.

Danach prüfen ob der SQL-Server als Dienst ausgeführt wird.

Wenn ja, die neue 77 Wawi installieren, DB-Verwaltungstool aufmachen und ein Profil zum SQL-Server erstellen.
Danach das Backup einspielen.
 

dc-nico

Sehr aktives Mitglied
17. März 2011
2.969
249
Brandenburg an der Havel
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Kann man nicht direkt den 2012er installieren, oder muss man immer mit der 2005er installieren wenn man alles neu installieren muss ?

Gruß

NICO
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Immer den neusten. 2014 oder 2012.
2005 darf und sollte nicht installiert werden.
 

dc-nico

Sehr aktives Mitglied
17. März 2011
2.969
249
Brandenburg an der Havel
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Hallo,

also ich habe nun den 2012er installiert und die 977 will die eazybusines Datenbank,umsich anmelden zu können.
Wawi sagt zwar, dass sie die Datenbank erstellen will, macht es aber anscheinend nicht.
Was muss ich denn tun damit man die Datenbank wieder erstellt bekommt?

Gruß

NICO
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

Was ist der Fehler?

Suche im System nach "eazybusiness.*"

Falls die gefunden wird, sind das die alten Dateien, diese umbenennen z.B. _eazybusiness.*
 

dc-nico

Sehr aktives Mitglied
17. März 2011
2.969
249
Brandenburg an der Havel
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

So, es war kein eazybusiness mehr vorhanden.
Wawi hatte natürlich keine Datenbank gefunden und somit immer Fehler ausgegeben.
Dann bin ich über den Datenbakmannager gegangen und die Wawi hat den SQL-Server 2014 installiert.
Da kames oft zu Fehlern und man musste abbrechen.
Nach 3 Versuchen ist es nun soweit, dass ich das Backup einspielen konnte und die Datenbank erweitert wird.
Hierbei kames zu folgendem Fehler:

Unbehandelte Ausnahme #727D5A9D12FF31B0 vom Typ System.Data.SqlClient.SqlException in Void OnError(System.Data.SqlClient.SqlException, Boolean, System.Action`1[System.Action])
System.Data.SqlClient.SqlException (0x80131904): Die CREATE UNIQUE INDEX-Anweisung wurde beendet, weil ein doppelter Schlüssel für den Objektnamen 'dbo.tLieferantenBestellungErinnerungPos' und den Indexnamen 'PK__tLiefera__39604C0264AF2F91' gefunden wurde. Der doppelte Schlüsselwert ist (0, 7, 135).
Die Einschränkung oder der Index konnte nicht erstellt werden. Siehe vorherige Fehler.
Die Anweisung wurde beendet. .....

Somit läuft die Erweiterung schieß und die Wawi beendet das ganze.

Gruß

NICO
 

dc-nico

Sehr aktives Mitglied
17. März 2011
2.969
249
Brandenburg an der Havel
AW: Beta akzeptiert bei Installation den SQL-Server nicht.

So,ich sage ein mal danke für die schnelle Lösung meines Problems.
Wawi Beta läuft jetzt und wird produktiv genutzt.

Gruß

NICO
 

Ähnliche Themen