Gelöst Beta 3 Anbindung an Wawi 1.5.10.0

liwe_fs

Gut bekanntes Mitglied
21. November 2012
149
6
MOS
Hi,

ich habe hier ein Problem mit der Wawi Anbindung der 5.0.0-beta.3
Domain bzw. Shop URL ist alles OK
Lizenzschlüssel ist ok habe ich mit Shop 4.6 getestet
Verzeichnissee und Rechte sind auch alle ok

2 komplette Neuinstallation alles Fehlanzeige mit Anbindung 4.6 kein Problem

Shop Neuinstallation = 5.0.0-beta.3
Wawi Version = 1.5.10.0
PHP = 7.2 oder 7.3 egal
SSL mit und ohne

Fehlermeldung
Synchronisation mit Webshop nicht möglich!
Die Shop-URL verweist nicht auf einen gültigen Shop!
Bitte prüfen Sie die Connector-Konfiguration!

Mit dem Shop 5.0.0-beta.1 hatte ich schon mal getestet da war es kein Problem.
 

eRock Marketing

Offizieller Service Partner
SPBanner
9. Januar 2018
504
204
Hatte das Problem auch, habe es aber nicht näher untersucht.

Ist für Shop 5 ggf. eine andere Config der z.b. .htaccess notwendig?
Via einem nginx wollte es nicht, bei einem Apache lief es dann.
 

Rainer S

Moderator
Mitarbeiter
8. August 2018
952
203
Nur eine Vermutung, der Server wo der Shop installiert werden soll ist engegen den Empfhelungen ein Nginx Server, dann könnte folgendes der Fall sein.
Folgende htaccess regel aus der htaccess im ordner dbeS wird wohl aufgrund der
Serverkonfiguration blockiert.

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule ^(.*)\.php$ index.php?id=$1 [QSA,L]
</IfModule>

was Sie in der nginx konfiguration hinterlegen müsste.

rewrite ^/dbeS/(.*)\.php /dbeS/index.php?id=$1&$args last;
 

eRock Marketing

Offizieller Service Partner
SPBanner
9. Januar 2018
504
204
Danke, wir nutzen immer nginx, da es eine bessere Performance mit dem JTL Shop liefert (getestet mit gleicher Serverhardware) - aber das bitte nicht als Maßstab sehen das ist nur die Meinung unserer Tests.
Jedenfalls haben wir erfolgreich mehrere JTL Shops in der Version 4 (meistens 4.06 vereinzelt auch noch 4.04 und 4.05) laufen mit umgeschriebener nginx - Konfiguration.
Exakt die gleiche Konfiguration war für den Shop5 Beta 3 im Einsatz. Da sollte demnach auch der dbeS Ordner beachtet sein (sofern sich wie angesprochen nichts gravierendes geändert hat).
 

Rainer S

Moderator
Mitarbeiter
8. August 2018
952
203
Doch im Shop 5 hat sich hier einiges verändert, deshalb bitte dann einmal o.g. durchführen wenn nginx im Einsatz ist. Das sollte das Problem lösen.
 
  • Gefällt mir
Reaktionen: eRock Marketing

liwe_fs

Gut bekanntes Mitglied
21. November 2012
149
6
MOS
Danke für den Tip mit dem Nginx Server
Es ist ein Apache Server mit der selben Config wie bei der 4.6 Shop Version.

Abfrage mit der /dbeS/index.php per curl
HTTP/2 200 date: Mon, 28 Oct 2019 16:31:46 GMT server: Apache/2.4.41 x-powered-by: PHP/7.3.6 cache-control: max-age=2592000 expires: Wed, 27 Nov 2019 16:31:46 GMT x-ua-compatible: IE=edge x-content-type-options: nosniff content-type: text/html; charset=utf-8

/dbeS/mytest.php gint es ja nicht mehr in der 5er Verion
 

SHAAN

Sehr aktives Mitglied
26. August 2020
693
228
Guten Tag!

Ich bin neu im Forum und bei JTL.

Ich habe mir die WAWi 1.5.27.3 und die Shop 5 Beta 5.0.0. rc2 installiert.
Nun bekomme ich beim Anbinden des Shops in der Wawi eine ähnliche Fehlermeldung.

Wenn ich die Domain bei der Anbindung mit http:// schreibe, dann erhalte ich die Rückmeldung: Lizenzschlüssel fehlerhaft oder Domain nicht gefunden.
Wenn ich die Domain bei der Anbindung mit https:// schreibe, dann erhalte ich die Rückmeldung: 8 Ihr JTL- Shop Version 5.0.0-rc.1 benötigt für den Datenabgleich mindestens JTL-Wawi Version 1

Ich nutze einen FlexServer Business von Profihost mit PHP 7.3.. Systemcheck ist ok.

Den Tipp von Rainer S weiß ich nicht umzusetzen.

Vielen Dank für die Unterstützung.
Beste Grüße
 

SHAAN

Sehr aktives Mitglied
26. August 2020
693
228
Was mir noch aufgefallen ist, dass die Domain im Frondend mit doppelslash abschließt ...de//

?
 

SHAAN

Sehr aktives Mitglied
26. August 2020
693
228
Sorry Anfängerfehler. Es wurde bei der Erstellung der Lizenz nach keiner Domain gefragt und ich hatte der Lizenz keine Domain zugewiesen. Jetzt geht es.
 

deliman

Sehr aktives Mitglied
13. Februar 2016
1.069
132
Hallo,

gab es seit dem Eintrag vom 28.10.2019 Änderungen hinsichtlich der nginx-Einstellungen?

"
...was Sie in der nginx konfiguration hinterlegen müsste.

rewrite ^/dbeS/(.*)\.php /dbeS/index.php?id=$1&$args last; "

Haben gestern bei TimmeHosting die aktuelle Shop Master von gestern in deren Testhosting auf nginx installiert - Shop läuft auch aber die Wawi-Anbindung will nicht.
Der Timme-Admin hat die o.g. Änderungen in der Konfiguration vorgenommen aber die Verbindung Wawi - Shop zeigt noch immer die selbe Fehlermeldung an.
 

deliman

Sehr aktives Mitglied
13. Februar 2016
1.069
132
Hallo,

gab es seit dem Eintrag vom 28.10.2019 Änderungen hinsichtlich der nginx-Einstellungen?

"
...was Sie in der nginx konfiguration hinterlegen müsste.

rewrite ^/dbeS/(.*)\.php /dbeS/index.php?id=$1&$args last; "

Haben gestern bei TimmeHosting die aktuelle Shop Master von gestern in deren Testhosting auf nginx installiert - Shop läuft auch aber die Wawi-Anbindung will nicht.
Der Timme-Admin hat die o.g. Änderungen in der Konfiguration vorgenommen aber die Verbindung Wawi - Shop zeigt noch immer die selbe Fehlermeldung an.

Problem bei uns gelöst. Der Serveradmin hat die nginx Regeln wohl noch mal überarbeitet und für den 5er eine eigene Regel festgelegt und nun läuft der Shop.
 

Ähnliche Themen