1. Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.
    Information ausblenden

Amazon Payments (LPA) für JTL Shop4

Dieses Thema im Forum "Plugins für JTL-Shop" wurde erstellt von Henryk, 24. November 2015.

  1. Sven83

    Sven83 Mitglied

    Registriert seit:
    26. Februar 2017
    Beiträge:
    77
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo Community,
    ich habe mal ein paar Fragen zum Umgang mit dem Plugin. Unser Shop ist noch nicht so lange online und wir setzen das Plugin für Amazon Payment (108) bei uns ein. Wenn eine Bestellung reinkommt, wird der Auftrag kurze Zeit später auch in die WaWi übertragen. Wir arbeiten den Auftrag ab, setzen die Bestellung auf versendet usw. Aber leider bleibt der Auftrag unbezahlt in der Wawi stehen. Sollte dieser Status sich nicht nach dem versenden ändern?

    Im Plugin steht bei dem Auftrag: Order-Status (Amazon) - Open.
    Bei Amazon auf der Webseite steht (unter Transaktionen verwalten): Status der Zahlung - Offen vollständig abgebucht

    Somit ist der Zahlungsvorgang doch abgeschlossen oder?

    Desweiteren ist mir aufgefallen, dass bei Amazon unter Transaktionen verwalten bei Bestellnummer des Verkäufers nur "(Nicht angegeben)" steht.
    Ist das so korrekt?

    Ich würde mich sehr über Hilfe hierzu freuen, vielen Dank.
     
  2. DITH-Shop

    DITH-Shop Gut bekanntes Mitglied

    Registriert seit:
    8. Juli 2013
    Beiträge:
    2.127
    Zustimmungen:
    29
    Punkte für Erfolge:
    48
    Das die Zahlung nach Versand nicht in der Wawi ankommt ist auch bei mir seit langem so.

    Die Bestellnummer wird tatsächlich nicht zu AMAZON übertragen, liegt wohl daran das diese zum Zeitpunkt der Erstellung noch nicht vorhanden ist, und nachträglich nicht gesetzt werden kann.
     
  3. Dustin

    Dustin Aktives Mitglied

    Registriert seit:
    14. Mai 2008
    Beiträge:
    2.705
    Zustimmungen:
    20
    Punkte für Erfolge:
    38
    Ort:
    Enger
    Also bei uns ist das mittlerweile super und funktioniert auch mit den Zahlungen.
     
  4. Xantiva

    Xantiva Aktives Mitglied

    Registriert seit:
    28. August 2016
    Beiträge:
    780
    Zustimmungen:
    77
    Punkte für Erfolge:
    28
    Ort:
    Düsseldorf
    @Dustin "mittlerweile"? Was habt Ihr denn gemacht, dass es nun auch mit den Zahlungen funktioniert?
     
  5. DITH-Shop

    DITH-Shop Gut bekanntes Mitglied

    Registriert seit:
    8. Juli 2013
    Beiträge:
    2.127
    Zustimmungen:
    29
    Punkte für Erfolge:
    48
    JA, ich hab dann gestern nen Update auf die 1.09 gefunden und installiert. Mal sehen ob das jetzt behoben ist
     
  6. consumed

    consumed Mitglied

    Registriert seit:
    30. Juli 2015
    Beiträge:
    60
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Wir versuchen gerade das Plugin von Amazon einzubinden.

    Der Button ist vorhanden, wenn wir im Link /?lpa-show ergänzen. Soweit so gut :)
    Jedoch ist es so, wenn ich mich test weise mit einem Amazon Account anmelde, dass folgende Fehlermeldung erscheint

    Pay Adressbuch
    Bei der Verarbeitung Ihrer Zahlung für diese Webseite ist leider ein Problem aufgetreten. Bitte wenden Sie sich an den Verkäufer, wenn Sie Hilfe benötigen.


    Der Check ?lpacheck hat soweit funktioniert -> IPN is reachable.
    Die Händler-URL sind in Amazon Pay bei der Produktion und bei der Sandbox eingetragen.
    Die restlichen URLS sind in den Webeinstellungen vorhanden.

    Was habe ich vll noch übersehen?
     
  7. Sven83

    Sven83 Mitglied

    Registriert seit:
    26. Februar 2017
    Beiträge:
    77
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Bei mir lag es an der Händler URL bei Amazon. Das Plugin funktionierte zwar, das es den Kauf annahm usw, aber ich erhielt keine Rückmeldung von Amazon z.B. den Trigger zum auslösen als Bezahlt.

    Jetzt funktioniert es.
     
  8. DITH-Shop

    DITH-Shop Gut bekanntes Mitglied

    Registriert seit:
    8. Juli 2013
    Beiträge:
    2.127
    Zustimmungen:
    29
    Punkte für Erfolge:
    48
    Bei mir gehts nicht.
    Was hast Du bei Integrator-Url?
    Laut AMAZON Hilfe ist das die Url an die die Zahlungsbestätigung geschickt wird.
     
  9. DITH-Shop

    DITH-Shop Gut bekanntes Mitglied

    Registriert seit:
    8. Juli 2013
    Beiträge:
    2.127
    Zustimmungen:
    29
    Punkte für Erfolge:
    48
    Da schließe ich mich an.... Käufe und so weiter, alles in Ordnung. Will ich die Zahlung nach dem Versand in der Wawi haben muss ich für jede einzelne Bestellung im PlugIn auf "refresh" klickjen
     
  10. Dustin

    Dustin Aktives Mitglied

    Registriert seit:
    14. Mai 2008
    Beiträge:
    2.705
    Zustimmungen:
    20
    Punkte für Erfolge:
    38
    Ort:
    Enger
    Also bei uns funktioniert das Plugin jetzt korrekt auch die Zahlungen werden nun automatisch gesetzt.
     
  11. DITH-Shop

    DITH-Shop Gut bekanntes Mitglied

    Registriert seit:
    8. Juli 2013
    Beiträge:
    2.127
    Zustimmungen:
    29
    Punkte für Erfolge:
    48
    Wie sind die Einstellungen?
    Plugin:
    Login / Pay/ Login und Pay?
    Synchron / Asynchron?
    IPN aktiv?


    AMAZON:
    Integrator Url?
     
  12. Sven83

    Sven83 Mitglied

    Registriert seit:
    26. Februar 2017
    Beiträge:
    77
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Die Integrator URL bleibt leer und bei der Händler-URL muss der Link zu deinem Shop rein:
    https://dein Shop usw usw/plugins/ss360_amazon_lpa_shop4/version/108/frontend/ipn.php
     
  13. Dustin

    Dustin Aktives Mitglied

    Registriert seit:
    14. Mai 2008
    Beiträge:
    2.705
    Zustimmungen:
    20
    Punkte für Erfolge:
    38
    Ort:
    Enger
    Login und Pay
    Asnchron
    IPN Aktiv

    bei Amazon Integrator Url steht nix drin
     
  14. DITH-Shop

    DITH-Shop Gut bekanntes Mitglied

    Registriert seit:
    8. Juli 2013
    Beiträge:
    2.127
    Zustimmungen:
    29
    Punkte für Erfolge:
    48
    DAS habe ich auch alles so drin.
    Links nach dem Update auf die 1.09 auch aktualisiert... (Sowohl im Plugin als auch bei AMAZON)

    Irgendwo klemmt es.
     
  15. DITH-Shop

    DITH-Shop Gut bekanntes Mitglied

    Registriert seit:
    8. Juli 2013
    Beiträge:
    2.127
    Zustimmungen:
    29
    Punkte für Erfolge:
    48
    Genau so habe ich es auch...
     
  16. Dustin

    Dustin Aktives Mitglied

    Registriert seit:
    14. Mai 2008
    Beiträge:
    2.705
    Zustimmungen:
    20
    Punkte für Erfolge:
    38
    Ort:
    Enger
    Ich arbeite noch mit der 1.08 muss ich dazu sagen
     
  17. Xantiva

    Xantiva Aktives Mitglied

    Registriert seit:
    28. August 2016
    Beiträge:
    780
    Zustimmungen:
    77
    Punkte für Erfolge:
    28
    Ort:
    Düsseldorf
    Dann verstehe ich das nicht. Ich poste hier noch mal unsere Einstellungen (Version 108) ...

    Wir verwenden nur "Pay" und kein Login, aber das dürfte ja die IPN Calls nicht beeinträchtigen.

    upload_2017-11-23_20-58-2.png

    upload_2017-11-23_20-57-6.png

    upload_2017-11-23_20-58-48.png

    Dafür habe ich das ständig im Log:
     
  18. Xantiva

    Xantiva Aktives Mitglied

    Registriert seit:
    28. August 2016
    Beiträge:
    780
    Zustimmungen:
    77
    Punkte für Erfolge:
    28
    Ort:
    Düsseldorf
    Jetzt habe ich die 109 installiert und warte dann auf den morgigen Versand, aber ...

    ... wieso wird denn jetzt wieder eine zusätzliche JavaScript-Datei auf allen Seiten eingebunden, wenn ich nur Pay und nicht Login aktiviert habe?

    /includes/plugins/s360_amazon_lpa_shop4/version/109/frontend/js/lpa-utils.js

    :(
     
  19. vekoop

    vekoop Mitglied

    Registriert seit:
    19. Juli 2013
    Beiträge:
    363
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    Hallo, wir bekommen seit neuestem diese Fehlermeldung im Log:

    LPA: LPA-Login-Fehler: CURL-Fehler: Operation timed out after 300479 milliseconds with 0 out of 0 bytes received

    Auf den ersten Blick scheint aber alles zu funktionieren, wir prüfen das aber nochmal.

    Ups, manchmal sollte man gründlich gucken, das gibt es auch noch:
    LPA: LPA-Login-Fehler: CURL-Fehler: OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to api.amazon.de:443
    LPA: LPA-Payment-Fehler: Technischer Fehler beim Bestellabschluss: OrderReference P02-0103742-xxx is not in draft state and cannot be modified with the request submitted by you.
     
    Zuletzt bearbeitet: 27. November 2017
  20. knackig

    knackig Mitglied

    Registriert seit:
    17. November 2011
    Beiträge:
    395
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    Ort:
    Nordhessen
    Nach Deinem Hinweis habe ich auch nochmal nachgeschaut... bei uns das Gleiche. Heute fiel mir eine Bestellung auf, die am Freitag verschickt wurde und heute immer noch als unbezahlt stand. Die Bestellung ist im Plugin auch nicht auffindbar. Das Einziehen des Betrages habe ich über Sellercentral angestoßen und die Zahlung manuell gesetzt. Im Log finde ich folgendes:

    LPA: LPA-Payment-Fehler: Technischer Fehler beim Bestellabschluss: OrderReference P02-8344003-XXXXXXXX is not in draft state and cannot be modified with the request submitted by you.
    LPA: LPA-Payment-Fehler: Technischer Fehler beim Bestellabschluss: 404;Not Found

    Die Bestellnummer in der Fehlermeldung stimmt mit der erwähnten Bestellung überein.
     

Diese Seite empfehlen

Verstanden Weitere Informationen

JTL-Software benutzt Cookies, teilweise von Drittanbietern, um Funktionalitäten auf unseren Webseiten zu ermöglichen.