Neu XML-Auftragsimport Fehlermeldung "Keine gültige Versandlandwährung"

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

payday

Aktives Mitglied
1. Oktober 2010
64
3
#1
Beim XML-Import in der Version 1.4.17.2 ist mir der folgende Fehler aufgefallen:

Wenn die Lieferadresse ein Land ist für die ich keine Währung hinterlegt habe, kommt die folgende Fehlermeldung beim Import und die Bestellung wird nicht importiert.

"Keine gültige Versandlandwährung"

Wieso muss ich eine Versandlandwährung anlegen, wenn ich diese gar nicht benötige, weil die Auftragswährung (EUR) eine andere ist? Ist dieses Verhalten beabsichtigt? Es gibt ein JTL Issues Ticket WAWI-32418, welches aber leider abgewiesen wurde. Darf man den Grund erfahren?

Da ich weltweit versende, ist es ist nämlich leider sehr umständlich für jedes Land extra eine Währung manuell anzulegen, obwohl ich diese Währung gar nicht benötige.
 

Rico Giesler

Administrator
Mitarbeiter
10. Mai 2017
9.341
836
#2
Wird denn von Deutschland aus versendet oder von beispielsweise Polen?
Wenn zweiteres zutrifft, dann bitte eine Währung für Polen anlegen.
Sollte das nicht gehen kann dir eventuell der Support im Kundencenter weiterhelfen.
 

payday

Aktives Mitglied
1. Oktober 2010
64
3
#3
Es wird nur von Deutschland aus versendet und die Auftragswährung ist immer EUR. Ich hatte heute eine Bestellung nach Norwegen. Die Bestellung wurde nicht importiert (Fehlermeldung: "Keine gültige Versandlandwährung"). Erst als ich die Währung NOK in der Wawi angelegt hatte war der Import möglich. Ich hatte mich bereits beim Support gemeldet und mir wurde bestätigt, dass dies ein Bug ist und eigentlich nicht sein sollte. Es wurde daraufhin das JTL Issues Ticket WAWI-32418 angelegt. Leider wurde das Ticket abgewiesen, deshalb die Frage nach dem Grund der Abweisung.
 

Enrico W.

Moderator
Mitarbeiter
27. November 2014
1.995
184
#4
Wenn die Währungen nicht angelegt werden sind Folgefehler nicht auszuschließen. So wäre es zum Beispiel schon nicht mehr möglich, eine Rechnung in der Lieferland-Währung auszugeben.
Ja, ich weiß - das ist in deinem Beispiel jetzt nicht erwünscht, aber wir können es leider auch nicht ausschließen.
Das einfachste, um dieses Problem zu umgehen: Du nimmst Dir ein mal die Zeit und legst die fehlenden Währungen an, die Du aller Wahrscheinlichkeit nach benötigen wirst.
Ich hab Dir hier mal die ISO-Codes aus der Datenbank in eine Excelliste gepackt. Einige kannst Du wahrscheinlich schon von vornherein ausschließen - daher musst Du dann ja nicht alle anlegen.
 

Anhänge

payday

Aktives Mitglied
1. Oktober 2010
64
3
#5
Vielen Dank für die Rückmeldung und die Excelliste. Was ich in Bezug auf die möglichen Folgefehler nicht ganz verstehe, ist das ich manuell einen Auftrag und eine Rechnung mit einer Lieferadresse ins Ausland erstellen kann ohne die Fremdwährung vorher anzulegen. Dabei kommt keine Fehlermeldung. Wenn ich den identischen Auftrag aber als XML importiere ist dies leider nicht möglich und ich muss erst die eigentlich nicht benötigte Fremdwährung anlegen.

Falls es doch nicht anders geht, wäre es sehr hilfreich, wenn in einer zukunftigen Wawi-Version schon alle Währungen standardmäßig angelegt sind, damit man nicht alle einzeln manuell hinzufügen muss.