Gelöst Update auf die Final 1.4 bricht mit Fehlermeldung ab

saimax

Aktives Mitglied
10. Mai 2010
35
2
Hamburg
Ich versuche jetzt die JTL Wawi von 1.3.21.0 auf die neue JTL Wawi 1.4.26.1 final upzudaten.
Es klappt leider nicht und der update Prozess bricht mit einer Fehlermeldung ab.

03:49:40 Fehler in der Version 1.4.8.0 beim Befehl:
==============================================
ALTER TABLE tBestellung ALTER COLUMN nPlatform int NOT NULL
==============================================
Message: Index "_dta_index_tBestellung_7_1360984175__K26_K20_K8_K1_2_3_4_5_6_7_9_10_11_12_13_14_15_16_17_18_19_21_22_23_24_25_27_28_29_30_31_" ist von Spalte "nPlatform" abhängig.
LineNumber: 1
Procedure:


03:49:40 Fehler in der Version 1.4.8.0 beim Befehl:
==============================================
ALTER TABLE tBestellung ALTER COLUMN nPlatform int NOT NULL
==============================================
Message: Fehler bei ALTER TABLE ALTER COLUMN nPlatform, da mindestens ein Objekt auf diese Spalte zugreift.
LineNumber: 1
Procedure:


Ich habe dies mehrmals probiert aber leider kommt es immer an dieser Stelle zu einen Problem.
Hat einer das gleiche Problem oder kennt eine Lösung.
Danke im Voraus
 

JTL_fwenzl

WMS Entwickler
Mitarbeiter
15. Dezember 2017
250
88
Hürth
Hallo Saimax,

rein von der Benennnung sieht der Index "_dta_index_tBestellung_7_1360984175__K26_K20_K8_K1_2_3_4_5_6_7_9_10_11_12_13_14_15_16_17_18_19_21_22_23_24_25_27_28_29_30_31_ "
nicht so aus, als würde er zur Standardinstallation gehören.

1557732464065.png

Versuchen Sie doch bitte den genannten Index über das SQL-Management Studio zu deaktivieren oder zu löschen.

Gruß,
Frank
 
  • Gefällt mir
Reaktionen: Manuel Pietzsch

saimax

Aktives Mitglied
10. Mai 2010
35
2
Hamburg
Vielen Dank für die Antwort.
Konnte nicht sofort antworten da es immer etwas dauert bis die installation abbricht..
1. Habe die Einträge (es sind 4 Stück) deaktiviert aber es kommt der gleiche Fehler
2. Habe daraufhin die eintrage gelöscht und installiert, auch hier kommt der Fehler wieder und zwar
werden die gleichen 4 Indizien angelegt die dann wieder diese Fehlermeldung verursachen.
Ich muss wohl noch mit der 1.3 leben.
Danke für die Hilfe.

P.S. die indiezies haben wirklich die gleichen Namen wie die gelöschten hatte Screenshots davon gemacht und verglichen.
 

SebastianB

Moderator
Mitarbeiter
6. November 2012
1.839
121
Hallo,

das sind Indizes und Statistiken vom "Database Tuning Advisor". Wenn man den verwendet hat muss die Datenbank erst wieder in den Ursprungszustand versetzt werden, sonst laufen unsere Updates nicht durch.

Es gibt glaub ich im Internet Skripte die das erledigen - aber vorher auf jeden Fall ein Backup der DB anlegen.

LG
Sebastian
 

saimax

Aktives Mitglied
10. Mai 2010
35
2
Hamburg
So das einzige was ich zu dem Thema gefunden habe ist das man mit dem SQL Profiler oder dem Datenbankoptimierungsratgeber was macht.
Das Problem bei mir ist bei beiden nichts gespeichert also keine Prozesse vorhanden sind die ich beenden oder löschen kann.
Ich habe auch nie mit einen der beiden Tools was gemacht.
Einer noch eine Idee?
 

JTL_fwenzl

WMS Entwickler
Mitarbeiter
15. Dezember 2017
250
88
Hürth
Hallo,

ich hatte noch die Hoffnung, das es sich um ein paar einzelne Indexe handelt ;)

Wenn der Datenbankoptimierungsratgeber mal über die DB gelaufen ist, dann ists komplizierter.
Im Prinzip muß man alle Objekte die mit _dta_index_irgendwas benannt sind löschen.

https://docs.microsoft.com/en-us/previous-versions/sql/sql-server-2008-r2/ms190172(v=sql.105)

Ich schau mal morgen ob es dafür ein Skript gibt. Sollte kein unlösbares Problem sein.

Herausfinden kann man die zu löschenden Einträge mit dieser Abfrage:
Code:
select * from sys.indexes where is_hypothetical = 1

Gruß,
Frank
 

saimax

Aktives Mitglied
10. Mai 2010
35
2
Hamburg
Bei mir hat der Code

select * from sys.indexes where is_hypothetical = 1

keine Zeile betroffen angezeigt.
Ich habe jetzt einige Stunden mehrere Versuche ausgeführt dies und das Probiert aber leider bricht das update immer ab.
Morgen werde ich nach 18:00 Uhr wieder dazu kommen.
Melde mich wenn ich weiss wie man es lösen kann.
Danke allen die mir Tips für die Lösung gegeben haben.
 

saimax

Aktives Mitglied
10. Mai 2010
35
2
Hamburg
DANKE
Ich habe es hinbekommen. Keine Ahnung warum gestern es nicht ging hatte wohl Tomaten auf den Augen.
Für alle die ähnliche Probleme haben.
Der Tip von JTL_fwenzl in Beitrag #7 war richtig nur hatte ich irgendwie einen anderen Fehler gemacht. (den ich leider so auch nicht mehr reproduzieren kann)
Danke an JTL_fwenzl.
Und die Lösung ist
In der SQL Management Konsole

use eazybusiness
select * from sys.indexes where is_hypothetical = 1

Danach den Inhalt löschen

DECLARE @sql VARCHAR(MAX) = ''
SELECT
@sql = @sql + 'DROP INDEX [' + i.name + '] ON [dbo].[' + t.name + ']' + CHAR(13) + CHAR(10)
FROM
sys.indexes i
INNER JOIN sys.tables t
ON i.object_id = t.object_id
WHERE
i.is_hypothetical = 1
EXECUTE sp_sqlexec @sql

(Quelle: https://stackoverflow.com/questions/21111927/should-i-delete-hypothetical-indexes)

Danach konnte ich das update ohne Probleme installieren.
Es sind einige Indizies gelöscht (ca 1500) aber ich habe noch ein Backup der alten DB so wenn was fehlen sollte ich mir die Infos da raushole.
Aber bis jetzt sieht alles sauber aus im vorher nachher vergleich.
Der Beitrag kann als erledigt / gelöst markiert werden nur weiss ich nicht wie das geht.
Thx Saimax
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 2
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Zahlungsmodul Fehler nach Update 1.5.34.0 auf 1.5.45.1 - Keine Liste erlaubter TAN-Verfahren erhalten JTL-Wawi - Fehler und Bugs 0
Update 4.06 B17 auf 5.01 > Error 500 und Fehlerausgabe funktioniert nicht Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Seit update auf 1.5.45.1 geht Rückzahlung über Zahlungsmodul nicht mehr Arbeitsabläufe in JTL-Wawi 0
Nach dem Update auf 5, object cache leeren oder nicht? Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Wie läuft Plugin-Update von Shop4 auf Shop5? Technische Fragen zu Plugins und Templates 4
Update von JTL Shop 4 auf 5 bei externer WaWi Upgrade JTL-Shop4 auf JTL-Shop5 5
Neu Update von 1.4xx auf 1.5xx worauf sollten wir achten? Installation von JTL-Wawi 3
Neu Kein Wawi Abgleich nach Update auf Shop5 Installation / Updates von JTL-Shop 4
Neu Nach Update auf Shop 5: Kundendaten an Shop senden funktioniert nicht mehr Allgemeine Fragen zu JTL-Shop 4
Gelöst HTTP ERROR 503 nach Update auf 5.01 Upgrade JTL-Shop4 auf JTL-Shop5 3
Neu Diverse Fehler nach update auf 1.0.4.5 JTL-POS - Fehler und Bugs 0
Neu *Probleme mit Shopware-Connector nach Update auf 1.5.42.0 und großem Abgleich* Shopware-Connector 1
Neu Artikelbeschreibungen bei Änderungen werden nicht übernommen, Alphabetische Reihenfolge bei Variationen seit update auf JTL 1.5.42.0 Shopify-Connector 8
Neu Onlineshopabgleich nach Update auf 1.5.42.0 nicht mehr möglich JTL-Wawi - Fehler und Bugs 0
Gelöst Probleme bei Update auf JTL5 - Class not found Installation / Updates von JTL-Shop 1
nach Update auf 5 kein Wawi Abgleich mehr möglich Upgrade JTL-Shop4 auf JTL-Shop5 2
Gelöst Seit Update der Android App auf V 1.0.4.3 keine Kartenzahlung mit Zettle by Paypal möglich JTL-POS - Fehler und Bugs 3
Gelöst Abgleich mit dem JTL-Connector nach Update auf 1.5.42.0 nicht mehr möglich JTL-Wawi - Fehler und Bugs 6
Beantwortet Stücklistenartikel zum Teil weg, nach Update auf Update auf 1.5.41.3 JTL-Wawi - Fehler und Bugs 2
Neu Kein Admin Zugang nach Update auf Shop 5 Installation / Updates von JTL-Shop 10
Neu Wawi startet nicht mehr nach Update auf Version: 1.5.41.1 Installation von JTL-Wawi 9
Neu Shopify-Connector funktioniert seit Update auf 1.5.41.2 nicht mehr Shopify-Connector 4
Neu Problem mit Update (Version 1.5.46.0) JTL-Wawi - Fehler und Bugs 2
Nach Update .htaccess Problem Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Kein automatischer Update des Bestands nach Wareneingangsbuchung(en) JTL-Wawi - Fehler und Bugs 2
Neu Box im Footer wird beim Paypal-Plugin-Update gelöscht JTL-Shop - Fehler und Bugs 1
Neu Wie kann man bei einem Shop-Update informiert werden? Betrieb / Pflege von JTL-Shop 2
Neu Verbindungsproblem nach Update - Duplicate entry "46" Error JTL-Wawi - Fehler und Bugs 0
Neu UPDATE 1.5.45.1 Probleme danach JTL-Wawi - Fehler und Bugs 0
Neu Speichern der Syncdaten nach dem Update notwendig JTL-Shop - Fehler und Bugs 1
Neu Amazon Listing nach Update nicht mehr möglich Amazon-Lister - Fehler und Bugs 2
Neu Connector Update 2.9.0 in verständlichen Worten Shopware-Connector 6
In Bearbeitung Seit Connector Update: Wenn Versand gesetzt, wird kein Lieferschein über den Connector an Shopware 5 übertragen Shopware-Connector 1
Neu PayPal Update 2.0.1 JTL-Shop - Fehler und Bugs 0
Neu JTL Update - Nicht genügend Speicherplatz für die Simulation JTL-Wawi - Fehler und Bugs 10
Beantwortet Update Shop 5 - SQLSTATE Fehler - diverse Installation / Updates von JTL-Shop 1
In Bearbeitung keine update mehr Allgemeine Fragen zu JTL-POS 1
Neu Update Shop5 - endlose Cache Bereinigung Installation / Updates von JTL-Shop 0
Neu OSS - kommt da ein Update seitens JTL Arbeitsabläufe in JTL-Wawi 7
Neu Update Variations-Aufpreis nicht möglich JTL-Ameise - Fehler und Bugs 1
Neu WAWI DB Update Fehler eines Mandanten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shop läuft nicht mehr nach Update Mollie 1.01 Plugins für JTL-Shop 0
Gelöst Kasse kann keine Verbindung zum TSE herstellen nach letztem Update JTL-POS - Fehler und Bugs 2
seit dem Update Preise mit 16% Umsatzsteuer im Shop Upgrade JTL-Shop4 auf JTL-Shop5 0
In Bearbeitung Internes Kundendisplay Bild trotz Update immer noch verpixelt JTL-POS - Fehler und Bugs 2
Neu Korrektur-/ Umbuchung durchführen extrem langsam seit Update JTL-Wawi - Fehler und Bugs 0

Ähnliche Themen