Neu SW6 Connector - Malformed UTF-8 characters, possibly incorrectly encoded

danielbic

Mitglied
25. März 2021
14
4
Hallo,
wir haben bei sehr vielen Artikeln das Problem "Malformed UTF-8 characters". Wir wissen nun nicht welches Zeichen schuld daran ist. Wir senden in den Feldern auch eine Tabelle mit html und einmal ist auch natürlich ein Grad-Zeichen enthalten usw.
Was müssen wir machen? Müssen wir irgendwo ein Format umstellen, etc.?
Bin um jede Hilfe froh, anbei das Logfile mit den Feldern und der Fehlermeldung.
Danke schon jetzt für die Hilfe.
LG, Daniel
 

Anhänge

  • Connector-Abgleich-Debug 20211013 17-12-31.txt
    767,1 KB · Aufrufe: 9

Scriptfarm DEV

Aktives Mitglied
7. Dezember 2018
63
17
Das ist natürlich schwer das aus der Ferne zu sagen, liegt es nur an Umlauten, Sonderzeichen oder sonstigen.
Ich würde einfach versuchen es über das Ausschlussverfahren einzugrenzen.
Nur einen Artikel mit überschaubaren HTML Content übertragen und dann versuchen dort die Übeltäter zu finden, dann seit ihr schon einen Schritt weiter
 

danielbic

Mitglied
25. März 2021
14
4
Wir versuchen es mit einem einzigen Artikel, wo wir keine Sonderzeichen verwenden. Die Fehlermeldung von SW6 liefert keine genaue Infos, so zumindest die Info aus diesem Forum. Hier habe ich auch gefunden, dass es an doppelten Relationen bzw. doppelten Merkmalen oder zu langen Meta-Descriptions liegen könnte.
Irgendwie ein Rätselraten. Deshalb habe ich gehofft, dass JTL mal in die Logs schaut, scheinbar können die das...
 

McAvity

Sehr aktives Mitglied
7. September 2016
595
145
@danielbic @Immanuel

Ich würde sagen die ganzen Newlines per "\n" in den HTML-Beschreibungen sind das Problem, einfach mal entfernen z.B. bei diesem "Shimano INNENLAGER MT800 PRESS-FIT" Artikel in der Description und dann mal schauen.

Just my 2 cents.

MfG

McAvity
 

pmart

Mitglied
7. Juni 2021
39
4
Ich hatte vor einiger Zeit dasselbe Problem. Ein Komplettabgleich hatte es nur noch schlimmer gemacht, indem Merkmale einfach doppelt und dreifach übertragen wurden. Ich würde einen neuen Connector einrichten und den alten löschen. Das hat es bei mir am Ende behoben.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu SW6 | Abnahmemengen über Wawi steuerbar? Shopware-Connector 2
Neu SW6 - Auffächern der Eigenschaften in der Produktliste Shopware-Connector 0
Neu Custom Porducts SW6 swag_customized_products_template_id Shopware-Connector 2
Neu Shopware 6 <> JTL Connector Beta: Individuelle Sortierung der Artikel Shopware-Connector 0
Neu (WooCommerce) JTL Connector Aufträge lassen sich nicht bearbeiten "Fehler beim MARS-Batch" User helfen Usern - Fragen zu JTL-Wawi 0
Neu Onlineshop via Connector (Xonic) Problem JTL-Wawi - Fehler und Bugs 0
Neu Erfahrungen Connector mit Elementor-Paket mit direktem Google-Hosting WooCommerce-Connector 0
Neu JTL connector woocommerce Angebot/Aufträge WooCommerce-Connector 0
Neu Shopware 5 Connector fehlender CDN/File System Adapter Support Shopware-Connector 0
Neu Shopware 6 Connector.... ich verzweifle gleich Shopware-Connector 5
Neu Rey Theme kompatibel mit JTL-Connector? WooCommerce-Connector 0
Neu JTL-Connector für Shopware 6 Beta Version beendet? Shopware-Connector 3
Neu Connector Plugin Freigabe für SW 5.7.10 Shopware-Connector 4
Neu Wie vorgehen beim Connector Update? Modified eCommerce-Connector 0
Neu Shopware 5 Connector / abweichender Produkttitel Shopware-Connector 2
Neu Bilder > übertragung ausstehend (Shopify connector) Shopify-Connector 0
Neu SW5 Connector bricht ab bei Lieferschein senden Shopware-Connector 0
Neu Shopkonfiguration Connector konfigurieren keine Auswahl möglich WooCommerce-Connector 0
Neu Wann funktioniert der Shopware6 Connector? Shopware-Connector 8
Neu Jtl Connector - WooCommerce / Paypal-Aufträge werden nicht importiert WooCommerce-Connector 0
Neu Connector für Konfigurator/Stücklistenartikel WooCommerce-Connector 0
Neu Connector keine Verbindung WooCommerce-Connector 1
Verwiesen an Support Abgleich Fehler nach Shopware Connector Update Shopware-Connector 1
Neu Fehler in Connector-Requestdaten nach Änderung der Kundengruppe in der Wawi Allgemeines zu den JTL-Connectoren 2
Neu JTL Connector zu Presta "Product": {"delete"} -> Exception bei product.delete: Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverf PrestaShop-Connector 1
Neu Fehler beim Verbindungsaufbau: Exception bei core.connector.auth: Der Remoteserver hat einen Fehler zurückgegeben: (401) Nicht autorisiert. WooCommerce-Connector 1
Neu Connector Abgleich schlägt fehlt - Shopware 5 - Exception: The EntityManager is closed - Exception: The EntityManager is closed Shopware-Connector 2
Neu Connector-Version Shopware 5 Shopware-Connector 10
Neu Einstellung Liefer-Bestellstatus von JTL zu Woocommer ( JTL -WOOCOMMERCE CONNECTOR ) WooCommerce-Connector 0
Neu [JTL + Shopware] Connector löscht Suchfilter Onlineshop-Anbindung 3
Neu WooCommerce Connector Lizenz löschen WooCommerce-Connector 2
Neu Sprache Deutsch taucht mehrfach in Connector Zuordnungen auf Shopware-Connector 0
Neu Prestashop 1.7.8.3 Fehler beim Upgrade auf Connector von Version 1.10.0 auf Version 1.11.0 sowie 1.12.0 - Installation schlägt fehlt PrestaShop-Connector 2
Gelöst Fehler beim Verbindungsaufbau: Exception bei core.connector.auth: Call to a member function getBody() on null Shopware-Connector 3
Neu Custom connector ImageController Onlineshop-Anbindung 0
Neu Weiterentwicklung modified-Connector nach dem 31.12.2022 Modified eCommerce-Connector 0
Neu Weiterentwicklung Gambio-Connector nach dem 31.12.2022 Gambio-Connector 19
Neu Connector ohne phar laufen lassen Allgemeines zu den JTL-Connectoren 1
Neu Entity Manager is closed - Shopware 5 Connector / Shopabgleich Shopware-Connector 2
Neu Shopware 5 Artikelsynchronisation zu JTL schlägt fehl (Exception bei product.pull: Error while encoding into JSON: Malformed UTF-8 characters...) Shopware-Connector 1

Ähnliche Themen