Neu Shop5 RC.3 - Problem mit Neuinstallation

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

AM77

Mitglied
14. Mai 2019
25
0
Hallo,
ich wollte mir gerade mal den aktuellen RC3 anschauen, scheitere allerdings bereits im zweiten Schritt der Installation.
Bei diesem Schritt werden die Dateirechte geprüft und ich erhalte zunächst eine Liste von Dateien, deren Schreibrechte nicht passen. Kleine Anmerkung: Ein Hinweis welche Rechte benötigt werden wäre für die finale Version prima.
Jedenfalls taucht da unter anderem eine fehlende Berechtigung bei " bilder/intern/trustedshops " auf, dieses Verzeichnis gibt es aber im RC.3 überhaupt gar nicht. Und egal welche Rechte ich den aufgelisteten Verzeichnissen gebe (auch 777 versucht), so verharrt die Installation in diesem Zustand. Ich komme nicht zu Schritt 3, die Fehlerliste bleibt wie sie war unabhängig davon welche Berechtigungen auf dem Server gesetzt sind.
Getestet habe ich das Ganze mit Chrome und Edge. Hat jemand eine Idee was ich da falsch machen könnte?
Grüße
 

FMoche

Moderator
Mitarbeiter
15. Dezember 2014
845
114
Halle (Saale)
Hi,

du hast recht, die Prüfung ist nicht ganz korrekt. Da der Ordner nicht existiert, versucht der Installer ihn anzulegen und prüft dann, ob er beschreibbar ist.
Wenn dieser Test bei dir fehlschlägt, müsstest du korrekte Schreibrechte auf den Parent-Ordner setzen - also auf bilder/intern.
 

AM77

Mitglied
14. Mai 2019
25
0
Hallo,
ich habe aktuell 777 Rechte auf "bilder" (inkl. Unterordnern) gegeben um das auszuschließen - dennoch derselbe Fehler. Habe dann gerade mal den Ordner " bilder/intern/trustedshops " manuell angelegt und mit 777 versehen - keine Änderung. Ich hänge hier scheinbar gerade. Auch habe ich das Gefühl dass der "Erneut prüfen" Button unten keine Funktion hat.

Nachtrag: Ich habe es gerade mal mit dem "alten" Internet Explorer getestet. Dort werden nun meine Änderungen erkannt...ich mache mal weiter.
 

AM77

Mitglied
14. Mai 2019
25
0
Ich komme erst jetzt dazu weiterzumachen. Allerdings komme ich dennoch nicht wirklich weiter.
Edge und Chrome behaupten weiterhin dass es keine Schreibrechte gibt. Die Ansicht unter dem Internet Explorer ist da leicht differenzierter, wenn auch nicht hilfreich (siehe Anhänge).
Hier wird nun behauptet dass die Bilderordner in Ordnung sind, wenngleich die Berechtigungen auf dem Server noch gar nicht angepasst sind.
Umgekehrt stimmen angeblich die mediafiles nicht, hier ist es aber wiederum egal wie viele Rechte ich auch vergebe.
Ich hänge mal wieder...
 

Anhänge

Peter_ST

Neues Mitglied
10. November 2020
15
0
Ich kann das Problem bestätigen. Bei mir hat es geholfen den Cache des Browsers zu leeren. Das Problem scheint aufzutreten, wenn kein Domain SSL aktiviert ist. Zumindest hatte ich das Problem dann nach der Aktivierung von SSL nicht mehr.
 

AM77

Mitglied
14. Mai 2019
25
0
Ok, habe nun mal ohne SSL die Installation gestartet. Wenn ich regelmäßig den Browsercache leere werden die Berechtigungen erkannt. Ein Klick auf "erneut prüfen" sieht zwar gut aus, aber es passiert nichts ehe ich den Cache nicht leere.
Habe es aber hinbekommen und hänge nun beim Import des Schemas auf der DB. Aktuell sind in diesem Zustand ca. 30 Minuten vergangen (siehe Anhang). Ich fürchte da passiert nichts mehr...

Bin ich der einzige mit diesen Problemen? Ich habe eine komplette Neuinstallation gestartet...
 

Anhänge

Peter_ST

Neues Mitglied
10. November 2020
15
0
Hosting zufällig bei Hosteurope? Hatte dort exakt das gleiche Problem. Da habe ich aber das recht kleine Webpack im Verdacht.
 

Peter_ST

Neues Mitglied
10. November 2020
15
0
Dann liegt es wahrscheinlich an deren Config. Hatte dann bei anderen Hostern nämlich keine Probleme! Install Routine hatte bei mir lediglich " PHP-Skript-Ausführungszeit (max_execution_time) " von 30 abgenörgelt wo 120 benötigt wird. Ich denke aber genau deshalb lief das Erstellen der Datenbank dann auch nicht durch. Ist aber nur eine Vermutung.
 
Zuletzt bearbeitet:

AM77

Mitglied
14. Mai 2019
25
0
Dann liegt es an wahrscheinlich an deren Config. Hatte dann bei anderen Hostern nämlich keine Probleme! Install Routine hatte bei mir lediglich " PHP-Skript-Ausführungszeit (max_execution_time) " von 30 abgenörgelt wo 120 benötigt wird. Ich denke aber genau deshalb lief das Erstellen der Datenbank dann auch nicht durch. Ist aber nur eine Vermutung.
Kannst Du einen anderen Hoster zu ähnlichen Konditionen empfehlen?
 

Predpray

Aktives Mitglied
26. Oktober 2018
12
0
Es funktioniert auch nicht mit LAMPP. Ich habe Probleme mit den Schreibrechten.
Update:
Habe heute eine SubDomain bei meinem Hoster eingerichtet und dort die Installation vorgenommen. Alles TipTop. Hier und da müsste ich ein paar Werte anpassen lassen, aber es läuft. Habe dann die WAWI mit dem Shop verbunden und werde morgen nach und nach Testartikel anlegen und dann prüfen ob alles läuft.
 
Zuletzt bearbeitet:

web-seo-consulting

Sehr aktives Mitglied
23. Juli 2011
943
74
Küps
Installation eines neuen JTL- Shop 5 mit Firefox zeigte das alle Rechte nicht passen.

Gleicher Webspace mit Chrome zeigt an das die Rechte passen
Gleicher Webspace mit Edge zeigt das die Rechte passen

Kann doch net sein oder?
 
  • Wow
Reaktionen: DRaufeisen

DRaufeisen

Moderator
Mitarbeiter
3. Mai 2016
78
11
Halle (Saale)

AM77

Mitglied
14. Mai 2019
25
0
Ich will mal einen neuen Anlauf starten, inzwischen mit der Produktivversion. Allerdings erhalte ich auf meinem Hosteurope Webspace weiterhin die Fehler von oben.
Was ist denn eine preisgünstige Alternative, die auch funktionert?
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Startseite Shop5 kleines Problem Einrichtung von JTL-Shop4 4
Neu Shop5 versendet keine Emails ueber SMTP JTL-Shop - Fehler und Bugs 0
Neu JTL-Shop5 Bugs JTL-Shop - Fehler und Bugs 2
Neu JTL Shop5 bei JTL gehostet. Nova-Template ist nicht mit Smartphone zu nutzen . welche Einstellung muss da noch gemacht werden Templates für JTL-Shop 1
Neu Fehler nach "Ordner-Umzug" von Shop5 Allgemeine Fragen zu JTL-Shop 4
Neu Update Shop5 RC3 -> 5.0.0 kein Cookie Consent Manager mehr JTL-Shop - Fehler und Bugs 0
Neu Artikeldetailseite zerschossen - kein Ablegen der Artikel in warenkorb mehr möglich Shop5 / Nova template Allgemeine Fragen zu JTL-Shop 2
Neu Missglücktes Upgrade auf Shop5.0 Einrichtung von JTL-Shop4 2
Neu Spezialseiten aktualisieren Shop5 Betrieb / Pflege von JTL-Shop 1
Neu Wie zählt der Shop5 Besucher? JTL-Shop - BETA - Feedback und Bugmeldungen 2
Neu JTL Shop5 - Startseite aus dem Backend wird umgeleitet. Einrichtung von JTL-Shop4 0
Neu Bilderoverlay/Sticker Shop5 Nova Einrichtung von JTL-Shop4 16
Neu Fehler: Umlaute im Shop nach Umstellung auf Shop5 Installation / Updates von JTL-Shop 2
Neu JTL Shop5 email einstellungen Einrichtung von JTL-Shop4 3
Neu Nach Upgrade auf Shop5 Warnmeldungen der G Console, Erfahrungen? JTL-Shop - Fehler und Bugs 2
Neu Shop5 Update: Probleme im Backend/Versandarten JTL-Shop - Fehler und Bugs 7
Neu JTL Shop5 Consent Manager Einrichtung von JTL-Shop4 2
Beantwortet [Shop4/Shop5] Bestellung zurückhalten und nicht an die Wawi senden Technische Fragen zu Plugins und Templates 6
Beantwortet Guthaben wird nicht übertragen Shop5 JTL-Shop - Fehler und Bugs 3
Neu JTL Shop5 SEO Mehrsprachig Einrichtung von JTL-Shop4 0
Neu SHOP5 Paypal Rundungsfehler seit Update auf Shop5 Plugins für JTL-Shop 3
Neu SHOP5: Versandabhängige Artikel im Warenkorb bei Selbstabholung Betrieb / Pflege von JTL-Shop 0
Neu SHOP5: Bestseller Box in Artikelübersicht ausblenden oder verschieben. Allgemeine Fragen zu JTL-Shop 2
Gelöst Shop5: leere/fehlende Sprachvariable JTL-Shop - BETA - Feedback und Bugmeldungen 3
Neu Shop5 - Artikelübersicht: Beim Mouseover wird autom. das zweite Artikelbild angezeigt - wie abstellen? Einrichtung von JTL-Shop4 2
Gelöst Wartungsseite im Shop5/vom Backend zum Shop JTL-Shop - BETA - Feedback und Bugmeldungen 9
Neu Shop5 - Fehlerbehandlung Frontend - Kundenkonto JTL-Shop - Ideen, Lob und Kritik 4
Neu Shop5: Nachträgliche Paypal zahlung nach Onlineshop Abgleich nicht mehr möglich JTL-Shop - Fehler und Bugs 3
Neu Shop5 - Nutzung des PapeSpeed-Mod auch nach dem Release nicht möglich JTL-Shop - Fehler und Bugs 1
Neu WebpFormat unzureichend im Shop5 JTL-Shop - Ideen, Lob und Kritik 0
Neu Shop5: welches Paypal? JTL-Shop - BETA - Feedback und Bugmeldungen 3
Neu Shop5 - kein Popup mehr nach Artikel in den Warenkorb ? JTL-Shop - Ideen, Lob und Kritik 2
Neu Keine Sidebar mehr im Shop5 Desktop-View ??? JTL-Shop - Ideen, Lob und Kritik 9
Neu Gibt es eine Möglichkeit im Shop5 um diese gewaltige Anzeige Artikel wurde dem Warenkorb hinzugefügt zu deaktivieren Allgemeine Fragen zu JTL-Shop 11
Neu Wieder einmal - Syncronisation mit Shop5 nicht möglich Einrichtung von JTL-Shop4 7
Neu [Shop5] Gesucht: Urlaubshinweis-Plugin oder Workaround Plugins für JTL-Shop 11
Gelöst JTL Shop5 - wieder weiße Seite -. Umleitungsfehler ? Einrichtung von JTL-Shop4 1
Neu Fehler in Shop5 - Warenkorb Einrichtung von JTL-Shop4 3
Neu Shop5 -Gesetzestexte Installation / Updates von JTL-Shop 2
Neu [JTL-Shop5] Allgemeine Einrichtungs-Fragen Einrichtung von JTL-Shop4 1
Beantwortet JTL-Shop5: Preisdarstellung Betrieb / Pflege von JTL-Shop 2
Neu [Shop5] Payment Plugin -> Bestellung abschicken nach AdditionalTemplateFile Technische Fragen zu Plugins und Templates 2
Neu Zahlart Shop5 vs. Anzeige Rechnung - Verständnisfragen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu [Shop5] Bestellabschluss führt auf weiße Seite Einrichtung von JTL-Shop4 5
Neu Shop5 Filter JTL-Shop - Fehler und Bugs 1
Neu Shop5 Consent-Manager Einrichtung von JTL-Shop4 1
Neu Newsletter Anmeldung Footer (Shop5) JTL-Shop - Fehler und Bugs 6
Neu Shop5 - Startseite und Seitenabstand der Inhalte Allgemeine Fragen zu JTL-Shop 2
Neu Fehler DB Update von Shop4 auf Shop5 Installation / Updates von JTL-Shop 4
Neu Trennung von Forum / Themen für JTL-Shop4 & JTL-Shop5 Allgemeine Fragen zu JTL-Shop 6
Ähnliche Themen