Neu Problem mit Uploadmodul in der Kombi mit Shop 4.05 und PayPal 1.06

  • Ersteller des Themas Ersteller des Themas BSKev
  • Erstellungsdatum Erstellungsdatum

BSKev

Aktives Mitglied
13. Juni 2016
26
1
Hallo,

wir haben folgendes Problem seit dem Update auf Shop 4.05 und JTL-PayPal-Plugin 1.06 (WaWi 1.1.4.14):
Bei Bestellungen mit Datei-Upload (dieser ist verpflichtend, keine Test-Lizenz) erscheint in der WaWi unter Verkauf der Button "Shop-Upload" nicht, wenn die Bestellung per PayPal (Plus) bezahlt wurde - bei anderen Zahlarten aber sehr wohl. Vor dem Shop-Update mit 4.04 und PayPal 1.04 ging dies definitiv. Was ich nicht genau sagen kann, ob es mit Shop 4.05 dem dem "alten" PayPal 1.04 funktionierte.

Wie komme ich jetzt an die Upload-Dateien heran???

Edit: Hat das Problem sonst niemand oder setzt niemand das Upload-Modul ein?
Edit2: Offensichtlich werden die Upload-Dateien korrekt hochgeladen und auf dem Webserver unter /uploads gespeichert. Nur bei PayPal-Bestellungen wird der "Link" in der WaWi nicht angezeigt...


Viele Grüße,
Andreas
 
Zuletzt bearbeitet:

TurboPerformance

Aktives Mitglied
20. Januar 2010
35
8
Haiger
Haben ein anderes Problem bei uns im Warenkorb gibts garnicht mehr die möglichkeit eine Datei hochzuladen ?
Sowas schonmal gehabt?
 
Zuletzt bearbeitet:

JulianG

Administrator
Mitarbeiter
14. November 2013
1.254
398
Upload-Modul funktioniert im Verbindung mit PayPal-Plugin tatsächlich nicht. Fehler ist aufgenommen: https://gitlab.jtl-software.de/jtlshop/shop4/issues/1134

@TurboPerformance Da gibt es aktuell keinen bekannten Fehler. Wenn das bei allen Upload-Artikeln auftritt (am besten mal einen ganz neuen zum Testen anlegen) prüf bitte mal die Lizenz, ggf. entfernen, neu hinzufügen und abgleichen. Wenn es nur bei bestimmten Artikeln auftritt nimm die mal aus dem Shop und lad sie neu hoch (onlineshop-aktiv rausnehmen, abgleichen, wieder reinnehmen, abgleichen)
 

TurboPerformance

Aktives Mitglied
20. Januar 2010
35
8
Haiger
@JulianG Habe ich bereits alles probiert. Führt zu keinem Erfolg.
Habe auch mal alle Plugins deaktiviert.
tuploadschema in der DB ist auch gefüllt
Kann ich sonst noch irgendwas prüfen?
 
Zuletzt bearbeitet:

TurboPerformance

Aktives Mitglied
20. Januar 2010
35
8
Haiger
Durch JTL Support gelöst.
War wohl ein sehr spezieller Fehler.

Auszug Support Ticket:
Es musste etwas am Shopcode und in der Shop Datenbank verändert werden, dort waren fehler vorhanden, die bisher jedoch noch völlig unbekannt waren und auch nicht nachvollziehbar ist wodurch diese entstanden waren. Soweit ich es verstanden habe lagen falsche Verknüpfungen vor.

Kann geschlossen werden.
Vielen Dank nochmal !
 
Zuletzt bearbeitet:

BSKev

Aktives Mitglied
13. Juni 2016
26
1
Hallo,

bei uns scheint es dank der zugeschickten, gepatchten Dateien in Shop 4.05 und WaWi 1.3.12.0 auch zu gehen.

Allerdings haben wir ein neues Problem seit dem Shop-Update 4.05 (Build: 5) in Verbindung mit der gepatchten bestellabschluss.php und includes/bestellabschluss_inc.php:

Früher wurden die Dateien auf dem Webserver bei dem Download über den Button in der Wawi nicht gelöscht. Seit dem Build:5 werden diese zumindest bei uns vom Server gelöscht.

Leider schreibt die WaWi diese Dateien nicht korrekt (sprich: überhaupt nicht), wenn als lokales Verzeichnis ein Ordnerumleitung "weitergeleitetes" Verzeichnis genutzt wird (bie uns z.B. der Desktop, der nicht lokal im Windows-Profil liegt, sondern zentral auf dem Server). Der "Desktop" liegt bei uns also nicht unter C:\Users\.... (resp. C:\Benutzer\....), sondern in einer Netzwerkfreigabe. Damit können manche Programme nicht umgehen - die einen schreiben dann fröhlich in der Dateiverzeichnis C:\Users\USERNAME\Desktop (was dann natürlich nicht auf dem Desktop angezeigt wird) - und andere wie JTL WaWi- schreiben die Datreien ins Nirvana. Nur um es klarzustellen: In dem "Dateimanger" des Speichern-Dialoges wird der "Desktop" als oberstes Verzeichnis des Baums angezeigt und kann gewählt werden. Beim speichern merkt man (auch zeitlich), dass die Dateien vom Webserver geladen werden und es erfolgt keine Fehlermeldung. Anschließend sind diese Dateien aus dem /uploads-Verzeichnis des Webservers verschwunden und lokal nicht vorhanden.
In WaWi unter den Shop-Uploads zwar noch angezeigt, beim erneuten Download werden jedoch nur Dateien im zweistelligen Byte-Bereich (nicht kB!) erzeugt mit einem Inhalt wie "{"nCode":5,"cToken":"","oData":null}"
 

BSKev

Aktives Mitglied
13. Juni 2016
26
1
Hallo,

da das Problem nicht immer auftritt, sondern (wie sich mittlerweile gezeigt hat) nur wenn das Server-Verzeichnis durch einen Ausfall des Servers kurz "weg" war, denke ich, dass das kein spezifisches Problem der WaWi ist.

Es wäre nur schön, wenn man evtl. das Löschen vom Server auf Abruf + einstellbare Zeit festlegen könnte. Aber das ist wohl kein Support-Problem.
 

Ähnliche Themen