Neu Problem mit PHPmailer

Mach-Heile

Mitglied
18. August 2018
6
0
Guten Morgen.

Bin hier seit gestern vergeblich am Lösungen suchen und verzweifle langsam.

Angefangen hat das ganze mit der weißen Seite nachdem man auf zahlungspflichtig bestellen im Warenkorb klickt. Nun dann habe ich mir die Fehler anzeigen lassen und in den Foren hier viele Vorschläge gefunden.
Liegt nun anscheinend an dem E-Mails im Shop. Habe nun auch schon alle E-Mail Vorlagen zurückgesetzt und mir versucht eine Testmail zuzusenden, allerdings spuckt er immernoch Fehler in der random.php aus.
Evtl hat mal einer noch ein Tipp was ich probieren kann, bevor ich den ganzen Shop neu installiere

Danke euch schonmal

Fatal error: Uncaught exception 'Exception' with message 'There is no suitable CSPRNG installed on your system' in /var/www/vhosts/mach-heile.de/httpdocs/includes/vendor/paragonie/random_compat/lib/random.php:213 Stack trace: #0 /var/www/vhosts/mach-heile.de/httpdocs/includes/vendor/phpmailer/phpmailer/src/PHPMailer.php(2466): random_bytes(32) #1 /var/www/vhosts/mach-heile.de/httpdocs/includes/vendor/phpmailer/phpmailer/src/PHPMailer.php(2490): PHPMailer\PHPMailer\PHPMailer->generateId() #2 /var/www/vhosts/mach-heile.de/httpdocs/includes/vendor/phpmailer/phpmailer/src/PHPMailer.php(1450): PHPMailer\PHPMailer\PHPMailer->createBody() #3 /var/www/vhosts/mach-heile.de/httpdocs/includes/vendor/phpmailer/phpmailer/src/PHPMailer.php(1348): PHPMailer\PHPMailer\PHPMailer->preSend() #4 /var/www/vhosts/mach-heile.de/httpdocs/includes/mailTools.php(766): PHPMailer\PHPMailer\PHPMailer->send() #5 /var/www/vhosts/mach-heile.de/httpdocs/includes/mailTools.php(607): verschickeMail(Object(stdClass)) #6 /var/www/vhosts/mach-heile.de/httpdoc in /var/www/vhosts/mach-heile.de/httpdocs/includes/vendor/paragonie/random_compat/lib/random.php on line 213
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.197
594
Berlin

lotex24.systems

Sehr aktives Mitglied
3. Februar 2016
105
29
Wrocław
Hallo und sommerlichen guten Morgen,

Fehlermeldung sieht mir so aus, als ob PHP-Version und openSSL nicht können. Welche PHP-Version und kannst Du auf eine andere umstellen?

Jan

Edit
Da war ich wohl zu langsam. siehe Post von @css-umsetzung
 

Mach-Heile

Mitglied
18. August 2018
6
0
Sorry das ich jetzt erst antworte. Hatte hier privat einiges zu erledigen.

Habe hier noch php 5.6.4 drauf. Hatte nun leider ein Jahr aus paar privaten Gründen gewerblich nix machen können und reaktiviere das soeben wieder.

Hatte nun alle jtl Versionen auf aktuellen Stand gebracht und Plesk Onyx auch auf die aktuelle Version geupdated.

Hatte nun heute morgen mal php 7.1, 7.2 & 7.3 installiert und im Plesk mein Space auf die Versionen geändert als fastcgi...allerdings bekomme ich dann nur nen 500 Fehler angezeigt wenn ich irgendeine Seite versuche zu öffnen.

Sieht für mich nach einem Problem mit php aus. Als Dienst im Plesk ist auch nur die 5.6.40 gestartet, die anderen Versionen sind gestoppt und lassen sich auch nicht starten.

Als Fehler wird im Protokoll ein Apache Fehler angezeigt
Code:
2019-08-11 13:39:19
Warning
91.44.229.94
(104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
Apache-Fehler
2019-08-11 13:39:19
Error
91.44.229.94
End of script output before headers: shopzuruecksetzen.php
Apache-Fehler
2019-08-11 13:36:00
Error
91.44.229.94
End of script output before headers: mytest.phpApache-Fehler
2019-08-11 13:38:49
Error
91.44.229.94
500POST /dbeS/mytest.php HTTP/1.1[IMG]https://mach-heile.de:8443/theme/icons/16/plesk/log-browser-client.png?1537850805[/IMG]4.02 KSSL/TLS-Zugriff für Apache
Hatte erst gedacht eine komplette Neuinstallation des Servers mal durchzuführen, damit alles mal frisch drauf ist, hab allerdings noch ein Freund, der seinen Shop auch bei mir auf dem Server Hoster mit Mails. Das wäre dann etwas problematisch...

Habt ihr ne Idee wie es so zum laufen kommt? Danke euch für eure mühen
 
Zuletzt bearbeitet:

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.197
594
Berlin
Lass da jemanden ran der weiß was er tut.
Du musst ja auch schauen ob du Plugins hast die Ioncube abhängig sind.
Was du nicht nutzen solltest wäre die 7er php version die von Pkesk dabei ist.

Wie hast du die PHP Versionen installiert? Über die Console per Plesk installer oder hast du das selbst compiled?

Den Server deswegen gleich neu aufzusetzen wäre der falsche weg.
 

Mach-Heile

Mitglied
18. August 2018
6
0
Die Plugins habe ich mal deinstalliert, war sowieso nur Paypal und it-recht

Die 7.0 habe ich auch nicht mitinstalliert. Wollte das ganze wohl nun über die 7.2 nun laufen lassen...
Hab die normal über den Plesk installiert laufen lassen.
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.197
594
Berlin
Wollte das ganze wohl nun über die 7.2 nun laufen lassen...
Das würde voraussetzen das du eine JTL Shop 4.06 Version am laufen hast.
sonst solltest du wenn es eine 4.05er Version ist max. 7.0 laufen lassen.

Wenn das dein eigener Server ist hättest du auch das open_basedir anpassen können aber bei einem 4er Shop php 5.6 laufen zu lassen ist eh nicht der Knaller.
Von außen wird dir hier vermutlich keiner helfen können.
 

Mach-Heile

Mitglied
18. August 2018
6
0
So hatte nun Kontakt mit dem Provider. RAM Max wurde erreicht. Der Vserver ist einfach zu klein für die Anforderungen. Hab nun ein Upgrade auf ein neuen Server bestellt. Also mal sehen ob es nun dann läuft.
Muss dann nun eben die Daten komplett umziehen.

Das sowas nicht im Panel bei server4you abrufbar ist.

Danke euch aber für die bemühungen
 

Über uns

  • In unserem moderierten JTL-Forum könnt Ihr Euch themenbezogen mit der JTL-Community rund um die Produkte von JTL, passende Erweiterungen und den E-Commerce im Allgemeinen austauschen, Tipps und Tricks teilen sowie Verbesserungswünsche und Fehler diskutieren.

    Unsere Forumsnutzer helfen sich untereinander auch gerne weiter, wenn Sie mal nicht weiterkommen oder einen Ratschlag benötigen.

Schnell-Navigation

Benutzer Menü